import mstflint-4.17.0-1.el8

This commit is contained in:
CentOS Sources 2021-10-05 06:42:47 -04:00 committed by Stepan Oksanichenko
parent 5de52a6b7e
commit b960827e13
7 changed files with 21 additions and 75 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/mstflint-4.15.0-1.tar.gz SOURCES/mstflint-4.17.0-1.tar.gz

View File

@ -1 +1 @@
ce1e561e20c0ceeabed7e5173bbe4cdb3042d8e3 SOURCES/mstflint-4.15.0-1.tar.gz 15b85cd74758dfa485b5da52beb731079d36e2ae SOURCES/mstflint-4.17.0-1.tar.gz

View File

@ -1,42 +0,0 @@
From 8a54316a15c76154d307ba53be5d98b8503a5d5f Mon Sep 17 00:00:00 2001
From: Honggang Li <honli@redhat.com>
Date: Thu, 13 Jun 2019 20:58:50 -0400
Subject: [PATCH] Fix shebang for python scripts
rhel-8 does not support python2. User '#!/usr/bin/python3' for all
python scripts which with a shebang.
The substitution was done with following bash script.
====
pys=$(find . -type f -name '*.py')
for f in $pys; do
sed -ne '1p' $f | grep -q -E '^#!/usr/bin'
if [ $? -eq 0 ]; then
echo $f
sed -e '/^#!\/usr\/bin/d' -i $f
sed -e '1 i\#!/usr/bin/python3' -i $f
fi
done
===
Signed-off-by: Honggang Li <honli@redhat.com>
---
tracers/fwtrace/mstfwtrace.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tracers/fwtrace/mstfwtrace.py b/tracers/fwtrace/mstfwtrace.py
index 3c3ef8f..5193a31 100755
--- a/tracers/fwtrace/mstfwtrace.py
+++ b/tracers/fwtrace/mstfwtrace.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
# --
#
# Copyright (C) 2019 Mellanox Technologies Ltd. All rights reserved.
--
2.20.1

View File

@ -1,8 +1,8 @@
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
index d4f89a2..46604f5 100644 index 0d8f53b..d800302 100644
--- a/cmdif/Makefile.am --- a/cmdif/Makefile.am
+++ b/cmdif/Makefile.am +++ b/cmdif/Makefile.am
@@ -46,7 +46,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h @@ -50,7 +50,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
cmdif_pylibdir = $(libdir)/mstflint/python_tools/ cmdif_pylibdir = $(libdir)/mstflint/python_tools/
cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py
${CCMDIF_SO}: libcmdif.a ${CCMDIF_SO}: libcmdif.a
@ -12,7 +12,7 @@ index d4f89a2..46604f5 100644
CLEANFILES = ${CCMDIF_SO} CLEANFILES = ${CCMDIF_SO}
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
index 907e5ce..a7e2249 100644 index 3118b85..e708ad8 100644
--- a/dev_mgt/Makefile.am --- a/dev_mgt/Makefile.am
+++ b/dev_mgt/Makefile.am +++ b/dev_mgt/Makefile.am
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py @@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py
@ -25,20 +25,20 @@ index 907e5ce..a7e2249 100644
-L$(USER_DIR)/tools_layouts -ltools_layouts \ -L$(USER_DIR)/tools_layouts -ltools_layouts \
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul -L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
index 5f5677d..566a870 100644 index 351eb81..696e82a 100644
--- a/mtcr_py/Makefile.am --- a/mtcr_py/Makefile.am
+++ b/mtcr_py/Makefile.am +++ b/mtcr_py/Makefile.am
@@ -39,7 +39,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR} @@ -39,7 +39,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
mtcr_pylib_DATA = cmtcr.so mtcr.py mtcr_pylib_DATA = cmtcr.so mtcr.py
dist_mtcr_pylib_DATA = mtcr.py dist_mtcr_pylib_DATA = mtcr.py
cmtcr.so: cmtcr.so:
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so - $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so + $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
CLEANFILES = cmtcr.so CLEANFILES = cmtcr.so
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
index 353fe02..7d70fd8 100644 index f28290e..a141704 100644
--- a/reg_access/Makefile.am --- a/reg_access/Makefile.am
+++ b/reg_access/Makefile.am +++ b/reg_access/Makefile.am
@@ -53,7 +53,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py @@ -53,7 +53,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py

View File

@ -1,13 +0,0 @@
diff --git a/ext_libs/iniParser/iniparser.c b/ext_libs/iniParser/iniparser.c
index 8bc0a18..f981775 100644
--- a/ext_libs/iniParser/iniparser.c
+++ b/ext_libs/iniParser/iniparser.c
@@ -572,7 +572,7 @@ dictionary * iniparser_load(const char * ininame)
char line [ASCIILINESZ+1] ;
char section [ASCIILINESZ+1] ;
char key [ASCIILINESZ+1] ;
- char tmp [ASCIILINESZ+1] ;
+ char tmp [(ASCIILINESZ+1)*2] ;
char val [ASCIILINESZ+1] ;
int last=0 ;

View File

@ -1,8 +1,8 @@
diff --git a/flint/subcommands.cpp b/flint/subcommands.cpp diff --git a/flint/subcommands.cpp b/flint/subcommands.cpp
index 3840579..3d2680b 100644 index b47ff0a..d3a6561 100644
--- a/flint/subcommands.cpp --- a/flint/subcommands.cpp
+++ b/flint/subcommands.cpp +++ b/flint/subcommands.cpp
@@ -3018,7 +3018,7 @@ FlintStatus SgSubCommand::sgFs2() @@ -4626,7 +4626,7 @@ FlintStatus SgSubCommand::sgFs2()
return FLINT_SUCCESS; return FLINT_SUCCESS;
} }
@ -12,10 +12,10 @@ index 3840579..3d2680b 100644
FlintStatus SgSubCommand::sgFs3() FlintStatus SgSubCommand::sgFs3()
{ {
diff --git a/mlxfwops/lib/flint_base.h b/mlxfwops/lib/flint_base.h diff --git a/mlxfwops/lib/flint_base.h b/mlxfwops/lib/flint_base.h
index be7a913..e7e7b64 100644 index 603d932..4dc12b8 100644
--- a/mlxfwops/lib/flint_base.h --- a/mlxfwops/lib/flint_base.h
+++ b/mlxfwops/lib/flint_base.h +++ b/mlxfwops/lib/flint_base.h
@@ -395,7 +395,7 @@ struct BOARD_ID { @@ -388,7 +388,7 @@ struct BOARD_ID {
#define TRACER_HASH_SECT "Tracer Hash section" #define TRACER_HASH_SECT "Tracer Hash section"
#define REBOOT_REQUIRED_STR "To load new FW run reboot machine." #define REBOOT_REQUIRED_STR "To load new FW run reboot machine."
#ifndef MST_UL #ifndef MST_UL

View File

@ -2,16 +2,15 @@
Name: mstflint Name: mstflint
Summary: Mellanox firmware burning tool Summary: Mellanox firmware burning tool
Version: 4.15.0 Version: 4.17.0
Release: 1%{?dist} Release: 1%{?dist}
License: GPLv2+ or BSD License: GPLv2+ or BSD
Group: Applications/System Group: Applications/System
Source: https://github.com/Mellanox/mstflint/releases/download/v4.15.0-1/mstflint-4.15.0-1.tar.gz Source: https://github.com/Mellanox/mstflint/releases/download/v4.17.0-1/mstflint-4.17.0-1.tar.gz
Patch2: 0001-Fix-shebang-for-python-scripts.patch
Patch3: extend-buffer.patch
Patch4: add-default-link-flags-for-shared-libraries.patch Patch4: add-default-link-flags-for-shared-libraries.patch
Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch
Url: https://github.com/Mellanox/mstflint Url: https://github.com/Mellanox/mstflint
BuildRequires: make
BuildRequires: libstdc++-devel, zlib-devel, libibmad-devel, gcc-c++, gcc BuildRequires: libstdc++-devel, zlib-devel, libibmad-devel, gcc-c++, gcc
BuildRequires: libcurl-devel, boost-devel, libxml2-devel, openssl-devel BuildRequires: libcurl-devel, boost-devel, libxml2-devel, openssl-devel
%if %{__remake_config} %if %{__remake_config}
@ -26,9 +25,7 @@ This package contains firmware update tool, vpd dump and register dump tools
for network adapters based on Mellanox Technologies chips. for network adapters based on Mellanox Technologies chips.
%prep %prep
%setup -q -n mstflint-4.15.0 %setup -q -n mstflint-4.17.0
%patch2 -p1
%patch3 -p1
%patch4 -p1 %patch4 -p1
%patch6 -p1 %patch6 -p1
find . -type f -iname '*.[ch]' -exec chmod a-x '{}' ';' find . -type f -iname '*.[ch]' -exec chmod a-x '{}' ';'
@ -58,6 +55,10 @@ find %{buildroot} -type f -name '*.a' -delete
%{_mandir}/man1/* %{_mandir}/man1/*
%changelog %changelog
* Thu Jul 01 2021 Honggang Li <honli@redhat.com> - 4.17.0-1
- Rebase mstflint to latest upstream release v4.17.0-1
- Resolves: bz1915313
* Thu Nov 05 2020 Honggang Li <honli@redhat.com> - 4.15.0-1 * Thu Nov 05 2020 Honggang Li <honli@redhat.com> - 4.15.0-1
- Rebase to latest upstream release v4.15.0-1 - Rebase to latest upstream release v4.15.0-1
- Resolves: bz1851723 - Resolves: bz1851723