import CS mstflint-4.26.0-2.el9

This commit is contained in:
eabdullin 2024-09-30 16:08:25 +00:00
parent 57a1fb4972
commit b7be991670
4 changed files with 35 additions and 27 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/mstflint-4.25.0-1.tar.gz SOURCES/mstflint-4.26.0-1.tar.gz

View File

@ -1 +1 @@
e8fe8035cc019b896290b74d550fd477f80b8ced SOURCES/mstflint-4.25.0-1.tar.gz 0ae1b90ef5c66a7d9e335b8bf4921ab20fd82f4a SOURCES/mstflint-4.26.0-1.tar.gz

View File

@ -1,4 +1,4 @@
From 0bf822388a194c01c82beb6b6529b49255a4bd39 Mon Sep 17 00:00:00 2001 From a91f8252d007aa0d8b2d211ea0061a60ad003c73 Mon Sep 17 00:00:00 2001
From: Kamal Heib <kheib@redhat.com> From: Kamal Heib <kheib@redhat.com>
Date: Tue, 17 Oct 2023 14:19:52 -0400 Date: Tue, 17 Oct 2023 14:19:52 -0400
Subject: [PATCH] Add default link flags for shared libraries Subject: [PATCH] Add default link flags for shared libraries
@ -12,57 +12,56 @@ Signed-off-by: Kamal Heib <kheib@redhat.com>
4 files changed, 4 insertions(+), 4 deletions(-) 4 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
index b6c43d59c8b5..0e03839459f2 100644 index 7bb332aada48..3ffdf7d6653e 100644
--- a/cmdif/Makefile.am --- a/cmdif/Makefile.am
+++ b/cmdif/Makefile.am +++ b/cmdif/Makefile.am
@@ -51,7 +51,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h @@ -53,7 +53,7 @@ libcmdif_la_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.
cmdif_pylibdir = $(libdir)/mstflint/python_tools/ cmdif_pylibdir = $(libdir)/mstflint/python_tools/
cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py
${CCMDIF_SO}: libcmdif.a ${CCMDIF_SO}: libcmdif.la
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${CCMDIF_SO} \ - $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${CCMDIF_SO} \
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${CCMDIF_SO} \ + $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${CCMDIF_SO} \
-L$(USER_DIR)/tools_layouts -ltools_layouts -L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul $(top_builddir)/tools_layouts/.libs/libtools_layouts.a $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a
CLEANFILES = ${CCMDIF_SO} CLEANFILES = ${CCMDIF_SO}
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
index 2283c2d1c763..ab8910dfc435 100644 index a5f66e9fd935..0d1417daa647 100644
--- a/dev_mgt/Makefile.am --- a/dev_mgt/Makefile.am
+++ b/dev_mgt/Makefile.am +++ b/dev_mgt/Makefile.am
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py @@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so
dist_dev_mgt_pylib_DATA = dev_mgt.py dist_dev_mgt_pylib_DATA = dev_mgt.py
c_dev_mgt.so: libdev_mgt.a c_dev_mgt.so: libdev_mgt.la
- $(CC) -g -Wall -pthread -shared ${CFLAGS} tools_dev_types.o -o c_dev_mgt.so \ - $(CC) -g -Wall -pthread -shared ${CFLAGS} tools_dev_types.o -o c_dev_mgt.so \
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} tools_dev_types.o -o c_dev_mgt.so \ + $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} tools_dev_types.o -o c_dev_mgt.so \
-L$(USER_DIR)/reg_access -lreg_access \ $(top_builddir)/reg_access/.libs/libreg_access.a \
-L$(USER_DIR)/tools_layouts -ltools_layouts \ $(top_builddir)/tools_layouts/.libs/libtools_layouts.a \
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
index 934b8030a229..c8af0c2d5dac 100644 index 46fa4e60916d..2f431156a45e 100644
--- a/mtcr_py/Makefile.am --- a/mtcr_py/Makefile.am
+++ b/mtcr_py/Makefile.am +++ b/mtcr_py/Makefile.am
@@ -40,7 +40,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR} @@ -35,6 +35,6 @@ mtcr_pylibdir = $(libdir)/mstflint/python_tools/
mtcr_pylib_DATA = cmtcr.so mtcr.py mtcr_pylib_DATA = cmtcr.so
dist_mtcr_pylib_DATA = mtcr.py dist_mtcr_pylib_DATA = mtcr.py
cmtcr.so: cmtcr.so:
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK) - $(CC) -g -Wall -pthread -shared ${CFLAGS} -o cmtcr.so -Wl,--whole-archive $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a -Wl,--no-whole-archive
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK) + $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} -o cmtcr.so -Wl,--whole-archive $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a -Wl,--no-whole-archive
CLEANFILES = cmtcr.so CLEANFILES = cmtcr.so
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
index c33bac653620..a231a6cd57e1 100644 index 8e38c473cc9c..6228b45af312 100644
--- a/reg_access/Makefile.am --- a/reg_access/Makefile.am
+++ b/reg_access/Makefile.am +++ b/reg_access/Makefile.am
@@ -56,7 +56,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py regaccess_structs.py @@ -57,7 +57,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO}
dist_reg_access_pylib_DATA = regaccess.py regaccess_structs.py dist_reg_access_pylib_DATA = regaccess.py regaccess_hca_ext_structs.py regaccess_switch_ext_structs.py
${RREG_ACCESS_SO}: libreg_access.a ${RREG_ACCESS_SO}: libreg_access.la
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${RREG_ACCESS_SO} \ - $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${RREG_ACCESS_SO} \
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${RREG_ACCESS_SO} \ + $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${RREG_ACCESS_SO} \
-L$(USER_DIR)/tools_layouts -ltools_layouts -lmlxconfig_4th_gen_layouts -L$(MTCR_DIR) -lmtcr_ul $(top_builddir)/tools_layouts/.libs/libtools_layouts.a $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a
CLEANFILES = ${RREG_ACCESS_SO} CLEANFILES = ${RREG_ACCESS_SO}
-- --
2.41.0 2.44.0

View File

@ -2,8 +2,8 @@
Name: mstflint Name: mstflint
Summary: Mellanox firmware burning tool Summary: Mellanox firmware burning tool
Version: 4.25.0 Version: 4.26.0
Release: 1%{?dist} Release: 2%{?dist}
License: GPLv2+ or BSD License: GPLv2+ or BSD
Url: https://github.com/Mellanox/%{name} Url: https://github.com/Mellanox/%{name}
Source0: https://github.com/Mellanox/%{name}/releases/download/v%{version}-1/%{name}-%{version}-1.tar.gz Source0: https://github.com/Mellanox/%{name}/releases/download/v%{version}-1/%{name}-%{version}-1.tar.gz
@ -53,6 +53,7 @@ find %{buildroot} -type f -name '*.a' -delete
# Mark these shared libs executable for find-debuginfo.sh to find them. # Mark these shared libs executable for find-debuginfo.sh to find them.
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Debuginfo/ # https://docs.fedoraproject.org/en-US/packaging-guidelines/Debuginfo/
chmod +x %{buildroot}/%{_libdir}/mstflint/python_tools/*.so chmod +x %{buildroot}/%{_libdir}/mstflint/python_tools/*.so
chmod +x %{buildroot}/%{_libdir}/mstflint/sdk/*.so
%files %files
%doc README %doc README
@ -64,6 +65,14 @@ chmod +x %{buildroot}/%{_libdir}/mstflint/python_tools/*.so
%{_mandir}/man1/* %{_mandir}/man1/*
%changelog %changelog
* Mon Apr 29 2024 Kamal Heib <kheib@redhat.com> - 4.26.0-2
- Fix debuginfo
- Resolves: RHEL-34752
* Fri Apr 26 2024 Kamal Heib <kheib@redhat.com> - 4.26.0-1
- Update to upstream release 4.26.0
- Resolves: RHEL-24470
* Thu Oct 19 2023 Kamal Heib <kheib@redhat.com> - 4.25.0-1 * Thu Oct 19 2023 Kamal Heib <kheib@redhat.com> - 4.25.0-1
- Update to upstream release 4.25.0 - Update to upstream release 4.25.0
- Resolves: RHEL-886 - Resolves: RHEL-886