Rebase mstflint to latest upstream release v4.18.0-1

Resolves: rhbz#2029269

Signed-off-by: Honggang Li <honli@redhat.com>
This commit is contained in:
Honggang Li 2021-12-05 22:12:23 -05:00
parent 59c827a4fd
commit 7a66230466
5 changed files with 21 additions and 16 deletions

1
.gitignore vendored
View File

@ -35,3 +35,4 @@ noarch/
/mstflint-4.15.0-1.tar.gz
/mstflint-4.16.0-1.tar.gz
/mstflint-4.17.0-1.tar.gz
/mstflint-4.18.0-1.tar.gz

View File

@ -1,8 +1,8 @@
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
index 0d8f53b..d800302 100644
index 9807603..b23bcb9 100644
--- a/cmdif/Makefile.am
+++ b/cmdif/Makefile.am
@@ -50,7 +50,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
@@ -51,7 +51,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
cmdif_pylibdir = $(libdir)/mstflint/python_tools/
cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py
${CCMDIF_SO}: libcmdif.a
@ -12,7 +12,7 @@ index 0d8f53b..d800302 100644
CLEANFILES = ${CCMDIF_SO}
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
index 3118b85..e708ad8 100644
index 1fbd142..df5b14a 100644
--- a/dev_mgt/Makefile.am
+++ b/dev_mgt/Makefile.am
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py
@ -25,10 +25,10 @@ index 3118b85..e708ad8 100644
-L$(USER_DIR)/tools_layouts -ltools_layouts \
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
index 351eb81..696e82a 100644
index 934b803..c8af0c2 100644
--- a/mtcr_py/Makefile.am
+++ b/mtcr_py/Makefile.am
@@ -39,7 +39,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
@@ -40,7 +40,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
mtcr_pylib_DATA = cmtcr.so mtcr.py
dist_mtcr_pylib_DATA = mtcr.py
cmtcr.so:
@ -38,7 +38,7 @@ index 351eb81..696e82a 100644
CLEANFILES = cmtcr.so
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
index f28290e..a141704 100644
index 26f6a5a..9a42c37 100644
--- a/reg_access/Makefile.am
+++ b/reg_access/Makefile.am
@@ -53,7 +53,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py

View File

@ -2,11 +2,11 @@
Name: mstflint
Summary: Mellanox firmware burning tool
Version: 4.17.0
Release: 2%{?dist}
Version: 4.18.0
Release: 1%{?dist}
License: GPLv2+ or BSD
Group: Applications/System
Source: https://github.com/Mellanox/mstflint/releases/download/v4.17.0-1/mstflint-4.17.0-1.tar.gz
Source: https://github.com/Mellanox/mstflint/releases/download/v4.18.0-1/mstflint-4.18.0-1.tar.gz
Patch4: add-default-link-flags-for-shared-libraries.patch
Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch
Url: https://github.com/Mellanox/mstflint
@ -25,7 +25,7 @@ This package contains firmware update tool, vpd dump and register dump tools
for network adapters based on Mellanox Technologies chips.
%prep
%setup -q -n mstflint-4.17.0
%setup -q -n mstflint-4.18.0
%patch4 -p1
%patch6 -p1
find . -type f -iname '*.[ch]' -exec chmod a-x '{}' ';'
@ -55,6 +55,10 @@ find %{buildroot} -type f -name '*.a' -delete
%{_mandir}/man1/*
%changelog
* Sun Dec 05 2021 Honggang Li <honli@redhat.com> - 4.18.0-1
- Rebase mstflint to latest upstream release v4.18.0-1
- Resolves: rhbz#2029269
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 4.17.0-2
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688

View File

@ -1,8 +1,8 @@
diff --git a/flint/subcommands.cpp b/flint/subcommands.cpp
index b47ff0a..d3a6561 100644
index 420b82f..0a20bcd 100644
--- a/flint/subcommands.cpp
+++ b/flint/subcommands.cpp
@@ -4626,7 +4626,7 @@ FlintStatus SgSubCommand::sgFs2()
@@ -4484,7 +4484,7 @@ FlintStatus SgSubCommand::sgFs2()
return FLINT_SUCCESS;
}
@ -12,11 +12,11 @@ index b47ff0a..d3a6561 100644
FlintStatus SgSubCommand::sgFs3()
{
diff --git a/mlxfwops/lib/flint_base.h b/mlxfwops/lib/flint_base.h
index 603d932..4dc12b8 100644
index f3edc43..a85e43d 100644
--- a/mlxfwops/lib/flint_base.h
+++ b/mlxfwops/lib/flint_base.h
@@ -388,7 +388,7 @@ struct BOARD_ID {
#define TRACER_HASH_SECT "Tracer Hash section"
@@ -364,7 +364,7 @@ struct GPH {
#define REBOOT_REQUIRED_STR "To load new FW run reboot machine."
#ifndef MST_UL
-#define REBOOT_OR_FWRESET_REQUIRED_STR "To load new FW run mlxfwreset or reboot machine."

View File

@ -1 +1 @@
SHA512 (mstflint-4.17.0-1.tar.gz) = d4c79cf2aa49ab47de745965087cecdb13b0fd6c48c9d994292c4b1f2f8717bb17e7bdafd72b0cb2fae46ae6f88ff43a42b2d5ca42216eff5b348513b7ae8e45
SHA512 (mstflint-4.18.0-1.tar.gz) = dd969ab80965b545b3204f431fda9c90db4aa7c03da3f822df0c8d0ced7c0277fce50d5f6943aba4ca4d5cebe09e0c013d5c132d5c503b44c9085866acaf599e