Rebase mstflint to latest upstream release v4.17.0-1

Resolves: rhbz#1858570

Signed-off-by: Honggang Li <honli@redhat.com>
This commit is contained in:
Honggang Li 2021-07-01 10:42:26 -04:00
parent 3a16d7ffcb
commit 6e4f21ca0c
5 changed files with 17 additions and 12 deletions

1
.gitignore vendored
View File

@ -34,3 +34,4 @@ noarch/
/mstflint-4.14.0-3.tar.gz
/mstflint-4.15.0-1.tar.gz
/mstflint-4.16.0-1.tar.gz
/mstflint-4.17.0-1.tar.gz

View File

@ -25,15 +25,15 @@ index 3118b85..e708ad8 100644
-L$(USER_DIR)/tools_layouts -ltools_layouts \
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
index 3b52f8a..d38885c 100644
index 351eb81..696e82a 100644
--- a/mtcr_py/Makefile.am
+++ b/mtcr_py/Makefile.am
@@ -39,7 +39,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
mtcr_pylib_DATA = cmtcr.so mtcr.py
dist_mtcr_pylib_DATA = mtcr.py
cmtcr.so:
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB)
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB)
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
CLEANFILES = cmtcr.so

View File

@ -2,11 +2,11 @@
Name: mstflint
Summary: Mellanox firmware burning tool
Version: 4.16.0
Release: 3%{?dist}
Version: 4.17.0
Release: 1%{?dist}
License: GPLv2+ or BSD
Group: Applications/System
Source: https://github.com/Mellanox/mstflint/releases/download/v4.16.0-1/mstflint-4.16.0-1.tar.gz
Source: https://github.com/Mellanox/mstflint/releases/download/v4.17.0-1/mstflint-4.17.0-1.tar.gz
Patch4: add-default-link-flags-for-shared-libraries.patch
Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch
Url: https://github.com/Mellanox/mstflint
@ -25,7 +25,7 @@ This package contains firmware update tool, vpd dump and register dump tools
for network adapters based on Mellanox Technologies chips.
%prep
%setup -q -n mstflint-4.16.0
%setup -q -n mstflint-4.17.0
%patch4 -p1
%patch6 -p1
find . -type f -iname '*.[ch]' -exec chmod a-x '{}' ';'
@ -55,6 +55,10 @@ find %{buildroot} -type f -name '*.a' -delete
%{_mandir}/man1/*
%changelog
* Thu Jul 01 2021 Honggang Li <honli@redhat.com> - 4.17.0-1
- Rebase mstflint to latest upstream release v4.17.0-1
- Resolves: rhbz#1858570
* Wed Jun 16 2021 Mohan Boddu <mboddu@redhat.com> - 4.16.0-3
- Rebuilt for RHEL 9 BETA for openssl 3.0
Related: rhbz#1971065

View File

@ -1,8 +1,8 @@
diff --git a/flint/subcommands.cpp b/flint/subcommands.cpp
index 3840579..3d2680b 100644
index b47ff0a..d3a6561 100644
--- a/flint/subcommands.cpp
+++ b/flint/subcommands.cpp
@@ -3018,7 +3018,7 @@ FlintStatus SgSubCommand::sgFs2()
@@ -4626,7 +4626,7 @@ FlintStatus SgSubCommand::sgFs2()
return FLINT_SUCCESS;
}
@ -12,10 +12,10 @@ index 3840579..3d2680b 100644
FlintStatus SgSubCommand::sgFs3()
{
diff --git a/mlxfwops/lib/flint_base.h b/mlxfwops/lib/flint_base.h
index be7a913..e7e7b64 100644
index 603d932..4dc12b8 100644
--- a/mlxfwops/lib/flint_base.h
+++ b/mlxfwops/lib/flint_base.h
@@ -395,7 +395,7 @@ struct BOARD_ID {
@@ -388,7 +388,7 @@ struct BOARD_ID {
#define TRACER_HASH_SECT "Tracer Hash section"
#define REBOOT_REQUIRED_STR "To load new FW run reboot machine."
#ifndef MST_UL

View File

@ -1 +1 @@
SHA512 (mstflint-4.16.0-1.tar.gz) = cb04d3097ee8bd89756882999a5df26e067660fe2e3461611c1dd820db7bf8cfdabddb95df36d0cbdd1a469966cac22a64e1e86bdec72d915999d0a77f62f30f
SHA512 (mstflint-4.17.0-1.tar.gz) = d4c79cf2aa49ab47de745965087cecdb13b0fd6c48c9d994292c4b1f2f8717bb17e7bdafd72b0cb2fae46ae6f88ff43a42b2d5ca42216eff5b348513b7ae8e45