import mstflint-4.15.0-1.el8
This commit is contained in:
parent
bd9b485206
commit
5de52a6b7e
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/mstflint-4.14.0-1.tar.gz
|
||||
SOURCES/mstflint-4.15.0-1.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
a40914d0212dba225576b83172ef9fec50db1150 SOURCES/mstflint-4.14.0-1.tar.gz
|
||||
ce1e561e20c0ceeabed7e5173bbe4cdb3042d8e3 SOURCES/mstflint-4.15.0-1.tar.gz
|
||||
|
@ -1,45 +0,0 @@
|
||||
From 28dfbf252a31b4e8c1d0f5e038f6889b7eadfc16 Mon Sep 17 00:00:00 2001
|
||||
From: Honggang Li <honli@redhat.com>
|
||||
Date: Wed, 1 Apr 2020 10:52:12 +0800
|
||||
Subject: [PATCH] Fix a format security compilation defect
|
||||
|
||||
subcommands.cpp:1852:42: error: format not a string literal and no format arguments [-Werror=format-security]
|
||||
1852 | false, "N/A").c_str());
|
||||
|
||||
Signed-off-by: Honggang Li <honli@redhat.com>
|
||||
---
|
||||
flint/subcommands.cpp | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/flint/subcommands.cpp b/flint/subcommands.cpp
|
||||
index 7230f9a59f94..0f6440be7b28 100755
|
||||
--- a/flint/subcommands.cpp
|
||||
+++ b/flint/subcommands.cpp
|
||||
@@ -1847,7 +1847,7 @@ bool BurnSubCommand::checkFwVersion(bool CreateFromImgInfo, u_int16_t fw_ver0, u
|
||||
char curr_ver[124], new_ver[124];
|
||||
printf("\n");
|
||||
printf(" Current FW version on flash: ");
|
||||
- snprintf(curr_ver, 124,
|
||||
+ snprintf(curr_ver, 124, "%s",
|
||||
current.get_fw_version(VERSION_FORMAT(_devInfo.fw_info.fw_ver[1]),
|
||||
false, "N/A").c_str());
|
||||
|
||||
@@ -1856,13 +1856,13 @@ bool BurnSubCommand::checkFwVersion(bool CreateFromImgInfo, u_int16_t fw_ver0, u
|
||||
|
||||
printf(" New FW version: ");
|
||||
if (CreateFromImgInfo) {
|
||||
- snprintf(new_ver, 124,
|
||||
+ snprintf(new_ver, 124, "%s",
|
||||
new_version.get_fw_version(
|
||||
VERSION_FORMAT(_imgInfo.fw_info.fw_ver[1]), false,
|
||||
"N/A").c_str());
|
||||
}
|
||||
else {
|
||||
- snprintf(new_ver, 124,
|
||||
+ snprintf(new_ver, 124, "%s",
|
||||
new_version.get_fw_version(VERSION_FORMAT(fw_ver1), false,
|
||||
"N/A").c_str());
|
||||
}
|
||||
--
|
||||
2.25.1
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
|
||||
index 0d8f53b..d800302 100644
|
||||
index d4f89a2..46604f5 100644
|
||||
--- a/cmdif/Makefile.am
|
||||
+++ b/cmdif/Makefile.am
|
||||
@@ -50,7 +50,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
|
||||
@@ -46,7 +46,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
|
||||
cmdif_pylibdir = $(libdir)/mstflint/python_tools/
|
||||
cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py
|
||||
${CCMDIF_SO}: libcmdif.a
|
||||
@ -12,7 +12,7 @@ index 0d8f53b..d800302 100644
|
||||
|
||||
CLEANFILES = ${CCMDIF_SO}
|
||||
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
|
||||
index 3118b85..e708ad8 100644
|
||||
index 907e5ce..a7e2249 100644
|
||||
--- a/dev_mgt/Makefile.am
|
||||
+++ b/dev_mgt/Makefile.am
|
||||
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py
|
||||
@ -37,135 +37,8 @@ index 5f5677d..566a870 100644
|
||||
|
||||
CLEANFILES = cmtcr.so
|
||||
|
||||
diff --git a/mvpd/Makefile.am b/mvpd/Makefile.am
|
||||
index e9fa5c6..fab1599 100755
|
||||
--- a/mvpd/Makefile.am
|
||||
+++ b/mvpd/Makefile.am
|
||||
@@ -1,61 +1,61 @@
|
||||
-#--
|
||||
-# Copyright (c) 2004-2010 Mellanox Technologies LTD. All rights reserved.
|
||||
-#
|
||||
-# This software is available to you under a choice of one of two
|
||||
-# licenses. You may choose to be licensed under the terms of the GNU
|
||||
-# General Public License (GPL) Version 2, available from the file
|
||||
-# COPYING in the main directory of this source tree, or the
|
||||
-# OpenIB.org BSD license below:
|
||||
-#
|
||||
-# Redistribution and use in source and binary forms, with or
|
||||
-# without modification, are permitted provided that the following
|
||||
-# conditions are met:
|
||||
-#
|
||||
-# - Redistributions of source code must retain the above
|
||||
-# copyright notice, this list of conditions and the following
|
||||
-# disclaimer.
|
||||
-#
|
||||
-# - Redistributions in binary form must reproduce the above
|
||||
-# copyright notice, this list of conditions and the following
|
||||
-# disclaimer in the documentation and/or other materials
|
||||
-# provided with the distribution.
|
||||
-#
|
||||
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
||||
-# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
|
||||
-# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
||||
-# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
|
||||
-# BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
|
||||
-# ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
|
||||
-# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
|
||||
-# SOFTWARE.
|
||||
-#--
|
||||
-
|
||||
-# Makefile.am -- Process this file with automake to produce Makefile.in
|
||||
-MTCR_DIR = $(top_srcdir)/${MTCR_CONF_DIR}
|
||||
-COMMON_DIR = $(top_srcdir)/common
|
||||
-LAYOUTS_DIR = $(top_srcdir)/tools_layouts
|
||||
-USER_DIR = $(top_srcdir)
|
||||
-
|
||||
-AM_CPPFLAGS = -I. -I$(USER_DIR) -I$(srcdir) -I$(LAYOUTS_DIR) -I$(USER_DIR)/include/mtcr_ul
|
||||
-AM_CFLAGS = -W -Wall -g -MP -MD $(COMPILER_FPIC)
|
||||
-
|
||||
-noinst_LTLIBRARIES = libmvpd.a
|
||||
-
|
||||
-libmvpd_a_SOURCES = mvpd.c mvpd.h
|
||||
-
|
||||
-libmvpd_a_DEPENDENCIES = $(MTCR_DIR)/libmtcr_ul.a
|
||||
-libmvpd_a_LIBADD = $(libmvpd_a_DEPENDENCIES)
|
||||
-
|
||||
-RMVPD_SO = rmvpd.so
|
||||
-
|
||||
-
|
||||
-LDADD= ../${MTCR_CONF_DIR}/libmtcr_ul.a ${LDL}
|
||||
-
|
||||
-
|
||||
-noinst_HEADERS = mvpd.h
|
||||
-
|
||||
-${RMVPD_SO}: libmvpd.a
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${RMVPD_SO} \
|
||||
- -L$(MTCR_DIR) -lmtcr_ul
|
||||
-
|
||||
-CLEANFILES = ${RMVPD_SO}
|
||||
+#--
|
||||
+# Copyright (c) 2004-2010 Mellanox Technologies LTD. All rights reserved.
|
||||
+#
|
||||
+# This software is available to you under a choice of one of two
|
||||
+# licenses. You may choose to be licensed under the terms of the GNU
|
||||
+# General Public License (GPL) Version 2, available from the file
|
||||
+# COPYING in the main directory of this source tree, or the
|
||||
+# OpenIB.org BSD license below:
|
||||
+#
|
||||
+# Redistribution and use in source and binary forms, with or
|
||||
+# without modification, are permitted provided that the following
|
||||
+# conditions are met:
|
||||
+#
|
||||
+# - Redistributions of source code must retain the above
|
||||
+# copyright notice, this list of conditions and the following
|
||||
+# disclaimer.
|
||||
+#
|
||||
+# - Redistributions in binary form must reproduce the above
|
||||
+# copyright notice, this list of conditions and the following
|
||||
+# disclaimer in the documentation and/or other materials
|
||||
+# provided with the distribution.
|
||||
+#
|
||||
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
||||
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
|
||||
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
||||
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
|
||||
+# BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
|
||||
+# ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
|
||||
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
|
||||
+# SOFTWARE.
|
||||
+#--
|
||||
+
|
||||
+# Makefile.am -- Process this file with automake to produce Makefile.in
|
||||
+MTCR_DIR = $(top_srcdir)/${MTCR_CONF_DIR}
|
||||
+COMMON_DIR = $(top_srcdir)/common
|
||||
+LAYOUTS_DIR = $(top_srcdir)/tools_layouts
|
||||
+USER_DIR = $(top_srcdir)
|
||||
+
|
||||
+AM_CPPFLAGS = -I. -I$(USER_DIR) -I$(srcdir) -I$(LAYOUTS_DIR) -I$(USER_DIR)/include/mtcr_ul
|
||||
+AM_CFLAGS = -W -Wall -g -MP -MD $(COMPILER_FPIC)
|
||||
+
|
||||
+noinst_LTLIBRARIES = libmvpd.a
|
||||
+
|
||||
+libmvpd_a_SOURCES = mvpd.c mvpd.h
|
||||
+
|
||||
+libmvpd_a_DEPENDENCIES = $(MTCR_DIR)/libmtcr_ul.a
|
||||
+libmvpd_a_LIBADD = $(libmvpd_a_DEPENDENCIES)
|
||||
+
|
||||
+RMVPD_SO = rmvpd.so
|
||||
+
|
||||
+
|
||||
+LDADD= ../${MTCR_CONF_DIR}/libmtcr_ul.a ${LDL}
|
||||
+
|
||||
+
|
||||
+noinst_HEADERS = mvpd.h
|
||||
+
|
||||
+${RMVPD_SO}: libmvpd.a
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${RMVPD_SO} \
|
||||
+ -L$(MTCR_DIR) -lmtcr_ul
|
||||
+
|
||||
+CLEANFILES = ${RMVPD_SO}
|
||||
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
|
||||
index f28290e..a141704 100644
|
||||
index 353fe02..7d70fd8 100644
|
||||
--- a/reg_access/Makefile.am
|
||||
+++ b/reg_access/Makefile.am
|
||||
@@ -53,7 +53,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff --git a/flint/subcommands.cpp b/flint/subcommands.cpp
|
||||
index 9dd3afd..076879a 100755
|
||||
index 3840579..3d2680b 100644
|
||||
--- a/flint/subcommands.cpp
|
||||
+++ b/flint/subcommands.cpp
|
||||
@@ -3103,7 +3103,7 @@ FlintStatus SgSubCommand::sgFs2()
|
||||
@@ -3018,7 +3018,7 @@ FlintStatus SgSubCommand::sgFs2()
|
||||
return FLINT_SUCCESS;
|
||||
}
|
||||
|
||||
@ -11,3 +11,16 @@ index 9dd3afd..076879a 100755
|
||||
|
||||
FlintStatus SgSubCommand::sgFs3()
|
||||
{
|
||||
diff --git a/mlxfwops/lib/flint_base.h b/mlxfwops/lib/flint_base.h
|
||||
index be7a913..e7e7b64 100644
|
||||
--- a/mlxfwops/lib/flint_base.h
|
||||
+++ b/mlxfwops/lib/flint_base.h
|
||||
@@ -395,7 +395,7 @@ struct BOARD_ID {
|
||||
#define TRACER_HASH_SECT "Tracer Hash section"
|
||||
#define REBOOT_REQUIRED_STR "To load new FW run reboot machine."
|
||||
#ifndef MST_UL
|
||||
-#define REBOOT_OR_FWRESET_REQUIRED_STR "To load new FW run mlxfwreset or reboot machine."
|
||||
+#define REBOOT_OR_FWRESET_REQUIRED_STR "To load new FW run mstfwreset or reboot machine."
|
||||
#else
|
||||
#define REBOOT_OR_FWRESET_REQUIRED_STR "To load new FW run mstfwreset or reboot machine."
|
||||
#endif
|
||||
|
@ -2,16 +2,15 @@
|
||||
|
||||
Name: mstflint
|
||||
Summary: Mellanox firmware burning tool
|
||||
Version: 4.14.0
|
||||
Version: 4.15.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ or BSD
|
||||
Group: Applications/System
|
||||
Source: https://github.com/Mellanox/mstflint/releases/download/v4.14.0-1/mstflint-4.14.0-1.tar.gz
|
||||
Source: https://github.com/Mellanox/mstflint/releases/download/v4.15.0-1/mstflint-4.15.0-1.tar.gz
|
||||
Patch2: 0001-Fix-shebang-for-python-scripts.patch
|
||||
Patch3: extend-buffer.patch
|
||||
Patch4: add-default-link-flags-for-shared-libraries.patch
|
||||
Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch
|
||||
Patch7: 0001-Fix-a-format-security-compilation-defect.patch
|
||||
Url: https://github.com/Mellanox/mstflint
|
||||
BuildRequires: libstdc++-devel, zlib-devel, libibmad-devel, gcc-c++, gcc
|
||||
BuildRequires: libcurl-devel, boost-devel, libxml2-devel, openssl-devel
|
||||
@ -27,12 +26,11 @@ This package contains firmware update tool, vpd dump and register dump tools
|
||||
for network adapters based on Mellanox Technologies chips.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%setup -q -n mstflint-4.15.0
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
find . -type f -iname '*.[ch]' -exec chmod a-x '{}' ';'
|
||||
find . -type f -iname '*.cpp' -exec chmod a-x '{}' ';'
|
||||
|
||||
@ -44,7 +42,7 @@ find . -type f -iname '*.cpp' -exec chmod a-x '{}' ';'
|
||||
%make_build
|
||||
|
||||
%install
|
||||
make DESTDIR=%{buildroot} install
|
||||
%make_install
|
||||
# Remove the devel files that we don't ship
|
||||
rm -fr %{buildroot}%{_includedir}
|
||||
find %{buildroot} -type f -name '*.la' -delete
|
||||
@ -60,6 +58,10 @@ find %{buildroot} -type f -name '*.a' -delete
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Thu Nov 05 2020 Honggang Li <honli@redhat.com> - 4.15.0-1
|
||||
- Rebase to latest upstream release v4.15.0-1
|
||||
- Resolves: bz1851723
|
||||
|
||||
* Thu Apr 16 2020 Honggang Li <honli@redhat.com> - 4.14.0-1
|
||||
- Rebase to latest upstream release v4.14.0-1
|
||||
- Resolves: bz1789386
|
||||
|
Loading…
Reference in New Issue
Block a user