Update to upstream release 4.26.0
Resolves: RHEL-24816 Signed-off-by: Kamal Heib <kheib@redhat.com>
This commit is contained in:
parent
4b0184a994
commit
5be4636a52
1
.gitignore
vendored
1
.gitignore
vendored
@ -44,3 +44,4 @@ noarch/
|
||||
/mstflint-4.23.0-1.tar.gz
|
||||
/mstflint-4.24.0-1.tar.gz
|
||||
/mstflint-4.25.0-1.tar.gz
|
||||
/mstflint-4.26.0-1.tar.gz
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 6d7cfeb8cfe35bc0e92af26be5f71629b60f2584 Mon Sep 17 00:00:00 2001
|
||||
From: Kamal Heib <kheib@redhat.com>
|
||||
Date: Mon, 16 Oct 2023 22:38:02 -0400
|
||||
Subject: [PATCH] mflash: Fix build failure
|
||||
|
||||
Fix the following failure:
|
||||
|
||||
mflash_dev_capability.c:43:1: note: 'getenv' is defined in header '<stdlib.h>';
|
||||
did you forget to '#include <stdlib.h>'?
|
||||
42 | #include "mflash_dev_capability.h"
|
||||
+++ |+#include <stdlib.h>
|
||||
43 |
|
||||
|
||||
Signed-off-by: Kamal Heib <kheib@redhat.com>
|
||||
---
|
||||
mflash/mflash_dev_capability.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/mflash/mflash_dev_capability.c b/mflash/mflash_dev_capability.c
|
||||
index ff3c8bcf82ea..52e3e0ea7fc3 100644
|
||||
--- a/mflash/mflash_dev_capability.c
|
||||
+++ b/mflash/mflash_dev_capability.c
|
||||
@@ -40,6 +40,7 @@
|
||||
*/
|
||||
|
||||
#include "mflash_dev_capability.h"
|
||||
+#include <stdlib.h>
|
||||
|
||||
// When (*status != MFE_OK) return value is undefined
|
||||
int is_four_byte_address_needed(mflash* mfl, MfError* status)
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 0bf822388a194c01c82beb6b6529b49255a4bd39 Mon Sep 17 00:00:00 2001
|
||||
From a91f8252d007aa0d8b2d211ea0061a60ad003c73 Mon Sep 17 00:00:00 2001
|
||||
From: Kamal Heib <kheib@redhat.com>
|
||||
Date: Tue, 17 Oct 2023 14:19:52 -0400
|
||||
Subject: [PATCH] Add default link flags for shared libraries
|
||||
@ -12,57 +12,56 @@ Signed-off-by: Kamal Heib <kheib@redhat.com>
|
||||
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
|
||||
index b6c43d59c8b5..0e03839459f2 100644
|
||||
index 7bb332aada48..3ffdf7d6653e 100644
|
||||
--- a/cmdif/Makefile.am
|
||||
+++ b/cmdif/Makefile.am
|
||||
@@ -51,7 +51,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
|
||||
@@ -53,7 +53,7 @@ libcmdif_la_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.
|
||||
cmdif_pylibdir = $(libdir)/mstflint/python_tools/
|
||||
cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py
|
||||
${CCMDIF_SO}: libcmdif.a
|
||||
${CCMDIF_SO}: libcmdif.la
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${CCMDIF_SO} \
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${CCMDIF_SO} \
|
||||
-L$(USER_DIR)/tools_layouts -ltools_layouts -L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
||||
$(top_builddir)/tools_layouts/.libs/libtools_layouts.a $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a
|
||||
|
||||
CLEANFILES = ${CCMDIF_SO}
|
||||
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
|
||||
index 2283c2d1c763..ab8910dfc435 100644
|
||||
index a5f66e9fd935..0d1417daa647 100644
|
||||
--- a/dev_mgt/Makefile.am
|
||||
+++ b/dev_mgt/Makefile.am
|
||||
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py
|
||||
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so
|
||||
dist_dev_mgt_pylib_DATA = dev_mgt.py
|
||||
|
||||
c_dev_mgt.so: libdev_mgt.a
|
||||
c_dev_mgt.so: libdev_mgt.la
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} tools_dev_types.o -o c_dev_mgt.so \
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} tools_dev_types.o -o c_dev_mgt.so \
|
||||
-L$(USER_DIR)/reg_access -lreg_access \
|
||||
-L$(USER_DIR)/tools_layouts -ltools_layouts \
|
||||
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
||||
$(top_builddir)/reg_access/.libs/libreg_access.a \
|
||||
$(top_builddir)/tools_layouts/.libs/libtools_layouts.a \
|
||||
$(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a
|
||||
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
|
||||
index 934b8030a229..c8af0c2d5dac 100644
|
||||
index 46fa4e60916d..2f431156a45e 100644
|
||||
--- a/mtcr_py/Makefile.am
|
||||
+++ b/mtcr_py/Makefile.am
|
||||
@@ -40,7 +40,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
|
||||
mtcr_pylib_DATA = cmtcr.so mtcr.py
|
||||
@@ -35,6 +35,6 @@ mtcr_pylibdir = $(libdir)/mstflint/python_tools/
|
||||
mtcr_pylib_DATA = cmtcr.so
|
||||
dist_mtcr_pylib_DATA = mtcr.py
|
||||
cmtcr.so:
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} -o cmtcr.so -Wl,--whole-archive $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a -Wl,--no-whole-archive
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} -o cmtcr.so -Wl,--whole-archive $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a -Wl,--no-whole-archive
|
||||
|
||||
CLEANFILES = cmtcr.so
|
||||
|
||||
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
|
||||
index c33bac653620..a231a6cd57e1 100644
|
||||
index 8e38c473cc9c..6228b45af312 100644
|
||||
--- a/reg_access/Makefile.am
|
||||
+++ b/reg_access/Makefile.am
|
||||
@@ -56,7 +56,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py regaccess_structs.py
|
||||
dist_reg_access_pylib_DATA = regaccess.py regaccess_structs.py
|
||||
@@ -57,7 +57,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO}
|
||||
dist_reg_access_pylib_DATA = regaccess.py regaccess_hca_ext_structs.py regaccess_switch_ext_structs.py
|
||||
|
||||
${RREG_ACCESS_SO}: libreg_access.a
|
||||
${RREG_ACCESS_SO}: libreg_access.la
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${RREG_ACCESS_SO} \
|
||||
-L$(USER_DIR)/tools_layouts -ltools_layouts -lmlxconfig_4th_gen_layouts -L$(MTCR_DIR) -lmtcr_ul
|
||||
$(top_builddir)/tools_layouts/.libs/libtools_layouts.a $(top_builddir)/${MTCR_CONF_DIR}/.libs/libmtcr_ul.a
|
||||
|
||||
CLEANFILES = ${RREG_ACCESS_SO}
|
||||
--
|
||||
2.41.0
|
||||
2.44.0
|
||||
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
Name: mstflint
|
||||
Summary: Mellanox firmware burning tool
|
||||
Version: 4.25.0
|
||||
Version: 4.26.0
|
||||
Release: %autorelease
|
||||
# COPYING says the license is your choice of OpenIB.org BSD or GPLv2.
|
||||
# kernel/Makefile has the 3-clause BSD.
|
||||
@ -13,7 +13,6 @@ Url: https://github.com/Mellanox/%{name}
|
||||
Source0: https://github.com/Mellanox/%{name}/releases/download/v%{version}-1/%{name}-%{version}-1.tar.gz
|
||||
Group: Applications/System
|
||||
|
||||
patch1: 0001-mflash-Fix-build-failure.patch
|
||||
Patch4: add-default-link-flags-for-shared-libraries.patch
|
||||
Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch
|
||||
|
||||
@ -35,7 +34,6 @@ for network adapters based on Mellanox Technologies chips.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
|
||||
%patch1 -p1
|
||||
%patch4 -p1
|
||||
%patch6 -p1
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mstflint-4.25.0-1.tar.gz) = 1665e7f8645adffa30376d8a312685fa2316947ede3d0a9fcc0a29d8c32a2a7218bf23a22d8566eab3c7096afe9a1cc7298c82f6182076f723ae45d4c6e8ffe4
|
||||
SHA512 (mstflint-4.26.0-1.tar.gz) = 6ba357f5ed3a8c5ac4195b7b45c5abad3eb95d549f5bd2cc8ae84dee7dab894c47839a3ce3aec04bdaa4942ca953bb148a68cf72c2e9d4e60e090595c96c163e
|
||||
|
Loading…
Reference in New Issue
Block a user