Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/mstflint.git#150a8840bd6b34b754df53373bc92f9d9238b32a
This commit is contained in:
parent
0ef60979d6
commit
465ff3657d
1
.gitignore
vendored
1
.gitignore
vendored
@ -33,3 +33,4 @@ noarch/
|
||||
/mstflint-4.14.0-1.tar.gz
|
||||
/mstflint-4.14.0-3.tar.gz
|
||||
/mstflint-4.15.0-1.tar.gz
|
||||
/mstflint-4.16.0-1.tar.gz
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
|
||||
index d4f89a2..46604f5 100644
|
||||
index 0d8f53b..d800302 100644
|
||||
--- a/cmdif/Makefile.am
|
||||
+++ b/cmdif/Makefile.am
|
||||
@@ -46,7 +46,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
|
||||
@@ -50,7 +50,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
|
||||
cmdif_pylibdir = $(libdir)/mstflint/python_tools/
|
||||
cmdif_pylib_DATA = ${CCMDIF_SO} cmdif.py
|
||||
${CCMDIF_SO}: libcmdif.a
|
||||
@ -12,7 +12,7 @@ index d4f89a2..46604f5 100644
|
||||
|
||||
CLEANFILES = ${CCMDIF_SO}
|
||||
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
|
||||
index 907e5ce..a7e2249 100644
|
||||
index 3118b85..e708ad8 100644
|
||||
--- a/dev_mgt/Makefile.am
|
||||
+++ b/dev_mgt/Makefile.am
|
||||
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py
|
||||
@ -25,20 +25,20 @@ index 907e5ce..a7e2249 100644
|
||||
-L$(USER_DIR)/tools_layouts -ltools_layouts \
|
||||
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
||||
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
|
||||
index 5f5677d..566a870 100644
|
||||
index 3b52f8a..d38885c 100644
|
||||
--- a/mtcr_py/Makefile.am
|
||||
+++ b/mtcr_py/Makefile.am
|
||||
@@ -39,7 +39,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
|
||||
mtcr_pylib_DATA = cmtcr.so mtcr.py
|
||||
dist_mtcr_pylib_DATA = mtcr.py
|
||||
cmtcr.so:
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so
|
||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB)
|
||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB)
|
||||
|
||||
CLEANFILES = cmtcr.so
|
||||
|
||||
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
|
||||
index 353fe02..7d70fd8 100644
|
||||
index f28290e..a141704 100644
|
||||
--- a/reg_access/Makefile.am
|
||||
+++ b/reg_access/Makefile.am
|
||||
@@ -53,7 +53,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/ext_libs/iniParser/iniparser.c b/ext_libs/iniParser/iniparser.c
|
||||
index 8bc0a18..f981775 100644
|
||||
--- a/ext_libs/iniParser/iniparser.c
|
||||
+++ b/ext_libs/iniParser/iniparser.c
|
||||
@@ -572,7 +572,7 @@ dictionary * iniparser_load(const char * ininame)
|
||||
char line [ASCIILINESZ+1] ;
|
||||
char section [ASCIILINESZ+1] ;
|
||||
char key [ASCIILINESZ+1] ;
|
||||
- char tmp [ASCIILINESZ+1] ;
|
||||
+ char tmp [(ASCIILINESZ+1)*2] ;
|
||||
char val [ASCIILINESZ+1] ;
|
||||
|
||||
int last=0 ;
|
@ -2,15 +2,15 @@
|
||||
|
||||
Name: mstflint
|
||||
Summary: Mellanox firmware burning tool
|
||||
Version: 4.15.0
|
||||
Version: 4.16.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ or BSD
|
||||
Group: Applications/System
|
||||
Source: https://github.com/Mellanox/mstflint/releases/download/v4.15.0-1/mstflint-4.15.0-1.tar.gz
|
||||
Patch3: extend-buffer.patch
|
||||
Source: https://github.com/Mellanox/mstflint/releases/download/v4.16.0-1/mstflint-4.16.0-1.tar.gz
|
||||
Patch4: add-default-link-flags-for-shared-libraries.patch
|
||||
Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch
|
||||
Url: https://github.com/Mellanox/mstflint
|
||||
BuildRequires: make
|
||||
BuildRequires: libstdc++-devel, zlib-devel, libibmad-devel, gcc-c++, gcc
|
||||
BuildRequires: libcurl-devel, boost-devel, libxml2-devel, openssl-devel
|
||||
%if %{__remake_config}
|
||||
@ -25,8 +25,7 @@ This package contains firmware update tool, vpd dump and register dump tools
|
||||
for network adapters based on Mellanox Technologies chips.
|
||||
|
||||
%prep
|
||||
%setup -q -n mstflint-4.15.0
|
||||
%patch3 -p1
|
||||
%setup -q -n mstflint-4.16.0
|
||||
%patch4 -p1
|
||||
%patch6 -p1
|
||||
find . -type f -iname '*.[ch]' -exec chmod a-x '{}' ';'
|
||||
@ -56,6 +55,12 @@ find %{buildroot} -type f -name '*.a' -delete
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Sun Jan 31 2021 Honggang Li <honli@redhat.com> - 4.16.0-1
|
||||
- Rebase mstflint to latest upstream release v4.16.0-1
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.15.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Sep 16 2020 Honggang Li <honli@redhat.com> - 4.15.0-1
|
||||
- Rebase mstflint to latest upstream release v4.15.0-1
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mstflint-4.15.0-1.tar.gz) = 00a7302132ab6c4dd0d743dfa9a07c7468e8515f8f851a0a5f6ad2ae797e5a3a33142a8c8fb60a0286131054c14253baf92c96cbb051cf9231431062057249b2
|
||||
SHA512 (mstflint-4.16.0-1.tar.gz) = cb04d3097ee8bd89756882999a5df26e067660fe2e3461611c1dd820db7bf8cfdabddb95df36d0cbdd1a469966cac22a64e1e86bdec72d915999d0a77f62f30f
|
||||
|
Loading…
Reference in New Issue
Block a user