Update to upstream release 4.25.0

Signed-off-by: Kamal Heib <kheib@redhat.com>
This commit is contained in:
Kamal Heib 2023-10-16 19:02:09 -04:00
parent 2f2ee24fbd
commit 2cd40784ba
5 changed files with 62 additions and 10 deletions

1
.gitignore vendored
View File

@ -43,3 +43,4 @@ noarch/
/mstflint-4.21.0-1.tar.gz
/mstflint-4.23.0-1.tar.gz
/mstflint-4.24.0-1.tar.gz
/mstflint-4.25.0-1.tar.gz

View File

@ -0,0 +1,33 @@
From 6d7cfeb8cfe35bc0e92af26be5f71629b60f2584 Mon Sep 17 00:00:00 2001
From: Kamal Heib <kheib@redhat.com>
Date: Mon, 16 Oct 2023 22:38:02 -0400
Subject: [PATCH] mflash: Fix build failure
Fix the following failure:
mflash_dev_capability.c:43:1: note: 'getenv' is defined in header '<stdlib.h>';
did you forget to '#include <stdlib.h>'?
42 | #include "mflash_dev_capability.h"
+++ |+#include <stdlib.h>
43 |
Signed-off-by: Kamal Heib <kheib@redhat.com>
---
mflash/mflash_dev_capability.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/mflash/mflash_dev_capability.c b/mflash/mflash_dev_capability.c
index ff3c8bcf82ea..52e3e0ea7fc3 100644
--- a/mflash/mflash_dev_capability.c
+++ b/mflash/mflash_dev_capability.c
@@ -40,6 +40,7 @@
*/
#include "mflash_dev_capability.h"
+#include <stdlib.h>
// When (*status != MFE_OK) return value is undefined
int is_four_byte_address_needed(mflash* mfl, MfError* status)
--
2.41.0

View File

@ -1,5 +1,18 @@
From 0bf822388a194c01c82beb6b6529b49255a4bd39 Mon Sep 17 00:00:00 2001
From: Kamal Heib <kheib@redhat.com>
Date: Tue, 17 Oct 2023 14:19:52 -0400
Subject: [PATCH] Add default link flags for shared libraries
Signed-off-by: Kamal Heib <kheib@redhat.com>
---
cmdif/Makefile.am | 2 +-
dev_mgt/Makefile.am | 2 +-
mtcr_py/Makefile.am | 2 +-
reg_access/Makefile.am | 2 +-
4 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/cmdif/Makefile.am b/cmdif/Makefile.am
index 9807603..b23bcb9 100644
index b6c43d59c8b5..0e03839459f2 100644
--- a/cmdif/Makefile.am
+++ b/cmdif/Makefile.am
@@ -51,7 +51,7 @@ libcmdif_a_SOURCES = tools_cif.c tools_cif.h icmd_cif_common.c icmd_cif_common.h
@ -12,7 +25,7 @@ index 9807603..b23bcb9 100644
CLEANFILES = ${CCMDIF_SO}
diff --git a/dev_mgt/Makefile.am b/dev_mgt/Makefile.am
index 1fbd142..df5b14a 100644
index 2283c2d1c763..ab8910dfc435 100644
--- a/dev_mgt/Makefile.am
+++ b/dev_mgt/Makefile.am
@@ -50,7 +50,7 @@ dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py
@ -25,7 +38,7 @@ index 1fbd142..df5b14a 100644
-L$(USER_DIR)/tools_layouts -ltools_layouts \
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
index 934b803..c8af0c2 100644
index 934b8030a229..c8af0c2d5dac 100644
--- a/mtcr_py/Makefile.am
+++ b/mtcr_py/Makefile.am
@@ -40,7 +40,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
@ -38,15 +51,18 @@ index 934b803..c8af0c2 100644
CLEANFILES = cmtcr.so
diff --git a/reg_access/Makefile.am b/reg_access/Makefile.am
index 26f6a5a..9a42c37 100644
index c33bac653620..a231a6cd57e1 100644
--- a/reg_access/Makefile.am
+++ b/reg_access/Makefile.am
@@ -53,7 +53,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py
dist_reg_access_pylib_DATA = regaccess.py
@@ -56,7 +56,7 @@ reg_access_pylib_DATA = ${RREG_ACCESS_SO} regaccess.py regaccess_structs.py
dist_reg_access_pylib_DATA = regaccess.py regaccess_structs.py
${RREG_ACCESS_SO}: libreg_access.a
- $(CC) -g -Wall -pthread -shared ${CFLAGS} *.o -o ${RREG_ACCESS_SO} \
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} *.o -o ${RREG_ACCESS_SO} \
-L$(USER_DIR)/tools_layouts -ltools_layouts -lmlxconfig_4th_gen_layouts -L$(MTCR_DIR) -lmtcr_ul
-L$(USER_DIR)/tools_layouts -ltools_layouts -lmlxconfig_4th_gen_layouts -L$(MTCR_DIR) -lmtcr_ul
CLEANFILES = ${RREG_ACCESS_SO}
--
2.41.0

View File

@ -2,14 +2,15 @@
Name: mstflint
Summary: Mellanox firmware burning tool
Version: 4.24.0
Version: 4.25.0
Release: %autorelease
License: GPLv2+ or BSD
Url: https://github.com/Mellanox/%{name}
Source0: https://github.com/Mellanox/%{name}/releases/download/v%{version}-1/%{name}-%{version}-1.tar.gz
Group: Applications/System
Patch4: add-default-link-flags-for-shared-libraries.patch
patch1: 0001-mflash-Fix-build-failure.patch
Patch4: add-default-link-flags-for-shared-libraries.patch
Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch
BuildRequires: make
@ -30,6 +31,7 @@ for network adapters based on Mellanox Technologies chips.
%prep
%setup -q -n %{name}-%{version}
%patch1 -p1
%patch4 -p1
%patch6 -p1

View File

@ -1 +1 @@
SHA512 (mstflint-4.24.0-1.tar.gz) = 143dd558e9b57e26d25459885957422b650dc2cdc5b0069b77d1cda07d3da4161a57b10b7d38fffe609c23c7905611ec04834f9c06174a7ba7462dd71085c3b5
SHA512 (mstflint-4.25.0-1.tar.gz) = 1665e7f8645adffa30376d8a312685fa2316947ede3d0a9fcc0a29d8c32a2a7218bf23a22d8566eab3c7096afe9a1cc7298c82f6182076f723ae45d4c6e8ffe4