Rebase mstflint to latest upstream release v4.17.0-1
Signed-off-by: Honggang Li <honli@redhat.com>
This commit is contained in:
parent
9754d4e012
commit
23d029bf91
1
.gitignore
vendored
1
.gitignore
vendored
@ -35,3 +35,4 @@ noarch/
|
|||||||
/mstflint-4.15.0-1.tar.gz
|
/mstflint-4.15.0-1.tar.gz
|
||||||
/mstflint-4.16.0-1.tar.gz
|
/mstflint-4.16.0-1.tar.gz
|
||||||
/mstflint-4.16.0-2.tar.gz
|
/mstflint-4.16.0-2.tar.gz
|
||||||
|
/mstflint-4.17.0-1.tar.gz
|
||||||
|
@ -25,15 +25,15 @@ index 3118b85..e708ad8 100644
|
|||||||
-L$(USER_DIR)/tools_layouts -ltools_layouts \
|
-L$(USER_DIR)/tools_layouts -ltools_layouts \
|
||||||
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
-L$(USER_DIR)/${MTCR_CONF_DIR} -lmtcr_ul
|
||||||
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
|
diff --git a/mtcr_py/Makefile.am b/mtcr_py/Makefile.am
|
||||||
index 3b52f8a..d38885c 100644
|
index 351eb81..696e82a 100644
|
||||||
--- a/mtcr_py/Makefile.am
|
--- a/mtcr_py/Makefile.am
|
||||||
+++ b/mtcr_py/Makefile.am
|
+++ b/mtcr_py/Makefile.am
|
||||||
@@ -39,7 +39,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
|
@@ -39,7 +39,7 @@ MTCR_DIR = $(USER_DIR)/${MTCR_CONF_DIR}
|
||||||
mtcr_pylib_DATA = cmtcr.so mtcr.py
|
mtcr_pylib_DATA = cmtcr.so mtcr.py
|
||||||
dist_mtcr_pylib_DATA = mtcr.py
|
dist_mtcr_pylib_DATA = mtcr.py
|
||||||
cmtcr.so:
|
cmtcr.so:
|
||||||
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB)
|
- $(CC) -g -Wall -pthread -shared ${CFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
|
||||||
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB)
|
+ $(CC) -g -Wall -pthread -shared ${CFLAGS} ${LDFLAGS} $(MTCR_DIR)/*.o -o cmtcr.so $(MFT_CORE_LIB_LINK)
|
||||||
|
|
||||||
CLEANFILES = cmtcr.so
|
CLEANFILES = cmtcr.so
|
||||||
|
|
||||||
|
@ -2,11 +2,11 @@
|
|||||||
|
|
||||||
Name: mstflint
|
Name: mstflint
|
||||||
Summary: Mellanox firmware burning tool
|
Summary: Mellanox firmware burning tool
|
||||||
Version: 4.16.0
|
Version: 4.17.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ or BSD
|
License: GPLv2+ or BSD
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Source: https://github.com/Mellanox/mstflint/releases/download/v4.16.0-2/mstflint-4.16.0-2.tar.gz
|
Source: https://github.com/Mellanox/mstflint/releases/download/v4.17.0-1/mstflint-4.17.0-1.tar.gz
|
||||||
Patch4: add-default-link-flags-for-shared-libraries.patch
|
Patch4: add-default-link-flags-for-shared-libraries.patch
|
||||||
Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch
|
Patch6: replace-mlxfwreset-with-mstfwreset-in-mstflint-message.patch
|
||||||
Url: https://github.com/Mellanox/mstflint
|
Url: https://github.com/Mellanox/mstflint
|
||||||
@ -25,7 +25,7 @@ This package contains firmware update tool, vpd dump and register dump tools
|
|||||||
for network adapters based on Mellanox Technologies chips.
|
for network adapters based on Mellanox Technologies chips.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n mstflint-4.16.0
|
%setup -q -n mstflint-4.17.0
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
find . -type f -iname '*.[ch]' -exec chmod a-x '{}' ';'
|
find . -type f -iname '*.[ch]' -exec chmod a-x '{}' ';'
|
||||||
@ -55,6 +55,9 @@ find %{buildroot} -type f -name '*.a' -delete
|
|||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 01 2021 Honggang Li <honli@redhat.com> - 4.17.0-1
|
||||||
|
- Rebase mstflint to latest upstream release v4.17.0-1
|
||||||
|
|
||||||
* Wed Apr 07 2021 Honggang Li <honli@redhat.com> - 4.16.0-2
|
* Wed Apr 07 2021 Honggang Li <honli@redhat.com> - 4.16.0-2
|
||||||
- Rebase mstflint to latest upstream release v4.16.0-2
|
- Rebase mstflint to latest upstream release v4.16.0-2
|
||||||
|
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
diff --git a/flint/subcommands.cpp b/flint/subcommands.cpp
|
diff --git a/flint/subcommands.cpp b/flint/subcommands.cpp
|
||||||
index 3840579..3d2680b 100644
|
index b47ff0a..d3a6561 100644
|
||||||
--- a/flint/subcommands.cpp
|
--- a/flint/subcommands.cpp
|
||||||
+++ b/flint/subcommands.cpp
|
+++ b/flint/subcommands.cpp
|
||||||
@@ -3018,7 +3018,7 @@ FlintStatus SgSubCommand::sgFs2()
|
@@ -4626,7 +4626,7 @@ FlintStatus SgSubCommand::sgFs2()
|
||||||
return FLINT_SUCCESS;
|
return FLINT_SUCCESS;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -12,10 +12,10 @@ index 3840579..3d2680b 100644
|
|||||||
FlintStatus SgSubCommand::sgFs3()
|
FlintStatus SgSubCommand::sgFs3()
|
||||||
{
|
{
|
||||||
diff --git a/mlxfwops/lib/flint_base.h b/mlxfwops/lib/flint_base.h
|
diff --git a/mlxfwops/lib/flint_base.h b/mlxfwops/lib/flint_base.h
|
||||||
index be7a913..e7e7b64 100644
|
index 603d932..4dc12b8 100644
|
||||||
--- a/mlxfwops/lib/flint_base.h
|
--- a/mlxfwops/lib/flint_base.h
|
||||||
+++ b/mlxfwops/lib/flint_base.h
|
+++ b/mlxfwops/lib/flint_base.h
|
||||||
@@ -395,7 +395,7 @@ struct BOARD_ID {
|
@@ -388,7 +388,7 @@ struct BOARD_ID {
|
||||||
#define TRACER_HASH_SECT "Tracer Hash section"
|
#define TRACER_HASH_SECT "Tracer Hash section"
|
||||||
#define REBOOT_REQUIRED_STR "To load new FW run reboot machine."
|
#define REBOOT_REQUIRED_STR "To load new FW run reboot machine."
|
||||||
#ifndef MST_UL
|
#ifndef MST_UL
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mstflint-4.16.0-2.tar.gz) = 9e6b979a12429e91274a64b74d2986c189e282e63839b911d4be3d81558e12efd1e288c28c00d1a66fa45897b1c6eb7d9231cc093569557c2a5015f681c13832
|
SHA512 (mstflint-4.17.0-1.tar.gz) = d4c79cf2aa49ab47de745965087cecdb13b0fd6c48c9d994292c4b1f2f8717bb17e7bdafd72b0cb2fae46ae6f88ff43a42b2d5ca42216eff5b348513b7ae8e45
|
||||||
|
Loading…
Reference in New Issue
Block a user