Drop *.patch
This commit is contained in:
parent
a52ad0a91b
commit
506ab83655
@ -1,262 +0,0 @@
|
||||
From 880ad3e61f01578384770934a61b52088685ffce Mon Sep 17 00:00:00 2001
|
||||
From: Yaakov Selkowitz <yselkowi@redhat.com>
|
||||
Date: Wed, 2 Aug 2023 01:26:47 -0400
|
||||
Subject: [PATCH 1/4] wxi: enable pcre2
|
||||
|
||||
This is a follow-up to commit e781e05a3f7d0a38a385bc02098d2d3bdeab1741.
|
||||
|
||||
Signed-off-by: Yaakov Selkowitz <yselkowi@redhat.com>
|
||||
---
|
||||
data/meson.build | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/data/meson.build b/data/meson.build
|
||||
index 65b9766..822edb8 100644
|
||||
--- a/data/meson.build
|
||||
+++ b/data/meson.build
|
||||
@@ -69,6 +69,7 @@ wxi_data = files(
|
||||
'wixl/p11-kit.wxi',
|
||||
'wixl/pango.wxi',
|
||||
'wixl/pcre.wxi',
|
||||
+ 'wixl/pcre2.wxi',
|
||||
'wixl/pixman.wxi',
|
||||
'wixl/portablexdr.wxi',
|
||||
'wixl/readline.wxi',
|
||||
--
|
||||
2.41.0
|
||||
|
||||
From 4f1966a0db2aec3df70038336192ac318a035503 Mon Sep 17 00:00:00 2001
|
||||
From: Yaakov Selkowitz <yselkowi@redhat.com>
|
||||
Date: Wed, 2 Aug 2023 01:28:48 -0400
|
||||
Subject: [PATCH 2/4] wxi-validate: ignore ntdll.dll
|
||||
|
||||
mingw{32,64}-librsvg2 in Fedora rawhide depend on this system DLL.
|
||||
|
||||
Signed-off-by: Yaakov Selkowitz <yselkowi@redhat.com>
|
||||
---
|
||||
data/wxi-validate.pl | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/data/wxi-validate.pl b/data/wxi-validate.pl
|
||||
index 147e72a..2c47552 100755
|
||||
--- a/data/wxi-validate.pl
|
||||
+++ b/data/wxi-validate.pl
|
||||
@@ -72,6 +72,7 @@ my $dllbuiltin = "^(" .
|
||||
"msvcrt|" .
|
||||
"mswsock|" .
|
||||
"ncrypt|" .
|
||||
+ "ntdll|" .
|
||||
"ole32|" .
|
||||
"oleaut32|" .
|
||||
"opengl32|" .
|
||||
--
|
||||
2.41.0
|
||||
|
||||
From cd18e0b8ea20f7e5cff5c19c70d2cd18cb1e53c7 Mon Sep 17 00:00:00 2001
|
||||
From: Yaakov Selkowitz <yselkowi@redhat.com>
|
||||
Date: Wed, 2 Aug 2023 01:30:12 -0400
|
||||
Subject: [PATCH 3/4] wxi: add dependencies to cairo
|
||||
|
||||
Signed-off-by: Yaakov Selkowitz <yselkowi@redhat.com>
|
||||
---
|
||||
data/wixl/cairo.wxi | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/data/wixl/cairo.wxi b/data/wixl/cairo.wxi
|
||||
index d7fd501..98c9357 100644
|
||||
--- a/data/wixl/cairo.wxi
|
||||
+++ b/data/wixl/cairo.wxi
|
||||
@@ -1,4 +1,6 @@
|
||||
<?xml version="1.0" encoding="utf-8"?>
|
||||
+<?require fontconfig.wxi?>
|
||||
+<?require freetype.wxi?>
|
||||
<?require gcc.wxi?>
|
||||
<?require glib2.wxi?>
|
||||
<?require libpng.wxi?>
|
||||
@@ -22,6 +24,8 @@
|
||||
</Fragment>
|
||||
<Fragment>
|
||||
<ComponentGroup Id="CG.cairo">
|
||||
+ <ComponentGroupRef Id="CG.fontconfig"/>
|
||||
+ <ComponentGroupRef Id="CG.freetype"/>
|
||||
<ComponentGroupRef Id="CG.gcc"/>
|
||||
<ComponentGroupRef Id="CG.glib2"/>
|
||||
<ComponentGroupRef Id="CG.libpng"/>
|
||||
--
|
||||
2.41.0
|
||||
|
||||
From 6e86dbc102f1cc56f79edf9b8e71eb69e1d6277e Mon Sep 17 00:00:00 2001
|
||||
From: Yaakov Selkowitz <yselkowi@redhat.com>
|
||||
Date: Wed, 2 Aug 2023 01:30:53 -0400
|
||||
Subject: [PATCH 4/4] wxi: update icu to 73.2
|
||||
|
||||
Signed-off-by: Yaakov Selkowitz <yselkowi@redhat.com>
|
||||
---
|
||||
data/wixl/icu.wxi | 88 +++++++++++++++++++++++++----------------------
|
||||
1 file changed, 46 insertions(+), 42 deletions(-)
|
||||
|
||||
diff --git a/data/wixl/icu.wxi b/data/wixl/icu.wxi
|
||||
index 152bae5..bbc06a6 100644
|
||||
--- a/data/wixl/icu.wxi
|
||||
+++ b/data/wixl/icu.wxi
|
||||
@@ -3,7 +3,7 @@
|
||||
<Include xmlns="http://schemas.microsoft.com/wix/2006/wi">
|
||||
<Fragment>
|
||||
<DirectoryRef Id="INSTALLDIR">
|
||||
- <Directory Id="dirDDC25FB69D564E8116FB2820CB90625E" Name="bin">
|
||||
+ <Directory Id="dir1B2F751CF227966804534093775533C9" Name="bin">
|
||||
<Component Win64="$(var.Win64)" Id="cmp5CFFEE5FCDA1047F64C7EE6AA0AE053C" Guid="*">
|
||||
<File Id="fil30026524D9A8680155888DE1802A66CB" KeyPath="yes" Source="$(var.SourceDir)/bin/derb.exe"/>
|
||||
</Component>
|
||||
@@ -37,29 +37,32 @@
|
||||
<Component Win64="$(var.Win64)" Id="cmpEA210ADDBF0153D8B4279BC16085FCE0" Guid="*">
|
||||
<File Id="filFA1A874154792C2AE819A040A89594E4" KeyPath="yes" Source="$(var.SourceDir)/bin/gensprep.exe"/>
|
||||
</Component>
|
||||
- <Component Win64="$(var.Win64)" Id="cmp4C4C248557E85E49781E97AFAF430FC5" Guid="*">
|
||||
- <File Id="filE0A6E3FD94481AA502BEB373AB0CA504" KeyPath="yes" Source="$(var.SourceDir)/bin/icudata72.dll"/>
|
||||
+ <Component Win64="$(var.Win64)" Id="cmpE0111910DC282BA136B680D2DD88769F" Guid="*">
|
||||
+ <File Id="fil3002B40FF5AC470F1D3259C8316932A6" KeyPath="yes" Source="$(var.SourceDir)/bin/icudata73.dll"/>
|
||||
</Component>
|
||||
- <Component Win64="$(var.Win64)" Id="cmpF8B40F0FCCAA6CC2B4BFA97D17F1B64C" Guid="*">
|
||||
- <File Id="fil2AB31389CD6BE19865E0A2459ECCDA40" KeyPath="yes" Source="$(var.SourceDir)/bin/icui18n72.dll"/>
|
||||
+ <Component Win64="$(var.Win64)" Id="cmpBD172F67DF2530D2C44A974C4DA04EDF" Guid="*">
|
||||
+ <File Id="fil12ACA1883A949391960E58D0A288FCE8" KeyPath="yes" Source="$(var.SourceDir)/bin/icuexportdata.exe"/>
|
||||
+ </Component>
|
||||
+ <Component Win64="$(var.Win64)" Id="cmp9A2A75393E3D72CEC5B99748098EA3AF" Guid="*">
|
||||
+ <File Id="filAB3D94BAD3C7842BDE7A7383AA1CB80E" KeyPath="yes" Source="$(var.SourceDir)/bin/icui18n73.dll"/>
|
||||
</Component>
|
||||
<Component Win64="$(var.Win64)" Id="cmpF30CE166B516D3F059E889D43F178BF2" Guid="*">
|
||||
<File Id="filFA5922182B8DAD7C4EDA2FC6AED8BFDA" KeyPath="yes" Source="$(var.SourceDir)/bin/icuinfo.exe"/>
|
||||
</Component>
|
||||
- <Component Win64="$(var.Win64)" Id="cmpDE8AEFFF3BFDBDF1062FB83F20C2E0AD" Guid="*">
|
||||
- <File Id="filE2854FA007D93FBDFD576EAC0949102B" KeyPath="yes" Source="$(var.SourceDir)/bin/icuio72.dll"/>
|
||||
+ <Component Win64="$(var.Win64)" Id="cmpEA8F70DB8FAF3305791A11EBBF11D36D" Guid="*">
|
||||
+ <File Id="fil9D1A90132F945FC82D650E4F70E7E0D4" KeyPath="yes" Source="$(var.SourceDir)/bin/icuio73.dll"/>
|
||||
</Component>
|
||||
<Component Win64="$(var.Win64)" Id="cmp546D0F99610BC45592CFC2627A82E2B6" Guid="*">
|
||||
<File Id="fil064186150829A3FB4F3E965880560C02" KeyPath="yes" Source="$(var.SourceDir)/bin/icupkg.exe"/>
|
||||
</Component>
|
||||
- <Component Win64="$(var.Win64)" Id="cmp589E11344FD248D67C913E666619B648" Guid="*">
|
||||
- <File Id="fil3395D856C0A4E912E1DECCEA86991B44" KeyPath="yes" Source="$(var.SourceDir)/bin/icutest72.dll"/>
|
||||
+ <Component Win64="$(var.Win64)" Id="cmp85F9B243449A69AC1DFDC213C60CD26A" Guid="*">
|
||||
+ <File Id="fil6AA7CF8E6B198499834FF041A9E303C3" KeyPath="yes" Source="$(var.SourceDir)/bin/icutest73.dll"/>
|
||||
</Component>
|
||||
- <Component Win64="$(var.Win64)" Id="cmp8489C447A72FF9FC91F89E1688AD468E" Guid="*">
|
||||
- <File Id="fil16BEFFF899A84962C77B4E7487D879BA" KeyPath="yes" Source="$(var.SourceDir)/bin/icutu72.dll"/>
|
||||
+ <Component Win64="$(var.Win64)" Id="cmpDF2D17F1DAE2A7C080A886699F55FB3E" Guid="*">
|
||||
+ <File Id="fil0DFB0E12BFC6ECE5906DF6873B9454CE" KeyPath="yes" Source="$(var.SourceDir)/bin/icutu73.dll"/>
|
||||
</Component>
|
||||
- <Component Win64="$(var.Win64)" Id="cmpAAF888887E99FB44D82DC14057465C7F" Guid="*">
|
||||
- <File Id="filDA2339D716C830F06C2586B99A81B66E" KeyPath="yes" Source="$(var.SourceDir)/bin/icuuc72.dll"/>
|
||||
+ <Component Win64="$(var.Win64)" Id="cmpBD12EBF60B1006F7A816CC1A0C615480" Guid="*">
|
||||
+ <File Id="filA7E699788D5DD63C10C0250FC171860F" KeyPath="yes" Source="$(var.SourceDir)/bin/icuuc73.dll"/>
|
||||
</Component>
|
||||
<Component Win64="$(var.Win64)" Id="cmpD66DA194B6906EEA355A32A3BE79675B" Guid="*">
|
||||
<File Id="fil2B5E52280628A22C31F1222D9912B17F" KeyPath="yes" Source="$(var.SourceDir)/bin/makeconv.exe"/>
|
||||
@@ -71,17 +74,17 @@
|
||||
<File Id="fil4DDA98B1D7A95E4BE83881C611BF96A4" KeyPath="yes" Source="$(var.SourceDir)/bin/uconv.exe"/>
|
||||
</Component>
|
||||
</Directory>
|
||||
- <Directory Id="dirC92ACCB75F45E9C70F52432213CD191D" Name="lib">
|
||||
- <Directory Id="dirBD26BE99E97E828C3BD97EA93FB70F3E" Name="icu">
|
||||
- <Directory Id="dirF709A0545EFC0C4B26434C0B3C7981AC" Name="72.1">
|
||||
- <Component Win64="$(var.Win64)" Id="cmpF4A922FEE35C9F1734E718E2AA50482D" Guid="*">
|
||||
- <File Id="fil27941D82A92127B82DC9658B07364086" KeyPath="yes" Source="$(var.SourceDir)/lib/icu/72.1/Makefile.inc"/>
|
||||
+ <Directory Id="dir029A699042E6FA7C50E3DB6A6225DC2B" Name="lib">
|
||||
+ <Directory Id="dir81C3C9A78B83CCA0A6179172B32B6C2C" Name="icu">
|
||||
+ <Directory Id="dir7E4C6C859DCE3DE6DDA74844A1EFFE14" Name="73.2">
|
||||
+ <Component Win64="$(var.Win64)" Id="cmpE86150FEABCFA77AD04AF353737DA8A8" Guid="*">
|
||||
+ <File Id="filC4191E5B368344DB3559D1818DA84976" KeyPath="yes" Source="$(var.SourceDir)/lib/icu/73.2/Makefile.inc"/>
|
||||
</Component>
|
||||
- <Component Win64="$(var.Win64)" Id="cmp66AFFBC2B308ADF12E09F44B14DAA68D" Guid="*">
|
||||
- <File Id="fil2528EE76EC8001040AAD647E1D475A6B" KeyPath="yes" Source="$(var.SourceDir)/lib/icu/72.1/pkgdata.inc"/>
|
||||
+ <Component Win64="$(var.Win64)" Id="cmp75DE0BF835E2BFF00271008FB937D078" Guid="*">
|
||||
+ <File Id="filFDCCEFF16DBB1EBA7A5BF40CF2234D3B" KeyPath="yes" Source="$(var.SourceDir)/lib/icu/73.2/pkgdata.inc"/>
|
||||
</Component>
|
||||
</Directory>
|
||||
- <Directory Id="dirF27BF95D129761167FFEFB95EFC24CD0" Name="current">
|
||||
+ <Directory Id="dir21F02C480A98A7CECA6AEC7075239829" Name="current">
|
||||
</Directory>
|
||||
</Directory>
|
||||
<Component Win64="$(var.Win64)" Id="cmp5E2902A3E3E243F11202993295226565" Guid="*">
|
||||
@@ -102,7 +105,7 @@
|
||||
<Component Win64="$(var.Win64)" Id="cmp221E0A780759E0F3DEB6521EED27F6FF" Guid="*">
|
||||
<File Id="fil5E5FB702C0751F55D8FBD30D7CC562BB" KeyPath="yes" Source="$(var.SourceDir)/lib/libicuuc.dll.a"/>
|
||||
</Component>
|
||||
- <Directory Id="dir1256E8654FB3A80ABE73B78F9DD0664C" Name="pkgconfig">
|
||||
+ <Directory Id="dirF1AA9F2338C09729DE2BCB5FE6162D9A" Name="pkgconfig">
|
||||
<Component Win64="$(var.Win64)" Id="cmpA290A063074EC4AC3B5B6E8D0CB90A61" Guid="*">
|
||||
<File Id="fil6C555D0090ACFF552312D6F2F1BFC328" KeyPath="yes" Source="$(var.SourceDir)/lib/pkgconfig/icu-i18n.pc"/>
|
||||
</Component>
|
||||
@@ -114,17 +117,17 @@
|
||||
</Component>
|
||||
</Directory>
|
||||
</Directory>
|
||||
- <Directory Id="dir29E4F267DDB87B7B75EA0C2E9841F71B" Name="share">
|
||||
- <Directory Id="dir6F2304C838358C0BFBC0ABEF6558A6AA" Name="icu">
|
||||
- <Directory Id="dir882ABC9669BDAE5FD5F121D77099C693" Name="72.1">
|
||||
- <Component Win64="$(var.Win64)" Id="cmp5716BC44A0ED390EB5DEFB5D0446F351" Guid="*">
|
||||
- <File Id="filC9A4559B85B3D5BA63CD5F7E25F306D5" KeyPath="yes" Source="$(var.SourceDir)/share/icu/72.1/LICENSE"/>
|
||||
+ <Directory Id="dirDACA4133852A189E180EA3B7F7B9213C" Name="share">
|
||||
+ <Directory Id="dirC1C10A636BDB7854099277CF249EE8A9" Name="icu">
|
||||
+ <Directory Id="dir4B7E35506066EE334EA8F3B3AD4DE8B7" Name="73.2">
|
||||
+ <Component Win64="$(var.Win64)" Id="cmp44D5FB10C8954F3A98F00BDD2063DF77" Guid="*">
|
||||
+ <File Id="filD8C27D8502F0566BC7C66CE04808F673" KeyPath="yes" Source="$(var.SourceDir)/share/icu/73.2/LICENSE"/>
|
||||
</Component>
|
||||
- <Component Win64="$(var.Win64)" Id="cmp79160B67CCEA9AEDB0796AF35E9BA3F6" Guid="*">
|
||||
- <File Id="filD451280DF94EAFA616AF7EBD2A5B6FA8" KeyPath="yes" Source="$(var.SourceDir)/share/icu/72.1/install-sh"/>
|
||||
+ <Component Win64="$(var.Win64)" Id="cmp7E04B7DB60D5807E764CA861931E9FBA" Guid="*">
|
||||
+ <File Id="fil47172A579D95F4590B447405B8D7958D" KeyPath="yes" Source="$(var.SourceDir)/share/icu/73.2/install-sh"/>
|
||||
</Component>
|
||||
- <Component Win64="$(var.Win64)" Id="cmp6D626CD0EF1429E02BF200E37FCE4CDD" Guid="*">
|
||||
- <File Id="fil0ABAC5AC45CCC1899A7881960BE797F0" KeyPath="yes" Source="$(var.SourceDir)/share/icu/72.1/mkinstalldirs"/>
|
||||
+ <Component Win64="$(var.Win64)" Id="cmp9944CEC772805061212168BE976F66A7" Guid="*">
|
||||
+ <File Id="fil68590C0826FFC8F74FABB4AF93744DDC" KeyPath="yes" Source="$(var.SourceDir)/share/icu/73.2/mkinstalldirs"/>
|
||||
</Component>
|
||||
</Directory>
|
||||
</Directory>
|
||||
@@ -145,19 +148,20 @@
|
||||
<ComponentRef Id="cmpF38BEBF50009812E413D28DA79F253A1"/>
|
||||
<ComponentRef Id="cmp18D1C2B2BD4DC8719DA5B85EA32FB047"/>
|
||||
<ComponentRef Id="cmpEA210ADDBF0153D8B4279BC16085FCE0"/>
|
||||
- <ComponentRef Id="cmp4C4C248557E85E49781E97AFAF430FC5"/>
|
||||
- <ComponentRef Id="cmpF8B40F0FCCAA6CC2B4BFA97D17F1B64C"/>
|
||||
+ <ComponentRef Id="cmpE0111910DC282BA136B680D2DD88769F"/>
|
||||
+ <ComponentRef Id="cmpBD172F67DF2530D2C44A974C4DA04EDF"/>
|
||||
+ <ComponentRef Id="cmp9A2A75393E3D72CEC5B99748098EA3AF"/>
|
||||
<ComponentRef Id="cmpF30CE166B516D3F059E889D43F178BF2"/>
|
||||
- <ComponentRef Id="cmpDE8AEFFF3BFDBDF1062FB83F20C2E0AD"/>
|
||||
+ <ComponentRef Id="cmpEA8F70DB8FAF3305791A11EBBF11D36D"/>
|
||||
<ComponentRef Id="cmp546D0F99610BC45592CFC2627A82E2B6"/>
|
||||
- <ComponentRef Id="cmp589E11344FD248D67C913E666619B648"/>
|
||||
- <ComponentRef Id="cmp8489C447A72FF9FC91F89E1688AD468E"/>
|
||||
- <ComponentRef Id="cmpAAF888887E99FB44D82DC14057465C7F"/>
|
||||
+ <ComponentRef Id="cmp85F9B243449A69AC1DFDC213C60CD26A"/>
|
||||
+ <ComponentRef Id="cmpDF2D17F1DAE2A7C080A886699F55FB3E"/>
|
||||
+ <ComponentRef Id="cmpBD12EBF60B1006F7A816CC1A0C615480"/>
|
||||
<ComponentRef Id="cmpD66DA194B6906EEA355A32A3BE79675B"/>
|
||||
<ComponentRef Id="cmp9753332E689CC33398657A3EBE555820"/>
|
||||
<ComponentRef Id="cmp5402843A4A815DCD2D0F259DAE521743"/>
|
||||
- <ComponentRef Id="cmpF4A922FEE35C9F1734E718E2AA50482D"/>
|
||||
- <ComponentRef Id="cmp66AFFBC2B308ADF12E09F44B14DAA68D"/>
|
||||
+ <ComponentRef Id="cmpE86150FEABCFA77AD04AF353737DA8A8"/>
|
||||
+ <ComponentRef Id="cmp75DE0BF835E2BFF00271008FB937D078"/>
|
||||
<ComponentRef Id="cmp5E2902A3E3E243F11202993295226565"/>
|
||||
<ComponentRef Id="cmp16D4585D27FB481E9591E39A1B3EAA62"/>
|
||||
<ComponentRef Id="cmpDDBB83D3797E7582FEF7F7F89C8AC9CC"/>
|
||||
@@ -167,9 +171,9 @@
|
||||
<ComponentRef Id="cmpA290A063074EC4AC3B5B6E8D0CB90A61"/>
|
||||
<ComponentRef Id="cmpA7DC8C6BDE112043EAC15E1C5735FD9F"/>
|
||||
<ComponentRef Id="cmp5B15EB74A47251EA86B5193D1F36B454"/>
|
||||
- <ComponentRef Id="cmp5716BC44A0ED390EB5DEFB5D0446F351"/>
|
||||
- <ComponentRef Id="cmp79160B67CCEA9AEDB0796AF35E9BA3F6"/>
|
||||
- <ComponentRef Id="cmp6D626CD0EF1429E02BF200E37FCE4CDD"/>
|
||||
+ <ComponentRef Id="cmp44D5FB10C8954F3A98F00BDD2063DF77"/>
|
||||
+ <ComponentRef Id="cmp7E04B7DB60D5807E764CA861931E9FBA"/>
|
||||
+ <ComponentRef Id="cmp9944CEC772805061212168BE976F66A7"/>
|
||||
</ComponentGroup>
|
||||
</Fragment>
|
||||
</Include>
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,65 +0,0 @@
|
||||
From d79ad6d2c89cadb83eeb14321c862e4b4691fb97 Mon Sep 17 00:00:00 2001
|
||||
From: Jerry James <loganjerry@gmail.com>
|
||||
Date: Wed, 23 Aug 2023 12:07:54 -0600
|
||||
Subject: [PATCH] Change GUINT_FROM_LE to GUINT16_FROM_LE
|
||||
|
||||
Signed-off-by: Jerry James <loganjerry@gmail.com>
|
||||
---
|
||||
libmsi/string.c | 14 +++++++-------
|
||||
1 file changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/libmsi/string.c b/libmsi/string.c
|
||||
index 988d6eb..0b20c0b 100644
|
||||
--- a/libmsi/string.c
|
||||
+++ b/libmsi/string.c
|
||||
@@ -495,14 +495,14 @@ string_table *msi_load_string_table( GsfInfile *stg, unsigned *bytes_per_strref
|
||||
if( r != LIBMSI_RESULT_SUCCESS)
|
||||
goto end;
|
||||
|
||||
- if ( (poolsize > 4) && (GUINT_FROM_LE(pool[1]) & 0x8000) )
|
||||
+ if ( (poolsize > 4) && (GUINT16_FROM_LE(pool[1]) & 0x8000) )
|
||||
*bytes_per_strref = LONG_STR_BYTES;
|
||||
else
|
||||
*bytes_per_strref = sizeof(uint16_t);
|
||||
|
||||
count = poolsize/4;
|
||||
if( poolsize > 4 )
|
||||
- codepage = GUINT_FROM_LE(pool[0]) | ( (GUINT_FROM_LE(pool[1]) & ~0x8000) << 16 );
|
||||
+ codepage = GUINT16_FROM_LE(pool[0]) | ( (GUINT16_FROM_LE(pool[1]) & ~0x8000) << 16 );
|
||||
else
|
||||
codepage = CP_ACP;
|
||||
|
||||
@@ -516,10 +516,10 @@ string_table *msi_load_string_table( GsfInfile *stg, unsigned *bytes_per_strref
|
||||
while ( i<count )
|
||||
{
|
||||
/* the string reference count is always the second word */
|
||||
- refs = GUINT_FROM_LE(pool[i*2+1]);
|
||||
+ refs = GUINT16_FROM_LE(pool[i*2+1]);
|
||||
|
||||
/* empty entries have two zeros, still have a string id */
|
||||
- if (GUINT_FROM_LE(pool[i*2]) == 0 && refs == 0)
|
||||
+ if (GUINT16_FROM_LE(pool[i*2]) == 0 && refs == 0)
|
||||
{
|
||||
i++;
|
||||
n++;
|
||||
@@ -531,14 +531,14 @@ string_table *msi_load_string_table( GsfInfile *stg, unsigned *bytes_per_strref
|
||||
* and the high word of the length is inserted in the null string's
|
||||
* reference count field.
|
||||
*/
|
||||
- if (GUINT_FROM_LE(pool[i*2]) == 0)
|
||||
+ if (GUINT16_FROM_LE(pool[i*2]) == 0)
|
||||
{
|
||||
- len = (GUINT_FROM_LE(pool[i*2+3]) << 16) + GUINT_FROM_LE(pool[i*2+2]);
|
||||
+ len = (GUINT16_FROM_LE(pool[i*2+3]) << 16) + GUINT16_FROM_LE(pool[i*2+2]);
|
||||
i += 2;
|
||||
}
|
||||
else
|
||||
{
|
||||
- len = GUINT_FROM_LE(pool[i*2]);
|
||||
+ len = GUINT16_FROM_LE(pool[i*2]);
|
||||
i += 1;
|
||||
}
|
||||
|
||||
--
|
||||
2.41.0
|
||||
|
Loading…
Reference in New Issue
Block a user