fix perl noise (bz 438931, 442884)
This commit is contained in:
parent
2f68be1818
commit
f2fc2428b1
@ -1,2 +1,4 @@
|
||||
mrtg-2.15.1.tar.gz
|
||||
mrtg-2.15.1.tar.gz.md5.gpg
|
||||
mrtg-2.16.1.tar.gz
|
||||
mrtg-2.16.1.tar.gz.md5.gpg
|
||||
|
35
mrtg-2.15.1-Socket6-fix.patch
Normal file
35
mrtg-2.15.1-Socket6-fix.patch
Normal file
@ -0,0 +1,35 @@
|
||||
diff -up mrtg-2.16.1/lib/mrtg2/SNMP_Session.pm.BAD mrtg-2.16.1/lib/mrtg2/SNMP_Session.pm
|
||||
--- mrtg-2.16.1/lib/mrtg2/SNMP_Session.pm.BAD 2008-04-18 07:25:55.000000000 -0400
|
||||
+++ mrtg-2.16.1/lib/mrtg2/SNMP_Session.pm 2008-04-18 07:26:30.000000000 -0400
|
||||
@@ -138,7 +138,7 @@ BEGIN {
|
||||
|
||||
if (eval {local $SIG{__DIE__};require Socket6;} &&
|
||||
eval {local $SIG{__DIE__};require IO::Socket::INET6; IO::Socket::INET6->VERSION("1.26");}) {
|
||||
- import Socket6;
|
||||
+ Socket6->import(qw(pack_sockaddr_in6 inet_pton));
|
||||
$ipv6_addr_len = length(pack_sockaddr_in6(161, inet_pton(AF_INET6(), "::1")));
|
||||
$SNMP_Session::ipv6available = 1;
|
||||
}
|
||||
@@ -592,7 +592,7 @@ use Carp;
|
||||
BEGIN {
|
||||
if($SNMP_Session::ipv6available) {
|
||||
import IO::Socket::INET6;
|
||||
- import Socket6;
|
||||
+ Socket6->import(qw(pack_sockaddr_in6 inet_pton));
|
||||
}
|
||||
}
|
||||
|
||||
diff -up mrtg-2.16.1/bin/mrtg.orig mrtg-2.16.1/bin/mrtg
|
||||
--- mrtg-2.16.1/bin/mrtg.orig 2008-04-18 07:28:19.000000000 -0400
|
||||
+++ mrtg-2.16.1/bin/mrtg 2008-04-18 07:29:33.000000000 -0400
|
||||
@@ -97,8 +97,8 @@ use locales_mrtg "0.07";
|
||||
# necessary for dead host detection (for IPv6 name lookups).
|
||||
BEGIN {
|
||||
if (eval {local $SIG{__DIE__};require Socket6;}) {
|
||||
- import Socket;
|
||||
- import Socket6
|
||||
+ use Socket();
|
||||
+ import Socket6;
|
||||
}
|
||||
}
|
||||
|
10
mrtg.spec
10
mrtg.spec
@ -5,8 +5,8 @@
|
||||
|
||||
Summary: Multi Router Traffic Grapher
|
||||
Name: mrtg
|
||||
Version: 2.15.1
|
||||
Release: 8%{?dist}
|
||||
Version: 2.16.1
|
||||
Release: 1%{?dist}
|
||||
URL: http://oss.oetiker.ch/mrtg/
|
||||
Source0: http://oss.oetiker.ch/mrtg/pub/mrtg-%{version}.tar.gz
|
||||
Source1: http://oss.oetiker.ch/mrtg/pub/mrtg-%{version}.tar.gz.md5.gpg
|
||||
@ -17,6 +17,7 @@ Source5: mrtg-httpd.conf
|
||||
Source6: filter-provides-mrtg.sh
|
||||
Patch0: mrtg-2.15.0-lib64.patch
|
||||
Patch1: mrtg-2.10.5-norpath.patch
|
||||
Patch2: mrtg-2.15.1-Socket6-fix.patch
|
||||
License: GPL+
|
||||
Group: Applications/Internet
|
||||
PreReq: vixie-cron
|
||||
@ -38,6 +39,7 @@ images which provide a LIVE visual representation of this traffic.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .lib64
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
for i in doc/mrtg-forum.1 doc/mrtg-squid.1; do
|
||||
iconv -f iso-8859-1 -t utf-8 < "$i" > "${i}_"
|
||||
@ -117,6 +119,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%dir %{_localstatedir}/lock/mrtg
|
||||
|
||||
%changelog
|
||||
* Fri Apr 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.16.1-1
|
||||
- Update to 2.16.1
|
||||
- fix perl noise (bz 438931, 442884)
|
||||
|
||||
* Mon Feb 11 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.15.1-8
|
||||
- Fix Buildroot
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user