Update to mrtg-2.17.2
This commit is contained in:
parent
9d16496153
commit
ec89a9b4c8
2
.gitignore
vendored
2
.gitignore
vendored
@ -4,3 +4,5 @@ mrtg-2.16.3.tar.gz.md5.gpg
|
||||
/mrtg-2.16.4.tar.gz.md5
|
||||
/mrtg-2.17.0.tar.gz
|
||||
/mrtg-2.17.0.tar.gz.md5
|
||||
/mrtg-2.17.2.tar.gz
|
||||
/mrtg-2.17.2.tar.gz.md5
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- mrtg-2.10.5/Makefile.in.lr 2003-10-25 09:09:18.000000000 +0200
|
||||
+++ mrtg-2.10.5/Makefile.in 2003-10-25 09:09:38.000000000 +0200
|
||||
@@ -30,7 +30,7 @@
|
||||
all: bin/rateup subst
|
||||
|
||||
bin/rateup: bin/rateup.o
|
||||
- LD_RUN_PATH=$(LD_RUN_PATH) $(CC) bin/rateup.o -o bin/rateup $(LDFLAGS) $(LIBS)
|
||||
+ $(CC) bin/rateup.o -o bin/rateup $(LDFLAGS) $(LIBS)
|
||||
|
||||
bin/rateup.o: $(top_srcdir)/src/rateup.c
|
||||
$(CC) $(CPPFLAGS) $(CFLAGS) -c $(top_srcdir)/src/rateup.c -o bin/rateup.o
|
@ -1,32 +0,0 @@
|
||||
diff -up mrtg-2.16.4/bin/mrtg.orig mrtg-2.16.4/bin/mrtg
|
||||
--- mrtg-2.16.4/bin/mrtg.orig 2010-12-13 14:26:25.000000000 +0100
|
||||
+++ mrtg-2.16.4/bin/mrtg 2010-12-13 14:31:30.168311050 +0100
|
||||
@@ -98,6 +98,7 @@ use locales_mrtg "0.07";
|
||||
BEGIN {
|
||||
if (eval {local $SIG{__DIE__};require Socket6;}) {
|
||||
import Socket;
|
||||
+ use Socket();
|
||||
import Socket6
|
||||
}
|
||||
}
|
||||
diff -up mrtg-2.16.4/lib/mrtg2/SNMP_Session.pm.orig mrtg-2.16.4/lib/mrtg2/SNMP_Session.pm
|
||||
--- mrtg-2.16.4/lib/mrtg2/SNMP_Session.pm.orig 2010-05-17 15:59:20.000000000 +0200
|
||||
+++ mrtg-2.16.4/lib/mrtg2/SNMP_Session.pm 2010-12-13 14:26:25.366152933 +0100
|
||||
@@ -146,7 +146,7 @@ BEGIN {
|
||||
|
||||
if (eval {local $SIG{__DIE__};require Socket6;} &&
|
||||
eval {local $SIG{__DIE__};require IO::Socket::INET6; IO::Socket::INET6->VERSION("1.26");}) {
|
||||
- import Socket6;
|
||||
+ Socket6->import(qw(pack_sockaddr_in6 inet_pton getaddrinfo));
|
||||
$ipv6_addr_len = length(pack_sockaddr_in6(161, inet_pton(AF_INET6(), "::1")));
|
||||
$SNMP_Session::ipv6available = 1;
|
||||
}
|
||||
@@ -601,7 +601,7 @@ use Carp;
|
||||
BEGIN {
|
||||
if($SNMP_Session::ipv6available) {
|
||||
import IO::Socket::INET6;
|
||||
- import Socket6;
|
||||
+ Socket6->import(qw(pack_sockaddr_in6 inet_pton getaddrinfo));
|
||||
}
|
||||
}
|
||||
|
28
mrtg.spec
28
mrtg.spec
@ -1,12 +1,12 @@
|
||||
%define _use_internal_dependency_generator 0
|
||||
%global _use_internal_dependency_generator 0
|
||||
|
||||
%define contentdir %{_localstatedir}/www/%{name}
|
||||
%define libdir %{_localstatedir}/lib/mrtg
|
||||
%global contentdir %{_localstatedir}/www/%{name}
|
||||
%global libdir %{_localstatedir}/lib/mrtg
|
||||
|
||||
Summary: Multi Router Traffic Grapher
|
||||
Name: mrtg
|
||||
Version: 2.17.0
|
||||
Release: 2%{?dist}
|
||||
Version: 2.17.2
|
||||
Release: 1%{?dist}
|
||||
URL: http://oss.oetiker.ch/mrtg/
|
||||
Source0: http://oss.oetiker.ch/mrtg/pub/mrtg-%{version}.tar.gz
|
||||
Source1: http://oss.oetiker.ch/mrtg/pub/mrtg-%{version}.tar.gz.md5
|
||||
@ -16,15 +16,6 @@ Source4: mrtg.crond.in
|
||||
Source5: mrtg-httpd.conf
|
||||
Source6: filter-provides-mrtg.sh
|
||||
Patch0: mrtg-2.15.0-lib64.patch
|
||||
Patch1: mrtg-2.10.5-norpath.patch
|
||||
# DO NOT DROP THIS PATCH. Without it, the mrtg logs fill up with:
|
||||
# Constant subroutine SNMP_Session::AF_INET6 redefined at
|
||||
# /usr/share/perl5/Exporter.pm line 64.
|
||||
# at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 149
|
||||
# Prototype mismatch: sub SNMP_Session::AF_INET6 () vs none at
|
||||
# /usr/share/perl5/Exporter.pm line 64.
|
||||
# at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 149
|
||||
Patch2: mrtg-2.16.4-Socket6-fix.patch
|
||||
License: GPLv2+
|
||||
Group: Applications/Internet
|
||||
Requires: vixie-cron
|
||||
@ -35,8 +26,8 @@ Requires: gd
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: gd-devel, libpng-devel
|
||||
|
||||
%define __find_requires %{SOURCE3}
|
||||
%define __find_provides %{SOURCE6}
|
||||
%global __find_requires %{SOURCE3}
|
||||
%global __find_provides %{SOURCE6}
|
||||
|
||||
%description
|
||||
The Multi Router Traffic Grapher (MRTG) is a tool to monitor the traffic
|
||||
@ -46,8 +37,6 @@ images which provide a LIVE visual representation of this traffic.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .lib64
|
||||
%patch1 -p1
|
||||
%patch2 -p1 -b .socket6
|
||||
|
||||
for i in doc/mrtg-forum.1 doc/mrtg-squid.1 CHANGES; do
|
||||
iconv -f iso-8859-1 -t utf-8 < "$i" > "${i}_"
|
||||
@ -121,6 +110,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%dir %{_localstatedir}/lock/mrtg
|
||||
|
||||
%changelog
|
||||
* Tue Feb 22 2011 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.17.2-1
|
||||
- Update to mrtg-2.17.2
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.17.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user