diff --git a/.cvsignore b/.cvsignore
index 0349f88..29f455a 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -1 +1 @@
-mrtg-2.9.17.tar.gz
+mrtg-2.10.5.tar.gz
diff --git a/mrtg-2.10.5-norpath.patch b/mrtg-2.10.5-norpath.patch
new file mode 100644
index 0000000..e25eca9
--- /dev/null
+++ b/mrtg-2.10.5-norpath.patch
@@ -0,0 +1,11 @@
+--- mrtg-2.10.5/Makefile.in.lr 2003-10-25 09:09:18.000000000 +0200
++++ mrtg-2.10.5/Makefile.in 2003-10-25 09:09:38.000000000 +0200
+@@ -30,7 +30,7 @@
+ all: bin/rateup subst
+
+ bin/rateup: bin/rateup.o
+- LD_RUN_PATH=$(LD_RUN_PATH) $(CC) bin/rateup.o -o bin/rateup $(LDFLAGS) $(LIBS)
++ $(CC) bin/rateup.o -o bin/rateup $(LDFLAGS) $(LIBS)
+
+ bin/rateup.o: $(top_srcdir)/src/rateup.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) -c $(top_srcdir)/src/rateup.c -o bin/rateup.o
diff --git a/mrtg-httpd.conf b/mrtg-httpd.conf
new file mode 100644
index 0000000..2d1c8ac
--- /dev/null
+++ b/mrtg-httpd.conf
@@ -0,0 +1,13 @@
+#
+# This configuration file maps the mrtg output (generated daily)
+# into the URL space. By default these results are only accessible
+# from the local host.
+#
+Alias /mrtg /var/www/mrtg
+
+
+ Order deny,allow
+ Deny from all
+ Allow from localhost
+ # Allow from .example.com
+
diff --git a/mrtg.spec b/mrtg.spec
index 95b4257..44bb1ab 100644
--- a/mrtg.spec
+++ b/mrtg.spec
@@ -1,28 +1,30 @@
%define _use_internal_dependency_generator 0
-%define contentdir /var/www/html/%{name}
+%define contentdir /var/www/%{name}
Summary: Multi Router Traffic Grapher
Name: mrtg
-Version: 2.9.17
-Release: 14
+Version: 2.10.5
+Release: 1
URL: http://ee-staff.ethz.ch/~oetiker/webtools/mrtg/mrtg.html
Source0: http://www.ee.ethz.ch/~oetiker/webtools/mrtg/pub/%{name}-%{version}.tar.gz
-Source1: mrtg.cfg
-Source2: README-14allcgi
-Source3: 14all.cgi
-Source4: filter-requires-mrtg.sh
-Source5: mrtg.crond.in
+Source3: mrtg.cfg
+Source4: README-14allcgi
+Source5: 14all.cgi
+Source6: filter-requires-mrtg.sh
+Source7: mrtg.crond.in
+Source8: mrtg-httpd.conf
Patch: mrtg-2.9.17-lib64.patch
+Patch1: mrtg-2.10.5-norpath.patch
License: GPL
Group: Applications/Internet
-Requires: perl >= 5.004
+Requires: perl >= 0:5.004
Requires: gd
PreReq: vixie-cron, /sbin/service
Buildroot: %{_tmppath}/%{name}-%{version}-root
BuildPrereq: freetype-devel, gd-devel, libjpeg-devel, libpng-devel
-%define __find_requires %{SOURCE4}
+%define __find_requires %{SOURCE6}
%description
The Multi Router Traffic Grapher (MRTG) is a tool to monitor the traffic
@@ -32,6 +34,7 @@ images which provide a LIVE visual representation of this traffic.
%prep
%setup -q
%patch -p0 -b .lib64
+%patch1 -p1
%build
LIBS="-lgd -lpng -lz -lfreetype"; export LIBS
@@ -48,17 +51,21 @@ mkdir -p $RPM_BUILD_ROOT%{contentdir}
mkdir -p $RPM_BUILD_ROOT%{_bindir}
mkdir -p $RPM_BUILD_ROOT%{_libdir}/mrtg2/Pod
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
+mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
install -m 644 images/* $RPM_BUILD_ROOT%{contentdir}/
install -m 644 doc/*.html $RPM_BUILD_ROOT%{contentdir}/
-install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/mrtg
+install -m 644 %{SOURCE3} $RPM_BUILD_ROOT/etc/mrtg
perl -e 's|\@WORKDIR@|%{contentdir}|g' -pi $RPM_BUILD_ROOT/etc/mrtg/mrtg.cfg
sed -e 's,@bindir@,%{_bindir},g' -e 's,@sysconfdir@,%{_sysconfdir},g' \
$RPM_SOURCE_DIR/mrtg.crond.in > $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/mrtg
chmod 644 $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/mrtg
-install -m 644 %{SOURCE2} contrib/14all/README
-install -m 755 %{SOURCE3} contrib/14all
+install -m 644 $RPM_SOURCE_DIR/mrtg-httpd.conf \
+ $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/mrtg.conf
+
+install -m 644 %{SOURCE4} contrib/14all/README
+install -m 755 %{SOURCE5} contrib/14all
for i in bin/mrtg bin/rateup bin/cfgmaker bin/indexmaker; do
install -m 755 -c $i $RPM_BUILD_ROOT%{_bindir}/
@@ -102,12 +109,39 @@ rm -rf $RPM_BUILD_ROOT
%dir %{_sysconfdir}/mrtg
%config(noreplace) %{_sysconfdir}/mrtg/mrtg.cfg
%config %{_sysconfdir}/cron.d/mrtg
+%config(noreplace) %{_sysconfdir}/httpd/conf.d/mrtg.conf
%{contentdir}
%{_bindir}/*
%{_libdir}/mrtg2
%{_mandir}/*/*
%changelog
+* Sat Oct 25 2003 Florian La Roche
+- update to 2.10.5
+- to not set LD_RUN_PATH
+
+* Sat Aug 2 2003 Joe Orton 2.9.29-5
+- rebuild
+
+* Fri Aug 1 2003 Joe Orton 2.9.29-4.ent
+- move default output directory to /var/www/mrtg
+
+* Mon Jun 9 2003 Nalin Dahyabhai 2.9.28-4
+- disable use of RPM's internal dependency generator so that we can filter out
+ requirements of the contrib scripts included in the docs directory
+
+* Wed Jun 04 2003 Elliot Lee
+- rebuilt
+
+* Tue Jun 3 2003 Jeff Johnson
+- add explicit epoch's where needed.
+
+* Tue May 6 2003 Nalin Dahyabhai 2.9.28-2
+- rebuild
+
+* Wed Apr 30 2003 Nalin Dahyabhai 2.9.28-1
+- update to 2.9.29
+
* Wed Mar 5 2003 Nalin Dahyabhai 2.9.17-14
- fixup lib/lib64 references (#82916)
diff --git a/sources b/sources
index 27505d8..60196e7 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-fdddc249de0c8e63f1af4b994248133b mrtg-2.9.17.tar.gz
+5657edcdc3ca0af2d4e063867dbd1529 mrtg-2.10.5.tar.gz