import mptcpd-0.8-1.el9

This commit is contained in:
CentOS Sources 2021-12-07 12:23:16 -05:00 committed by Stepan Oksanichenko
parent 6d634b064e
commit 1ea8f561c0
5 changed files with 12 additions and 161 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/mptcpd-0.7.tar.gz
SOURCES/mptcpd-0.8.tar.gz

View File

@ -1 +1 @@
a5307a3515e2fa7fd8c3be26a160ce5bed56878d SOURCES/mptcpd-0.7.tar.gz
a75235d98b7d2ab1ed71e0bd9d1683e6da462bfb SOURCES/mptcpd-0.8.tar.gz

View File

@ -1,70 +0,0 @@
From a908793d8c816ba8e08950f7407de2ea9d144800 Mon Sep 17 00:00:00 2001
Message-Id: <a908793d8c816ba8e08950f7407de2ea9d144800.1622734184.git.dcaratti@redhat.com>
From: dddaniel <d.danzberger@ddf-software.de>
Date: Fri, 23 Apr 2021 23:19:23 +0200
Subject: [PATCH] configure: add --disable-stack-protection option (#125)
Enabling -DFORTIFY_SOURCE=* and -fstack-protector-* by default may
overwrite global (build) system settings, causing redefinition errors at
compile time.
---
configure.ac | 37 +++++++++++++++++++++++++------------
1 file changed, 25 insertions(+), 12 deletions(-)
diff --git a/configure.ac b/configure.ac
index 3d6a2f0..4be1b81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,24 +255,37 @@ AX_APPEND_COMPILE_FLAGS([-Wextra -Werror -pedantic])
# ---------------------------------------------------------------
# Enable compile-time defense
# ---------------------------------------------------------------
-# Fortify source
-# Enabling optimization implies _FORTIFY_SOURCE on some platforms.
-# Explicitly redefine to _FORTIFY_SOURCE=2 to make sure we have the
-# desired fortification level.
-AX_APPEND_FLAG([-U_FORTIFY_SOURCE], [CPPFLAGS])
-AX_APPEND_FLAG([-D_FORTIFY_SOURCE=2], [CPPFLAGS])
+
+AC_ARG_ENABLE(stack-protection,
+ [AS_HELP_STRING([--disable-stack-protection],
+ [Disable compiler stack protection.
+ FORTIFY_SOURCE=2 and -fstack-protector-strong]
+ )],
+ [],
+ [enable_stack_protection=yes])
+
+AS_IF([test "x$enable_stack_protection" = "xyes"],
+ [
+ # Fortify source
+ # Enabling optimization implies _FORTIFY_SOURCE on some platforms.
+ # Explicitly redefine to _FORTIFY_SOURCE=2 to make sure we have the
+ # desired fortification level.
+ AX_APPEND_FLAG([-U_FORTIFY_SOURCE], [CPPFLAGS])
+ AX_APPEND_FLAG([-D_FORTIFY_SOURCE=2], [CPPFLAGS])
+
+ # Stack-based buffer overrun detection
+ MPTCPD_ADD_COMPILE_FLAG([-fstack-protector-strong],
+ [# GCC < 4.9
+ MPTCPD_ADD_COMPILE_FLAG([-fstack-protector])
+ ])
+ ],[]
+ )
# Format string vulnerabilities
# -Wformat=2 implies:
# -Wformat -Wformat-nonliteral -Wformat-security -Wformat-y2k
AX_APPEND_COMPILE_FLAGS([-Wformat=2])
-# Stack-based buffer overrun detection
-MPTCPD_ADD_COMPILE_FLAG([-fstack-protector-strong],
- [# GCC < 4.9
- MPTCPD_ADD_COMPILE_FLAG([-fstack-protector])
- ])
-
# Position Independent Execution (PIE)
AX_APPEND_COMPILE_FLAGS([-fPIE], [EXECUTABLE_CFLAGS])
AC_SUBST([EXECUTABLE_CFLAGS])
--
2.31.1

View File

@ -1,85 +0,0 @@
From f1207f311ec04aeda07759e04538d65d41d4ea4a Mon Sep 17 00:00:00 2001
Message-Id: <f1207f311ec04aeda07759e04538d65d41d4ea4a.1624465064.git.dcaratti@redhat.com>
From: dcaratti <davide.caratti@gmail.com>
Date: Wed, 23 Jun 2021 18:12:41 +0200
Subject: [PATCH] Allow empty values of "plugin_dir" in mptcpd.conf. (#145)
The plugin dirname is $(libdir)/mptcpd/ on standard configurations:
use this value in case the value of plugin_dir is empty in
/etc/mptcpd/mptcpd.conf.
---
src/Makefile.am | 3 ++-
src/configuration.c | 27 ++++++++++-----------------
2 files changed, 12 insertions(+), 18 deletions(-)
diff --git a/src/Makefile.am b/src/Makefile.am
index 09ca74c..4aa5037 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -31,7 +31,8 @@ libpath_manager_la_LIBADD = \
libpath_manager_la_CPPFLAGS = \
$(AM_CPPFLAGS) \
- -DMPTCPD_CONFIG_FILE='"$(sysconfdir)/@PACKAGE@/@PACKAGE@.conf"'
+ -DMPTCPD_CONFIG_FILE='"$(sysconfdir)/@PACKAGE@/@PACKAGE@.conf"' \
+ -DMPTCPD_DEFAULT_PLUGINDIR='"$(libdir)/@PACKAGE@"'
EXTRA_DIST = mptcp.service.in
diff --git a/src/configuration.c b/src/configuration.c
index 2a48405..70a8e19 100644
--- a/src/configuration.c
+++ b/src/configuration.c
@@ -304,8 +304,6 @@ static bool check_file_perms(char const *f)
static bool parse_config_file(struct mptcpd_config *config,
char const *filename)
{
- bool parsed = true;
-
assert(filename != NULL);
if (!check_file_perms(filename))
@@ -337,22 +335,17 @@ static bool parse_config_file(struct mptcpd_config *config,
group,
"plugin-dir");
- if (plugin_dir == NULL) {
- l_error("No plugin directory set in mptcpd "
- "configuration.");
+ set_plugin_dir(config,
+ plugin_dir ? plugin_dir :
+ l_strdup(MPTCPD_DEFAULT_PLUGINDIR));
- parsed = false;
- } else {
- set_plugin_dir(config, plugin_dir);
-
- // Default plugin name. Can be NULL.
- char *const default_plugin =
- l_settings_get_string(settings,
- group,
- "path-manager");
+ // Default plugin name. Can be NULL.
+ char *const default_plugin =
+ l_settings_get_string(settings,
+ group,
+ "path-manager");
- set_default_plugin(config, default_plugin);
- }
+ set_default_plugin(config, default_plugin);
} else {
l_debug("Unable to mptcpd load settings from file '%s'",
filename);
@@ -360,7 +353,7 @@ static bool parse_config_file(struct mptcpd_config *config,
l_settings_free(settings);
- return parsed;
+ return true;
}
/**
--
2.31.1

View File

@ -1,7 +1,7 @@
Summary: Multipath TCP daemon
Name: mptcpd
Version: 0.7
Release: 3%{?dist}
Version: 0.8
Release: 1%{?dist}
License: BSD
URL: https://multipath-tcp.org
Requires(post): systemd
@ -19,8 +19,6 @@ BuildRequires: systemd-rpm-macros
Source0: https://github.com/intel/mptcpd/archive/v%{version}/%{name}-%{version}.tar.gz
Patch1: 0001-issue125.patch
Patch2: 0002-issue144.patch
Patch3: 0003-fix-multilib-install.patch
%description
@ -56,6 +54,8 @@ install -d %{buildroot}/%{_unitdir}
install -d %{buildroot}/%{_libdir}/%{name}
install -d %{buildroot}/%{_includedir}/%{name}
%make_install
sed -i '/^# addr-flags=subflow/s/^# //g' %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
sed -i '/^# notify-flags=existing,skip_link_local,skip_loopback/s/^# //g' %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
find %{buildroot} -name '*.la' -exec rm -f {} ';'
%post -p /sbin/ldconfig
@ -69,9 +69,12 @@ find %{buildroot} -name '*.la' -exec rm -f {} ';'
%dir %{_libdir}/%{name}
%{_libdir}/libmptcpd.so.*
%{_libdir}/%{name}/*.so
%{_libdir}/%{name}/libmptcpwrap.so*
%{_libexecdir}/%{name}
%{_bindir}/mptcpize
%{_unitdir}/mptcp.service
%{_mandir}/man8/%{name}.8.gz
%{_mandir}/man8/mptcpize.8.gz
# todo add %doc
%license COPYING
@ -83,6 +86,9 @@ find %{buildroot} -name '*.la' -exec rm -f {} ';'
%{_libdir}/pkgconfig/mptcpd.pc
%changelog
* Wed Sep 29 2021 Davide Caratti <dcaratti@redhat.com> - 0.8-1
- update to version 0.8
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.7-3
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688