import mpitests-5.6.2-1.el8
This commit is contained in:
parent
4ea1c6fb21
commit
028a3cb57d
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
SOURCES/osu-micro-benchmarks-5.4.2.tar.gz
|
||||
SOURCES/v2018.1.tar.gz
|
||||
SOURCES/IMB-v2019.6.tar.gz
|
||||
SOURCES/osu-micro-benchmarks-5.6.2.tar.gz
|
||||
|
@ -1,2 +1,2 @@
|
||||
532412ecf2e4ddf516913211a34c88452eca9e6b SOURCES/osu-micro-benchmarks-5.4.2.tar.gz
|
||||
fae1fb6ddafd9a96ed96a1a04b59293e679bbec6 SOURCES/v2018.1.tar.gz
|
||||
10181aeb3bc5be69b751ca0be0a40086566e0622 SOURCES/IMB-v2019.6.tar.gz
|
||||
28cae75574f57b3092e4b8d8ba472db15c25c534 SOURCES/osu-micro-benchmarks-5.6.2.tar.gz
|
||||
|
@ -1,23 +0,0 @@
|
||||
OMB: disable collective async
|
||||
|
||||
To build mpitests against old MPI implementations that don't provide
|
||||
MPI_Ibarrier etc.
|
||||
|
||||
diff -up osu-micro-benchmarks-5.4/mpi/collective/Makefile.in.orig osu-micro-benchmarks-5.4/mpi/collective/Makefile.in
|
||||
--- osu-micro-benchmarks-5.4/mpi/collective/Makefile.in.orig 2017-11-03 23:06:44.176756058 +0100
|
||||
+++ osu-micro-benchmarks-5.4/mpi/collective/Makefile.in 2017-11-03 23:07:05.677306833 +0100
|
||||
@@ -93,13 +93,7 @@ collective_PROGRAMS = osu_alltoallv$(EXE
|
||||
osu_reduce_scatter$(EXEEXT) osu_barrier$(EXEEXT) \
|
||||
osu_reduce$(EXEEXT) osu_allreduce$(EXEEXT) \
|
||||
osu_alltoall$(EXEEXT) osu_bcast$(EXEEXT) osu_gather$(EXEEXT) \
|
||||
- osu_allgather$(EXEEXT) osu_scatter$(EXEEXT) \
|
||||
- osu_iallgather$(EXEEXT) osu_ibcast$(EXEEXT) \
|
||||
- osu_ialltoall$(EXEEXT) osu_ibarrier$(EXEEXT) \
|
||||
- osu_igather$(EXEEXT) osu_iscatter$(EXEEXT) \
|
||||
- osu_iscatterv$(EXEEXT) osu_igatherv$(EXEEXT) \
|
||||
- osu_iallgatherv$(EXEEXT) osu_ialltoallv$(EXEEXT) \
|
||||
- osu_ialltoallw$(EXEEXT)
|
||||
+ osu_allgather$(EXEEXT) osu_scatter$(EXEEXT)
|
||||
@CUDA_KERNELS_TRUE@am__append_1 = ../../util/kernel.cu
|
||||
@BUILD_PROFILING_LIB_TRUE@@EMBEDDED_BUILD_TRUE@am__append_2 = $(top_builddir)/../lib/lib@PMPILIBNAME@.la
|
||||
@OPENACC_TRUE@am__append_3 = -acc
|
@ -1,19 +1,19 @@
|
||||
%global intel_mpi_bench_vers 2018.1
|
||||
%global osu_micro_bench_vers 5.4.2
|
||||
%global intel_mpi_bench_vers IMB-v2019.6
|
||||
%global osu_micro_bench_vers 5.6.2
|
||||
Summary: MPI Benchmarks and tests
|
||||
Name: mpitests
|
||||
Version: %{osu_micro_bench_vers}
|
||||
Release: 4%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: CPL and BSD
|
||||
Group: Applications/Engineering
|
||||
# These days we get the benchmark soucres from Intel and OSU directly
|
||||
# rather than from openfabrics.
|
||||
URL: http://www.openfabrics.org
|
||||
# https://software.intel.com/en-us/articles/intel-mpi-benchmarks
|
||||
Source0: https://github.com/intel/mpi-benchmarks/archive/v%{intel_mpi_bench_vers}.tar.gz
|
||||
Source0: https://github.com/intel/mpi-benchmarks/archive/%{intel_mpi_bench_vers}.tar.gz
|
||||
Source1: http://mvapich.cse.ohio-state.edu/download/mvapich/osu-micro-benchmarks-%{osu_micro_bench_vers}.tar.gz
|
||||
# Only for old openmpi
|
||||
Patch101: OMB-disable-collective-async.patch
|
||||
#Patch101: OMB-disable-collective-async.patch
|
||||
BuildRequires: hwloc-devel, libibmad-devel, rdma-core-devel
|
||||
|
||||
%description
|
||||
@ -75,13 +75,14 @@ export CC=mpicc
|
||||
export CXX=mpicxx
|
||||
export FC=mpif90
|
||||
export F77=mpif77
|
||||
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
|
||||
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fPIC"
|
||||
export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fPIC"
|
||||
do_build() {
|
||||
mkdir build-$MPI_COMPILER
|
||||
cp -al mpi-benchmarks-%{intel_mpi_bench_vers} osu-micro-benchmarks-%{osu_micro_bench_vers} build-$MPI_COMPILER
|
||||
cd build-$MPI_COMPILER/mpi-benchmarks-%{intel_mpi_bench_vers}/src
|
||||
make -f make_mpich OPTFLAGS="%{build_cflags}" LDFLAGS="%{build_ldflags}" MPI_HOME="$MPI_HOME" all
|
||||
cd ../../osu-micro-benchmarks-%{osu_micro_bench_vers}
|
||||
cd build-$MPI_COMPILER/mpi-benchmarks-%{intel_mpi_bench_vers}
|
||||
make OPTFLAGS="%{build_cflags}" LDFLAGS="%{build_ldflags}" MPI_HOME="$MPI_HOME" all
|
||||
cd ../osu-micro-benchmarks-%{osu_micro_bench_vers}
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
cd ../..
|
||||
@ -119,11 +120,11 @@ do_install() {
|
||||
find %{buildroot}/staging -name 'osu_*' -type f -perm -111 | while read X; do
|
||||
mv $X %{buildroot}$MPI_BIN/mpitests-$(basename $X)
|
||||
done
|
||||
cd ../mpi-benchmarks-%{intel_mpi_bench_vers}/src
|
||||
cd ../mpi-benchmarks-%{intel_mpi_bench_vers}/
|
||||
for X in IMB-*; do
|
||||
cp $X %{buildroot}$MPI_BIN/mpitests-$X
|
||||
done
|
||||
cd ../../..
|
||||
cd ../..
|
||||
}
|
||||
|
||||
# do N installs, one for each mpi stack
|
||||
@ -168,6 +169,11 @@ do_install
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue May 12 2020 Honggang Li <honli@redhat.com> - 5.6.2-1
|
||||
- Update OSU benchmarks to upstream release 5.6.2
|
||||
- Update IMB benchmarks to upstream release v2019.6
|
||||
- Resolves: rhbz#1817837
|
||||
|
||||
* Sat Sep 22 2018 Jarod Wilson <jarod@redhat.com> - 5.4.2-4
|
||||
- Properly fix build and linker flags, annocheck now silent
|
||||
- Resolves: rhbz#1624145
|
||||
|
Loading…
Reference in New Issue
Block a user