Version 3.4
This commit is contained in:
parent
1e5d01f946
commit
ac3cd7fb27
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
|||||||
/mpich-3.1.1.tar.gz
|
/mpich-3.1.1.tar.gz
|
||||||
/mpich-3.3.1.tar.gz
|
/mpich-3.3.1.tar.gz
|
||||||
/mpich-3.3.2.tar.gz
|
/mpich-3.3.2.tar.gz
|
||||||
|
/mpich-3.4.tar.gz
|
||||||
|
@ -1,34 +0,0 @@
|
|||||||
From fbb8f503df077c726b0c99d467bc984566273b92 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
||||||
Date: Tue, 15 Sep 2020 14:20:17 +0200
|
|
||||||
Subject: [PATCH 1/2] mpl: limit scope on macos .local workaround
|
|
||||||
|
|
||||||
This was added in 62f4178981617384fc116da4c839baf469bef512.
|
|
||||||
Assuming that "localhost" is equivalent to any name ending in .local
|
|
||||||
is unwarranted. RFC6762 reserves the ".local" suffix for MulticastDNS use,
|
|
||||||
but it is also used in other context for "local network" addresses and such.
|
|
||||||
So let's at least limit the scope to not hurt other systems.
|
|
||||||
---
|
|
||||||
src/mpl/src/sock/mpl_sockaddr.c | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/mpl/src/sock/mpl_sockaddr.c b/src/mpl/src/sock/mpl_sockaddr.c
|
|
||||||
index 51e9f9973f..9334cc4fb2 100644
|
|
||||||
--- a/src/mpl/src/sock/mpl_sockaddr.c
|
|
||||||
+++ b/src/mpl/src/sock/mpl_sockaddr.c
|
|
||||||
@@ -75,6 +75,7 @@ int MPL_get_sockaddr(const char *s_hostname, MPL_sockaddr_t * p_addr)
|
|
||||||
struct addrinfo *ai_list;
|
|
||||||
int ret;
|
|
||||||
|
|
||||||
+#ifdef __APPLE__
|
|
||||||
/* Macos adds .local to hostname when network is unavailable or limited.
|
|
||||||
* This will result in long timeout in getaddrinfo below.
|
|
||||||
* Bypass it by resetting the hostname to "localhost"
|
|
||||||
@@ -83,6 +84,7 @@ int MPL_get_sockaddr(const char *s_hostname, MPL_sockaddr_t * p_addr)
|
|
||||||
if (n > 6 && strcmp(s_hostname + n - 6, ".local") == 0) {
|
|
||||||
s_hostname = "localhost";
|
|
||||||
}
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
/* NOTE: there is report that getaddrinfo implementations will call kernel
|
|
||||||
* even when s_hostname is entirely numerical string and it may cause
|
|
@ -1,57 +0,0 @@
|
|||||||
From ecb72e6699f4f8525115e0b42f81121a1cf8eefa Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
||||||
Date: Tue, 15 Sep 2020 14:59:58 +0200
|
|
||||||
Subject: [PATCH 2/2] mpl: do not require non-loopback networking
|
|
||||||
|
|
||||||
getaddrinfo(3) says:
|
|
||||||
If hints.ai_flags includes the AI_ADDRCONFIG flag, then IPv4
|
|
||||||
addresses are returned in the list pointed to by res only if the
|
|
||||||
local system has at least one IPv4 address configured, and IPv6
|
|
||||||
addresses are returned only if the local system has at least one
|
|
||||||
IPv6 address configured. The loopback address is not considered for
|
|
||||||
this case as valid as a configured address.
|
|
||||||
|
|
||||||
This means that MPL_get_sockaddr() will fail to resolve the local host
|
|
||||||
(either as "localhost" or by the actual hostname) on a system that has
|
|
||||||
no non-loopback networking. This break exection of mpirun e.g. in a
|
|
||||||
container for tests and such.
|
|
||||||
|
|
||||||
From https://bugzilla.redhat.com/show_bug.cgi?id=1839007:
|
|
||||||
|
|
||||||
<mock-chroot> sh-5.0# hostname
|
|
||||||
68da8e7c62a2404bb4bf75c9ce643e06
|
|
||||||
<mock-chroot> sh-5.0# module load mpi/mpich-x86_64
|
|
||||||
<mock-chroot> sh-5.0# mpirun ./a.out
|
|
||||||
Fatal error in PMPI_Init: Other MPI error, error stack:
|
|
||||||
MPIR_Init_thread(586)..............:
|
|
||||||
MPID_Init(224).....................: channel initialization failed
|
|
||||||
MPIDI_CH3_Init(105)................:
|
|
||||||
MPID_nem_init(324).................:
|
|
||||||
MPID_nem_tcp_init(175).............:
|
|
||||||
MPID_nem_tcp_get_business_card(404):
|
|
||||||
MPID_nem_tcp_init(375).............: gethostbyname failed, 68da8e7c62a2404bb4bf75c9ce643e06 (errno 0)
|
|
||||||
|
|
||||||
<mock-chroot> sh-5.0# ip a
|
|
||||||
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
|
|
||||||
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
|
|
||||||
inet 127.0.0.1/8 scope host lo
|
|
||||||
valid_lft forever preferred_lft forever
|
|
||||||
inet6 ::1/128 scope host
|
|
||||||
valid_lft forever preferred_lft forever
|
|
||||||
---
|
|
||||||
src/mpl/src/sock/mpl_sockaddr.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/mpl/src/sock/mpl_sockaddr.c b/src/mpl/src/sock/mpl_sockaddr.c
|
|
||||||
index 9334cc4fb2..c0e991c68d 100644
|
|
||||||
--- a/src/mpl/src/sock/mpl_sockaddr.c
|
|
||||||
+++ b/src/mpl/src/sock/mpl_sockaddr.c
|
|
||||||
@@ -98,7 +98,7 @@ int MPL_get_sockaddr(const char *s_hostname, MPL_sockaddr_t * p_addr)
|
|
||||||
ai_hint.ai_family = af_type;
|
|
||||||
ai_hint.ai_socktype = SOCK_STREAM;
|
|
||||||
ai_hint.ai_protocol = IPPROTO_TCP;
|
|
||||||
- ai_hint.ai_flags = AI_ADDRCONFIG | AI_V4MAPPED;
|
|
||||||
+ ai_hint.ai_flags = AI_V4MAPPED;
|
|
||||||
ret = getaddrinfo(s_hostname, NULL, &ai_hint, &ai_list);
|
|
||||||
if (ret) {
|
|
||||||
return ret;
|
|
101
4320.patch
101
4320.patch
@ -1,101 +0,0 @@
|
|||||||
From a1524608b05e6c89e2b99f64923f064d888465ce Mon Sep 17 00:00:00 2001
|
|
||||||
From: Hui Zhou <hzhou321@anl.gov>
|
|
||||||
Date: Mon, 18 Nov 2019 14:52:55 -0600
|
|
||||||
Subject: [PATCH 1/2] ch3: fix improper error handling from MPL_get_sockaddr
|
|
||||||
|
|
||||||
MPL layer does not directly return mpi_errno. Use MPIR_ERR_CHKANDJUMP
|
|
||||||
macro to create the appropriate return code. See pmodels/mpich#4318.
|
|
||||||
|
|
||||||
Cherry-picked from [8d923937ec5d].
|
|
||||||
---
|
|
||||||
.../channels/nemesis/netmod/tcp/tcp_init.c | 23 +++++++++++--------
|
|
||||||
1 file changed, 13 insertions(+), 10 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/mpid/ch3/channels/nemesis/netmod/tcp/tcp_init.c b/src/mpid/ch3/channels/nemesis/netmod/tcp/tcp_init.c
|
|
||||||
index 4c2383ed8f..bc58211eb6 100644
|
|
||||||
--- a/src/mpid/ch3/channels/nemesis/netmod/tcp/tcp_init.c
|
|
||||||
+++ b/src/mpid/ch3/channels/nemesis/netmod/tcp/tcp_init.c
|
|
||||||
@@ -307,8 +307,9 @@ static int GetSockInterfaceAddr(int myRank, char *ifname, int maxIfname,
|
|
||||||
if (MPIR_CVAR_NEMESIS_TCP_NETWORK_IFACE) {
|
|
||||||
char s[100];
|
|
||||||
int len;
|
|
||||||
- mpi_errno = MPL_get_sockaddr_iface(MPIR_CVAR_NEMESIS_TCP_NETWORK_IFACE, p_addr);
|
|
||||||
- MPIR_ERR_CHKANDJUMP1(mpi_errno, mpi_errno, MPI_ERR_OTHER, "**iface_notfound", "**iface_notfound %s", MPIR_CVAR_NEMESIS_TCP_NETWORK_IFACE);
|
|
||||||
+ int ret = MPL_get_sockaddr_iface(MPIR_CVAR_NEMESIS_TCP_NETWORK_IFACE, p_addr);
|
|
||||||
+ MPIR_ERR_CHKANDJUMP1(ret != 0, mpi_errno, MPI_ERR_OTHER, "**iface_notfound",
|
|
||||||
+ "**iface_notfound %s", MPIR_CVAR_NEMESIS_TCP_NETWORK_IFACE);
|
|
||||||
|
|
||||||
MPL_sockaddr_to_str(p_addr, s, 100);
|
|
||||||
MPL_DBG_MSG_FMT(MPIDI_CH3_DBG_CONNECT, VERBOSE, (MPL_DBG_FDEST,
|
|
||||||
@@ -354,12 +355,13 @@ static int GetSockInterfaceAddr(int myRank, char *ifname, int maxIfname,
|
|
||||||
|
|
||||||
ifname_string = ifname;
|
|
||||||
|
|
||||||
- /* If we didn't find a specific name, then try to get an IP address
|
|
||||||
- directly from the available interfaces, if that is supported on
|
|
||||||
- this platform. Otherwise, we'll drop into the next step that uses
|
|
||||||
- the ifname */
|
|
||||||
- mpi_errno = MPL_get_sockaddr_iface( NULL, p_addr);
|
|
||||||
- if (mpi_errno) MPIR_ERR_POP(mpi_errno);
|
|
||||||
+ /* If we didn't find a specific name, then try to get an IP address
|
|
||||||
+ * directly from the available interfaces, if that is supported on
|
|
||||||
+ * this platform. Otherwise, we'll drop into the next step that uses
|
|
||||||
+ * the ifname */
|
|
||||||
+ int ret = MPL_get_sockaddr_iface(NULL, p_addr);
|
|
||||||
+ MPIR_ERR_CHKANDJUMP1(ret != 0, mpi_errno, MPI_ERR_OTHER, "**iface_notfound",
|
|
||||||
+ "**iface_notfound %s", NULL);
|
|
||||||
ifaddrFound = 1;
|
|
||||||
}
|
|
||||||
else {
|
|
||||||
@@ -369,8 +371,9 @@ static int GetSockInterfaceAddr(int myRank, char *ifname, int maxIfname,
|
|
||||||
|
|
||||||
/* If we don't have an IP address, try to get it from the name */
|
|
||||||
if (!ifaddrFound) {
|
|
||||||
- mpi_errno = MPL_get_sockaddr(ifname_string, p_addr);
|
|
||||||
- MPIR_ERR_CHKANDJUMP2(mpi_errno, mpi_errno, MPI_ERR_OTHER, "**gethostbyname", "**gethostbyname %s %d", ifname_string, h_errno);
|
|
||||||
+ int ret = MPL_get_sockaddr(ifname_string, p_addr);
|
|
||||||
+ MPIR_ERR_CHKANDJUMP2(ret != 0, mpi_errno, MPI_ERR_OTHER, "**gethostbyname",
|
|
||||||
+ "**gethostbyname %s %d", ifname_string, h_errno);
|
|
||||||
}
|
|
||||||
|
|
||||||
fn_exit:
|
|
||||||
|
|
||||||
From 89157ad35c0885b4758d250d019f0f7cf0f59095 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Hui Zhou <hzhou321@anl.gov>
|
|
||||||
Date: Wed, 15 Jan 2020 13:29:56 -0600
|
|
||||||
Subject: [PATCH 2/2] pmi: fix a wrong condition checking return of
|
|
||||||
MPL_get_sockaddr
|
|
||||||
|
|
||||||
Cherry-picked from [3e6af3c2fbaf]. See pmodels/mpich#4318.
|
|
||||||
---
|
|
||||||
src/mpl/include/mpl_sockaddr.h | 3 +++
|
|
||||||
src/pmi/simple/simple_pmi.c | 2 +-
|
|
||||||
2 files changed, 4 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/mpl/include/mpl_sockaddr.h b/src/mpl/include/mpl_sockaddr.h
|
|
||||||
index c0eb749419..a9860c1353 100644
|
|
||||||
--- a/src/mpl/include/mpl_sockaddr.h
|
|
||||||
+++ b/src/mpl/include/mpl_sockaddr.h
|
|
||||||
@@ -21,6 +21,9 @@
|
|
||||||
|
|
||||||
typedef struct sockaddr_storage MPL_sockaddr_t;
|
|
||||||
|
|
||||||
+/* The following functions when return an int, it returns 0 on success,
|
|
||||||
+ * non-zero indicates error. It is consistent with posix socket functions.
|
|
||||||
+ */
|
|
||||||
void MPL_sockaddr_set_aftype(int type);
|
|
||||||
int MPL_get_sockaddr(const char *s_hostname, MPL_sockaddr_t * p_addr);
|
|
||||||
int MPL_get_sockaddr_direct(int type, MPL_sockaddr_t * p_addr);
|
|
||||||
diff --git a/src/pmi/simple/simple_pmi.c b/src/pmi/simple/simple_pmi.c
|
|
||||||
index df37a8689f..7f660bdac9 100644
|
|
||||||
--- a/src/pmi/simple/simple_pmi.c
|
|
||||||
+++ b/src/pmi/simple/simple_pmi.c
|
|
||||||
@@ -881,7 +881,7 @@ static int PMII_Connect_to_pm(char *hostname, int portnum)
|
|
||||||
int q_wait = 1;
|
|
||||||
|
|
||||||
ret = MPL_get_sockaddr(hostname, &addr);
|
|
||||||
- if (!ret) {
|
|
||||||
+ if (ret) {
|
|
||||||
PMIU_printf(1, "Unable to get host entry for %s\n", hostname);
|
|
||||||
return PMI_FAIL;
|
|
||||||
}
|
|
17
mpich.spec
17
mpich.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A high-performance implementation of MPI
|
Summary: A high-performance implementation of MPI
|
||||||
Name: mpich
|
Name: mpich
|
||||||
Version: 3.3.2
|
Version: 3.4
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: https://www.mpich.org/
|
URL: https://www.mpich.org/
|
||||||
|
|
||||||
@ -11,16 +11,11 @@ Source2: mpich.pth.py2
|
|||||||
Source3: mpich.pth.py3
|
Source3: mpich.pth.py3
|
||||||
Patch0: mpich-modules.patch
|
Patch0: mpich-modules.patch
|
||||||
Patch1: 0001-Drop-real128.patch
|
Patch1: 0001-Drop-real128.patch
|
||||||
# fix for #1793563 and #1799473
|
|
||||||
Patch2: https://github.com/pmodels/mpich/pull/4320.patch
|
|
||||||
# Drop build flags, e.g. -specs... and -lto from mpi wrappers (mpicc and mpicxx)
|
# Drop build flags, e.g. -specs... and -lto from mpi wrappers (mpicc and mpicxx)
|
||||||
# for discussion see:
|
# for discussion see:
|
||||||
# https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/7TFWEKTDWBYBHEGMIWBVI3AVGORZGNBS/
|
# https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/7TFWEKTDWBYBHEGMIWBVI3AVGORZGNBS/
|
||||||
Patch3: fix_wrapper_flags.patch
|
Patch3: fix_wrapper_flags.patch
|
||||||
|
|
||||||
Patch4: 0001-mpl-limit-scope-on-macos-.local-workaround.patch
|
|
||||||
Patch5: 0002-mpl-do-not-require-non-loopback-networking.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -113,11 +108,8 @@ mpich support for Python 3.
|
|||||||
%ifarch %{arm}
|
%ifarch %{arm}
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%endif
|
%endif
|
||||||
%patch2 -p1
|
|
||||||
%patch3 -p1
|
|
||||||
|
|
||||||
%patch4 -p1
|
%patch3 -p1
|
||||||
%patch5 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CONFIGURE_OPTS=(
|
CONFIGURE_OPTS=(
|
||||||
@ -248,6 +240,9 @@ make check VERBOSE=1 \
|
|||||||
%{python3_sitearch}/%{name}.pth
|
%{python3_sitearch}/%{name}.pth
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 5 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 3.4-1
|
||||||
|
- Update to latest version
|
||||||
|
|
||||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.2-9
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.2-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mpich-3.3.2.tar.gz) = 555a92e66f0154dde8ac609b3d1410524f644f4eb727bcd910fc20504cf93ede13ab4b5f14dbf5e2201001474a1d687aba3b7d263e74144fc7f968a19a163193
|
SHA512 (mpich-3.4.tar.gz) = c96bcef5e7e0d7fbeb7be05868982a4dcd8f99387364807f2a6b04e6a03cdd798e3900f2afd00fde55e24151dcd520147a590302819ab4cc67246a42a223eb0d
|
||||||
|
Loading…
Reference in New Issue
Block a user