Update to 4.1; Switch to default ch4:ofi device
This commit is contained in:
parent
db223e3554
commit
91fddcde5e
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@
|
|||||||
/mpich-3.4.1.tar.gz
|
/mpich-3.4.1.tar.gz
|
||||||
/mpich-4.0.2.tar.gz
|
/mpich-4.0.2.tar.gz
|
||||||
/mpich-4.0.3.tar.gz
|
/mpich-4.0.3.tar.gz
|
||||||
|
/mpich-4.1.tar.gz
|
||||||
|
@ -1,25 +1,25 @@
|
|||||||
From e4f0e86f815d8bd3dbb7cccf660bae6ab7f302dd Mon Sep 17 00:00:00 2001
|
From 030214c7084cf5aaf4372147f48343b9915ca743 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
From: rpm-build <rpm-build>
|
||||||
Date: Sun, 10 Apr 2022 09:35:14 +0200
|
Date: Wed, 1 Mar 2023 19:24:41 -0700
|
||||||
Subject: [PATCH 3/4] Drop build flags, e.g. -specs... and -lto from mpi
|
Subject: [PATCH 3/3] Drop build flags, e.g. -specs... and -lto from mpi
|
||||||
wrappers (mpicc and mpicxx)
|
wrappers (mpicc and mpicxx)
|
||||||
|
|
||||||
For discussion see:
|
For discussion see:
|
||||||
https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/7TFWEKTDWBYBHEGMIWBVI3AVGORZGNBS/
|
https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/7TFWEKTDWBYBHEGMIWBVI3AVGORZGNBS/
|
||||||
---
|
---
|
||||||
src/env/mpicc.bash.in | 8 ++++----
|
src/env/mpicc.bash.in | 6 +++---
|
||||||
src/env/mpicc.sh.in | 8 ++++----
|
src/env/mpicc.sh.in | 6 +++---
|
||||||
src/env/mpicxx.bash.in | 8 ++++----
|
src/env/mpicxx.bash.in | 6 +++---
|
||||||
src/env/mpicxx.sh.in | 8 ++++----
|
src/env/mpicxx.sh.in | 6 +++---
|
||||||
src/env/mpifort.bash.in | 6 +++---
|
src/env/mpifort.bash.in | 4 ++--
|
||||||
src/env/mpifort.sh.in | 6 +++---
|
src/env/mpifort.sh.in | 4 ++--
|
||||||
6 files changed, 22 insertions(+), 22 deletions(-)
|
6 files changed, 16 insertions(+), 16 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/env/mpicc.bash.in b/src/env/mpicc.bash.in
|
diff --git a/src/env/mpicc.bash.in b/src/env/mpicc.bash.in
|
||||||
index 56d2dcb242..933ee22bf0 100644
|
index 3fc695f..f31e436 100644
|
||||||
--- a/src/env/mpicc.bash.in
|
--- a/src/env/mpicc.bash.in
|
||||||
+++ b/src/env/mpicc.bash.in
|
+++ b/src/env/mpicc.bash.in
|
||||||
@@ -247,13 +247,13 @@ if [ -n "$profConf" ] ; then
|
@@ -247,9 +247,9 @@ if [ -n "$profConf" ] ; then
|
||||||
fi
|
fi
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -32,16 +32,11 @@ index 56d2dcb242..933ee22bf0 100644
|
|||||||
final_libs="@MPICH_MPICC_LIBS@"
|
final_libs="@MPICH_MPICC_LIBS@"
|
||||||
if test "@INTERLIB_DEPS@" = "no" -o "${interlib_deps}" = "no" ; then
|
if test "@INTERLIB_DEPS@" = "no" -o "${interlib_deps}" = "no" ; then
|
||||||
final_ldflags="${final_ldflags} @LDFLAGS@"
|
final_ldflags="${final_ldflags} @LDFLAGS@"
|
||||||
- final_libs="${final_libs} @LIBS@ @WRAPPER_LIBS@"
|
|
||||||
+ final_libs="${final_libs} @LIBS@ "
|
|
||||||
fi
|
|
||||||
|
|
||||||
# -----------------------------------------------------------------------
|
|
||||||
diff --git a/src/env/mpicc.sh.in b/src/env/mpicc.sh.in
|
diff --git a/src/env/mpicc.sh.in b/src/env/mpicc.sh.in
|
||||||
index 654131528e..4ebdc8b6ef 100644
|
index 99a8c90..89ef111 100644
|
||||||
--- a/src/env/mpicc.sh.in
|
--- a/src/env/mpicc.sh.in
|
||||||
+++ b/src/env/mpicc.sh.in
|
+++ b/src/env/mpicc.sh.in
|
||||||
@@ -253,13 +253,13 @@ if [ -n "$profConf" ] ; then
|
@@ -253,9 +253,9 @@ if [ -n "$profConf" ] ; then
|
||||||
fi
|
fi
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -54,16 +49,11 @@ index 654131528e..4ebdc8b6ef 100644
|
|||||||
final_libs="@MPICH_MPICC_LIBS@"
|
final_libs="@MPICH_MPICC_LIBS@"
|
||||||
if test "@INTERLIB_DEPS@" = "no" -o "${interlib_deps}" = "no" ; then
|
if test "@INTERLIB_DEPS@" = "no" -o "${interlib_deps}" = "no" ; then
|
||||||
final_ldflags="${final_ldflags} @LDFLAGS@"
|
final_ldflags="${final_ldflags} @LDFLAGS@"
|
||||||
- final_libs="${final_libs} @LIBS@ @WRAPPER_LIBS@"
|
|
||||||
+ final_libs="${final_libs} @LIBS@ "
|
|
||||||
fi
|
|
||||||
|
|
||||||
# -----------------------------------------------------------------------
|
|
||||||
diff --git a/src/env/mpicxx.bash.in b/src/env/mpicxx.bash.in
|
diff --git a/src/env/mpicxx.bash.in b/src/env/mpicxx.bash.in
|
||||||
index 10d11e3fba..4066bb46f2 100644
|
index 29566ba..f80882e 100644
|
||||||
--- a/src/env/mpicxx.bash.in
|
--- a/src/env/mpicxx.bash.in
|
||||||
+++ b/src/env/mpicxx.bash.in
|
+++ b/src/env/mpicxx.bash.in
|
||||||
@@ -253,13 +253,13 @@ if [ -n "$profConf" ] ; then
|
@@ -253,9 +253,9 @@ if [ -n "$profConf" ] ; then
|
||||||
fi
|
fi
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -76,16 +66,11 @@ index 10d11e3fba..4066bb46f2 100644
|
|||||||
final_libs="@MPICH_MPICXX_LIBS@"
|
final_libs="@MPICH_MPICXX_LIBS@"
|
||||||
if test "@INTERLIB_DEPS@" = "no" -o "${interlib_deps}" = "no" ; then
|
if test "@INTERLIB_DEPS@" = "no" -o "${interlib_deps}" = "no" ; then
|
||||||
final_ldflags="${final_ldflags} @LDFLAGS@"
|
final_ldflags="${final_ldflags} @LDFLAGS@"
|
||||||
- final_libs="${final_libs} @LIBS@ @WRAPPER_LIBS@"
|
|
||||||
+ final_libs="${final_libs} @LIBS@ "
|
|
||||||
fi
|
|
||||||
|
|
||||||
# A temporary statement to invoke the compiler
|
|
||||||
diff --git a/src/env/mpicxx.sh.in b/src/env/mpicxx.sh.in
|
diff --git a/src/env/mpicxx.sh.in b/src/env/mpicxx.sh.in
|
||||||
index 1c0078100f..2c090cb06c 100644
|
index 0b830fe..32dab65 100644
|
||||||
--- a/src/env/mpicxx.sh.in
|
--- a/src/env/mpicxx.sh.in
|
||||||
+++ b/src/env/mpicxx.sh.in
|
+++ b/src/env/mpicxx.sh.in
|
||||||
@@ -259,13 +259,13 @@ if [ -n "$profConf" ] ; then
|
@@ -259,9 +259,9 @@ if [ -n "$profConf" ] ; then
|
||||||
fi
|
fi
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -98,16 +83,11 @@ index 1c0078100f..2c090cb06c 100644
|
|||||||
final_libs="@MPICH_MPICXX_LIBS@"
|
final_libs="@MPICH_MPICXX_LIBS@"
|
||||||
if test "@INTERLIB_DEPS@" = "no" -o "${interlib_deps}" = "no" ; then
|
if test "@INTERLIB_DEPS@" = "no" -o "${interlib_deps}" = "no" ; then
|
||||||
final_ldflags="${final_ldflags} @LDFLAGS@"
|
final_ldflags="${final_ldflags} @LDFLAGS@"
|
||||||
- final_libs="${final_libs} @LIBS@ @WRAPPER_LIBS@"
|
|
||||||
+ final_libs="${final_libs} @LIBS@ "
|
|
||||||
fi
|
|
||||||
|
|
||||||
# A temporary statement to invoke the compiler
|
|
||||||
diff --git a/src/env/mpifort.bash.in b/src/env/mpifort.bash.in
|
diff --git a/src/env/mpifort.bash.in b/src/env/mpifort.bash.in
|
||||||
index 1130c57986..91a6cb56c5 100644
|
index 5312aea..2322b4f 100644
|
||||||
--- a/src/env/mpifort.bash.in
|
--- a/src/env/mpifort.bash.in
|
||||||
+++ b/src/env/mpifort.bash.in
|
+++ b/src/env/mpifort.bash.in
|
||||||
@@ -335,12 +335,12 @@ elif [ -n "$FCMODINC" ] ; then
|
@@ -335,8 +335,8 @@ elif [ -n "$FCMODINC" ] ; then
|
||||||
FCMODDIRS="${FCMODINC}$modincdir"
|
FCMODDIRS="${FCMODINC}$modincdir"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -118,16 +98,11 @@ index 1130c57986..91a6cb56c5 100644
|
|||||||
final_libs="@MPICH_MPIFORT_LIBS@"
|
final_libs="@MPICH_MPIFORT_LIBS@"
|
||||||
if test "@INTERLIB_DEPS@" = "no" -o "${interlib_deps}" = "no" ; then
|
if test "@INTERLIB_DEPS@" = "no" -o "${interlib_deps}" = "no" ; then
|
||||||
final_ldflags="${final_ldflags} @LDFLAGS@"
|
final_ldflags="${final_ldflags} @LDFLAGS@"
|
||||||
- final_libs="${final_libs} @LIBS@ @WRAPPER_LIBS@"
|
|
||||||
+ final_libs="${final_libs} @LIBS@ "
|
|
||||||
fi
|
|
||||||
|
|
||||||
# A temporary statement to invoke the compiler
|
|
||||||
diff --git a/src/env/mpifort.sh.in b/src/env/mpifort.sh.in
|
diff --git a/src/env/mpifort.sh.in b/src/env/mpifort.sh.in
|
||||||
index a1e7f4dd8e..9d89a8bbe7 100644
|
index 902b0f7..665fe85 100644
|
||||||
--- a/src/env/mpifort.sh.in
|
--- a/src/env/mpifort.sh.in
|
||||||
+++ b/src/env/mpifort.sh.in
|
+++ b/src/env/mpifort.sh.in
|
||||||
@@ -352,12 +352,12 @@ elif [ -n "$FCMODINC" ] ; then
|
@@ -352,8 +352,8 @@ elif [ -n "$FCMODINC" ] ; then
|
||||||
FCMODDIRS="${FCMODINC}$modincdir"
|
FCMODDIRS="${FCMODINC}$modincdir"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -138,8 +113,6 @@ index a1e7f4dd8e..9d89a8bbe7 100644
|
|||||||
final_libs="@MPICH_MPIFORT_LIBS@"
|
final_libs="@MPICH_MPIFORT_LIBS@"
|
||||||
if test "@INTERLIB_DEPS@" = "no" -o "${interlib_deps}" = "no" ; then
|
if test "@INTERLIB_DEPS@" = "no" -o "${interlib_deps}" = "no" ; then
|
||||||
final_ldflags="${final_ldflags} @LDFLAGS@"
|
final_ldflags="${final_ldflags} @LDFLAGS@"
|
||||||
- final_libs="${final_libs} @LIBS@ @WRAPPER_LIBS@"
|
--
|
||||||
+ final_libs="${final_libs} @LIBS@ "
|
2.39.2
|
||||||
fi
|
|
||||||
|
|
||||||
# A temporary statement to invoke the compiler
|
|
||||||
|
38
6374.patch
38
6374.patch
@ -1,38 +0,0 @@
|
|||||||
From 2b8c5c7dc4974fc471b446e6cc939936aa14fd8f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Hui Zhou <hzhou321@anl.gov>
|
|
||||||
Date: Sat, 21 Jan 2023 10:35:32 -0600
|
|
||||||
Subject: [PATCH] coll: fix allgatherv early return case
|
|
||||||
|
|
||||||
The localcopy omitted considering displs.
|
|
||||||
---
|
|
||||||
src/binding/c/coll_api.txt | 10 ++++++++--
|
|
||||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/binding/c/coll_api.txt b/src/binding/c/coll_api.txt
|
|
||||||
index 55be70d093e..d288272e2f3 100644
|
|
||||||
--- a/src/binding/c/coll_api.txt
|
|
||||||
+++ b/src/binding/c/coll_api.txt
|
|
||||||
@@ -57,7 +57,10 @@ MPI_Allgatherv:
|
|
||||||
{ -- early_return --
|
|
||||||
if (comm_ptr->comm_kind == MPIR_COMM_KIND__INTRACOMM && MPIR_Comm_size(comm_ptr) == 1) {
|
|
||||||
if (sendbuf != MPI_IN_PLACE) {
|
|
||||||
- MPIR_Localcopy(sendbuf, sendcount, sendtype, recvbuf, recvcounts[0], recvtype);
|
|
||||||
+ MPI_Aint recvtype_extent;
|
|
||||||
+ MPIR_Datatype_get_extent_macro(recvtype, recvtype_extent);
|
|
||||||
+ MPIR_Localcopy(sendbuf, sendcount, sendtype,
|
|
||||||
+ (char *) recvbuf + displs[0] * recvtype_extent, recvcounts[0], recvtype);
|
|
||||||
}
|
|
||||||
goto fn_exit;
|
|
||||||
}
|
|
||||||
@@ -188,7 +191,10 @@ MPI_Iallgatherv:
|
|
||||||
{ -- early_return --
|
|
||||||
if (comm_ptr->comm_kind == MPIR_COMM_KIND__INTRACOMM && MPIR_Comm_size(comm_ptr) == 1) {
|
|
||||||
if (sendbuf != MPI_IN_PLACE) {
|
|
||||||
- MPIR_Localcopy(sendbuf, sendcount, sendtype, recvbuf, recvcounts[0], recvtype);
|
|
||||||
+ MPI_Aint recvtype_extent;
|
|
||||||
+ MPIR_Datatype_get_extent_macro(recvtype, recvtype_extent);
|
|
||||||
+ MPIR_Localcopy(sendbuf, sendcount, sendtype,
|
|
||||||
+ (char *) recvbuf + displs[0] * recvtype_extent, recvcounts[0], recvtype);
|
|
||||||
}
|
|
||||||
MPIR_Request *request_ptr = MPIR_Request_create_complete(MPIR_REQUEST_KIND__COLL);
|
|
||||||
*request = request_ptr->handle;
|
|
@ -6,10 +6,10 @@ revision.
|
|||||||
Submitted upstream: <https://github.com/pmodels/mpich/pull/6301>
|
Submitted upstream: <https://github.com/pmodels/mpich/pull/6301>
|
||||||
|
|
||||||
diff --git a/confdb/aclocal_cc.m4 b/confdb/aclocal_cc.m4
|
diff --git a/confdb/aclocal_cc.m4 b/confdb/aclocal_cc.m4
|
||||||
index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
index a85e082..2710ada 100644
|
||||||
--- a/confdb/aclocal_cc.m4
|
--- a/confdb/aclocal_cc.m4
|
||||||
+++ b/confdb/aclocal_cc.m4
|
+++ b/confdb/aclocal_cc.m4
|
||||||
@@ -388,7 +388,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
@@ -381,7 +381,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
||||||
#pragma weak PFoo_ = Foo
|
#pragma weak PFoo_ = Foo
|
||||||
#pragma weak pfoo_ = Foo
|
#pragma weak pfoo_ = Foo
|
||||||
int Foo(int);
|
int Foo(int);
|
||||||
@ -19,7 +19,7 @@ index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
|||||||
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
||||||
int main() {
|
int main() {
|
||||||
diff --git a/modules/json-c/autoconf-archive/m4/aclocal_cc.m4 b/modules/json-c/autoconf-archive/m4/aclocal_cc.m4
|
diff --git a/modules/json-c/autoconf-archive/m4/aclocal_cc.m4 b/modules/json-c/autoconf-archive/m4/aclocal_cc.m4
|
||||||
index 8a1552d561306f24..cd28a4f937eaf824 100644
|
index 8a1552d..cd28a4f 100644
|
||||||
--- a/modules/json-c/autoconf-archive/m4/aclocal_cc.m4
|
--- a/modules/json-c/autoconf-archive/m4/aclocal_cc.m4
|
||||||
+++ b/modules/json-c/autoconf-archive/m4/aclocal_cc.m4
|
+++ b/modules/json-c/autoconf-archive/m4/aclocal_cc.m4
|
||||||
@@ -383,7 +383,7 @@ extern int pfoo_(int);
|
@@ -383,7 +383,7 @@ extern int pfoo_(int);
|
||||||
@ -32,7 +32,7 @@ index 8a1552d561306f24..cd28a4f937eaf824 100644
|
|||||||
],[
|
],[
|
||||||
AC_LANG_SOURCE([
|
AC_LANG_SOURCE([
|
||||||
diff --git a/modules/yaksa/m4/aclocal_cc.m4 b/modules/yaksa/m4/aclocal_cc.m4
|
diff --git a/modules/yaksa/m4/aclocal_cc.m4 b/modules/yaksa/m4/aclocal_cc.m4
|
||||||
index d15d6741602daf07..9fcf48527653ff01 100644
|
index d15d674..9fcf485 100644
|
||||||
--- a/modules/yaksa/m4/aclocal_cc.m4
|
--- a/modules/yaksa/m4/aclocal_cc.m4
|
||||||
+++ b/modules/yaksa/m4/aclocal_cc.m4
|
+++ b/modules/yaksa/m4/aclocal_cc.m4
|
||||||
@@ -422,7 +422,7 @@ extern int pfoo_(int);
|
@@ -422,7 +422,7 @@ extern int pfoo_(int);
|
||||||
@ -45,10 +45,10 @@ index d15d6741602daf07..9fcf48527653ff01 100644
|
|||||||
],[
|
],[
|
||||||
AC_LANG_SOURCE([
|
AC_LANG_SOURCE([
|
||||||
diff --git a/src/mpi/romio/confdb/aclocal_cc.m4 b/src/mpi/romio/confdb/aclocal_cc.m4
|
diff --git a/src/mpi/romio/confdb/aclocal_cc.m4 b/src/mpi/romio/confdb/aclocal_cc.m4
|
||||||
index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
index a85e082..2710ada 100644
|
||||||
--- a/src/mpi/romio/confdb/aclocal_cc.m4
|
--- a/src/mpi/romio/confdb/aclocal_cc.m4
|
||||||
+++ b/src/mpi/romio/confdb/aclocal_cc.m4
|
+++ b/src/mpi/romio/confdb/aclocal_cc.m4
|
||||||
@@ -388,7 +388,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
@@ -381,7 +381,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
||||||
#pragma weak PFoo_ = Foo
|
#pragma weak PFoo_ = Foo
|
||||||
#pragma weak pfoo_ = Foo
|
#pragma weak pfoo_ = Foo
|
||||||
int Foo(int);
|
int Foo(int);
|
||||||
@ -58,10 +58,10 @@ index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
|||||||
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
||||||
int main() {
|
int main() {
|
||||||
diff --git a/src/mpi/romio/mpl/confdb/aclocal_cc.m4 b/src/mpi/romio/mpl/confdb/aclocal_cc.m4
|
diff --git a/src/mpi/romio/mpl/confdb/aclocal_cc.m4 b/src/mpi/romio/mpl/confdb/aclocal_cc.m4
|
||||||
index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
index a85e082..2710ada 100644
|
||||||
--- a/src/mpi/romio/mpl/confdb/aclocal_cc.m4
|
--- a/src/mpi/romio/mpl/confdb/aclocal_cc.m4
|
||||||
+++ b/src/mpi/romio/mpl/confdb/aclocal_cc.m4
|
+++ b/src/mpi/romio/mpl/confdb/aclocal_cc.m4
|
||||||
@@ -388,7 +388,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
@@ -381,7 +381,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
||||||
#pragma weak PFoo_ = Foo
|
#pragma weak PFoo_ = Foo
|
||||||
#pragma weak pfoo_ = Foo
|
#pragma weak pfoo_ = Foo
|
||||||
int Foo(int);
|
int Foo(int);
|
||||||
@ -71,10 +71,10 @@ index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
|||||||
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
||||||
int main() {
|
int main() {
|
||||||
diff --git a/src/mpl/confdb/aclocal_cc.m4 b/src/mpl/confdb/aclocal_cc.m4
|
diff --git a/src/mpl/confdb/aclocal_cc.m4 b/src/mpl/confdb/aclocal_cc.m4
|
||||||
index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
index a85e082..2710ada 100644
|
||||||
--- a/src/mpl/confdb/aclocal_cc.m4
|
--- a/src/mpl/confdb/aclocal_cc.m4
|
||||||
+++ b/src/mpl/confdb/aclocal_cc.m4
|
+++ b/src/mpl/confdb/aclocal_cc.m4
|
||||||
@@ -388,7 +388,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
@@ -381,7 +381,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
||||||
#pragma weak PFoo_ = Foo
|
#pragma weak PFoo_ = Foo
|
||||||
#pragma weak pfoo_ = Foo
|
#pragma weak pfoo_ = Foo
|
||||||
int Foo(int);
|
int Foo(int);
|
||||||
@ -84,49 +84,10 @@ index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
|||||||
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
||||||
int main() {
|
int main() {
|
||||||
diff --git a/src/pm/hydra/confdb/aclocal_cc.m4 b/src/pm/hydra/confdb/aclocal_cc.m4
|
diff --git a/src/pm/hydra/confdb/aclocal_cc.m4 b/src/pm/hydra/confdb/aclocal_cc.m4
|
||||||
index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
index a85e082..2710ada 100644
|
||||||
--- a/src/pm/hydra/confdb/aclocal_cc.m4
|
--- a/src/pm/hydra/confdb/aclocal_cc.m4
|
||||||
+++ b/src/pm/hydra/confdb/aclocal_cc.m4
|
+++ b/src/pm/hydra/confdb/aclocal_cc.m4
|
||||||
@@ -388,7 +388,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
@@ -381,7 +381,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
||||||
#pragma weak PFoo_ = Foo
|
|
||||||
#pragma weak pfoo_ = Foo
|
|
||||||
int Foo(int);
|
|
||||||
- int Foo(a) { return a; }
|
|
||||||
+ int Foo(int a) { return a; }
|
|
||||||
]])],[AC_LANG_SOURCE([[
|
|
||||||
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
|
||||||
int main() {
|
|
||||||
diff --git a/src/pm/hydra/mpl/confdb/aclocal_cc.m4 b/src/pm/hydra/mpl/confdb/aclocal_cc.m4
|
|
||||||
index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
|
||||||
--- a/src/pm/hydra/mpl/confdb/aclocal_cc.m4
|
|
||||||
+++ b/src/pm/hydra/mpl/confdb/aclocal_cc.m4
|
|
||||||
@@ -388,7 +388,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
|
||||||
#pragma weak PFoo_ = Foo
|
|
||||||
#pragma weak pfoo_ = Foo
|
|
||||||
int Foo(int);
|
|
||||||
- int Foo(a) { return a; }
|
|
||||||
+ int Foo(int a) { return a; }
|
|
||||||
]])],[AC_LANG_SOURCE([[
|
|
||||||
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
|
||||||
int main() {
|
|
||||||
diff --git a/src/pm/hydra2/confdb/aclocal_cc.m4 b/src/pm/hydra2/confdb/aclocal_cc.m4
|
|
||||||
index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
|
||||||
--- a/src/pm/hydra2/confdb/aclocal_cc.m4
|
|
||||||
+++ b/src/pm/hydra2/confdb/aclocal_cc.m4
|
|
||||||
@@ -388,7 +388,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
|
||||||
#pragma weak PFoo_ = Foo
|
|
||||||
#pragma weak pfoo_ = Foo
|
|
||||||
int Foo(int);
|
|
||||||
- int Foo(a) { return a; }
|
|
||||||
+ int Foo(int a) { return a; }
|
|
||||||
]])],[AC_LANG_SOURCE([[
|
|
||||||
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
|
||||||
int main() {
|
|
||||||
diff --git a/src/pm/hydra2/mpl/confdb/aclocal_cc.m4 b/src/pm/hydra2/mpl/confdb/aclocal_cc.m4
|
|
||||||
index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
|
||||||
--- a/src/pm/hydra2/mpl/confdb/aclocal_cc.m4
|
|
||||||
+++ b/src/pm/hydra2/mpl/confdb/aclocal_cc.m4
|
|
||||||
@@ -388,7 +388,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
|
||||||
#pragma weak PFoo_ = Foo
|
#pragma weak PFoo_ = Foo
|
||||||
#pragma weak pfoo_ = Foo
|
#pragma weak pfoo_ = Foo
|
||||||
int Foo(int);
|
int Foo(int);
|
||||||
@ -136,10 +97,10 @@ index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
|||||||
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
||||||
int main() {
|
int main() {
|
||||||
diff --git a/test/mpi/confdb/aclocal_cc.m4 b/test/mpi/confdb/aclocal_cc.m4
|
diff --git a/test/mpi/confdb/aclocal_cc.m4 b/test/mpi/confdb/aclocal_cc.m4
|
||||||
index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
index a85e082..2710ada 100644
|
||||||
--- a/test/mpi/confdb/aclocal_cc.m4
|
--- a/test/mpi/confdb/aclocal_cc.m4
|
||||||
+++ b/test/mpi/confdb/aclocal_cc.m4
|
+++ b/test/mpi/confdb/aclocal_cc.m4
|
||||||
@@ -388,7 +388,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
@@ -381,7 +381,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
||||||
#pragma weak PFoo_ = Foo
|
#pragma weak PFoo_ = Foo
|
||||||
#pragma weak pfoo_ = Foo
|
#pragma weak pfoo_ = Foo
|
||||||
int Foo(int);
|
int Foo(int);
|
||||||
@ -149,10 +110,10 @@ index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
|||||||
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
extern int PFoo(int), PFoo_(int), pfoo_(int);
|
||||||
int main() {
|
int main() {
|
||||||
diff --git a/test/mpi/dtpools/confdb/aclocal_cc.m4 b/test/mpi/dtpools/confdb/aclocal_cc.m4
|
diff --git a/test/mpi/dtpools/confdb/aclocal_cc.m4 b/test/mpi/dtpools/confdb/aclocal_cc.m4
|
||||||
index 36b44216d36dd8db..cafb5a6ae137f750 100644
|
index a85e082..2710ada 100644
|
||||||
--- a/test/mpi/dtpools/confdb/aclocal_cc.m4
|
--- a/test/mpi/dtpools/confdb/aclocal_cc.m4
|
||||||
+++ b/test/mpi/dtpools/confdb/aclocal_cc.m4
|
+++ b/test/mpi/dtpools/confdb/aclocal_cc.m4
|
||||||
@@ -388,7 +388,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
@@ -381,7 +381,7 @@ AC_CACHE_CHECK([for multiple weak symbol support], pac_cv_prog_c_multiple_weak_s
|
||||||
#pragma weak PFoo_ = Foo
|
#pragma weak PFoo_ = Foo
|
||||||
#pragma weak pfoo_ = Foo
|
#pragma weak pfoo_ = Foo
|
||||||
int Foo(int);
|
int Foo(int);
|
||||||
|
13
mpich.spec
13
mpich.spec
@ -1,6 +1,6 @@
|
|||||||
Summary: A high-performance implementation of MPI
|
Summary: A high-performance implementation of MPI
|
||||||
Name: mpich
|
Name: mpich
|
||||||
Version: 4.0.3
|
Version: 4.1
|
||||||
Release: %autorelease
|
Release: %autorelease
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: https://www.mpich.org/
|
URL: https://www.mpich.org/
|
||||||
@ -14,8 +14,6 @@ Patch: 0002-pkgconf-also-drop-rpath-flags-from-pkgconf-file.patch
|
|||||||
Patch: 0003-Drop-build-flags-e.g.-specs.-and-lto-from-mpi-wrappe.patch
|
Patch: 0003-Drop-build-flags-e.g.-specs.-and-lto-from-mpi-wrappe.patch
|
||||||
Patch: 0004-Make-mpich.module-useful.patch
|
Patch: 0004-Make-mpich.module-useful.patch
|
||||||
# TODO: submit ^ upstream
|
# TODO: submit ^ upstream
|
||||||
# https://github.com/pmodels/mpich/pull/6374
|
|
||||||
Patch: 6374.patch
|
|
||||||
|
|
||||||
Patch: mpich-configure-max_align_t.patch
|
Patch: mpich-configure-max_align_t.patch
|
||||||
Patch: mpich-aclocal_cc-implicit-int.patch
|
Patch: mpich-aclocal_cc-implicit-int.patch
|
||||||
@ -127,9 +125,7 @@ CONFIGURE_OPTS=(
|
|||||||
--enable-lib-depend
|
--enable-lib-depend
|
||||||
--disable-rpath
|
--disable-rpath
|
||||||
--disable-silent-rules
|
--disable-silent-rules
|
||||||
--enable-fortran
|
|
||||||
--with-gnu-ld
|
--with-gnu-ld
|
||||||
--with-device=ch3:nemesis
|
|
||||||
--with-pm=hydra:gforker
|
--with-pm=hydra:gforker
|
||||||
--includedir=%{_includedir}/%{name}-%{_arch}
|
--includedir=%{_includedir}/%{name}-%{_arch}
|
||||||
--bindir=%{_libdir}/%{name}/bin
|
--bindir=%{_libdir}/%{name}/bin
|
||||||
@ -138,10 +134,11 @@ CONFIGURE_OPTS=(
|
|||||||
--mandir=%{_mandir}/%{name}-%{_arch}
|
--mandir=%{_mandir}/%{name}-%{_arch}
|
||||||
--docdir=%{_datadir}/%{name}/doc
|
--docdir=%{_datadir}/%{name}/doc
|
||||||
--htmldir=%{_datadir}/%{name}/doc
|
--htmldir=%{_datadir}/%{name}/doc
|
||||||
--with-hwloc-prefix=system
|
--with-hwloc
|
||||||
--with-libfabric=system
|
--with-libfabric
|
||||||
--with-ucx=system
|
--with-ucx
|
||||||
)
|
)
|
||||||
|
# --with-device=ch3:nemesis
|
||||||
|
|
||||||
# Set -fallow-argument-mismatch for #1795817
|
# Set -fallow-argument-mismatch for #1795817
|
||||||
%configure "${CONFIGURE_OPTS[@]}" \
|
%configure "${CONFIGURE_OPTS[@]}" \
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mpich-4.0.3.tar.gz) = d1463dca8f0073cee6a2db894dbb3889986c6ee6353577f778abc38c90a06afb960e3dbbe87d3c2f284e32650b723a153a143f10b32e4a3bfe6087682ffe9649
|
SHA512 (mpich-4.1.tar.gz) = 950d27d8b6e2e58971312eb98cc263860f024a34a6e61dcf0fa5ff0156e8089ba268e25ee8f602aadd748fe066481b81e3442a296e54af3aea829f43b7b5f1bf
|
||||||
|
Loading…
Reference in New Issue
Block a user