Couple bugfixes:
- Set PKG_CONFIG_DIR (bug #1113627) - Fix modulefile names and python paths (bug#1201343)
This commit is contained in:
parent
e8044be092
commit
479d870edd
@ -1,6 +1,6 @@
|
|||||||
--- src/packaging/envmods/mpich.module.in 2013-01-30 14:45:08.000000000 -0500
|
--- src/packaging/envmods/mpich.module.in 2013-01-30 14:45:08.000000000 -0500
|
||||||
+++ src/packaging/envmods/mpich.module.in.new 2013-02-21 18:28:01.218528398 -0500
|
+++ src/packaging/envmods/mpich.module.in.new 2013-02-21 18:28:01.218528398 -0500
|
||||||
@@ -3,12 +3,21 @@
|
@@ -3,12 +3,22 @@
|
||||||
# MPICH module for use with 'environment-modules' package:
|
# MPICH module for use with 'environment-modules' package:
|
||||||
#
|
#
|
||||||
|
|
||||||
@ -10,21 +10,22 @@
|
|||||||
# Define prefix so PATH and MANPATH can be updated.
|
# Define prefix so PATH and MANPATH can be updated.
|
||||||
-setenv prefix @prefix@
|
-setenv prefix @prefix@
|
||||||
-setenv exec_prefix @exec_prefix@
|
-setenv exec_prefix @exec_prefix@
|
||||||
+setenv MPI_BIN @LIBDIR@/@MPILIBNAME@/bin
|
+setenv MPI_BIN @LIBDIR@/bin
|
||||||
+setenv MPI_SYSCONFIG @sysconfdir@
|
+setenv MPI_SYSCONFIG @sysconfdir@
|
||||||
+setenv MPI_FORTRAN_MOD_DIR @includedir@
|
+setenv MPI_FORTRAN_MOD_DIR @includedir@
|
||||||
+setenv MPI_INCLUDE @includedir@
|
+setenv MPI_INCLUDE @includedir@
|
||||||
+setenv MPI_LIB @libdir@
|
+setenv MPI_LIB @libdir@
|
||||||
+setenv MPI_MAN @mandir@
|
+setenv MPI_MAN @mandir@
|
||||||
+setenv MPI_PYTHON_SITEARCH @pysitearch@/@MPILIBNAME@
|
+setenv MPI_PYTHON_SITEARCH @pysitearch@/@MPINAME@
|
||||||
+setenv MPI_COMPILER @MPILIBNAME@-@ARCH@
|
+setenv MPI_COMPILER @MPINAME@-@ARCH@
|
||||||
+setenv MPI_SUFFIX _@MPILIBNAME@
|
+setenv MPI_SUFFIX _@MPINAME@
|
||||||
+setenv MPI_HOME @LIBDIR@/@MPILIBNAME@
|
+setenv MPI_HOME @LIBDIR@
|
||||||
prepend-path PATH @bindir@
|
prepend-path PATH @bindir@
|
||||||
+prepend-path LD_LIBRARY_PATH @libdir@
|
+prepend-path LD_LIBRARY_PATH @libdir@
|
||||||
prepend-path MANPATH @mandir@
|
prepend-path MANPATH @mandir@
|
||||||
|
+prepend-path PKG_CONFIG_PATH @LIBDIR@/lib/pkgconfig
|
||||||
-
|
-
|
||||||
-# Undefine prefix and exec_prefix which are too generic environment variables.
|
-# Undefine prefix and exec_prefix which are too generic environment variables.
|
||||||
-unsetenv prefix
|
-unsetenv prefix
|
||||||
-unsetenv exec_prefix
|
-unsetenv exec_prefix
|
||||||
+prepend-path PYTHONPATH @pysitearch@/@MPILIBNAME@
|
+prepend-path PYTHONPATH @pysitearch@/@MPINAME@
|
||||||
|
12
mpich.spec
12
mpich.spec
@ -1,9 +1,7 @@
|
|||||||
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
|
||||||
|
|
||||||
Summary: A high-performance implementation of MPI
|
Summary: A high-performance implementation of MPI
|
||||||
Name: mpich
|
Name: mpich
|
||||||
Version: 3.1.4
|
Version: 3.1.4
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
URL: http://www.mpich.org/
|
URL: http://www.mpich.org/
|
||||||
@ -17,6 +15,8 @@ BuildRequires: hwloc-devel >= 1.8
|
|||||||
%ifnarch s390 s390x aarch64
|
%ifnarch s390 s390x aarch64
|
||||||
BuildRequires: valgrind-devel
|
BuildRequires: valgrind-devel
|
||||||
%endif
|
%endif
|
||||||
|
# For python_sitearch
|
||||||
|
BuildRequires: python-devel
|
||||||
Provides: mpi
|
Provides: mpi
|
||||||
Provides: mpich2 = 3.0.1
|
Provides: mpich2 = 3.0.1
|
||||||
Obsoletes: mpich2 < 3.0
|
Obsoletes: mpich2 < 3.0
|
||||||
@ -167,7 +167,7 @@ make DESTDIR=%{buildroot} install
|
|||||||
mkdir -p %{buildroot}%{_sysconfdir}/modulefiles/mpi
|
mkdir -p %{buildroot}%{_sysconfdir}/modulefiles/mpi
|
||||||
mkdir -p %{buildroot}%{python_sitearch}/%{name}
|
mkdir -p %{buildroot}%{python_sitearch}/%{name}
|
||||||
cp -pr src/packaging/envmods/mpich.module %{buildroot}%{_sysconfdir}/modulefiles/mpi/%{name}-%{_arch}
|
cp -pr src/packaging/envmods/mpich.module %{buildroot}%{_sysconfdir}/modulefiles/mpi/%{name}-%{_arch}
|
||||||
sed -i 's#'%{_bindir}'#'%{_libdir}/%{name}/bin'#;s#@LIBDIR@#'%{_libdir}'#;s#@pysitearch@#'%{python_sitearch}'#;s#@ARCH@#'%{_arch}'#' %{buildroot}%{_sysconfdir}/modulefiles/mpi/%{name}-%{_arch}
|
sed -i 's#'%{_bindir}'#'%{_libdir}/%{name}/bin'#;s#@LIBDIR@#'%{_libdir}/%{name}'#;s#@MPINAME@#%{name}#;s#@pysitearch@#'%{python_sitearch}'#;s#@ARCH@#'%{_arch}'#' %{buildroot}%{_sysconfdir}/modulefiles/mpi/%{name}-%{_arch}
|
||||||
|
|
||||||
mkdir -p %{buildroot}%{_sysconfdir}/profile.d
|
mkdir -p %{buildroot}%{_sysconfdir}/profile.d
|
||||||
cat << EOF > %{buildroot}%{_sysconfdir}/profile.d/mpich-%{_arch}.sh
|
cat << EOF > %{buildroot}%{_sysconfdir}/profile.d/mpich-%{_arch}.sh
|
||||||
@ -217,6 +217,10 @@ make check
|
|||||||
%{_mandir}/%{name}/man3/
|
%{_mandir}/%{name}/man3/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 13 2015 Orion Poplawski <orion@cora.nwra.com> - 3.1.4-2
|
||||||
|
- Set PKG_CONFIG_DIR (bug #1113627)
|
||||||
|
- Fix modulefile names and python paths (bug#1201343)
|
||||||
|
|
||||||
* Wed Mar 11 2015 Orion Poplawski <orion@cora.nwra.com> - 3.1.4-1
|
* Wed Mar 11 2015 Orion Poplawski <orion@cora.nwra.com> - 3.1.4-1
|
||||||
- Update to 3.1.4
|
- Update to 3.1.4
|
||||||
- Own and set PKG_CONFIG_DIR (bug #1113627)
|
- Own and set PKG_CONFIG_DIR (bug #1113627)
|
||||||
|
Loading…
Reference in New Issue
Block a user