Update to modulemd-tools-0.7-7
Resolves: rhbz#2186223
This commit is contained in:
parent
5d71c0ce69
commit
3a4eabcb7c
@ -16,17 +16,21 @@ index dc28167..e457b03 100644
|
||||
__pycache__/
|
||||
+.vscode/
|
||||
diff --git a/.tito/packages/modulemd-tools b/.tito/packages/modulemd-tools
|
||||
index ab403cf..9f9c5a0 100644
|
||||
index ab403cf..01321ff 100644
|
||||
--- a/.tito/packages/modulemd-tools
|
||||
+++ b/.tito/packages/modulemd-tools
|
||||
@@ -1 +1 @@
|
||||
-0.7-1 ./
|
||||
+0.7-6 ./
|
||||
+0.7-7 ./
|
||||
diff --git a/.tito/releasers.conf b/.tito/releasers.conf
|
||||
index 6ccadd0..62fd4b9 100644
|
||||
index 6ccadd0..dfcf64b 100644
|
||||
--- a/.tito/releasers.conf
|
||||
+++ b/.tito/releasers.conf
|
||||
@@ -1,7 +1,7 @@
|
||||
@@ -1,7 +1,11 @@
|
||||
+[rhel]
|
||||
+releaser = tito.release.DistGitReleaser
|
||||
+branches = rhel-8.5.0
|
||||
+
|
||||
[fedora]
|
||||
releaser = tito.release.FedoraGitReleaser
|
||||
-branches = master f32 f33 epel8
|
||||
@ -8690,14 +8694,14 @@ index 0000000..f922b5e
|
||||
+ - bar-utils-2:3-4.fc33.noarch
|
||||
+...
|
||||
diff --git a/modulemd-tools.spec b/modulemd-tools.spec
|
||||
index 1bf1f59..d8b65f6 100644
|
||||
index 1bf1f59..c2f5b07 100644
|
||||
--- a/modulemd-tools.spec
|
||||
+++ b/modulemd-tools.spec
|
||||
@@ -1,6 +1,6 @@
|
||||
Name: modulemd-tools
|
||||
Version: 0.7
|
||||
-Release: 1%{?dist}
|
||||
+Release: 6%{?dist}
|
||||
+Release: 7%{?dist}
|
||||
Summary: Collection of tools for parsing and generating modulemd YAML files
|
||||
License: MIT
|
||||
BuildArch: noarch
|
||||
@ -8804,7 +8808,7 @@ index 1bf1f59..d8b65f6 100644
|
||||
cd ..
|
||||
|
||||
|
||||
@@ -106,21 +135,77 @@ cd ..
|
||||
@@ -106,21 +135,80 @@ cd ..
|
||||
%{python3_sitelib}/repo2module-*.egg-info/
|
||||
%{python3_sitelib}/dir2module
|
||||
%{python3_sitelib}/dir2module-*.egg-info/
|
||||
@ -8830,6 +8834,9 @@ index 1bf1f59..d8b65f6 100644
|
||||
|
||||
|
||||
%changelog
|
||||
+* Thu Jun 29 2023 Jakub Kadlcik <jkadlcik@redhat.com> 0.7-7
|
||||
+- repo2module: don't traceback because of a modular SRPM in the repo
|
||||
+
|
||||
+* Fri Aug 27 2021 Jakub Kadlcik <jkadlcik@redhat.com> 0.7-6
|
||||
+- Do not install bld2repo as RHEL8 doesn't have python3-koji
|
||||
+ (jkadlcik@redhat.com)
|
||||
@ -8883,7 +8890,7 @@ index 1bf1f59..d8b65f6 100644
|
||||
* Tue Feb 09 2021 Jakub Kadlcik <frostyx@email.cz> 0.7-1
|
||||
- Generate manpages on the fly
|
||||
- Automated test builds incl. Docker/Travis
|
||||
@@ -129,7 +214,7 @@ cd ..
|
||||
@@ -129,7 +217,7 @@ cd ..
|
||||
- Drop libmodulemd dependency in favor of python3-libmodulemd
|
||||
|
||||
* Sun Nov 22 2020 Jakub Kadlcik <frostyx@email.cz> 0.6-1
|
||||
@ -9051,7 +9058,7 @@ index e33e390..8090a2b 100644
|
||||
def test_upgrade_unexpected_version(self):
|
||||
# Neither current modulemd version cannot be unexpected
|
||||
diff --git a/repo2module/repo2module/cli.py b/repo2module/repo2module/cli.py
|
||||
index c91e08f..1d4ce27 100644
|
||||
index c91e08f..44dd24c 100644
|
||||
--- a/repo2module/repo2module/cli.py
|
||||
+++ b/repo2module/repo2module/cli.py
|
||||
@@ -1,6 +1,6 @@
|
||||
@ -9062,7 +9069,19 @@ index c91e08f..1d4ce27 100644
|
||||
import createrepo_c as cr
|
||||
import gi
|
||||
import logging
|
||||
@@ -71,48 +71,49 @@ def get_source_packages(packages):
|
||||
@@ -61,6 +61,11 @@ def get_source_packages(packages):
|
||||
"""
|
||||
source_packages = set()
|
||||
for pkg in packages:
|
||||
+ # In this case, the `pkg` is a SRPM file
|
||||
+ if not pkg.rpm_sourcerpm:
|
||||
+ source_packages.add(pkg.name)
|
||||
+ continue
|
||||
+
|
||||
# Get the source RPM NEVRA without the trailing ".rpm"
|
||||
subject = Subject(pkg.rpm_sourcerpm[:-4])
|
||||
|
||||
@@ -71,48 +76,49 @@ def get_source_packages(packages):
|
||||
|
||||
return source_packages
|
||||
|
||||
@ -9148,7 +9167,7 @@ index c91e08f..1d4ce27 100644
|
||||
stream.set_summary('<auto-generated module summary>')
|
||||
stream.set_description('<auto-generated module description>')
|
||||
stream.add_module_license("MIT")
|
||||
@@ -135,15 +136,15 @@ def cli(debug,
|
||||
@@ -135,15 +141,15 @@ def cli(debug,
|
||||
stream.add_profile(common_profile)
|
||||
|
||||
# Add defaults for this module
|
@ -1,13 +1,13 @@
|
||||
Name: modulemd-tools
|
||||
Version: 0.7
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
Summary: Collection of tools for parsing and generating modulemd YAML files
|
||||
License: MIT
|
||||
BuildArch: noarch
|
||||
|
||||
URL: https://github.com/rpm-software-management/modulemd-tools
|
||||
Source0: https://github.com/rpm-software-management/modulemd-tools/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0: modulemd-tools-0.7-1-to-modulemd-tools-0.7-6.patch
|
||||
Patch0: modulemd-tools-0.7-1-to-modulemd-tools-0.7-7.patch
|
||||
|
||||
BuildRequires: createrepo_c
|
||||
BuildRequires: python3-devel
|
||||
@ -53,7 +53,7 @@ bld2repo - Simple tool for dowloading build required RPMs of a modular build fro
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch 0 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -158,6 +158,9 @@ cd ..
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jun 29 2023 Jakub Kadlcik <jkadlcik@redhat.com> 0.7-7
|
||||
- repo2module: don't traceback because of a modular SRPM in the repo
|
||||
|
||||
* Fri Aug 27 2021 Jakub Kadlcik <jkadlcik@redhat.com> 0.7-6
|
||||
- Do not install bld2repo as RHEL8 doesn't have python3-koji
|
||||
(jkadlcik@redhat.com)
|
||||
|
Loading…
Reference in New Issue
Block a user