Update to 2.1

This commit is contained in:
Paul Howarth 2007-02-16 14:20:03 +00:00
parent c5881afa33
commit dd0b463620
10 changed files with 473 additions and 287 deletions

View File

@ -1 +1 @@
mod_fcgid.2.0.tar.gz
mod_fcgid.2.1.tar.gz

View File

@ -1,156 +1,238 @@
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=gb2312">
<meta name="GENERATOR" content="Microsoft FrontPage 4.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<title>The mod_fcgid Home Page</title>
<meta http-equiv="Content-Type" content="text/html; charset=gb2312">
<meta name="GENERATOR" content="Microsoft FrontPage 4.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<title>The mod_fcgid Home Page</title>
</head>
<body>
<p><b><a name="regular fastcgi"></a>This is a for regular fastcgi.&nbsp;</b><p>LoadModule fcgid_module
modules/mod_fcgid.so<p>
&lt;Location /fcgid><br>
&nbsp;&nbsp;&nbsp; SetHandler fcgid-script<br>
&nbsp;&nbsp;&nbsp; Options ExecCGI<br>
&nbsp;&nbsp;&nbsp; allow from all<br>
&lt;/Location&gt;<p>
&nbsp;
<p><b><a name="regular fastcgi"></a>This is a for regular fastcgi.&nbsp;</b></p>
<p>LoadModule fcgid_module modules/mod_fcgid.so</p>
<p>&lt;Location /fcgid&gt;<br>
&nbsp;&nbsp;&nbsp; SetHandler fcgid-script<br>
&nbsp;&nbsp;&nbsp; Options ExecCGI<br>
&nbsp;&nbsp;&nbsp; allow from all<br>
&lt;/Location&gt;</p>
<p>&nbsp;
</p>
<hr>
<p><b><a name="suEXEC"></a>This is for suEXEC. Please get more information about suEXEC <a href="http://httpd.apache.org/docs-2.0/suexec.html">here</a>.&nbsp;</b><p>LoadModule fcgid_module
modules/mod_fcgid.so<p>
&lt;Location /fcgid&gt;<br>
&nbsp;&nbsp;&nbsp; SetHandler fcgid-script<br>
&nbsp;&nbsp;&nbsp; Options ExecCGI<br>
&nbsp;&nbsp;&nbsp; allow from all<br>
&lt;/Location&gt;<p>
&lt;VirtualHost 192.168.1.89><br>
&nbsp;&nbsp;&nbsp; ServerAdmin <a href="mailto:webmaster@host.foo.com">webmaster@host.foo.com<br>
</a>&nbsp;&nbsp;&nbsp; DocumentRoot /usr/local/apache2/htdocs/<br>
&nbsp;&nbsp;&nbsp; ServerName host.foo.com<br>
&nbsp;&nbsp;&nbsp; SuexecUserGroup pqf pqf<br>
&lt;/VirtualHost&gt;<p>
¡¡
<p><b><a name="suEXEC"></a>This is for suEXEC. Please get more
information about suEXEC <a
href="http://httpd.apache.org/docs-2.0/suexec.html">here</a>.&nbsp;</b></p>
<p>LoadModule fcgid_module modules/mod_fcgid.so</p>
<p>&lt;Location /fcgid&gt;<br>
&nbsp;&nbsp;&nbsp; SetHandler fcgid-script<br>
&nbsp;&nbsp;&nbsp; Options ExecCGI<br>
&nbsp;&nbsp;&nbsp; allow from all<br>
&lt;/Location&gt;</p>
<p>&lt;VirtualHost 192.168.1.89&gt;<br>
&nbsp;&nbsp;&nbsp; ServerAdmin <a href="mailto:webmaster@host.foo.com">webmaster@host.foo.com<br>
</a>&nbsp;&nbsp;&nbsp; DocumentRoot /usr/local/apache2/htdocs/<br>
&nbsp;&nbsp;&nbsp; ServerName host.foo.com<br>
&nbsp;&nbsp;&nbsp; SuexecUserGroup pqf pqf<br>
&lt;/VirtualHost&gt;</p>
<p>¡¡
</p>
<hr>
<p><b><a name="PHP"></a>This is for fastcgi-mode PHP (UNIX)</b><p>LoadModule fcgid_module modules/mod_fcgid.so<p>
&lt;Directory /usr/local/apache2/htdocs/php><br>
&nbsp;&nbsp;&nbsp; SetHandler fcgid-script<br>
&nbsp;&nbsp;&nbsp; FCGIWrapper /usr/local/bin/php .php<br>
&nbsp;&nbsp;&nbsp; Options ExecCGI<br>
&nbsp;&nbsp;&nbsp; allow from all<br>
&lt;/Directory><p><b>This works too:</b><p>LoadModule fcgid_module
modules/mod_fcgid.so&nbsp;<p>
AddHandler fcgid-script .php<br>
&lt;Directory /usr/local/apache2/htdocs/php&gt;<br>
&nbsp;&nbsp;&nbsp; FCGIWrapper /usr/local/bin/php .php<br>
&nbsp;&nbsp;&nbsp; Options ExecCGI<br>
&nbsp;&nbsp;&nbsp; allow from all<br>
&lt;/Directory&gt;<p><b># Please make sure:<br>
# php is configured with --enable-fastcgi option<br>
# check error_log(with debug level), if
any thing goes wrong</b>
<p><b><a name="PHP"></a>This is for fastcgi-mode PHP (UNIX)</b></p>
<p>LoadModule fcgid_module modules/mod_fcgid.so</p>
<p> &lt;Directory /usr/local/apache2/htdocs/php&gt;<br>
&nbsp;&nbsp;&nbsp; SetHandler fcgid-script<br>
&nbsp;&nbsp;&nbsp; FCGIWrapper /usr/local/bin/php .php
</p>
<p>&nbsp;&nbsp; <span style="font-weight: bold;"># You need mod_fcgid
version &gt;= 2.1 to support arguments in FCGIWrapper, if you want<br>
&nbsp;&nbsp; # FCGIWrapper "/usr/local/bin/php -c /etc/" .php</span></p>
&nbsp;&nbsp;&nbsp; Options ExecCGI<br>
<p> &nbsp;&nbsp;&nbsp; allow from all<br>
&lt;/Directory&gt;</p>
<p><b>This works too:</b></p>
<p>LoadModule fcgid_module modules/mod_fcgid.so&nbsp;</p>
<p>AddHandler fcgid-script .php<br>
&lt;Directory /usr/local/apache2/htdocs/php&gt;<br>
&nbsp;&nbsp;&nbsp; FCGIWrapper /usr/local/bin/php .php</p>
<p>&nbsp;&nbsp;&nbsp; <span style="font-weight: bold;">#</span> <span
style="font-weight: bold;">You need mod_fcgid version &gt;= 2.1 to
support arguments in FCGIWrapper, if you want<br>
&nbsp;&nbsp; # FCGIWrapper "/usr/local/bin/php -c /etc/" .php</span></p>
<p>&nbsp;&nbsp;&nbsp; Options ExecCGI<br>
&nbsp;&nbsp;&nbsp; allow from all<br>
&lt;/Directory&gt;</p>
<p><b># Please make sure:<br>
# php is configured with --enable-fastcgi option<br>
# check error_log(with debug level), if any thing goes wrong</b> </p>
<p> </p>
<hr>
<p><b><a name="suPHP"></a>This is for suPHP&nbsp; ( UNIX )</b>
<p>LoadModule fcgid_module modules/mod_fcgid.so<br>
<p><b><a name="Ruby"></a>This is for fastcgi-mode </b><span
style="font-weight: bold;">Ruby on Rails ( Thank Andre Nathan giving
me this demo configuration )<br>
</span><br>
LoadModule fcgid_module modules/mod_fcgid.so<br>
SocketPath /tmp/fcgidsock<br>
SharememPath /tmp/fcgidshm<br>
DefaultInitEnv RAILS_ENV production<br>
<br>
&lt;VirtualHost *:80><br>
&nbsp;&nbsp;&nbsp; ServerName test2.example.com<br>
&nbsp;&nbsp;&nbsp; DocumentRoot /usr/local/apache2/htdocs/test2.example.com/<br>
&nbsp;&nbsp;&nbsp; SuexecUserGroup pqf pqf<br>
&lt;/VirtualHost><br>
&lt;Directory /home/sneakymustard/tumble/public&gt;<br>
&nbsp;&nbsp;&nbsp; Options ExecCGI FollowSymLinks<br>
&nbsp;&nbsp;&nbsp; AllowOverride AuthConfig Indexes Limit<br>
&nbsp;&nbsp;&nbsp; Order allow,deny<br>
&nbsp;&nbsp;&nbsp; Allow from all<br>
<br>
&lt;Directory /usr/local/apache2/htdocs/test2.example.com/><br>
&nbsp;&nbsp;&nbsp; AddHandler fcgid-script .php<br>
&nbsp;&nbsp;&nbsp; Options ExecCGI<br>
&nbsp;&nbsp;&nbsp; allow from all<br>
&nbsp;&nbsp;&nbsp; FCGIWrapper /usr/local/apache2/htdocs/test2.example.com/php .php<br>
&lt;/Directory></p>
<p>
<b>
# Please make sure:<br>
# php is configured with --enable-fastcgi option<br>
# copy php execution to /usr/local/apache2/htdocs/test2.example.com/ directory<br>
# make sure all files in /usr/local/apache2/htdocs/test2.example.com/ with right
owner and group<br>
# check error_log(with debug level) and suexec_log, if
any thing goes wrong</b>
&nbsp;&nbsp;&nbsp; AddHandler fcgid-script .fcgi</p>
<p><span style="font-weight: bold;">&nbsp;&nbsp;&nbsp; # You need
mod_fcgid version &gt;= 2.1 to support arguments "xxx/dispatch.fcgi" in
FCGIWrapper <br>
</span>&nbsp;&nbsp;&nbsp; FCGIWrapper "/usr/bin/ruby
/home/sneakymustard/tumble/public/dispatch.fcgi" .fcgi<br>
<br>
&nbsp;&nbsp;&nbsp; RewriteEngine On<br>
&nbsp;&nbsp;&nbsp; RewriteRule ^$ index.html [QSA]<br>
&nbsp;&nbsp;&nbsp; RewriteRule ^([^.]+)$ $1.html [QSA]<br>
&nbsp;&nbsp;&nbsp; RewriteCond %{REQUEST_FILENAME} !-f<br>
&nbsp;&nbsp;&nbsp; RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]<br>
&lt;/Directory&gt;<br>
<br>
</p>
<span style="font-weight: bold;"></span>
<p> </p>
<hr>
<p><b><a name="suPHP"></a>This is for suPHP&nbsp; ( UNIX )</b> </p>
<p>LoadModule fcgid_module modules/mod_fcgid.so<br>
<br>
&lt;VirtualHost *:80&gt;<br>
&nbsp;&nbsp;&nbsp; ServerName test2.example.com<br>
&nbsp;&nbsp;&nbsp; DocumentRoot
/usr/local/apache2/htdocs/test2.example.com/<br>
&nbsp;&nbsp;&nbsp; SuexecUserGroup pqf pqf<br>
&lt;/VirtualHost&gt;<br>
<br>
&lt;Directory /usr/local/apache2/htdocs/test2.example.com/&gt;<br>
&nbsp;&nbsp;&nbsp; AddHandler fcgid-script .php<br>
&nbsp;&nbsp;&nbsp; Options ExecCGI<br>
&nbsp;&nbsp;&nbsp; allow from all<br>
&nbsp;&nbsp;&nbsp; FCGIWrapper
/usr/local/apache2/htdocs/test2.example.com/php .php</p>
<p></p>
<p>&nbsp;&nbsp;&nbsp; <span style="font-weight: bold;">#</span> <span
style="font-weight: bold;">You need mod_fcgid version &gt;= 2.1 to
support arguments in FCGIWrapper, if you want<br>
&nbsp;&nbsp; # FCGIWrapper "/usr/local/bin/php -c /etc/" .php</span></p>
<p> &lt;/Directory&gt;</p>
<p> <b> # Please make sure:<br>
# php is configured with --enable-fastcgi option<br>
# copy php execution to /usr/local/apache2/htdocs/test2.example.com/
directory<br>
# make sure all files in /usr/local/apache2/htdocs/test2.example.com/
with right owner and group<br>
# check error_log(with debug level) and suexec_log, if any thing goes
wrong</b> <br>
</p>
<hr>
<p><br>
<b><a name="PHP-Windows"></a>This is for fastcgi-mode PHP ( Windows )</b><p>LoadModule fcgid_module modules/mod_fcgid.so<p>
&lt;Directory &quot;C:/Apache2/htdocs/php/&quot;&gt;<br>
&nbsp;&nbsp;&nbsp; SetHandler fcgid-script<br>
&nbsp;&nbsp;&nbsp; Options execCGI<br>
&nbsp;&nbsp;&nbsp; AllowOverride None<br>
&nbsp;&nbsp;&nbsp; Order allow,deny<br>
&nbsp;&nbsp;&nbsp; Allow from all<br>
&nbsp;&nbsp;&nbsp; FCGIWrapper &quot;c:/php/php.exe&quot; .php<br>
&lt;/Directory><p><b>This works too:</b><p>LoadModule fcgid_module modules/mod_fcgid.so&nbsp;<p>
AddHandler fcgid-script .php<br>
&lt;Directory &quot;C:/Apache2/htdocs/php/&quot;&gt;<br>
&nbsp;&nbsp;&nbsp; FCGIWrapper &quot;c:/php/php.exe&quot; .php<br>
&nbsp;&nbsp;&nbsp; Options ExecCGI<br>
&nbsp;&nbsp;&nbsp; allow from all<br>
<b><a name="PHP-Windows"></a>This is for fastcgi-mode PHP ( Windows )</b>
</p>
<p>LoadModule fcgid_module modules/mod_fcgid.so<br>
DefaultInitEnv PHPRC "c:/php/"<br>
DefaultInitEnv PATH
"c:/php;C:/WINDOWS/system32;C:/WINDOWS;C:/WINDOWS/System32/Wbem;"<br>
DefaultInitEnv SystemRoot "C:/Windows"<br>
DefaultInitEnv SystemDrive "C:"<br>
DefaultInitEnv TEMP "C:/WINDOWS/TEMP"<br>
DefaultInitEnv TMP "C:/WINDOWS/TEMP"<br>
DefaultInitEnv windir "C:/WINDOWS"<br>
&lt;Directory "C:/Apache2/htdocs/php/"&gt;<br>
&nbsp;&nbsp;&nbsp; SetHandler fcgid-script<br>
&nbsp;&nbsp;&nbsp; Options execCGI<br>
&nbsp;&nbsp;&nbsp; AllowOverride None<br>
&nbsp;&nbsp;&nbsp; Order allow,deny<br>
&nbsp;&nbsp;&nbsp; Allow from all<br>
&nbsp;&nbsp;&nbsp; FCGIWrapper "c:/php/php.exe" .php</p>
<p>&nbsp;&nbsp;&nbsp; <span style="font-weight: bold;">#</span> <span
style="font-weight: bold;">You need mod_fcgid version &gt;= 2.1 to
support arguments in FCGIWrapper, if you want<br>
&nbsp;&nbsp; # FCGIWrapper "/usr/local/bin/php -c /etc/" .php</span><br>
&lt;/Directory&gt;</p>
<p><b>This works too:</b>
</p>
<p>LoadModule fcgid_module modules/mod_fcgid.so<br>
DefaultInitEnv PHPRC "c:/php/"<br>
DefaultInitEnv PATH
"c:/php;C:/WINDOWS/system32;C:/WINDOWS;C:/WINDOWS/System32/Wbem;"<br>
DefaultInitEnv SystemRoot "C:/Windows"<br>
DefaultInitEnv SystemDrive "C:"<br>
DefaultInitEnv TEMP "C:/WINDOWS/TEMP"<br>
DefaultInitEnv TMP "C:/WINDOWS/TEMP"<br>
DefaultInitEnv windir "C:/WINDOWS"<br>
AddHandler fcgid-script .php<br>
&lt;Directory "C:/Apache2/htdocs/php/"&gt;<br>
&nbsp;&nbsp;&nbsp; FCGIWrapper "c:/php/php.exe" .php</p>
<p>&nbsp;&nbsp;&nbsp; <span style="font-weight: bold;">#</span> <span
style="font-weight: bold;">You need mod_fcgid version &gt;= 2.1 to
support arguments in FCGIWrapper, if you want<br>
&nbsp;&nbsp; # FCGIWrapper "/usr/local/bin/php -c /etc/" .php<br>
</span></p>
<p><span style="font-weight: bold;"></span>&nbsp;&nbsp;&nbsp;&nbsp;
Options ExecCGI<br>
&nbsp;&nbsp;&nbsp; allow from all<br>
&lt;/Directory&gt;<br>
<hr>
<p><b><a name="Authenticator"></a>This is for Authenticator</b></p>
<p>LoadModule fcgid_module modules/mod_fcgid.so
<p>&lt;Location /fcgid><br>
SetHandler fcgid-script<br>
Options ExecCGI<br>
allow from all<br>
AuthType Basic<br>
AuthName ProtectedRealm<br>
FastCgiAuthenticator /some/path/authenticator<br>
require valid-user<br>
&lt;/Location><br>
</p>
<p><b>Another configuration: <a name="FastCgiAuthenticatorAuthoritative">FastCgiAuthenticatorAuthoritative</a>
(default On)</b></p>
<p>Setting the <code>FastCgiAuthenticatorAuthoritative</code> directive
explicitly to <em>Off</em> allows authentication to be passed on to lower level
modules</p>
<hr>
<p><b><a name="Authorizer"></a>This is for Authorizer</b></p>
<p><b><a name="Authenticator"></a>This is for Authenticator</b></p>
<p>LoadModule fcgid_module modules/mod_fcgid.so
<p>&lt;Location /fcgid><br>
SetHandler fcgid-script<br>
Options ExecCGI<br>
allow from all<br>
AuthType Basic<br>
AuthName ProtectedRealm<br>
FastCgiAuthorizer /some/place/Authorizer<br>
&lt;/Location></p>
<p><b>Another configuration: <a name="FastCgiAuthorizerAuthoritative">FastCgiAuthorizerAuthoritative</a>
(default On)</b></p>
<p>Setting the <code>FastCgiAuthorizerAuthoritative</code> directive explicitly
to <em>Off</em> allows authorization to be passed on to lower level modules</p>
<hr>
<p><b><a name="AccessChecker"></a>This is for AccessChecker</b></p>
<p>LoadModule fcgid_module modules/mod_fcgid.so
<p>&lt;Location /fcgid><br>
SetHandler fcgid-script<br>
Options ExecCGI<br>
allow from all<br>
FastCgiAccessChecker /some/place/access-checker<br>
&lt;/Location><br>
</p>
<p><b>Another configuration: </b><a name="FastCgiAccessCheckerAuthoritative"><b>FastCgiAccessCheckerAuthoritative</b></a><b>
<p>&lt;Location /fcgid&gt;<br>
SetHandler fcgid-script<br>
Options ExecCGI<br>
allow from all<br>
AuthType Basic<br>
AuthName ProtectedRealm<br>
FastCgiAuthenticator /some/path/authenticator<br>
require valid-user<br>
&lt;/Location&gt;<br>
</p>
<p><b>Another configuration: <a
name="FastCgiAuthenticatorAuthoritative">FastCgiAuthenticatorAuthoritative</a>
(default On)</b></p>
<p>Setting the <code>FastCgiAccessCheckerAuthoritative</code> directive
explicitly to <em>Off</em> allows access checking to be passed on to lower level
modules</p>
<p>¡¡</p>
<p>¡¡</p>
<p>Setting the <code>FastCgiAuthenticatorAuthoritative</code>
directive explicitly to <em>Off</em> allows authentication to be
passed on to lower level modules</p>
<hr>
<p><b><a name="Authorizer"></a>This is for Authorizer</b></p>
<p>LoadModule fcgid_module modules/mod_fcgid.so
</p>
<p>&lt;Location /fcgid&gt;<br>
SetHandler fcgid-script<br>
Options ExecCGI<br>
allow from all<br>
AuthType Basic<br>
AuthName ProtectedRealm<br>
FastCgiAuthorizer /some/place/Authorizer<br>
&lt;/Location&gt;</p>
<p><b>Another configuration: <a name="FastCgiAuthorizerAuthoritative">FastCgiAuthorizerAuthoritative</a>
(default On)</b></p>
<p>Setting the <code>FastCgiAuthorizerAuthoritative</code> directive
explicitly to <em>Off</em> allows authorization to be passed on to
lower level modules</p>
<hr>
<p><b><a name="AccessChecker"></a>This is for AccessChecker</b></p>
<p>LoadModule fcgid_module modules/mod_fcgid.so
</p>
<p>&lt;Location /fcgid&gt;<br>
SetHandler fcgid-script<br>
Options ExecCGI<br>
allow from all<br>
FastCgiAccessChecker /some/place/access-checker<br>
&lt;/Location&gt;<br>
</p>
<p><b>Another configuration: </b><a
name="FastCgiAccessCheckerAuthoritative"><b>FastCgiAccessCheckerAuthoritative</b></a><b>
(default On)</b></p>
<p>Setting the <code>FastCgiAccessCheckerAuthoritative</code>
directive explicitly to <em>Off</em> allows access checking to be
passed on to lower level modules</p>
<p>¡¡</p>
<p>¡¡</p>
<p> </p>
<p> </p>
<p> </p>
@ -171,7 +253,5 @@ modules</p>
<p> </p>
<p> </p>
<p> </p>
</body>
</html>

303
doc.htm
View File

@ -1,113 +1,210 @@
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>The mod_fcgid Home Page</title>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<title>The mod_fcgid Home Page</title>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
</head>
<body bgcolor="#ffffff">
<table border="0" cellpadding="5" cellspacing="0" width="893">
<tr>
<td align="center" valign="top" width="200">
&nbsp;
<table cellpadding="5" cellspacing="0">
<tr>
<td nowrap bgcolor="#f8eda6" align="left">
<a href="index.htm">Home</a> <br>
<a href="index.cn.htm">Chinese Info</a> <br>
<a href="download.htm">Download (source)</a> <br>
<a href="doc.htm">Documentations</a> <br>
<a href="feedback.htm">Feedback</a>
</td> </tr> </table> </td>
<td valign="top" width="669">
<ul>
<li>
<p><b><font size="4">Here are some examples of configuration</font></b></p>
</li>
</ul>
<p><a href="configuration.htm#regular fastcgi">Configuration for Regular fastcgi
(non-PHP, non-Ruby, non-Python)&nbsp;</a><p><a href="configuration.htm#suEXEC">Configuration
for suEXEC fastcgi</a><p><a href="configuration.htm#PHP">Configuration for PHP
(UNIX)</a><p><a href="configuration.htm#suPHP">Configuration for suPHP (UNIX)</a><p><a href="configuration.htm#PHP-Windows">Configuration
for PHP (Windows)</a><p><a href="configuration.htm#Authenticator">Configuration
for Authenticator</a><p><a href="configuration.htm#Authorizer">Configuration
for Authorizer</a><p><a href="configuration.htm#AccessChecker">Configuration
for AccessChecker</a><p>&nbsp;
<hr>
<ul>
<li><h2><b><font size="4">There are
<tbody>
<tr>
<td align="center" valign="top" width="200"> &nbsp;
<table cellpadding="5" cellspacing="0">
<tbody>
<tr>
<td align="left" bgcolor="#f8eda6" nowrap="nowrap"> <a
href="index.htm">Home</a> <br>
<a href="index.cn.htm">Chinese Info</a> <br>
<a href="download.htm">Download (source)</a> <br>
<a href="doc.htm">Documentations</a> <br>
<a href="feedback.htm">Feedback</a> <br>
<a
href="http://sourceforge.net/donate/index.php?group_id=174879"><img
src="http://images.sourceforge.net/images/project-support.jpg"
alt="Support This Project" border="0" height="32" width="88"> </a> </td>
</tr>
</tbody>
</table>
</td>
<td valign="top" width="669">
<ul>
<li>
<p><b><font size="4">Here are some examples of configuration</font></b></p>
</li>
</ul>
<p><a href="configuration.htm#regular%20fastcgi">Configuration
for Regular fastcgi
(non-PHP, non-Ruby, non-Python)&nbsp;</a></p>
<p><a href="configuration.htm#suEXEC">Configuration
for suEXEC fastcgi</a></p>
<p><a href="configuration.htm#PHP">Configuration for PHP
(UNIX)</a><br>
</p>
<p><a href="configuration.htm#Ruby">Configuration for Ruby on
Rails</a><br>
</p>
<p><a href="configuration.htm#suPHP">Configuration for suPHP
(UNIX)</a></p>
<p><a href="configuration.htm#PHP-Windows">Configuration
for PHP (Windows)</a></p>
<p><a href="configuration.htm#Authenticator">Configuration
for Authenticator</a></p>
<p><a href="configuration.htm#Authorizer">Configuration
for Authorizer</a></p>
<p><a href="configuration.htm#AccessChecker">Configuration
for AccessChecker</a></p>
<p>&nbsp; </p>
<hr>
<ul>
<li>
<h2><a class="mozTocH2" name="mozTocId601839"></a><b><font
size="4">There are
some other configurations you can set</font></b></h2>
</li>
</ul>
<p><b>IdleTimeout n (300
seconds)</b><p>An idle fastcgi application will be terminated after IdleTimeout
seconds. <p><b>IdleScanInterval n (120 seconds)</b><p>The scan interval for idle
fastcgi applications. <p><b>BusyTimeout n (300 seconds)</b><p>a fastcgi
application will be terminated if handing a single request longer than busy
timeout.<p><b>BusyScanInterval n (120 seconds)</b><p>The scan interval for busy
timeout fastcgi applications.<p><b>ErrorScanInterval n (3 seconds)</b><p>The
scan interval for exit pending fastcgi applications. fastcgi applications will
be terminated within this scanning.<p><b>ZombieScanInterval n (3 seconds)</b><p>The
scan interval for zombie process.&nbsp;<p><b>ProcessLifeTime n (3600 seconds)</b><p>A
fastcgi application will be terminated if lifetime expired, even no error is
detected.<p><b>SocketPath path (logs/fcgidsock)</b><p>The directory to put the
UNIX domain socket. (UNIX only)<p><b>SpawnScoreUpLimit n (10)</b><p>The
spawn-speed control score up water limit. Score increases while a process is spawned or terminated, and decreases
as time progresses; while the score is higher than <b>SpawnScoreUpLimit</b>, the spawning will be
held for a while. The higher this number is, the higher speed of the spawning
can be.<p><b>SpawnScore n (1)</b><p>The weight of spawning.&nbsp; This weight
will be plused to the spawn-control score on every spawn. The higher this number
is, the lower speed of spawning can be.<p><b>TerminationScore n (2)</b><p>The
weight of termination. This weight will be plused to the score while fastcgi
process terminates. The higher this number is, the lower speed of spawning can
be.<p><b>MaxProcessCount n (1000)</b><p>The max count of total fastcgi process
count.<p><b>DefaultMaxClassProcessCount n (100)</b><p>The maximum number of
fastcgi application instances allowed to run for any one fastcgi application.&nbsp;<p><b>DefaultMinClassProcessCount n
(3)</b><p>The minimum number of
fastcgi application instances for any one fastcgi application.&nbsp;<p><b>DefaultInitEnv&nbsp;
env_name env_value</b><p>The default environment variables before a fastcgi
</li>
</ul>
<p><b>IdleTimeout n (300
seconds)</b></p>
<p>An idle fastcgi application will be terminated after
IdleTimeout
seconds. </p>
<p><b>IdleScanInterval n (120 seconds)</b></p>
<p>The scan interval for idle
fastcgi applications. </p>
<p><b>BusyTimeout n (300 seconds)</b></p>
<p>a fastcgi
application will be terminated if handing a single request longer than
busy
timeout.</p>
<p><b>BusyScanInterval n (120 seconds)</b></p>
<p>The scan interval for busy
timeout fastcgi applications.</p>
<p><b>ErrorScanInterval n (3 seconds)</b></p>
<p>The
scan interval for exit pending fastcgi applications. fastcgi
applications will
be terminated within this scanning.</p>
<p><b>ZombieScanInterval n (3 seconds)</b></p>
<p>The
scan interval for zombie process.&nbsp;</p>
<p><b>ProcessLifeTime n (3600 seconds)</b></p>
<p>A
fastcgi application will be terminated if lifetime expired, even no
error is
detected.</p>
<p><b>SocketPath path (logs/fcgidsock)</b></p>
<p>The directory to put the
UNIX domain socket. (UNIX only)<br>
</p>
<p><span style="font-weight: bold;">SharememPath path
(logs/fcgid_shm)</span><br>
</p>
<p>The share memory file path. (UNIX only) (version &gt;= 2.1
only)<br>
</p>
<p><b>SpawnScoreUpLimit n (10)</b></p>
<p>The
spawn-speed control score up water limit. Score increases while a
process is spawned or terminated, and decreases
as time progresses; while the score is higher than <b>SpawnScoreUpLimit</b>,
the spawning will be
held for a while. The higher this number is, the higher speed of the
spawning
can be.</p>
<p><b>SpawnScore n (1)</b></p>
<p>The weight of spawning.&nbsp; This weight
will be plused to the spawn-control score on every spawn. The higher
this number
is, the lower speed of spawning can be.</p>
<p><b>TerminationScore n (2)</b></p>
<p>The
weight of termination. This weight will be plused to the score while
fastcgi
process terminates. The higher this number is, the lower speed of
spawning can
be.</p>
<p><b>MaxProcessCount n (1000)</b></p>
<p>The max count of total fastcgi process
count.</p>
<p><b>DefaultMaxClassProcessCount n (100)</b></p>
<p>The maximum number of
fastcgi application instances allowed to run for any one fastcgi
application.&nbsp;</p>
<p><b>DefaultMinClassProcessCount n
(3)</b></p>
<p>The minimum number of
fastcgi application instances for any one fastcgi application.&nbsp;</p>
<p><b>DefaultInitEnv&nbsp;
env_name env_value</b></p>
<p>The default environment variables before a fastcgi
application is spawned. You can set this configuration more
than once.<p><b>IPCConnectTimeout n (3 seconds)</b><p>The connect timeout to a
fastcgi application.&nbsp;<p><b>IPCCommTimeout n (20 seconds)</b><p>The communication
timeout to a fastcgi application. Please increase this value if your CGI have a
slow initialization or slow respond.<p><b>OutputBufferSize n (64k bytes)</b><p>CGI
output cache buffer size.<p><b>PHP_Fix_Pathinfo_Enable</b><b> n(n=0/1, default 0)</b><p>If
than once.<br>
</p>
<table style="text-align: left; width: 667px; height: 147px;"
border="1" cellpadding="2" cellspacing="2">
<tbody>
<tr>
<td style="vertical-align: top;">Note: If you get:<br>
<div><span style="font-weight: bold;">Can't create TCP/IP
socket (10106)</span> error while running PHP script(<span
style="font-weight: bold;">on Win32 only</span>), you will have to set
these(<span style="font-weight: bold;">Please modify the values if
necessary</span>):<br>
<font face="Arial" size="2">DefaultInitEnv PHPRC "c:/php/"<br>
DefaultInitEnv PATH
"c:/php;C:/WINDOWS/system32;C:/WINDOWS;C:/WINDOWS/System32/Wbem;"<br>
DefaultInitEnv SystemRoot "C:/Windows"<br>
DefaultInitEnv SystemDrive "C:"<br>
DefaultInitEnv TEMP "C:/WINDOWS/TEMP"<br>
DefaultInitEnv TMP "C:/WINDOWS/TEMP"<br>
DefaultInitEnv windir "C:/WINDOWS"<br>
<br>
(Thank Steffen of apachelounge.com for this note)<br>
</font></div>
</td>
</tr>
</tbody>
</table>
<p><br>
</p>
<p><b>IPCConnectTimeout n (3 seconds)</b></p>
<p>The connect timeout to a
fastcgi application.&nbsp;</p>
<p><b>IPCCommTimeout n (20 seconds)</b></p>
<p>The communication
timeout to a fastcgi application. Please increase this value if your
CGI have a
slow initialization or slow respond.</p>
<p><b>OutputBufferSize n (64k bytes)</b></p>
<p>CGI
output cache buffer size.</p>
<p><b>PHP_Fix_Pathinfo_Enable</b><b> n(n=0/1, default 0)</b></p>
<p>If
you are using PHP and set cgi.fix_pathinfo=1 in php.ini, set
PHP_Fix_Pathinfo_Enable 1.<p><b>MaxRequestsPerProcess n (-1)</b><p>(Added in
version 1.11, patch from Robert L Mathews)<p>Adds a MaxRequestsPerProcess parameter that allows mod_fcgid to
exit after handling a certain number of requests, similar to the existing ProcessLifeTime option.&nbsp;<p>This solves a problem with PHP in FastCGI mode. By default, PHP stops
accepting new FastCGI connections after handling 500 requests; unfortunately, there is a potential race condition during the PHP cleanup code in which
PHP can be shutting down but still have the socket open, so mod_fcgid under heavy load can send request number 501 to PHP and have it "accepted", but then
PHP appears to simply exit, causing errors.<p>If you are using PHP, you should
set it to 500. -1 mean fastcgi process will not exit no matter how many requests
PHP_Fix_Pathinfo_Enable 1.</p>
<p><b>MaxRequestsPerProcess n (-1)</b></p>
<p>(Added in
version 1.11, patch from Robert L Mathews)</p>
<p>Adds a MaxRequestsPerProcess parameter that allows mod_fcgid
to
exit after handling a certain number of requests, similar to the
existing ProcessLifeTime option.&nbsp;</p>
<p>This solves a problem with PHP in FastCGI mode. By default,
PHP stops
accepting new FastCGI connections after handling 500 requests;
unfortunately, there is a potential race condition during the PHP
cleanup code in which
PHP can be shutting down but still have the socket open, so mod_fcgid
under heavy load can send request number 501 to PHP and have it
"accepted", but then
PHP appears to simply exit, causing errors.</p>
<p>If you are using PHP, you should
set it to 500. -1 mean fastcgi process will not exit no matter how many
requests
it has handled.<br>
</td>
</tr>
</p>
</td>
</tr>
</tbody>
</table>
</body></html>
</body>
</html>

View File

@ -11,5 +11,6 @@ LoadModule fcgid_module modules/mod_fcgid.so
AddHandler fcgid-script fcg fcgi fpl
</IfModule>
# Sane place to put sockets
# Sane place to put sockets and shared memory file
SocketPath run/mod_fcgid
SharememPath run/fcgid_shm

View File

@ -1,21 +0,0 @@
--- mod_fcgid.1.09/directives.htm 2006-06-18 09:27:53.000000000 +0100
+++ mod_fcgid.1.09/directives.htm 2006-06-18 09:29:02.000000000 +0100
@@ -27,13 +27,13 @@
<td nowrap bgcolor="#f8eda6" align="left">
-<a href="index.htm">Home</a> <br>
-<a href="index.cn.htm">Chinese Info</a> <br>
-<a href="download.htm">Download (source)</a> <br>
-<a href="doc.htm">Documentations</a> <br>
+<a href="http://fastcgi.coremail.cn/index.htm">Home</a> <br>
+<a href="http://fastcgi.coremail.cn/index.cn.htm">Chinese Info</a> <br>
+<a href="http://fastcgi.coremail.cn/download.htm">Download (source)</a> <br>
+<a href="http://fastcgi.coremail.cn/doc.htm">Documentations</a> <br>
-<a href="feedback.htm">Feedback</a>
+<a href="http://fastcgi.coremail.cn/feedback.htm">Feedback</a>
</td> </tr> </table> </td>

View File

@ -0,0 +1,17 @@
--- mod_fcgid.2.1/directives.htm 2007-02-16 03:40:23.000000000 +0000
+++ mod_fcgid.2.1/directives.htm 2007-02-16 10:45:44.000000000 +0000
@@ -14,10 +14,10 @@
<tr>
<td align="left" bgcolor="#f8eda6" nowrap="nowrap"> <a
href="index.htm">Home</a> <br>
- <a href="index.cn.htm">Chinese Info</a> <br>
- <a href="download.htm">Download (source)</a> <br>
- <a href="doc.htm">Documentations</a> <br>
- <a href="feedback.htm">Feedback</a> <br>
+ <a href="http://fastcgi.coremail.cn/index.cn.htm">Chinese Info</a> <br>
+ <a href="http://fastcgi.coremail.cn/download.htm">Download (source)</a> <br>
+ <a href="http://fastcgi.coremail.cn/doc.htm">Documentations</a> <br>
+ <a href="http://fastcgi.coremail.cn/feedback.htm">Feedback</a> <br>
<a
href="http://sourceforge.net/donate/index.php?group_id=174879"><img
src="http://images.sourceforge.net/images/project-support.jpg"

View File

@ -10,7 +10,7 @@
%endif
Name: mod_fcgid
Version: 2.0
Version: 2.1
Release: 1%{?dist}
Summary: Apache2 module for high-performance server-side scripting
Group: System Environment/Daemons
@ -20,11 +20,11 @@ Source0: http://dl.sf.net/mod-fcgid/mod_fcgid.%{version}.tar.gz
Source1: fcgid.conf
Source2: fastcgi.te
Source3: fastcgi.fc
Source4: README.Fedora
Source4: mod_fcgid-2.1-README.Fedora
Source5: http://fastcgi.coremail.cn/doc.htm
Source6: http://fastcgi.coremail.cn/configuration.htm
Source7: README.SELinux
Patch0: mod_fcgid.1.09-docurls.patch
Source7: mod_fcgid-2.1-README.SELinux
Patch0: mod_fcgid.2.1-docurls.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: httpd-devel >= 2.0
Requires: httpd-mmn = %([ -a %{_includedir}/httpd/.mmn ] && %{__cat} %{_includedir}/httpd/.mmn || echo missing)
@ -38,9 +38,9 @@ as possible.
%if %{selinux_module}
%define selinux_policyver %(sed -e 's,.*selinux-policy-\\([^/]*\\)/.*,\\1,' /usr/share/selinux/devel/policyhelp)
%package selinux
Summary: SELinux policy module supporting FastCGI applications with mod_fcgid
Group: System Environment/Base
BuildRequires: %{selinux_buildreqs}
Summary: SELinux policy module supporting FastCGI applications with mod_fcgid
Group: System Environment/Base
BuildRequires: %{selinux_buildreqs}
# selinux-policy is required for directory ownership of %{_datadir}/selinux/*
# Modules built against one version of a policy may not work with older policy
# versions, as noted on fedora-selinux-list:
@ -48,9 +48,9 @@ BuildRequires: %{selinux_buildreqs}
# Hence the versioned dependency. The versioning will hopefully be replaced by
# an ABI version requirement or something similar in the future
%if "%{selinux_policyver}" != ""
Requires: selinux-policy >= %{selinux_policyver}
Requires: selinux-policy >= %{selinux_policyver}
%endif
Requires: %{name} = %{version}-%{release}
Requires: %{name} = %{version}-%{release}
Requires(post): /usr/sbin/semodule, /sbin/restorecon
Requires(postun): /usr/sbin/semodule, /sbin/restorecon
@ -60,8 +60,13 @@ SELinux policy module supporting FastCGI applications with mod_fcgid.
%prep
%setup -q -n mod_fcgid.%{version}
%{__cp} -p %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE6} %{SOURCE7} .
%{__cp} -p %{SOURCE1} fcgid.conf
%{__cp} -p %{SOURCE2} fastcgi.te
%{__cp} -p %{SOURCE3} fastcgi.fc
%{__cp} -p %{SOURCE4} README.Fedora
%{__cp} -p %{SOURCE5} directives.htm
%{__cp} -p %{SOURCE6} configuration.htm
%{__cp} -p %{SOURCE7} README.SELinux
%patch0 -p1
%{__sed} -i -e 's/\r$//' directives.htm configuration.htm
@ -71,9 +76,9 @@ topdir=$(/usr/bin/dirname $(/usr/sbin/apxs -q exp_installbuilddir))
%if %{selinux_module}
for selinuxvariant in %{selinux_variants}
do
%{__make} NAME=${selinuxvariant} -f /usr/share/selinux/devel/Makefile
%{__mv} fastcgi.pp fastcgi.pp.${selinuxvariant}
%{__make} NAME=${selinuxvariant} -f /usr/share/selinux/devel/Makefile clean
%{__make} NAME=${selinuxvariant} -f /usr/share/selinux/devel/Makefile
%{__mv} fastcgi.pp fastcgi.pp.${selinuxvariant}
%{__make} NAME=${selinuxvariant} -f /usr/share/selinux/devel/Makefile clean
done
%endif
@ -81,20 +86,20 @@ done
%{__rm} -rf %{buildroot}
topdir=$(/usr/bin/dirname $(/usr/sbin/apxs -q exp_installbuilddir))
%{__make} \
top_dir=${topdir} \
DESTDIR=%{buildroot} \
MKINSTALLDIRS="%{__mkdir_p}" \
install
%{__install} -D -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/httpd/conf.d/fcgid.conf
top_dir=${topdir} \
DESTDIR=%{buildroot} \
MKINSTALLDIRS="%{__mkdir_p}" \
install
%{__install} -D -m 644 fcgid.conf %{buildroot}%{_sysconfdir}/httpd/conf.d/fcgid.conf
%{__install} -d -m 755 %{buildroot}%{_localstatedir}/run/mod_fcgid
# Install SELinux policy modules
%if %{selinux_module}
for selinuxvariant in %{selinux_variants}
do
%{__install} -d %{buildroot}%{_datadir}/selinux/${selinuxvariant}
%{__install} -p -m 644 fastcgi.pp.${selinuxvariant} \
%{buildroot}%{_datadir}/selinux/${selinuxvariant}/fastcgi.pp
%{__install} -d %{buildroot}%{_datadir}/selinux/${selinuxvariant}
%{__install} -p -m 644 fastcgi.pp.${selinuxvariant} \
%{buildroot}%{_datadir}/selinux/${selinuxvariant}/fastcgi.pp
done
# Hardlink identical policy module packages together
/usr/sbin/hardlink -cv %{buildroot}%{_datadir}/selinux
@ -129,7 +134,7 @@ fi
%endif
%files
%defattr(-,root,root,0755)
%defattr(-,root,root,-)
%doc ChangeLog AUTHOR COPYING configuration.htm directives.htm
%doc README.Fedora
%{_libdir}/httpd/modules/mod_fcgid.so
@ -138,12 +143,19 @@ fi
%if %{selinux_module}
%files selinux
%defattr(-,root,root,0755)
%defattr(-,root,root,-)
%doc fastcgi.fc fastcgi.te README.SELinux
%{_datadir}/selinux/*/fastcgi.pp
%endif
%changelog
* Fri Feb 16 2007 Paul Howarth <paul@city-fan.org> 2.1-1
- Update to 2.1
- Update documentation and patches
- Rename some source files to reduce chances of conflicting names
- Include SharememPath directive in conf file to avoid unfortunate upstream
default location
* Mon Oct 30 2006 Paul Howarth <paul@city-fan.org> 2.0-1
- Update to 2.0
- Source is now hosted at sourceforge.net

View File

@ -1 +1 @@
3aa51f1e293e6d881028295a23021dae mod_fcgid.2.0.tar.gz
68a6479e398a20577334f16a8b06c418 mod_fcgid.2.1.tar.gz