diff --git a/.cvsignore b/.cvsignore index 794ff95..772f798 100644 --- a/.cvsignore +++ b/.cvsignore @@ -1 +1 @@ -mod_fcgid.1.10.tar.gz +mod_fcgid.2.0.tar.gz diff --git a/configuration.htm b/configuration.htm index 4a6e4ad..9090493 100644 --- a/configuration.htm +++ b/configuration.htm @@ -9,62 +9,62 @@
-This is a for regular fastcgi.
LoadModule fcgid_module +
This is a for regular fastcgi.
LoadModule fcgid_module modules/mod_fcgid.so
-<Location /fcgid>
- SetHandler fcgid-script
- Options ExecCGI
- allow from all
+<Location /fcgid>
+ SetHandler fcgid-script
+ Options ExecCGI
+ allow from all
</Location>
This is for suEXEC. Please get more information about suEXEC here.
LoadModule fcgid_module +
This is for suEXEC. Please get more information about suEXEC here.
LoadModule fcgid_module modules/mod_fcgid.so
-<Location /fcgid>
- SetHandler fcgid-script
- Options ExecCGI
- allow from all
+<Location /fcgid>
+ SetHandler fcgid-script
+ Options ExecCGI
+ allow from all
</Location>
-<VirtualHost 192.168.1.89>
- ServerAdmin webmaster@host.foo.com
- DocumentRoot /usr/local/apache2/htdocs/
- ServerName host.foo.com
- SuexecUserGroup pqf pqf
+<VirtualHost 192.168.1.89>
+ ServerAdmin webmaster@host.foo.com
+ DocumentRoot /usr/local/apache2/htdocs/
+ ServerName host.foo.com
+ SuexecUserGroup pqf pqf
</VirtualHost>
This is for fastcgi-mode PHP (UNIX)
LoadModule fcgid_module modules/mod_fcgid.so
-<Directory /usr/local/apache2/htdocs/php>
- SetHandler fcgid-script
- FCGIWrapper /usr/local/bin/php .php
- Options ExecCGI
- allow from all
-</Directory>
This works too:
LoadModule fcgid_module +
This is for fastcgi-mode PHP (UNIX)
LoadModule fcgid_module modules/mod_fcgid.so
+<Directory /usr/local/apache2/htdocs/php>
+ SetHandler fcgid-script
+ FCGIWrapper /usr/local/bin/php .php
+ Options ExecCGI
+ allow from all
+</Directory>
This works too:
LoadModule fcgid_module modules/mod_fcgid.so
-AddHandler fcgid-script .php
-<Directory /usr/local/apache2/htdocs/php>
- FCGIWrapper /usr/local/bin/php .php
- Options ExecCGI
- allow from all
+AddHandler fcgid-script .php
+<Directory /usr/local/apache2/htdocs/php>
+ FCGIWrapper /usr/local/bin/php .php
+ Options ExecCGI
+ allow from all
</Directory>
# Please make sure:
# php is configured with --enable-fastcgi option
# check error_log(with debug level), if
any thing goes wrong
LoadModule fcgid_module modules/mod_fcgid.so
+
LoadModule fcgid_module modules/mod_fcgid.so
-<VirtualHost *:80>
- ServerName test2.example.com
- DocumentRoot /usr/local/apache2/htdocs/test2.example.com/
- SuexecUserGroup pqf pqf
+<VirtualHost *:80>
+ ServerName test2.example.com
+ DocumentRoot /usr/local/apache2/htdocs/test2.example.com/
+ SuexecUserGroup pqf pqf
</VirtualHost>
-<Directory /usr/local/apache2/htdocs/test2.example.com/>
- AddHandler fcgid-script .php
- Options ExecCGI
- allow from all
- FCGIWrapper /usr/local/apache2/htdocs/test2.example.com/php .php
+<Directory /usr/local/apache2/htdocs/test2.example.com/>
+ AddHandler fcgid-script .php
+ Options ExecCGI
+ allow from all
+ FCGIWrapper /usr/local/apache2/htdocs/test2.example.com/php .php
</Directory>
@@ -79,23 +79,89 @@ any thing goes wrong
-This is for fastcgi-mode PHP ( Windows )
LoadModule fcgid_module modules/mod_fcgid.so
-<Directory "C:/Apache2/htdocs/php/">
- SetHandler fcgid-script
- Options execCGI
- AllowOverride None
- Order allow,deny
- Allow from all
- FCGIWrapper "c:/php/php.exe" .php
-</Directory>
This works too:
LoadModule fcgid_module modules/mod_fcgid.so
-AddHandler fcgid-script .php
-<Directory "C:/Apache2/htdocs/php/">
- FCGIWrapper "c:/php/php.exe" .php
- Options ExecCGI
- allow from all
+This is for fastcgi-mode PHP ( Windows )
LoadModule fcgid_module modules/mod_fcgid.so
+<Directory "C:/Apache2/htdocs/php/">
+ SetHandler fcgid-script
+ Options execCGI
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+ FCGIWrapper "c:/php/php.exe" .php
+</Directory>
This works too:
LoadModule fcgid_module modules/mod_fcgid.so
+AddHandler fcgid-script .php
+<Directory "C:/Apache2/htdocs/php/">
+ FCGIWrapper "c:/php/php.exe" .php
+ Options ExecCGI
+ allow from all
</Directory>
LoadModule fcgid_module modules/mod_fcgid.so +
<Location /fcgid>
+ SetHandler fcgid-script
+ Options ExecCGI
+ allow from all
+ AuthType Basic
+ AuthName ProtectedRealm
+ FastCgiAuthenticator /some/path/authenticator
+ require valid-user
+</Location>
+
Another configuration: FastCgiAuthenticatorAuthoritative +(default On)
+Setting the FastCgiAuthenticatorAuthoritative
directive
+explicitly to Off allows authentication to be passed on to lower level
+modules
LoadModule fcgid_module modules/mod_fcgid.so +
<Location /fcgid>
+ SetHandler fcgid-script
+ Options ExecCGI
+ allow from all
+ AuthType Basic
+ AuthName ProtectedRealm
+ FastCgiAuthorizer /some/place/Authorizer
+</Location>
Another configuration: FastCgiAuthorizerAuthoritative +(default On)
+ +Setting the FastCgiAuthorizerAuthoritative
directive explicitly
+to Off allows authorization to be passed on to lower level modules
LoadModule fcgid_module modules/mod_fcgid.so +
<Location /fcgid>
+ SetHandler fcgid-script
+ Options ExecCGI
+ allow from all
+ FastCgiAccessChecker /some/place/access-checker
+</Location>
+
Another configuration: FastCgiAccessCheckerAuthoritative +(default On)
+Setting the FastCgiAccessCheckerAuthoritative
directive
+explicitly to Off allows access checking to be passed on to lower level
+modules
+
+ +
+
+
+
+
+
+
+
+
+
+
diff --git a/doc.htm b/doc.htm index 056a4eb..2966dc5 100644 --- a/doc.htm +++ b/doc.htm @@ -51,7 +51,10 @@ (non-PHP, non-Ruby, non-Python)
Configuration for suEXEC fastcgi
Configuration for suPHP (UNIX)
Configuration -for PHP (Windows)
+for PHP (Windows)
Configuration +for Authenticator
Configuration +for AccessChecker
IPCConnectTimeout n (3 seconds)
The connect timeout to a fastcgi application.
IPCCommTimeout n (20 seconds)
The communication timeout to a fastcgi application. Please increase this value if your CGI have a slow initialization or slow respond.
OutputBufferSize n (64k bytes)
CGI -output cache buffer size.
PHP_Fix_Pathinfo_Enable n(n=0/1, default 0)
If +output cache buffer size.
PHP_Fix_Pathinfo_Enable n(n=0/1, default 0)
If you are using PHP and set cgi.fix_pathinfo=1 in php.ini, set -PHP_Fix_Pathinfo_Enable 1. +PHP_Fix_Pathinfo_Enable 1.
MaxRequestsPerProcess n (-1)
(Added in +version 1.11, patch from Robert L Mathews)
Adds a MaxRequestsPerProcess parameter that allows mod_fcgid to +exit after handling a certain number of requests, similar to the existing ProcessLifeTime option.
This solves a problem with PHP in FastCGI mode. By default, PHP stops +accepting new FastCGI connections after handling 500 requests; unfortunately, there is a potential race condition during the PHP cleanup code in which +PHP can be shutting down but still have the socket open, so mod_fcgid under heavy load can send request number 501 to PHP and have it "accepted", but then +PHP appears to simply exit, causing errors.
If you are using PHP, you should
+set it to 500. -1 mean fastcgi process will not exit no matter how many requests
+it has handled.
diff --git a/mod_fcgid.spec b/mod_fcgid.spec
index c1440e3..276cbd2 100644
--- a/mod_fcgid.spec
+++ b/mod_fcgid.spec
@@ -10,13 +10,13 @@
%endif
Name: mod_fcgid
-Version: 1.10
-Release: 7%{?dist}
+Version: 2.0
+Release: 1%{?dist}
Summary: Apache2 module for high-performance server-side scripting
Group: System Environment/Daemons
License: GPL
URL: http://fastcgi.coremail.cn/
-Source0: http://fastcgi.coremail.cn/mod_fcgid.%{version}.tar.gz
+Source0: http://dl.sf.net/mod-fcgid/mod_fcgid.%{version}.tar.gz
Source1: fcgid.conf
Source2: fastcgi.te
Source3: fastcgi.fc
@@ -144,6 +144,11 @@ fi
%endif
%changelog
+* Mon Oct 30 2006 Paul Howarth