diff --git a/mod_fcgid-2.1-README.RPM b/mod_fcgid-2.1-README.RPM
index 4580bae..18891e0 100644
--- a/mod_fcgid-2.1-README.RPM
+++ b/mod_fcgid-2.1-README.RPM
@@ -37,12 +37,16 @@ CGI application.
/etc/httpd/conf.d/mywiki.conf
# Wiki application data common to all wiki instances
- Alias /wiki/ "/usr/share/moin/htdocs/"
+ Alias /moin_static182 "/usr/share/moin/htdocs/"
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
+
+ ExpiresActive On
+ ExpiresDefault "access plus 1 year"
+
# Wiki instance with mod_fcgid
@@ -56,12 +60,21 @@ CGI application.
- * If you are using SELinux with Fedora Core 5 or later, or Red Hat Enterprise
- Linux 5 or later, install the mod_fcgid-selinux package and see the
- README.SELinux file in that package for details of the file contexts to use
-
* Restart the web server to load the new configuration:
service httpd restart
That should do it!
+
+Ruby on Rails with mod_fcgid
+============================
+
+One of the differences between mod_fastcgi and mod_fcgid is that the former
+sets the SCRIPT_NAME environment variable whilst the latter does not, and it's
+reported (http://bugzilla.redhat.com/476658) that Ruby on Rails expects this
+environment variable to be present. A workaround for this is to add:
+
+ActionController::AbstractRequest.relative_url_root = ""
+
+to the Rails::Initializer.run segment of config/environment.rb
+
diff --git a/mod_fcgid-2.1-README.SELinux b/mod_fcgid-2.1-README.SELinux
index 5165376..c894033 100644
--- a/mod_fcgid-2.1-README.SELinux
+++ b/mod_fcgid-2.1-README.SELinux
@@ -1,12 +1,11 @@
Using mod_fcgid with SELinux in Fedora Core 5 / RHEL 5 onwards
==============================================================
-Versions of this package built for Fedora Core 5 / Red Hat Enterprise Linux 5
-or later include an SELinux policy module to support FastCGI applications.
-This has only been tested so far with moin, so feedback from other applications
-is welcome. The policy included here is a transitional policy that will soon
-be included in the selinux-policy package for Fedora 8 onwards, and the
-mod_fcgid-selinux package will be obsoleted when that happens.
+Versions of this package built for Fedora Core 5, 6, or 7 and Red Hat
+Enterprise Linux 5 or later include an SELinux policy module to support
+FastCGI applications. Later Fedora releases include the policy in the main
+selinux-policy package and do not require the separate module. This has only
+been tested so far with moin, so feedback from other applications is welcome.
The module source (fastcgi.{fc,te}) is included for reference as documentation
in the package.
diff --git a/mod_fcgid.spec b/mod_fcgid.spec
index 5bd989f..1776c8f 100644
--- a/mod_fcgid.spec
+++ b/mod_fcgid.spec
@@ -15,7 +15,7 @@
Name: mod_fcgid
Version: 2.2
-Release: 8%{?dist}
+Release: 9%{?dist}
Summary: Apache2 module for high-performance server-side scripting
Group: System Environment/Daemons
License: GPL+
@@ -52,7 +52,7 @@ as possible.
%if %{selinux_module}
%global selinux_policyver %(%{__sed} -e 's,.*selinux-policy-\\([^/]*\\)/.*,\\1,' /usr/share/selinux/devel/policyhelp || echo 0.0.0)
-%define selinux_policynum %(echo %{selinux_policyver} | %{__awk} -F. '{ printf "%d%02d%02d", $1, $2, $3 }')
+%global selinux_policynum %(echo %{selinux_policyver} | %{__awk} -F. '{ printf "%d%02d%02d", $1, $2, $3 }')
%package selinux
Summary: SELinux policy module supporting FastCGI applications with mod_fcgid
Group: System Environment/Base
@@ -169,6 +169,9 @@ exit 0
%endif
%changelog
+* Thu Feb 26 2009 Paul Howarth 2.2-9
+- Update documentation for MoinMoin, Rails (#476658), and SELinux
+
* Wed Feb 25 2009 Fedora Release Engineering - 2.2-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild