16 lines
805 B
Diff
16 lines
805 B
Diff
--- mod_auth_openidc-2.4.3/Makefile.in.nonlto
|
|
+++ mod_auth_openidc-2.4.3/Makefile.in
|
|
@@ -73,8 +73,11 @@
|
|
@NAMEVER@.tar.gz: $(DISTFILES)
|
|
tar -c --transform="s#^#@NAMEVER@/#" -vzf $@ $(DISTFILES)
|
|
|
|
+APXS_CFLAGS := $(shell @APXS2@ -q CFLAGS | sed 's/-f[^ ]*lto[^ ]* //g') $(CFLAGS) $(shell @APXS2@ -q EXTRA_CPPFLAGS)
|
|
+APXS_CC := $(shell @APXS2@ -q CC) $(APXS_CFLAGS) $(shell @APXS2@ -q EXTRA_INCLUDES)
|
|
+
|
|
test/test test/test-cmd: test/test.c test/test-cmd.c test/stub.c src/mod_auth_openidc.la
|
|
- @APXS2@ @APXS2_OPTS@ -Wc,"-DNAMEVER=\"@NAMEVER@\" $(CFLAGS)" -Wl,"$(LIBS)" -Isrc -Wc,-Wall -Wc,-g -c -o $@ $@.c test/stub.c $(SRC:.c=.lo) @APR_LIBS@
|
|
+ $(APXS_CC) -DNAMEVER=\"@NAMEVER@\" $(CFLAGS) $(LIBS) -Isrc -Wall -g -o $@ $@.c test/stub.c $(SRC:.c=.o) @APR_LIBS@
|
|
|
|
test-compile: test/test test/test-cmd
|
|
|