Remove the unnecessary LTO patch
This commit is contained in:
parent
ba46e78791
commit
fdc3d43e88
@ -1,15 +0,0 @@
|
|||||||
--- mod_auth_openidc-2.4.3/Makefile.in.nonlto
|
|
||||||
+++ mod_auth_openidc-2.4.3/Makefile.in
|
|
||||||
@@ -73,8 +73,11 @@
|
|
||||||
@NAMEVER@.tar.gz: $(DISTFILES)
|
|
||||||
tar -c --transform="s#^#@NAMEVER@/#" -vzf $@ $(DISTFILES)
|
|
||||||
|
|
||||||
+APXS_CFLAGS := $(shell @APXS2@ -q CFLAGS | sed 's/-f[^ ]*lto[^ ]* //g') $(CFLAGS) $(shell @APXS2@ -q EXTRA_CPPFLAGS)
|
|
||||||
+APXS_CC := $(shell @APXS2@ -q CC) $(APXS_CFLAGS) $(shell @APXS2@ -q EXTRA_INCLUDES)
|
|
||||||
+
|
|
||||||
test/test test/test-cmd: test/test.c test/test-cmd.c test/stub.c src/mod_auth_openidc.la
|
|
||||||
- @APXS2@ @APXS2_OPTS@ -Wc,"-DNAMEVER=\"@NAMEVER@\" $(CFLAGS)" -Wl,"$(LIBS)" -Isrc -Wc,-Wall -Wc,-g -c -o $@ $@.c test/stub.c $(SRC:.c=.lo) @APR_LIBS@
|
|
||||||
+ $(APXS_CC) -DNAMEVER=\"@NAMEVER@\" $(CFLAGS) $(LIBS) -Isrc -Wall -g -o $@ $@.c test/stub.c $(SRC:.c=.o) @APR_LIBS@
|
|
||||||
|
|
||||||
test-compile: test/test test/test-cmd
|
|
||||||
|
|
@ -15,13 +15,12 @@
|
|||||||
|
|
||||||
Name: mod_auth_openidc
|
Name: mod_auth_openidc
|
||||||
Version: 2.4.4.1
|
Version: 2.4.4.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: OpenID Connect auth module for Apache HTTP Server
|
Summary: OpenID Connect auth module for Apache HTTP Server
|
||||||
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: https://github.com/zmartzone/mod_auth_openidc
|
URL: https://github.com/zmartzone/mod_auth_openidc
|
||||||
Source0: https://github.com/zmartzone/mod_auth_openidc/archive/v%{version}.tar.gz
|
Source0: https://github.com/zmartzone/mod_auth_openidc/archive/v%{version}.tar.gz
|
||||||
Patch0: mod_auth_openidc-2.4.3-nonlto.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -43,7 +42,6 @@ an OpenID Connect Relying Party and/or OAuth 2.0 Resource Server.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .nonlto
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# workaround rpm-buildroot-usage
|
# workaround rpm-buildroot-usage
|
||||||
@ -98,6 +96,9 @@ install -m 700 -d $RPM_BUILD_ROOT%{httpd_pkg_cache_dir}/cache
|
|||||||
%dir %attr(0700, apache, apache) %{httpd_pkg_cache_dir}/cache
|
%dir %attr(0700, apache, apache) %{httpd_pkg_cache_dir}/cache
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 30 2021 Tomas Halman <thalman@redhat.com> - 2.4.4.1-3
|
||||||
|
- Remove unnecessary LTO patch
|
||||||
|
|
||||||
* Fri Feb 26 2021 Jakub Hrozek <jhrozek@redhat.com> - 2.4.4.1-1
|
* Fri Feb 26 2021 Jakub Hrozek <jhrozek@redhat.com> - 2.4.4.1-1
|
||||||
- Temporarily disable check to get around a FTBFS issue (#1923374)
|
- Temporarily disable check to get around a FTBFS issue (#1923374)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user