Remove the unnecessary LTO patch

This commit is contained in:
Tomas Halman 2021-04-30 14:16:13 +02:00
parent ba46e78791
commit fdc3d43e88
2 changed files with 4 additions and 18 deletions

View File

@ -1,15 +0,0 @@
--- mod_auth_openidc-2.4.3/Makefile.in.nonlto
+++ mod_auth_openidc-2.4.3/Makefile.in
@@ -73,8 +73,11 @@
@NAMEVER@.tar.gz: $(DISTFILES)
tar -c --transform="s#^#@NAMEVER@/#" -vzf $@ $(DISTFILES)
+APXS_CFLAGS := $(shell @APXS2@ -q CFLAGS | sed 's/-f[^ ]*lto[^ ]* //g') $(CFLAGS) $(shell @APXS2@ -q EXTRA_CPPFLAGS)
+APXS_CC := $(shell @APXS2@ -q CC) $(APXS_CFLAGS) $(shell @APXS2@ -q EXTRA_INCLUDES)
+
test/test test/test-cmd: test/test.c test/test-cmd.c test/stub.c src/mod_auth_openidc.la
- @APXS2@ @APXS2_OPTS@ -Wc,"-DNAMEVER=\"@NAMEVER@\" $(CFLAGS)" -Wl,"$(LIBS)" -Isrc -Wc,-Wall -Wc,-g -c -o $@ $@.c test/stub.c $(SRC:.c=.lo) @APR_LIBS@
+ $(APXS_CC) -DNAMEVER=\"@NAMEVER@\" $(CFLAGS) $(LIBS) -Isrc -Wall -g -o $@ $@.c test/stub.c $(SRC:.c=.o) @APR_LIBS@
test-compile: test/test test/test-cmd

View File

@ -15,13 +15,12 @@
Name: mod_auth_openidc
Version: 2.4.4.1
Release: 2%{?dist}
Release: 3%{?dist}
Summary: OpenID Connect auth module for Apache HTTP Server
License: ASL 2.0
URL: https://github.com/zmartzone/mod_auth_openidc
Source0: https://github.com/zmartzone/mod_auth_openidc/archive/v%{version}.tar.gz
Patch0: mod_auth_openidc-2.4.3-nonlto.patch
BuildRequires: make
BuildRequires: gcc
@ -43,7 +42,6 @@ an OpenID Connect Relying Party and/or OAuth 2.0 Resource Server.
%prep
%setup -q
%patch0 -p1 -b .nonlto
%build
# workaround rpm-buildroot-usage
@ -98,6 +96,9 @@ install -m 700 -d $RPM_BUILD_ROOT%{httpd_pkg_cache_dir}/cache
%dir %attr(0700, apache, apache) %{httpd_pkg_cache_dir}/cache
%changelog
* Fri Apr 30 2021 Tomas Halman <thalman@redhat.com> - 2.4.4.1-3
- Remove unnecessary LTO patch
* Fri Feb 26 2021 Jakub Hrozek <jhrozek@redhat.com> - 2.4.4.1-1
- Temporarily disable check to get around a FTBFS issue (#1923374)