work around LTO build failure

This commit is contained in:
Joe Orton 2020-08-27 08:50:25 +01:00
parent c26febf0df
commit c322ab13fe
2 changed files with 21 additions and 1 deletions

View File

@ -0,0 +1,15 @@
--- mod_auth_openidc-2.4.3/Makefile.in.nonlto
+++ mod_auth_openidc-2.4.3/Makefile.in
@@ -73,8 +73,11 @@
@NAMEVER@.tar.gz: $(DISTFILES)
tar -c --transform="s#^#@NAMEVER@/#" -vzf $@ $(DISTFILES)
+APXS_CFLAGS := $(shell @APXS2@ -q CFLAGS | sed 's/-flto //') $(CFLAGS)
+APXS_CC := $(shell @APXS2@ -q CC) $(APXS_CFLAGS) $(shell @APXS2@ -q EXTRA_INCLUDES)
+
test/test test/test-cmd: test/test.c test/test-cmd.c test/stub.c src/mod_auth_openidc.la
- @APXS2@ @APXS2_OPTS@ -Wc,"-DNAMEVER=\"@NAMEVER@\" $(CFLAGS)" -Wl,"$(LIBS)" -Isrc -Wc,-Wall -Wc,-g -c -o $@ $@.c test/stub.c $(SRC:.c=.lo) @APR_LIBS@
+ $(APXS_CC) -DNAMEVER=\"@NAMEVER@\" $(CFLAGS) $(LIBS) -Isrc -Wall -g -o $@ $@.c test/stub.c $(SRC:.c=.o) @APR_LIBS@
test-compile: test/test test/test-cmd

View File

@ -15,12 +15,13 @@
Name: mod_auth_openidc Name: mod_auth_openidc
Version: 2.4.3 Version: 2.4.3
Release: 3%{?dist} Release: 4%{?dist}
Summary: OpenID Connect auth module for Apache HTTP Server Summary: OpenID Connect auth module for Apache HTTP Server
License: ASL 2.0 License: ASL 2.0
URL: https://github.com/zmartzone/mod_auth_openidc URL: https://github.com/zmartzone/mod_auth_openidc
Source0: https://github.com/zmartzone/mod_auth_openidc/archive/v%{version}.tar.gz Source0: https://github.com/zmartzone/mod_auth_openidc/archive/v%{version}.tar.gz
Patch0: mod_auth_openidc-2.4.3-nonlto.patch
BuildRequires: gcc BuildRequires: gcc
BuildRequires: httpd-devel BuildRequires: httpd-devel
@ -41,6 +42,7 @@ an OpenID Connect Relying Party and/or OAuth 2.0 Resource Server.
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b .nonlto
%build %build
# workaround rpm-buildroot-usage # workaround rpm-buildroot-usage
@ -93,6 +95,9 @@ install -m 700 -d $RPM_BUILD_ROOT%{httpd_pkg_cache_dir}/cache
%dir %attr(0700, apache, apache) %{httpd_pkg_cache_dir}/cache %dir %attr(0700, apache, apache) %{httpd_pkg_cache_dir}/cache
%changelog %changelog
* Thu Aug 27 2020 Joe Orton <jorton@redhat.com> - 2.4.3-4
- work around LTO build failure
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.3-3 * Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.3-3
- Second attempt - Rebuilt for - Second attempt - Rebuilt for
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild