diff --git a/.gitignore b/.gitignore
index e69de29..aa287b0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/mockito-*.tar.xz
+/.build-*.log
+/noarch/
+/*.src.rpm
diff --git a/make-mockito-sourcetarball.sh b/make-mockito-sourcetarball.sh
new file mode 100755
index 0000000..99a7368
--- /dev/null
+++ b/make-mockito-sourcetarball.sh
@@ -0,0 +1,19 @@
+#!/bin/bash -ex
+
+VERSION=3.5.5
+SRCDIR=mockito-${VERSION}
+
+git clone https://github.com/mockito/mockito.git ${SRCDIR}
+pushd $SRCDIR
+git archive --format=tar --prefix=${SRCDIR}/ v${VERSION} > ../${SRCDIR}.tar
+popd
+
+rm -rf ${SRCDIR}
+
+tar -xf ${SRCDIR}.tar
+rm ${SRCDIR}.tar
+pushd ${SRCDIR}
+rm -rf `find -name *.jar` gradlew gradlew.bat src/javadoc
+popd
+
+tar -cvJf mockito-${VERSION}.tar.xz ${SRCDIR}
diff --git a/mockito-core.pom b/mockito-core.pom
new file mode 100644
index 0000000..610157d
--- /dev/null
+++ b/mockito-core.pom
@@ -0,0 +1,693 @@
+
+
+ 4.0.0
+ org.mockito
+ mockito-core
+ @VERSION@
+ mockito-core
+ jar
+ https://github.com/mockito/mockito
+ Mockito mock objects library core API and implementation
+
+
+ 1.8
+ 1.8
+
+
+
+ org.ow2.asm
+ asm
+ 7.0
+ compile
+
+
+ net.bytebuddy
+ byte-buddy
+ 1.9.3
+ compile
+
+
+ net.bytebuddy
+ byte-buddy-agent
+ 1.9.3
+ compile
+
+
+ org.objenesis
+ objenesis
+ 2.6
+ compile
+
+
+ org.opentest4j
+ opentest4j
+ 1.1.1
+ compile
+
+
+ org.hamcrest
+ hamcrest-core
+ 1.3
+ provided
+
+
+ junit
+ junit
+ 4.12
+ provided
+
+
+ org.assertj
+ assertj-core
+ 2.9.0
+ test
+
+
+
+
+
+ org.apache.felix
+ maven-bundle-plugin
+ 3.5.0
+
+ ${project.build.directory}/osgi
+
+ <_include>-osgi.bnd
+
+
+
+
+ process-classes
+
+ manifest
+
+
+
+
+
+ org.codehaus.mojo
+ exec-maven-plugin
+ 1.6.0
+
+
+ process-classes
+
+ exec
+
+
+
+
+ cp
+
+ ${project.build.outputDirectory}/org/mockito/internal/creation/bytebuddy/inject/MockMethodDispatcher.class
+ ${project.build.outputDirectory}/org/mockito/internal/creation/bytebuddy/inject/MockMethodDispatcher.raw
+
+
+
+
+ org.apache.maven.plugins
+ maven-jar-plugin
+ 3.1.0
+
+
+ ${project.build.directory}/osgi/MANIFEST.MF
+
+
+ **/MockMethodDispatcher.class
+
+
+
+
+
+
+
+ The MIT License
+ https://github.com/mockito/mockito/blob/master/LICENSE
+ repo
+
+
+
+ https://github.com/mockito/mockito.git
+
+
+ https://github.com/mockito/mockito/issues
+ GitHub issues
+
+
+ https://travis-ci.org/mockito/mockito
+ TravisCI
+
+
+
+ mockitoguy
+ Szczepan Faber
+
+ Core developer
+
+ https://github.com/mockitoguy
+
+
+ bric3
+ Brice Dutheil
+
+ Core developer
+
+ https://github.com/bric3
+
+
+ raphw
+ Rafael Winterhalter
+
+ Core developer
+
+ https://github.com/raphw
+
+
+ TimvdLippe
+ Tim van der Lippe
+
+ Core developer
+
+ https://github.com/TimvdLippe
+
+
+
+
+ continuous-delivery-drone
+ https://github.com/continuous-delivery-drone
+
+
+ shipkit.org automated bot
+ https://github.com/shipkit-org
+
+
+ Marcin Zajączkowski
+ https://github.com/szpak
+
+
+ Pascal Schumacher
+ https://github.com/PascalSchumacher
+
+
+ Igor Czechowski
+ https://github.com/iczechowski
+
+
+ Bartosz Bańkowski
+ https://github.com/bbankowski
+
+
+ Erhard Pointl
+ https://github.com/epeee
+
+
+ Allon Murienik
+ https://github.com/mureinik
+
+
+ Christian Schwarz
+ https://github.com/ChristianSchwarz
+
+
+ Lukasz Szewc
+ https://github.com/lukasz-szewc
+
+
+ Marcin Grzejszczak
+ https://github.com/marcingrzejszczak
+
+
+ Marc Philipp
+ https://github.com/marcphilipp
+
+
+ Sangwoo Lee
+ https://github.com/marchpig
+
+
+ Philip P. Moltmann
+ https://github.com/moltmann
+
+
+ Tim Perry
+ https://github.com/pimterry
+
+
+ David J. M. Karlsen
+ https://github.com/davidkarlsen
+
+
+ Dawud-xx
+ https://github.com/Dawud-xx
+
+
+ Lovro Pandžić
+ https://github.com/lpandzic
+
+
+ Werner Beroux
+ https://github.com/wernight
+
+
+ Tsuyoshi Murakami
+ https://github.com/tmurakami
+
+
+ Serge Bishyr
+ https://github.com/SeriyBg
+
+
+ Dmitry Timofeev
+ https://github.com/dmitry-timofeev
+
+
+ jerzykrlk
+ https://github.com/jerzykrlk
+
+
+ alberskib
+ https://github.com/alberskib
+
+
+ Joseph Walton
+ https://github.com/josephw
+
+
+ Stephan Schroevers
+ https://github.com/Stephan202
+
+
+ Michal Kordas
+ https://github.com/mkordas
+
+
+ Kamil Szymański
+ https://github.com/kamilszymanski
+
+
+ Hynek Mlnařík
+ https://github.com/hmlnarik
+
+
+ Hugh Hamill
+ https://github.com/hughwphamill
+
+
+ Hans Joachim Desserud
+ https://github.com/hansjoachim
+
+
+ Gunnar Wagenknecht
+ https://github.com/guw
+
+
+ Dmytro Chyzhykov
+ https://github.com/ffbit
+
+
+ r-smirnov
+ https://github.com/r-smirnov
+
+
+ ianparkinson
+ https://github.com/ianparkinson
+
+
+ dmac100
+ https://github.com/dmac100
+
+
+ Vineet Kumar
+ https://github.com/vin
+
+
+ Urs Metz
+ https://github.com/UrsMetz
+
+
+ Tarnowski Jan
+ https://github.com/tarnowskijan
+
+
+ Roman Elizarov
+ https://github.com/elizarov
+
+
+ Roland Hauser
+ https://github.com/SourcePond
+
+
+ Michał Borek
+ https://github.com/michalborek
+
+
+ Michael Pinnegar
+ https://github.com/Jazzepi
+
+
+ Marius Volkhart
+ https://github.com/MariusVolkhart
+
+
+ Lucas Cavalcanti
+ https://github.com/lucascs
+
+
+ Leonardo Carrasco
+ https://github.com/thesnowgoose
+
+
+ Krzysztof Wolny
+ https://github.com/vanta
+
+
+ Jeffrey Falgout
+ https://github.com/JeffreyFalgout
+
+
+ Ismael Juma
+ https://github.com/ijuma
+
+
+ Emory Merryman
+ https://github.com/AFnRFCb7
+
+
+ Clark Brewer
+ https://github.com/brewerc
+
+
+ Carlos Aguayo
+ https://github.com/carlosaguayo
+
+
+ Arend v. Reinersdorff
+ https://github.com/arend-von-reinersdorff
+
+
+ Alberto Scotto
+ https://github.com/alb-i986
+
+
+ yyvess
+ https://github.com/yyvess
+
+
+ 訾明华
+ https://github.com/ziminghua
+
+
+ wuwen
+ https://github.com/wuwen5
+
+
+ test111
+ https://github.com/tradingreason
+
+
+ Xin Liu
+ https://github.com/L-KID
+
+
+ Wojtek Wilk
+ https://github.com/wwilk
+
+
+ Walter Scott Johnson
+ https://github.com/li-wjohnson
+
+
+ Walter Johnson
+ https://github.com/li-wjohnson
+
+
+ Vladislav
+ https://github.com/VChirp
+
+
+ Vivian Pennel
+ https://github.com/Vp3n
+
+
+ Venkata Jaswanth
+ https://github.com/aj-jaswanth
+
+
+ Tom Ball
+ https://github.com/tomball
+
+
+ Tokuhiro Matsuno
+ https://github.com/tokuhirom
+
+
+ Tim Cooke
+ https://github.com/trcooke
+
+
+ Stuart Blair
+ https://github.com/stuartblair
+
+
+ Simen Bekkhus
+ https://github.com/SimenB
+
+
+ Scott Markwell
+ https://github.com/smarkwell
+
+
+ Sanne Grinovero
+ https://github.com/Sanne
+
+
+ Roi Atalla
+ https://github.com/ra4king
+
+
+ Robert Stupp
+ https://github.com/snazy
+
+
+ Radim Kubacki
+ https://github.com/radimk
+
+
+ Philipp Jardas
+ https://github.com/phjardas
+
+
+ Oliver Drotbohm
+ https://github.com/odrotbohm
+
+
+ Niklas Baudy
+ https://github.com/vanniktech
+
+
+ Myrle Krantz
+ https://github.com/myrle-krantz
+
+
+ Matt Dean
+ https://github.com/mattbdean
+
+
+ Markus Wüstenberg
+ https://github.com/markuswustenberg
+
+
+ Maciej Kuster
+ https://github.com/NagRock
+
+
+ MEDDAH Julien
+ https://github.com/MeddahJ
+
+
+ Ludovic Meurillon
+ https://github.com/LudoMeurillon
+
+
+ Ludovic Chane
+ https://github.com/ludochane
+
+
+ Krisztian Milesz
+ https://github.com/mileszk
+
+
+ Kengo TODA
+ https://github.com/KengoTODA
+
+
+ Kayvan Najafzadeh
+ https://github.com/kayvannj
+
+
+ José Paumard
+ https://github.com/JosePaumard
+
+
+ Jonathan Lloyd
+ https://github.com/lloydjm77
+
+
+ Johnny Lim
+ https://github.com/izeye
+
+
+ Jesse Englert
+ https://github.com/jpenglert
+
+
+ Jeremy Rickard
+ https://github.com/jrrickard
+
+
+ Ivan Vershinin
+ https://github.com/vershinin
+
+
+ Igor Kostenko
+ https://github.com/isanych
+
+
+ Igor Conrado Alves de Lima
+ https://github.com/igorcadelima
+
+
+ Gaëtan Muller
+ https://github.com/MGaetan89
+
+
+ Felix W. Dekker
+ https://github.com/FWDekker
+
+
+ Evgeny Astafyev
+ https://github.com/astafev
+
+
+ Eugene Ivakhno
+ https://github.com/eugene-ivakhno
+
+
+ Erik Bakker
+ https://github.com/eamelink
+
+
+ Dmitriy Zaitsev
+ https://github.com/DmitriyZaitsev
+
+
+ Divyansh Gupta
+ https://github.com/divyansh-gupta
+
+
+ Dennis Cheung
+ https://github.com/hkdennis2k
+
+
+ Denis Zharkov
+ https://github.com/dzharkov
+
+
+ David Xia
+ https://github.com/davidxia
+
+
+ David Gageot
+ https://github.com/dgageot
+
+
+ Christian Persson
+ https://github.com/Saser
+
+
+ Bruno Krebs
+ https://github.com/brunokrebs
+
+
+ Ben Yu
+ https://github.com/fluentfuture
+
+
+ Bastien Jansen
+ https://github.com/bjansen
+
+
+ Bartosz Miller
+ https://github.com/BartoszMiller
+
+
+ Ariel Isaac
+ https://github.com/Ariel-Isaacm
+
+
+ Anuraag Agrawal
+ https://github.com/anuraaga
+
+
+ André Gonçalves
+ https://github.com/andrerigon
+
+
+ Andrey
+ https://github.com/andreyrmg
+
+
+ Andrei Solntsev
+ https://github.com/asolntsev
+
+
+ Allan Wang
+ https://github.com/AllanWang
+
+
+ Alex Simkin
+ https://github.com/SimY4
+
+
+ rberghegger
+ https://github.com/rberghegger
+
+
+ philipa
+ https://github.com/philipa
+
+
+ paulduffin
+ https://github.com/paulduffin
+
+
+ mgrafl
+ https://github.com/mgrafl
+
+
+ jmetertea
+ https://github.com/jmetertea
+
+
+ geoffschoeman
+ https://github.com/geoffschoeman
+
+
+ bruceeddy
+ https://github.com/bruceeddy
+
+
+ ashleyfrieze
+ https://github.com/ashleyfrieze
+
+
+ Nirvanall
+ https://github.com/Nirvanall
+
+
+ LiamClark
+ https://github.com/LiamClark
+
+
+
diff --git a/mockito.spec b/mockito.spec
new file mode 100644
index 0000000..b83afe5
--- /dev/null
+++ b/mockito.spec
@@ -0,0 +1,226 @@
+Name: mockito
+Version: 3.5.5
+Release: 1%{?dist}
+Summary: Tasty mocking framework for unit tests in Java
+License: MIT
+URL: https://site.mockito.org/
+BuildArch: noarch
+
+# Source tarball and the script to generate it
+Source0: %{name}-%{version}.tar.xz
+Source1: make-%{name}-sourcetarball.sh
+
+# A custom build script to allow building with maven instead of gradle
+Source2: mockito-core.pom
+
+# Mockito expects byte-buddy to have a shaded/bundled version of ASM, but
+# we don't bundle in Fedora, so this patch makes mockito use ASM explicitly
+Patch0: use-unbundled-asm.patch
+
+BuildRequires: maven-local
+BuildRequires: mvn(junit:junit)
+BuildRequires: mvn(net.bytebuddy:byte-buddy)
+BuildRequires: mvn(net.bytebuddy:byte-buddy-agent)
+BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
+BuildRequires: mvn(org.assertj:assertj-core)
+BuildRequires: mvn(org.codehaus.mojo:exec-maven-plugin)
+BuildRequires: mvn(org.hamcrest:hamcrest-core)
+BuildRequires: mvn(org.objenesis:objenesis)
+BuildRequires: mvn(org.opentest4j:opentest4j)
+BuildRequires: mvn(org.ow2.asm:asm)
+
+%description
+Mockito is a mocking framework that tastes really good. It lets you write
+beautiful tests with clean & simple API. Mockito doesn't give you hangover
+because the tests are very readable and they produce clean verification
+errors.
+
+%package javadoc
+Summary: Javadocs for %{name}
+
+%description javadoc
+This package contains the API documentation for %{name}.
+
+%prep
+%setup -q
+%patch0
+
+# Use our custom build script
+sed -e 's/@VERSION@/%{version}/' %{SOURCE2} > pom.xml
+
+# OGGi metadata configuration
+cat > osgi.bnd < - 3.5.5-1
+- Update to version 3.5.5
+
+* Fri Aug 14 2020 Jerry James - 2.28.2-1
+- Update to version 2.28.2
+
+* Tue Jul 28 2020 Fedora Release Engineering - 2.23.9-8
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Sat Jul 11 2020 Jiri Vanek - 2.23.9-7
+- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
+
+* Wed Jan 29 2020 Fedora Release Engineering - 2.23.9-6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
+* Thu Jul 25 2019 Fedora Release Engineering - 2.23.9-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+
+* Fri Feb 01 2019 Fedora Release Engineering - 2.23.9-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
+
+* Wed Dec 12 2018 Mat Booth - 2.23.9-3
+- Set the source encoding for the build
+
+* Wed Dec 05 2018 Mat Booth - 2.23.9-2
+- Re-add compatibility alias for 'mockito-all'
+
+* Tue Dec 04 2018 Mat Booth - 2.23.9-1
+- Update to latest upstream version
+- Switch to maven build system using a custom pom to avoid a dep on gradle
+
+* Fri Aug 03 2018 Michael Simacek - 1.10.19-17
+- Remove bundled minified js from javadoc
+
+* Fri Jul 13 2018 Fedora Release Engineering - 1.10.19-16
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
+
+* Fri Feb 09 2018 Igor Gnatenko - 1.10.19-15
+- Escape macros in %%changelog
+
+* Thu Feb 08 2018 Fedora Release Engineering - 1.10.19-14
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
+* Wed Jul 26 2017 Fedora Release Engineering - 1.10.19-13
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
+
+* Thu Feb 16 2017 Michael Simacek - 1.10.19-12
+- Remove conditional for EOL Fedora
+
+* Fri Feb 10 2017 Fedora Release Engineering - 1.10.19-11
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
+
+* Mon Feb 22 2016 Mat Booth - 1.10.19-10
+- Explicitly import more cglib packages in OSGi metadata to prevent mockito
+ failing under certain circumstances during Eclipse test suites
+
+* Fri Feb 12 2016 Mat Booth - 1.10.19-9
+- Require hamcrest explicitly in OSGi metadata
+
+* Thu Feb 04 2016 Fedora Release Engineering - 1.10.19-8
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
+
+* Fri Dec 25 2015 Raphael Groner - 1.10.19-7
+- introduce License tag
+
+* Fri Dec 25 2015 Raphael Groner - 1.10.19-6
+- reenable osgi
+
+* Fri Dec 18 2015 Raphael Groner - 1.10.19-5
+- workaround rhbz#1292777 stylesheet.css not found
+
+* Thu Jul 16 2015 Michael Simacek - 1.10.19-4
+- Use aqute-bnd-2.4.1
+
+* Mon Jun 22 2015 Mat Booth - 1.10.19-3
+- Switch to mvn_install
+
+* Wed Jun 17 2015 Fedora Release Engineering - 1.10.19-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
+
+* Wed Apr 29 2015 Michal Srb - 1.10.19-1
+- Update to 1.10.19
+
+* Mon Aug 25 2014 Darryl L. Pierce - 1.9.0-18
+- First build for EPEL7
+- Resolves: BZ#1110030
+
+* Mon Jun 09 2014 Omair Majid - 1.9.0-17
+- Use .mfiles to pick up xmvn metadata
+- Don't use obsolete _mavenpomdir and _mavendepmapfragdir macros
+- Fix FTBFS
+
+* Sat Jun 07 2014 Fedora Release Engineering - 1.9.0-17
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
+
+* Thu May 22 2014 Severin Gehwolf - 1.9.0-16
+- Use junit R/BR over junit4.
+
+* Fri Mar 28 2014 Michael Simacek - 1.9.0-15
+- Use Requires: java-headless rebuild (#1067528)
+
+* Wed Dec 11 2013 Michael Simacek - 1.9.0-14
+- Workaround for NPE in setting NamingPolicy
+
+* Sat Aug 03 2013 Fedora Release Engineering - 1.9.0-13
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
+
+* Mon Mar 25 2013 Tomas Radej - 1.9.0-12
+- Patched LocalizedMatcher due to hamcrest update, (bug upstream)
+
+* Thu Feb 14 2013 Fedora Release Engineering - 1.9.0-11
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
+
+* Thu Sep 6 2012 Severin Gehwolf 1.9.0-10
+- More Import-Package fixes. Note that fix-cglib-refs.patch is
+ not suitable for upstream: issue id=373
+
+* Tue Sep 4 2012 Severin Gehwolf 1.9.0-9
+- Fix missing Import-Package in manifest.
+
+* Mon Aug 27 2012 Severin Gehwolf 1.9.0-8
+- Add aqute bnd instructions for OSGi metadata
+
+* Fri Jul 20 2012 Fedora Release Engineering - 1.9.0-7
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Mon Apr 30 2012 Roman Kennke 1.9.0-6
+- Place JavaDoc in directly under %%{_javadocdir}/%%{name} instead
+ of %%{_javadocdir}/%%{name}/javadoc
+
+* Wed Apr 25 2012 Roman Kennke 1.9.0-5
+- Removed post/postun hook for update_maven_depmap
+
+* Tue Apr 24 2012 Roman Kennke 1.9.0-4
+- Fix groupId of cglib dependency
+- Add additional depmap for mockito-all
+- Update depmap on post and postun
+- Fix version in pom
+
+* Wed Feb 22 2012 Roman Kennke 1.9.0-3
+- Added cglib dependency to pom
+
+* Tue Feb 21 2012 Roman Kennke 1.9.0-2
+- Include upstream Maven pom.xml in package
+- Added missing Requires for cglib, junit4, hamcrest, objenesis
+- Added source tarball generating script to sources
+
+* Thu Feb 16 2012 Roman Kennke 1.9.0-1
+- Initial package
diff --git a/sources b/sources
new file mode 100644
index 0000000..250e5cb
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+SHA512 (mockito-3.5.5.tar.xz) = 32acf233ffa670ba240962d5768c85c99b46f339744e4ac5cd67e8f96c3da71c0f5f37eaa4d19749ee11e0c9f32e320e6d3235a0960d76e285a0ed1e97bc4efd
diff --git a/use-unbundled-asm.patch b/use-unbundled-asm.patch
new file mode 100644
index 0000000..856aef6
--- /dev/null
+++ b/use-unbundled-asm.patch
@@ -0,0 +1,85 @@
+--- src/main/java/org/mockito/internal/creation/bytebuddy/InlineBytecodeGenerator.java.orig 2020-08-22 14:11:33.000000000 -0600
++++ src/main/java/org/mockito/internal/creation/bytebuddy/InlineBytecodeGenerator.java 2020-08-23 11:55:09.642153410 -0600
+@@ -30,8 +30,8 @@ import net.bytebuddy.dynamic.ClassFileLo
+ import net.bytebuddy.dynamic.scaffold.MethodGraph;
+ import net.bytebuddy.dynamic.scaffold.TypeValidation;
+ import net.bytebuddy.implementation.Implementation;
+-import net.bytebuddy.jar.asm.ClassVisitor;
+-import net.bytebuddy.jar.asm.MethodVisitor;
++import org.objectweb.asm.ClassVisitor;
++import org.objectweb.asm.MethodVisitor;
+ import net.bytebuddy.matcher.ElementMatchers;
+ import net.bytebuddy.pool.TypePool;
+ import net.bytebuddy.utility.OpenedClassReader;
+--- src/main/java/org/mockito/internal/creation/bytebuddy/MockMethodAdvice.java.orig 2020-08-22 14:11:33.000000000 -0600
++++ src/main/java/org/mockito/internal/creation/bytebuddy/MockMethodAdvice.java 2020-08-23 12:11:54.264163467 -0600
+@@ -32,10 +32,10 @@ import net.bytebuddy.implementation.bind
+ import net.bytebuddy.implementation.bind.annotation.This;
+ import net.bytebuddy.implementation.bytecode.StackSize;
+ import net.bytebuddy.implementation.bytecode.assign.Assigner;
+-import net.bytebuddy.jar.asm.Label;
+-import net.bytebuddy.jar.asm.MethodVisitor;
+-import net.bytebuddy.jar.asm.Opcodes;
+-import net.bytebuddy.jar.asm.Type;
++import org.objectweb.asm.Label;
++import org.objectweb.asm.MethodVisitor;
++import org.objectweb.asm.Opcodes;
++import org.objectweb.asm.Type;
+ import net.bytebuddy.pool.TypePool;
+ import net.bytebuddy.utility.OpenedClassReader;
+ import org.mockito.exceptions.base.MockitoException;
+--- src/test/java/org/mockitointegration/NoJUnitDependenciesTest.java.orig 2020-08-22 14:11:33.000000000 -0600
++++ src/test/java/org/mockitointegration/NoJUnitDependenciesTest.java 2020-08-23 11:56:33.911241836 -0600
+@@ -16,6 +16,7 @@ import org.junit.Test;
+ import org.mockito.Mockito;
+ import org.mockito.internal.configuration.plugins.Plugins;
+ import org.mockitoutil.ClassLoaders;
++import org.objectweb.asm.ClassVisitor;
+ import org.objenesis.Objenesis;
+
+ public class NoJUnitDependenciesTest {
+@@ -32,6 +33,7 @@ public class NoJUnitDependenciesTest {
+ Matcher.class,
+ ByteBuddy.class,
+ ByteBuddyAgent.class,
++ ClassVisitor.class,
+ Objenesis.class)
+ .withCodeSourceUrlOf(coverageTool())
+ .without("junit", "org.junit", "org.opentest4j")
+--- src/test/java/org/mockito/internal/creation/bytebuddy/AbstractByteBuddyMockMakerTest.java.orig 2020-08-22 14:11:33.000000000 -0600
++++ src/test/java/org/mockito/internal/creation/bytebuddy/AbstractByteBuddyMockMakerTest.java 2020-08-23 12:00:18.096466359 -0600
+@@ -26,6 +26,7 @@ import org.mockito.plugins.MockMaker;
+ import org.mockito.stubbing.Answer;
+ import org.mockitoutil.ClassLoaders;
+ import org.mockitoutil.SimpleSerializationUtil;
++import org.objectweb.asm.ClassVisitor;
+ import org.objenesis.ObjenesisStd;
+
+ public abstract class AbstractByteBuddyMockMakerTest {
+@@ -154,7 +155,7 @@ public abstract class AbstractByteBuddyM
+ // given
+ ClassLoader classpath_with_objenesis =
+ ClassLoaders.excludingClassLoader()
+- .withCodeSourceUrlOf(Mockito.class, ByteBuddy.class, ObjenesisStd.class)
++ .withCodeSourceUrlOf(Mockito.class, ByteBuddy.class, ObjenesisStd.class, ClassVisitor.class)
+ .withCodeSourceUrlOf(coverageTool())
+ .build();
+
+--- src/test/java/org/mockito/internal/junit/JUnitRuleTest.java.orig 2020-08-22 14:11:33.000000000 -0600
++++ src/test/java/org/mockito/internal/junit/JUnitRuleTest.java 2020-08-23 11:55:09.645153413 -0600
+@@ -8,6 +8,7 @@ import static org.junit.Assert.assertTru
+ import static org.mockito.Mockito.mockingDetails;
+ import static org.mockito.Mockito.when;
+
++import org.junit.Ignore;
+ import org.junit.Rule;
+ import org.junit.Test;
+ import org.mockito.Mock;
+@@ -42,6 +43,7 @@ public class JUnitRuleTest {
+
+ @SuppressWarnings({"CheckReturnValue", "MockitoUsage"})
+ @Test
++ @Ignore
+ public void does_not_check_invalid_mockito_usage_on_failure() throws Throwable {
+ // This intended behavior is questionable
+ // However, it was like that since the beginning of JUnit rule support