diff --git a/.gitignore b/.gitignore
index 5e65016..6cb2638 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,6 @@
/mockito-3.5.13.tar.gz
/mockito-3.7.13.tar.gz
/mockito-3.12.4.tar.gz
+/mockito-5.5.0.tar.gz
+/mockito-core-5.5.0.pom
+/mockito-junit-jupiter-5.5.0.pom
diff --git a/aggregator.pom b/aggregator.pom
new file mode 100644
index 0000000..3dd438d
--- /dev/null
+++ b/aggregator.pom
@@ -0,0 +1,16 @@
+
+
+ 4.0.0
+ org.fedoraproject.xmvn.mockito
+ aggregator
+ any
+ pom
+
+ UTF-8
+
+
+ .
+ subprojects/junit-jupiter
+
+
diff --git a/generate-tarball.sh b/generate-tarball.sh
index 6b3c542..1819d20 100755
--- a/generate-tarball.sh
+++ b/generate-tarball.sh
@@ -13,9 +13,11 @@ pushd tarball-tmp
tar -xf "../${name}-${version}.orig.tar.gz"
# CLEAN TARBALL
+pushd "mockito-${version}"
find -name '*.jar' -delete
find -name '*.class' -delete
rm -rf gradlew gradlew.bat src/javadoc
+popd
tar -czf "../${name}-${version}.tar.gz" *
popd
diff --git a/mockito-core.pom b/mockito-core.pom
deleted file mode 100644
index c29986a..0000000
--- a/mockito-core.pom
+++ /dev/null
@@ -1,678 +0,0 @@
-
-
- 4.0.0
- org.mockito
- mockito-core
- @VERSION@
- mockito-core
- jar
- https://github.com/mockito/mockito
- Mockito mock objects library core API and implementation
-
-
-
- org.ow2.asm
- asm
- 7.2
- compile
-
-
- net.bytebuddy
- byte-buddy
- 1.11.13
- compile
-
-
- net.bytebuddy
- byte-buddy-agent
- 1.11.13
- compile
-
-
- org.objenesis
- objenesis
- 3.2
- compile
-
-
- org.opentest4j
- opentest4j
- 1.2
- compile
-
-
- org.hamcrest
- hamcrest
- 2.2
- provided
-
-
- junit
- junit
- 4.13.2
- provided
-
-
- org.assertj
- assertj-core
- 3.20.2
- test
-
-
-
-
-
- org.apache.maven.plugins
- maven-compiler-plugin
- 3.8.1
-
-
- 1.8
-
-
-
- org.apache.felix
- maven-bundle-plugin
- 3.5.0
-
- ${project.build.directory}/osgi
-
- <_include>-osgi.bnd
-
-
-
-
- process-classes
-
- manifest
-
-
-
-
-
- org.apache.maven.plugins
- maven-jar-plugin
- 3.1.0
-
-
- ${project.build.directory}/osgi/MANIFEST.MF
-
-
- **/MockMethodDispatcher.class
-
-
-
-
-
-
-
- The MIT License
- https://github.com/mockito/mockito/blob/master/LICENSE
- repo
-
-
-
- https://github.com/mockito/mockito.git
-
-
- https://github.com/mockito/mockito/issues
- GitHub issues
-
-
- https://travis-ci.org/mockito/mockito
- TravisCI
-
-
-
- mockitoguy
- Szczepan Faber
-
- Core developer
-
- https://github.com/mockitoguy
-
-
- bric3
- Brice Dutheil
-
- Core developer
-
- https://github.com/bric3
-
-
- raphw
- Rafael Winterhalter
-
- Core developer
-
- https://github.com/raphw
-
-
- TimvdLippe
- Tim van der Lippe
-
- Core developer
-
- https://github.com/TimvdLippe
-
-
-
-
- continuous-delivery-drone
- https://github.com/continuous-delivery-drone
-
-
- shipkit.org automated bot
- https://github.com/shipkit-org
-
-
- Marcin Zajączkowski
- https://github.com/szpak
-
-
- Pascal Schumacher
- https://github.com/PascalSchumacher
-
-
- Igor Czechowski
- https://github.com/iczechowski
-
-
- Bartosz Bańkowski
- https://github.com/bbankowski
-
-
- Erhard Pointl
- https://github.com/epeee
-
-
- Allon Murienik
- https://github.com/mureinik
-
-
- Christian Schwarz
- https://github.com/ChristianSchwarz
-
-
- Lukasz Szewc
- https://github.com/lukasz-szewc
-
-
- Marcin Grzejszczak
- https://github.com/marcingrzejszczak
-
-
- Marc Philipp
- https://github.com/marcphilipp
-
-
- Sangwoo Lee
- https://github.com/marchpig
-
-
- Philip P. Moltmann
- https://github.com/moltmann
-
-
- Tim Perry
- https://github.com/pimterry
-
-
- David J. M. Karlsen
- https://github.com/davidkarlsen
-
-
- Dawud-xx
- https://github.com/Dawud-xx
-
-
- Lovro Pandžić
- https://github.com/lpandzic
-
-
- Werner Beroux
- https://github.com/wernight
-
-
- Tsuyoshi Murakami
- https://github.com/tmurakami
-
-
- Serge Bishyr
- https://github.com/SeriyBg
-
-
- Dmitry Timofeev
- https://github.com/dmitry-timofeev
-
-
- jerzykrlk
- https://github.com/jerzykrlk
-
-
- alberskib
- https://github.com/alberskib
-
-
- Joseph Walton
- https://github.com/josephw
-
-
- Stephan Schroevers
- https://github.com/Stephan202
-
-
- Michal Kordas
- https://github.com/mkordas
-
-
- Kamil Szymański
- https://github.com/kamilszymanski
-
-
- Hynek Mlnařík
- https://github.com/hmlnarik
-
-
- Hugh Hamill
- https://github.com/hughwphamill
-
-
- Hans Joachim Desserud
- https://github.com/hansjoachim
-
-
- Gunnar Wagenknecht
- https://github.com/guw
-
-
- Dmytro Chyzhykov
- https://github.com/ffbit
-
-
- r-smirnov
- https://github.com/r-smirnov
-
-
- ianparkinson
- https://github.com/ianparkinson
-
-
- dmac100
- https://github.com/dmac100
-
-
- Vineet Kumar
- https://github.com/vin
-
-
- Urs Metz
- https://github.com/UrsMetz
-
-
- Tarnowski Jan
- https://github.com/tarnowskijan
-
-
- Roman Elizarov
- https://github.com/elizarov
-
-
- Roland Hauser
- https://github.com/SourcePond
-
-
- Michał Borek
- https://github.com/michalborek
-
-
- Michael Pinnegar
- https://github.com/Jazzepi
-
-
- Marius Volkhart
- https://github.com/MariusVolkhart
-
-
- Lucas Cavalcanti
- https://github.com/lucascs
-
-
- Leonardo Carrasco
- https://github.com/thesnowgoose
-
-
- Krzysztof Wolny
- https://github.com/vanta
-
-
- Jeffrey Falgout
- https://github.com/JeffreyFalgout
-
-
- Ismael Juma
- https://github.com/ijuma
-
-
- Emory Merryman
- https://github.com/AFnRFCb7
-
-
- Clark Brewer
- https://github.com/brewerc
-
-
- Carlos Aguayo
- https://github.com/carlosaguayo
-
-
- Arend v. Reinersdorff
- https://github.com/arend-von-reinersdorff
-
-
- Alberto Scotto
- https://github.com/alb-i986
-
-
- yyvess
- https://github.com/yyvess
-
-
- 訾明华
- https://github.com/ziminghua
-
-
- wuwen
- https://github.com/wuwen5
-
-
- test111
- https://github.com/tradingreason
-
-
- Xin Liu
- https://github.com/L-KID
-
-
- Wojtek Wilk
- https://github.com/wwilk
-
-
- Walter Scott Johnson
- https://github.com/li-wjohnson
-
-
- Walter Johnson
- https://github.com/li-wjohnson
-
-
- Vladislav
- https://github.com/VChirp
-
-
- Vivian Pennel
- https://github.com/Vp3n
-
-
- Venkata Jaswanth
- https://github.com/aj-jaswanth
-
-
- Tom Ball
- https://github.com/tomball
-
-
- Tokuhiro Matsuno
- https://github.com/tokuhirom
-
-
- Tim Cooke
- https://github.com/trcooke
-
-
- Stuart Blair
- https://github.com/stuartblair
-
-
- Simen Bekkhus
- https://github.com/SimenB
-
-
- Scott Markwell
- https://github.com/smarkwell
-
-
- Sanne Grinovero
- https://github.com/Sanne
-
-
- Roi Atalla
- https://github.com/ra4king
-
-
- Robert Stupp
- https://github.com/snazy
-
-
- Radim Kubacki
- https://github.com/radimk
-
-
- Philipp Jardas
- https://github.com/phjardas
-
-
- Oliver Drotbohm
- https://github.com/odrotbohm
-
-
- Niklas Baudy
- https://github.com/vanniktech
-
-
- Myrle Krantz
- https://github.com/myrle-krantz
-
-
- Matt Dean
- https://github.com/mattbdean
-
-
- Markus Wüstenberg
- https://github.com/markuswustenberg
-
-
- Maciej Kuster
- https://github.com/NagRock
-
-
- MEDDAH Julien
- https://github.com/MeddahJ
-
-
- Ludovic Meurillon
- https://github.com/LudoMeurillon
-
-
- Ludovic Chane
- https://github.com/ludochane
-
-
- Krisztian Milesz
- https://github.com/mileszk
-
-
- Kengo TODA
- https://github.com/KengoTODA
-
-
- Kayvan Najafzadeh
- https://github.com/kayvannj
-
-
- José Paumard
- https://github.com/JosePaumard
-
-
- Jonathan Lloyd
- https://github.com/lloydjm77
-
-
- Johnny Lim
- https://github.com/izeye
-
-
- Jesse Englert
- https://github.com/jpenglert
-
-
- Jeremy Rickard
- https://github.com/jrrickard
-
-
- Ivan Vershinin
- https://github.com/vershinin
-
-
- Igor Kostenko
- https://github.com/isanych
-
-
- Igor Conrado Alves de Lima
- https://github.com/igorcadelima
-
-
- Gaëtan Muller
- https://github.com/MGaetan89
-
-
- Felix W. Dekker
- https://github.com/FWDekker
-
-
- Evgeny Astafyev
- https://github.com/astafev
-
-
- Eugene Ivakhno
- https://github.com/eugene-ivakhno
-
-
- Erik Bakker
- https://github.com/eamelink
-
-
- Dmitriy Zaitsev
- https://github.com/DmitriyZaitsev
-
-
- Divyansh Gupta
- https://github.com/divyansh-gupta
-
-
- Dennis Cheung
- https://github.com/hkdennis2k
-
-
- Denis Zharkov
- https://github.com/dzharkov
-
-
- David Xia
- https://github.com/davidxia
-
-
- David Gageot
- https://github.com/dgageot
-
-
- Christian Persson
- https://github.com/Saser
-
-
- Bruno Krebs
- https://github.com/brunokrebs
-
-
- Ben Yu
- https://github.com/fluentfuture
-
-
- Bastien Jansen
- https://github.com/bjansen
-
-
- Bartosz Miller
- https://github.com/BartoszMiller
-
-
- Ariel Isaac
- https://github.com/Ariel-Isaacm
-
-
- Anuraag Agrawal
- https://github.com/anuraaga
-
-
- André Gonçalves
- https://github.com/andrerigon
-
-
- Andrey
- https://github.com/andreyrmg
-
-
- Andrei Solntsev
- https://github.com/asolntsev
-
-
- Allan Wang
- https://github.com/AllanWang
-
-
- Alex Simkin
- https://github.com/SimY4
-
-
- rberghegger
- https://github.com/rberghegger
-
-
- philipa
- https://github.com/philipa
-
-
- paulduffin
- https://github.com/paulduffin
-
-
- mgrafl
- https://github.com/mgrafl
-
-
- jmetertea
- https://github.com/jmetertea
-
-
- geoffschoeman
- https://github.com/geoffschoeman
-
-
- bruceeddy
- https://github.com/bruceeddy
-
-
- ashleyfrieze
- https://github.com/ashleyfrieze
-
-
- Nirvanall
- https://github.com/Nirvanall
-
-
- LiamClark
- https://github.com/LiamClark
-
-
-
diff --git a/mockito.spec b/mockito.spec
index 784b72c..c95dd8e 100644
--- a/mockito.spec
+++ b/mockito.spec
@@ -1,8 +1,8 @@
%bcond_with bootstrap
Name: mockito
-Version: 3.12.4
-Release: 7%{?dist}
+Version: 5.5.0
+Release: 1%{?dist}
Summary: Tasty mocking framework for unit tests in Java
License: MIT
URL: https://site.mockito.org/
@@ -14,10 +14,10 @@ Source0: %{name}-%{version}.tar.gz
Source1: generate-tarball.sh
# A custom build script to allow building with maven instead of gradle
-Source2: mockito-core.pom
+Source2: aggregator.pom
# Maven central POMs for subprojects
-Source3: https://repo1.maven.org/maven2/org/mockito/mockito-inline/%{version}/mockito-inline-%{version}.pom
+Source3: https://repo1.maven.org/maven2/org/mockito/mockito-core/%{version}/mockito-core-%{version}.pom
Source4: https://repo1.maven.org/maven2/org/mockito/mockito-junit-jupiter/%{version}/mockito-junit-jupiter-%{version}.pom
# Mockito expects byte-buddy to have a shaded/bundled version of ASM, but
@@ -54,92 +54,45 @@ Summary: Javadocs for %{name}
%description javadoc
This package contains the API documentation for %{name}.
-%package inline
-Summary: Mockito preconfigured inline mock maker
-Requires: %{name} = %{version}-%{release}
-
-%description inline
-Mockito preconfigured inline mock maker (intermediate and to be
-superseded by automatic usage in a future version).
-
-%if %{without bootstrap}
%package junit-jupiter
Summary: Mockito JUnit 5 support
Requires: %{name} = %{version}-%{release}
%description junit-jupiter
Mockito JUnit 5 support.
-%endif
%prep
%autosetup -p1
+cp %{SOURCE2} aggregator.pom
+cp %{SOURCE3} pom.xml
+cp %{SOURCE4} subprojects/junit-jupiter/pom.xml
+
# Disable failing test
# TODO check status: https://github.com/mockito/mockito/issues/2162
sed -i '/add_listeners_concurrently_sanity_check/i @org.junit.Ignore' src/test/java/org/mockitousage/debugging/StubbingLookupListenerCallbackTest.java
-# Use our custom build script
-sed -e 's/@VERSION@/%{version}/' %{SOURCE2} > pom.xml
-
# Workaround easymock incompatibility with Java 17 that should be fixed
# in easymock 4.4: https://github.com/easymock/easymock/issues/274
%pom_add_plugin :maven-surefire-plugin . "
--add-opens=java.base/sun.reflect.generics.reflectiveObjects=ALL-UNNAMED"
-# OSGi metadata configuration
-cat > osgi.bnd < osgi-junit-jupiter.bnd < - 5.5.0-1
+- Update to upstream version 5.5.0
+
* Thu Jul 20 2023 Fedora Release Engineering - 3.12.4-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
diff --git a/sources b/sources
index 238415e..8ac9fca 100644
--- a/sources
+++ b/sources
@@ -1 +1,3 @@
-SHA512 (mockito-3.12.4.tar.gz) = 3c0bc50a533bfd6626b993567fb585666a839ed408d51bfdd0b6d0b62a1fe6ba1678c7d2f2af4df7f3176bd2ff4ca94a166cd0c1b43ea993beefa3e30f1bc792
+SHA512 (mockito-5.5.0.tar.gz) = 4e36c396eb69fa95bb7828b2c2253c8010536f755b4b75e761b30c7f5f437e40c96503e6bb255e221c8fff3aaa795399598d6c413189e3374dec0a9268a88cc8
+SHA512 (mockito-core-5.5.0.pom) = 8f11bf7e61f1ac5d53949c30636abb50d9dd53ef71da585055857fedd592445912e83087674c59388f7e44d38f242708f6e19a988f25c4249b6a62268ac8c967
+SHA512 (mockito-junit-jupiter-5.5.0.pom) = 29a098fdeef8d154f52e547d6cffc5b17879811583a079d9cc359bfc4b651300da5feaa9974d81e613f42650fdfb345b66481ea1afdf9c12eca6c60c22ce5507