Require hamcrest explicitly in OSGi metadata
This commit is contained in:
parent
6916e3be89
commit
0cd63e165d
6
.gitignore
vendored
6
.gitignore
vendored
@ -1,2 +1,4 @@
|
||||
/mockito-1.9.0.tar.xz
|
||||
/mockito-1.10.19.tar.xz
|
||||
/mockito-*.tar.xz
|
||||
/.build-*.log
|
||||
/noarch/
|
||||
/*.src.rpm
|
||||
|
@ -1,12 +1,10 @@
|
||||
diff --git a/conf/mockito-core.bnd b/conf/mockito-core.bnd
|
||||
index bd0ba61..47d07a8 100644
|
||||
--- a/conf/mockito-core.bnd
|
||||
+++ b/conf/mockito-core.bnd
|
||||
@@ -1,13 +1,11 @@
|
||||
--- conf/mockito-core.bnd.orig 2014-12-31 16:43:56.000000000 +0000
|
||||
+++ conf/mockito-core.bnd 2015-09-01 19:36:18.534549995 +0100
|
||||
@@ -1,21 +1,19 @@
|
||||
--versionpolicy=[${version;==;${@}},${version;+;${@}})
|
||||
-
|
||||
-Bundle-Name= Mockito Mock Library for Java. Core bundle requires Hamcrest-core and Objenesis.
|
||||
+Bundle-Name= Mockito Mock Library for Java. Core bundle requires Hamcrest-core and Objenesis.
|
||||
+Bundle-Name= Mockito Mock Library for Java.
|
||||
Bundle-SymbolicName= org.mockito.mockito-core
|
||||
Bundle-Version= ${version}
|
||||
|
||||
@ -18,9 +16,10 @@ index bd0ba61..47d07a8 100644
|
||||
|
||||
Import-Package= junit.*;resolution:=optional, \
|
||||
org.junit.*;resolution:=optional, \
|
||||
@@ -15,7 +13,8 @@ Import-Package= junit.*;resolution:=optional, \
|
||||
org.hamcrest;version="[1.0,3.0)", \
|
||||
org.objenesis;version="[2.1,3.0)", \
|
||||
org.apache.tools.ant.*;resolution:=optional, \
|
||||
- org.hamcrest;version="[1.0,3.0)", \
|
||||
- org.objenesis;version="[2.1,3.0)", \
|
||||
+ org.objenesis;version="[1.0,3.0)", \
|
||||
org.mockito.asm.signature;resolution:=optional, \
|
||||
- org.mockito.*
|
||||
+ org.mockito.*, \
|
||||
|
19
mockito.spec
19
mockito.spec
@ -1,6 +1,6 @@
|
||||
Name: mockito
|
||||
Version: 1.10.19
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
Summary: A Java mocking framework
|
||||
|
||||
License: MIT
|
||||
@ -45,7 +45,7 @@ This package contains the API documentation for %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0
|
||||
%patch1 -p1
|
||||
%patch1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
@ -59,6 +59,7 @@ mkdir -p lib/compile
|
||||
%build
|
||||
build-jar-repository lib/compile objenesis cglib junit hamcrest/core
|
||||
ant jar javadoc
|
||||
|
||||
# Convert to OSGi bundle
|
||||
pushd target
|
||||
%if 0%{?fedora} >= 23
|
||||
@ -73,6 +74,11 @@ java -jar $(build-classpath aqute-bnd) wrap \
|
||||
%endif
|
||||
%{name}-core-%{version}.jar
|
||||
mv %{name}-core-%{version}.bar %{name}-core-%{version}.jar
|
||||
|
||||
# Explicit Require-Bundle on hamcrest
|
||||
unzip mockito-core-%{version}.jar META-INF/MANIFEST.MF
|
||||
sed -i -e '2iRequire-Bundle: org.hamcrest.core' META-INF/MANIFEST.MF
|
||||
jar umf META-INF/MANIFEST.MF mockito-core-%{version}.jar
|
||||
popd
|
||||
|
||||
sed -i -e "s|@version@|%{version}|g" maven/%{name}-core.pom
|
||||
@ -83,14 +89,15 @@ sed -i -e "s|@version@|%{version}|g" maven/%{name}-core.pom
|
||||
%mvn_install -J target/javadoc
|
||||
|
||||
%files -f .mfiles
|
||||
%license LICENSE
|
||||
%doc NOTICE
|
||||
%license LICENSE NOTICE
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%license LICENSE
|
||||
%doc NOTICE
|
||||
%license LICENSE NOTICE
|
||||
|
||||
%changelog
|
||||
* Fri Feb 12 2016 Mat Booth <mat.booth@redhat.com> - 1.10.19-9
|
||||
- Require hamcrest explicitly in OSGi metadata
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.19-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user