import mockito-3.1.2-2.module+el8.2.0+4938+c0cffa5b

This commit is contained in:
CentOS Sources 2020-05-08 02:30:17 +00:00 committed by Andrew Lukoshko
commit 0698ac7ddb
6 changed files with 1016 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/mockito-3.1.2.tar.xz

1
.mockito.metadata Normal file
View File

@ -0,0 +1 @@
15683d23b64ec2b289dccd9898efcbbde7741765 SOURCES/mockito-3.1.2.tar.xz

View File

@ -0,0 +1,20 @@
#!/bin/bash -ex
VERSION="$(sed -n 's/Version:\s*//p' *.spec)"
SRCDIR=mockito-${VERSION}
git clone https://github.com/mockito/mockito.git ${SRCDIR}
pushd $SRCDIR
git archive --format=tar --prefix=${SRCDIR}/ v${VERSION} > ../${SRCDIR}.tar
popd
rm -rf ${SRCDIR}
tar -xf ${SRCDIR}.tar
rm ${SRCDIR}.tar
pushd ${SRCDIR}
find -name '*.jar' -delete
rm -rf gradlew gradlew.bat src/javadoc
popd
tar -cvJf mockito-${VERSION}.tar.xz ${SRCDIR}

698
SOURCES/mockito-core.pom Normal file
View File

@ -0,0 +1,698 @@
<?xml version='1.0' encoding='UTF-8'?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>org.mockito</groupId>
<artifactId>mockito-core</artifactId>
<version>@VERSION@</version>
<name>mockito-core</name>
<packaging>jar</packaging>
<url>https://github.com/mockito/mockito</url>
<description>Mockito mock objects library core API and implementation</description>
<!-- NOTE! This file is loosely based on the mockito-core pom from maven central
but with many additions to allow building and running tests -->
<dependencies>
<dependency>
<groupId>org.ow2.asm</groupId>
<artifactId>asm</artifactId>
<version>7.2</version>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>net.bytebuddy</groupId>
<artifactId>byte-buddy</artifactId>
<version>1.9.3</version>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>net.bytebuddy</groupId>
<artifactId>byte-buddy-agent</artifactId>
<version>1.9.3</version>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>org.objenesis</groupId>
<artifactId>objenesis</artifactId>
<version>3.1</version>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>org.opentest4j</groupId>
<artifactId>opentest4j</artifactId>
<version>1.2</version>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest</artifactId>
<version>2.2</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>4.12</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.assertj</groupId>
<artifactId>assertj-core</artifactId>
<version>3.13.2</version>
<scope>test</scope>
</dependency>
</dependencies>
<build>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<version>3.8.1</version>
<configuration>
<source>1.8</source>
<target>1.8</target>
</configuration>
</plugin>
<plugin>
<groupId>org.apache.felix</groupId>
<artifactId>maven-bundle-plugin</artifactId>
<version>3.5.0</version>
<configuration>
<manifestLocation>${project.build.directory}/osgi</manifestLocation>
<instructions>
<_include>-osgi.bnd</_include>
</instructions>
</configuration>
<executions>
<execution>
<phase>process-classes</phase>
<goals>
<goal>manifest</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>exec-maven-plugin</artifactId>
<version>1.6.0</version>
<executions>
<execution>
<phase>process-classes</phase>
<goals>
<goal>exec</goal>
</goals>
</execution>
</executions>
<configuration>
<executable>cp</executable>
<arguments>
<argument>${project.build.sourceDirectory}/org/mockito/internal/creation/bytebuddy/inject/MockMethodDispatcher.class</argument>
<argument>${project.build.outputDirectory}/org/mockito/internal/creation/bytebuddy/inject/MockMethodDispatcher.raw</argument>
</arguments>
</configuration>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-jar-plugin</artifactId>
<version>3.1.0</version>
<configuration>
<archive>
<manifestFile>${project.build.directory}/osgi/MANIFEST.MF</manifestFile>
</archive>
<excludes>
<exclude>**/MockMethodDispatcher.class</exclude>
</excludes>
</configuration>
</plugin>
</plugins>
</build>
<licenses>
<license>
<name>The MIT License</name>
<url>https://github.com/mockito/mockito/blob/master/LICENSE</url>
<distribution>repo</distribution>
</license>
</licenses>
<scm>
<url>https://github.com/mockito/mockito.git</url>
</scm>
<issueManagement>
<url>https://github.com/mockito/mockito/issues</url>
<system>GitHub issues</system>
</issueManagement>
<ciManagement>
<url>https://travis-ci.org/mockito/mockito</url>
<system>TravisCI</system>
</ciManagement>
<developers>
<developer>
<id>mockitoguy</id>
<name>Szczepan Faber</name>
<roles>
<role>Core developer</role>
</roles>
<url>https://github.com/mockitoguy</url>
</developer>
<developer>
<id>bric3</id>
<name>Brice Dutheil</name>
<roles>
<role>Core developer</role>
</roles>
<url>https://github.com/bric3</url>
</developer>
<developer>
<id>raphw</id>
<name>Rafael Winterhalter</name>
<roles>
<role>Core developer</role>
</roles>
<url>https://github.com/raphw</url>
</developer>
<developer>
<id>TimvdLippe</id>
<name>Tim van der Lippe</name>
<roles>
<role>Core developer</role>
</roles>
<url>https://github.com/TimvdLippe</url>
</developer>
</developers>
<contributors>
<contributor>
<name>continuous-delivery-drone</name>
<url>https://github.com/continuous-delivery-drone</url>
</contributor>
<contributor>
<name>shipkit.org automated bot</name>
<url>https://github.com/shipkit-org</url>
</contributor>
<contributor>
<name>Marcin Zajączkowski</name>
<url>https://github.com/szpak</url>
</contributor>
<contributor>
<name>Pascal Schumacher</name>
<url>https://github.com/PascalSchumacher</url>
</contributor>
<contributor>
<name>Igor Czechowski</name>
<url>https://github.com/iczechowski</url>
</contributor>
<contributor>
<name>Bartosz Bańkowski</name>
<url>https://github.com/bbankowski</url>
</contributor>
<contributor>
<name>Erhard Pointl</name>
<url>https://github.com/epeee</url>
</contributor>
<contributor>
<name>Allon Murienik</name>
<url>https://github.com/mureinik</url>
</contributor>
<contributor>
<name>Christian Schwarz</name>
<url>https://github.com/ChristianSchwarz</url>
</contributor>
<contributor>
<name>Lukasz Szewc</name>
<url>https://github.com/lukasz-szewc</url>
</contributor>
<contributor>
<name>Marcin Grzejszczak</name>
<url>https://github.com/marcingrzejszczak</url>
</contributor>
<contributor>
<name>Marc Philipp</name>
<url>https://github.com/marcphilipp</url>
</contributor>
<contributor>
<name>Sangwoo Lee</name>
<url>https://github.com/marchpig</url>
</contributor>
<contributor>
<name>Philip P. Moltmann</name>
<url>https://github.com/moltmann</url>
</contributor>
<contributor>
<name>Tim Perry</name>
<url>https://github.com/pimterry</url>
</contributor>
<contributor>
<name>David J. M. Karlsen</name>
<url>https://github.com/davidkarlsen</url>
</contributor>
<contributor>
<name>Dawud-xx</name>
<url>https://github.com/Dawud-xx</url>
</contributor>
<contributor>
<name>Lovro Pandžić</name>
<url>https://github.com/lpandzic</url>
</contributor>
<contributor>
<name>Werner Beroux</name>
<url>https://github.com/wernight</url>
</contributor>
<contributor>
<name>Tsuyoshi Murakami</name>
<url>https://github.com/tmurakami</url>
</contributor>
<contributor>
<name>Serge Bishyr</name>
<url>https://github.com/SeriyBg</url>
</contributor>
<contributor>
<name>Dmitry Timofeev</name>
<url>https://github.com/dmitry-timofeev</url>
</contributor>
<contributor>
<name>jerzykrlk</name>
<url>https://github.com/jerzykrlk</url>
</contributor>
<contributor>
<name>alberskib</name>
<url>https://github.com/alberskib</url>
</contributor>
<contributor>
<name>Joseph Walton</name>
<url>https://github.com/josephw</url>
</contributor>
<contributor>
<name>Stephan Schroevers</name>
<url>https://github.com/Stephan202</url>
</contributor>
<contributor>
<name>Michal Kordas</name>
<url>https://github.com/mkordas</url>
</contributor>
<contributor>
<name>Kamil Szymański</name>
<url>https://github.com/kamilszymanski</url>
</contributor>
<contributor>
<name>Hynek Mlnařík</name>
<url>https://github.com/hmlnarik</url>
</contributor>
<contributor>
<name>Hugh Hamill</name>
<url>https://github.com/hughwphamill</url>
</contributor>
<contributor>
<name>Hans Joachim Desserud</name>
<url>https://github.com/hansjoachim</url>
</contributor>
<contributor>
<name>Gunnar Wagenknecht</name>
<url>https://github.com/guw</url>
</contributor>
<contributor>
<name>Dmytro Chyzhykov</name>
<url>https://github.com/ffbit</url>
</contributor>
<contributor>
<name>r-smirnov</name>
<url>https://github.com/r-smirnov</url>
</contributor>
<contributor>
<name>ianparkinson</name>
<url>https://github.com/ianparkinson</url>
</contributor>
<contributor>
<name>dmac100</name>
<url>https://github.com/dmac100</url>
</contributor>
<contributor>
<name>Vineet Kumar</name>
<url>https://github.com/vin</url>
</contributor>
<contributor>
<name>Urs Metz</name>
<url>https://github.com/UrsMetz</url>
</contributor>
<contributor>
<name>Tarnowski Jan</name>
<url>https://github.com/tarnowskijan</url>
</contributor>
<contributor>
<name>Roman Elizarov</name>
<url>https://github.com/elizarov</url>
</contributor>
<contributor>
<name>Roland Hauser</name>
<url>https://github.com/SourcePond</url>
</contributor>
<contributor>
<name>Michał Borek</name>
<url>https://github.com/michalborek</url>
</contributor>
<contributor>
<name>Michael Pinnegar</name>
<url>https://github.com/Jazzepi</url>
</contributor>
<contributor>
<name>Marius Volkhart</name>
<url>https://github.com/MariusVolkhart</url>
</contributor>
<contributor>
<name>Lucas Cavalcanti</name>
<url>https://github.com/lucascs</url>
</contributor>
<contributor>
<name>Leonardo Carrasco</name>
<url>https://github.com/thesnowgoose</url>
</contributor>
<contributor>
<name>Krzysztof Wolny</name>
<url>https://github.com/vanta</url>
</contributor>
<contributor>
<name>Jeffrey Falgout</name>
<url>https://github.com/JeffreyFalgout</url>
</contributor>
<contributor>
<name>Ismael Juma</name>
<url>https://github.com/ijuma</url>
</contributor>
<contributor>
<name>Emory Merryman</name>
<url>https://github.com/AFnRFCb7</url>
</contributor>
<contributor>
<name>Clark Brewer</name>
<url>https://github.com/brewerc</url>
</contributor>
<contributor>
<name>Carlos Aguayo</name>
<url>https://github.com/carlosaguayo</url>
</contributor>
<contributor>
<name>Arend v. Reinersdorff</name>
<url>https://github.com/arend-von-reinersdorff</url>
</contributor>
<contributor>
<name>Alberto Scotto</name>
<url>https://github.com/alb-i986</url>
</contributor>
<contributor>
<name>yyvess</name>
<url>https://github.com/yyvess</url>
</contributor>
<contributor>
<name>訾明华</name>
<url>https://github.com/ziminghua</url>
</contributor>
<contributor>
<name>wuwen</name>
<url>https://github.com/wuwen5</url>
</contributor>
<contributor>
<name>test111</name>
<url>https://github.com/tradingreason</url>
</contributor>
<contributor>
<name>Xin Liu</name>
<url>https://github.com/L-KID</url>
</contributor>
<contributor>
<name>Wojtek Wilk</name>
<url>https://github.com/wwilk</url>
</contributor>
<contributor>
<name>Walter Scott Johnson</name>
<url>https://github.com/li-wjohnson</url>
</contributor>
<contributor>
<name>Walter Johnson</name>
<url>https://github.com/li-wjohnson</url>
</contributor>
<contributor>
<name>Vladislav</name>
<url>https://github.com/VChirp</url>
</contributor>
<contributor>
<name>Vivian Pennel</name>
<url>https://github.com/Vp3n</url>
</contributor>
<contributor>
<name>Venkata Jaswanth</name>
<url>https://github.com/aj-jaswanth</url>
</contributor>
<contributor>
<name>Tom Ball</name>
<url>https://github.com/tomball</url>
</contributor>
<contributor>
<name>Tokuhiro Matsuno</name>
<url>https://github.com/tokuhirom</url>
</contributor>
<contributor>
<name>Tim Cooke</name>
<url>https://github.com/trcooke</url>
</contributor>
<contributor>
<name>Stuart Blair</name>
<url>https://github.com/stuartblair</url>
</contributor>
<contributor>
<name>Simen Bekkhus</name>
<url>https://github.com/SimenB</url>
</contributor>
<contributor>
<name>Scott Markwell</name>
<url>https://github.com/smarkwell</url>
</contributor>
<contributor>
<name>Sanne Grinovero</name>
<url>https://github.com/Sanne</url>
</contributor>
<contributor>
<name>Roi Atalla</name>
<url>https://github.com/ra4king</url>
</contributor>
<contributor>
<name>Robert Stupp</name>
<url>https://github.com/snazy</url>
</contributor>
<contributor>
<name>Radim Kubacki</name>
<url>https://github.com/radimk</url>
</contributor>
<contributor>
<name>Philipp Jardas</name>
<url>https://github.com/phjardas</url>
</contributor>
<contributor>
<name>Oliver Drotbohm</name>
<url>https://github.com/odrotbohm</url>
</contributor>
<contributor>
<name>Niklas Baudy</name>
<url>https://github.com/vanniktech</url>
</contributor>
<contributor>
<name>Myrle Krantz</name>
<url>https://github.com/myrle-krantz</url>
</contributor>
<contributor>
<name>Matt Dean</name>
<url>https://github.com/mattbdean</url>
</contributor>
<contributor>
<name>Markus Wüstenberg</name>
<url>https://github.com/markuswustenberg</url>
</contributor>
<contributor>
<name>Maciej Kuster</name>
<url>https://github.com/NagRock</url>
</contributor>
<contributor>
<name>MEDDAH Julien</name>
<url>https://github.com/MeddahJ</url>
</contributor>
<contributor>
<name>Ludovic Meurillon</name>
<url>https://github.com/LudoMeurillon</url>
</contributor>
<contributor>
<name>Ludovic Chane</name>
<url>https://github.com/ludochane</url>
</contributor>
<contributor>
<name>Krisztian Milesz</name>
<url>https://github.com/mileszk</url>
</contributor>
<contributor>
<name>Kengo TODA</name>
<url>https://github.com/KengoTODA</url>
</contributor>
<contributor>
<name>Kayvan Najafzadeh</name>
<url>https://github.com/kayvannj</url>
</contributor>
<contributor>
<name>José Paumard</name>
<url>https://github.com/JosePaumard</url>
</contributor>
<contributor>
<name>Jonathan Lloyd</name>
<url>https://github.com/lloydjm77</url>
</contributor>
<contributor>
<name>Johnny Lim</name>
<url>https://github.com/izeye</url>
</contributor>
<contributor>
<name>Jesse Englert</name>
<url>https://github.com/jpenglert</url>
</contributor>
<contributor>
<name>Jeremy Rickard</name>
<url>https://github.com/jrrickard</url>
</contributor>
<contributor>
<name>Ivan Vershinin</name>
<url>https://github.com/vershinin</url>
</contributor>
<contributor>
<name>Igor Kostenko</name>
<url>https://github.com/isanych</url>
</contributor>
<contributor>
<name>Igor Conrado Alves de Lima</name>
<url>https://github.com/igorcadelima</url>
</contributor>
<contributor>
<name>Gaëtan Muller</name>
<url>https://github.com/MGaetan89</url>
</contributor>
<contributor>
<name>Felix W. Dekker</name>
<url>https://github.com/FWDekker</url>
</contributor>
<contributor>
<name>Evgeny Astafyev</name>
<url>https://github.com/astafev</url>
</contributor>
<contributor>
<name>Eugene Ivakhno</name>
<url>https://github.com/eugene-ivakhno</url>
</contributor>
<contributor>
<name>Erik Bakker</name>
<url>https://github.com/eamelink</url>
</contributor>
<contributor>
<name>Dmitriy Zaitsev</name>
<url>https://github.com/DmitriyZaitsev</url>
</contributor>
<contributor>
<name>Divyansh Gupta</name>
<url>https://github.com/divyansh-gupta</url>
</contributor>
<contributor>
<name>Dennis Cheung</name>
<url>https://github.com/hkdennis2k</url>
</contributor>
<contributor>
<name>Denis Zharkov</name>
<url>https://github.com/dzharkov</url>
</contributor>
<contributor>
<name>David Xia</name>
<url>https://github.com/davidxia</url>
</contributor>
<contributor>
<name>David Gageot</name>
<url>https://github.com/dgageot</url>
</contributor>
<contributor>
<name>Christian Persson</name>
<url>https://github.com/Saser</url>
</contributor>
<contributor>
<name>Bruno Krebs</name>
<url>https://github.com/brunokrebs</url>
</contributor>
<contributor>
<name>Ben Yu</name>
<url>https://github.com/fluentfuture</url>
</contributor>
<contributor>
<name>Bastien Jansen</name>
<url>https://github.com/bjansen</url>
</contributor>
<contributor>
<name>Bartosz Miller</name>
<url>https://github.com/BartoszMiller</url>
</contributor>
<contributor>
<name>Ariel Isaac</name>
<url>https://github.com/Ariel-Isaacm</url>
</contributor>
<contributor>
<name>Anuraag Agrawal</name>
<url>https://github.com/anuraaga</url>
</contributor>
<contributor>
<name>André Gonçalves</name>
<url>https://github.com/andrerigon</url>
</contributor>
<contributor>
<name>Andrey</name>
<url>https://github.com/andreyrmg</url>
</contributor>
<contributor>
<name>Andrei Solntsev</name>
<url>https://github.com/asolntsev</url>
</contributor>
<contributor>
<name>Allan Wang</name>
<url>https://github.com/AllanWang</url>
</contributor>
<contributor>
<name>Alex Simkin</name>
<url>https://github.com/SimY4</url>
</contributor>
<contributor>
<name>rberghegger</name>
<url>https://github.com/rberghegger</url>
</contributor>
<contributor>
<name>philipa</name>
<url>https://github.com/philipa</url>
</contributor>
<contributor>
<name>paulduffin</name>
<url>https://github.com/paulduffin</url>
</contributor>
<contributor>
<name>mgrafl</name>
<url>https://github.com/mgrafl</url>
</contributor>
<contributor>
<name>jmetertea</name>
<url>https://github.com/jmetertea</url>
</contributor>
<contributor>
<name>geoffschoeman</name>
<url>https://github.com/geoffschoeman</url>
</contributor>
<contributor>
<name>bruceeddy</name>
<url>https://github.com/bruceeddy</url>
</contributor>
<contributor>
<name>ashleyfrieze</name>
<url>https://github.com/ashleyfrieze</url>
</contributor>
<contributor>
<name>Nirvanall</name>
<url>https://github.com/Nirvanall</url>
</contributor>
<contributor>
<name>LiamClark</name>
<url>https://github.com/LiamClark</url>
</contributor>
</contributors>
</project>

View File

@ -0,0 +1,76 @@
diff --git a/src/main/java/org/mockito/internal/creation/bytebuddy/InlineBytecodeGenerator.java b/src/main/java/org/mockito/internal/creation/bytebuddy/InlineBytecodeGenerator.java
index 34b1e89..326a64f 100644
--- a/src/main/java/org/mockito/internal/creation/bytebuddy/InlineBytecodeGenerator.java
+++ b/src/main/java/org/mockito/internal/creation/bytebuddy/InlineBytecodeGenerator.java
@@ -18,8 +18,8 @@ import net.bytebuddy.dynamic.ClassFileLocator;
import net.bytebuddy.dynamic.scaffold.MethodGraph;
import net.bytebuddy.dynamic.scaffold.TypeValidation;
import net.bytebuddy.implementation.Implementation;
-import net.bytebuddy.jar.asm.ClassVisitor;
-import net.bytebuddy.jar.asm.MethodVisitor;
+import org.objectweb.asm.ClassVisitor;
+import org.objectweb.asm.MethodVisitor;
import net.bytebuddy.matcher.ElementMatchers;
import net.bytebuddy.pool.TypePool;
import net.bytebuddy.utility.OpenedClassReader;
diff --git a/src/test/java/org/mockito/internal/creation/bytebuddy/AbstractByteBuddyMockMakerTest.java b/src/test/java/org/mockito/internal/creation/bytebuddy/AbstractByteBuddyMockMakerTest.java
index 2b08c10..a19ffa1 100644
--- a/src/test/java/org/mockito/internal/creation/bytebuddy/AbstractByteBuddyMockMakerTest.java
+++ b/src/test/java/org/mockito/internal/creation/bytebuddy/AbstractByteBuddyMockMakerTest.java
@@ -19,6 +19,7 @@ import org.mockito.plugins.MockMaker;
import org.mockito.stubbing.Answer;
import org.mockitoutil.ClassLoaders;
import org.mockitoutil.SimpleSerializationUtil;
+import org.objectweb.asm.ClassVisitor;
import org.objenesis.ObjenesisStd;
import java.io.Serializable;
@@ -138,7 +139,7 @@ public abstract class AbstractByteBuddyMockMakerTest<MM extends MockMaker> {
public void instantiate_fine_when_objenesis_on_the_classpath() throws Exception {
// given
ClassLoader classpath_with_objenesis = ClassLoaders.excludingClassLoader()
- .withCodeSourceUrlOf(Mockito.class, ByteBuddy.class, ObjenesisStd.class)
+ .withCodeSourceUrlOf(Mockito.class, ByteBuddy.class, ObjenesisStd.class, ClassVisitor.class)
.withCodeSourceUrlOf(coverageTool())
.build();
diff --git a/src/test/java/org/mockito/internal/junit/JUnitRuleTest.java b/src/test/java/org/mockito/internal/junit/JUnitRuleTest.java
index 7d5968d..f5c1644 100644
--- a/src/test/java/org/mockito/internal/junit/JUnitRuleTest.java
+++ b/src/test/java/org/mockito/internal/junit/JUnitRuleTest.java
@@ -4,6 +4,7 @@
*/
package org.mockito.internal.junit;
+import org.junit.Ignore;
import org.junit.Rule;
import org.junit.Test;
import org.mockito.Mock;
@@ -41,6 +42,7 @@ public class JUnitRuleTest {
@SuppressWarnings({"CheckReturnValue", "MockitoUsage"})
@Test
+ @Ignore
public void does_not_check_invalid_mockito_usage_on_failure() throws Throwable {
//This intended behavior is questionable
//However, it was like that since the beginning of JUnit rule support
diff --git a/src/test/java/org/mockitointegration/NoJUnitDependenciesTest.java b/src/test/java/org/mockitointegration/NoJUnitDependenciesTest.java
index 85e0113..64f2083 100644
--- a/src/test/java/org/mockitointegration/NoJUnitDependenciesTest.java
+++ b/src/test/java/org/mockitointegration/NoJUnitDependenciesTest.java
@@ -12,6 +12,7 @@ import org.junit.Test;
import org.mockito.Mockito;
import org.mockito.internal.configuration.plugins.Plugins;
import org.mockitoutil.ClassLoaders;
+import org.objectweb.asm.ClassVisitor;
import org.objenesis.Objenesis;
import java.util.Set;
@@ -30,6 +31,7 @@ public class NoJUnitDependenciesTest {
Matcher.class,
ByteBuddy.class,
ByteBuddyAgent.class,
+ ClassVisitor.class,
Objenesis.class
)
.withCodeSourceUrlOf(coverageTool())

220
SPECS/mockito.spec Normal file
View File

@ -0,0 +1,220 @@
Name: mockito
Version: 3.1.2
Release: 2%{?dist}
Summary: Tasty mocking framework for unit tests in Java
License: MIT
URL: https://site.mockito.org/
BuildArch: noarch
# Source tarball and the script to generate it
Source0: %{name}-%{version}.tar.xz
Source1: make-mockito-sourcetarball.sh
# A custom build script to allow building with maven instead of gradle
Source2: mockito-core.pom
# Mockito expects byte-buddy to have a shaded/bundled version of ASM, but
# we don't bundle in Fedora, so this patch makes mockito use ASM explicitly
Patch0: use-unbundled-asm.patch
BuildRequires: maven-local
BuildRequires: mvn(junit:junit)
BuildRequires: mvn(net.bytebuddy:byte-buddy)
BuildRequires: mvn(net.bytebuddy:byte-buddy-agent)
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
BuildRequires: mvn(org.assertj:assertj-core)
BuildRequires: mvn(org.codehaus.mojo:exec-maven-plugin)
BuildRequires: mvn(org.hamcrest:hamcrest)
BuildRequires: mvn(org.objenesis:objenesis)
BuildRequires: mvn(org.opentest4j:opentest4j)
BuildRequires: mvn(org.ow2.asm:asm)
%description
Mockito is a mocking framework that tastes really good. It lets you write
beautiful tests with clean & simple API. Mockito doesn't give you hangover
because the tests are very readable and they produce clean verification
errors.
%package javadoc
Summary: Javadocs for %{name}
%description javadoc
This package contains the API documentation for %{name}.
%prep
%setup -q
%patch0 -p1
# Use our custom build script
sed -e 's/@VERSION@/%{version}/' %{SOURCE2} > pom.xml
# OGGi metadata configuration
cat > osgi.bnd <<EOF
Automatic-Module-Name: org.mockito
Bundle-SymbolicName: org.mockito
Bundle-Name: Mockito Mock Library for Java.
Import-Package: junit.*;resolution:=optional,org.junit.*;resolution:=optional,org.hamcrest;resolution:=optional,org.mockito*;version="%{version}",*
Private-Package: org.mockito.*
-removeheaders: Bnd-LastModified,Include-Resource,Private-Package
EOF
# Compatibility alias
%mvn_alias org.%{name}:%{name}-core org.%{name}:%{name}-all
%build
# See the usage of exec-maven-plugin in the pom
javac src/main/java/org/mockito/internal/creation/bytebuddy/inject/MockMethodDispatcher.java
%mvn_build -- -Dproject.build.sourceEncoding=UTF-8
%install
%mvn_install
%files -f .mfiles
%license LICENSE
%doc README.md doc/design-docs/custom-argument-matching.md
%files javadoc -f .mfiles-javadoc
%license LICENSE
%changelog
* Tue Nov 05 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.2-2
- Mass rebuild for javapackages-tools 201902
* Wed Oct 16 2019 Marian Koncek <mkoncek@redhat.com> - 3.1.2-1
- Update to upstream version 3.1.2
* Thu Sep 19 2019 Marian Koncek <mkoncek@redhat.com> - 3.0.8-1
- Update to upstream version 3.0.8
* Fri May 24 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.23.9-4
- Mass rebuild for javapackages-tools 201901
* Wed Dec 12 2018 Mat Booth <mat.booth@redhat.com> - 2.23.9-3
- Set the source encoding for the build
* Wed Dec 05 2018 Mat Booth <mat.booth@redhat.com> - 2.23.9-2
- Re-add compatibility alias for 'mockito-all'
* Tue Dec 04 2018 Mat Booth <mat.booth@redhat.com> - 2.23.9-1
- Update to latest upstream version
- Switch to maven build system using a custom pom to avoid a dep on gradle
* Fri Aug 03 2018 Michael Simacek <msimacek@redhat.com> - 1.10.19-17
- Remove bundled minified js from javadoc
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.19-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.10.19-15
- Escape macros in %%changelog
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.19-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.19-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Thu Feb 16 2017 Michael Simacek <msimacek@redhat.com> - 1.10.19-12
- Remove conditional for EOL Fedora
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.19-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Mon Feb 22 2016 Mat Booth <mat.booth@redhat.com> - 1.10.19-10
- Explicitly import more cglib packages in OSGi metadata to prevent mockito
failing under certain circumstances during Eclipse test suites
* Fri Feb 12 2016 Mat Booth <mat.booth@redhat.com> - 1.10.19-9
- Require hamcrest explicitly in OSGi metadata
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.19-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Fri Dec 25 2015 Raphael Groner <projects.rg@smart.ms> - 1.10.19-7
- introduce License tag
* Fri Dec 25 2015 Raphael Groner <projects.rg@smart.ms> - 1.10.19-6
- reenable osgi
* Fri Dec 18 2015 Raphael Groner <projects.rg@smart.ms> - 1.10.19-5
- workaround rhbz#1292777 stylesheet.css not found
* Thu Jul 16 2015 Michael Simacek <msimacek@redhat.com> - 1.10.19-4
- Use aqute-bnd-2.4.1
* Mon Jun 22 2015 Mat Booth <mat.booth@redhat.com> - 1.10.19-3
- Switch to mvn_install
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10.19-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Wed Apr 29 2015 Michal Srb <msrb@redhat.com> - 1.10.19-1
- Update to 1.10.19
* Mon Aug 25 2014 Darryl L. Pierce <dpierce@redhat.com> - 1.9.0-18
- First build for EPEL7
- Resolves: BZ#1110030
* Mon Jun 09 2014 Omair Majid <omajid@redhat.com> - 1.9.0-17
- Use .mfiles to pick up xmvn metadata
- Don't use obsolete _mavenpomdir and _mavendepmapfragdir macros
- Fix FTBFS
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.0-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Thu May 22 2014 Severin Gehwolf <sgehwolf@redhat.com> - 1.9.0-16
- Use junit R/BR over junit4.
* Fri Mar 28 2014 Michael Simacek <msimacek@redhat.com> - 1.9.0-15
- Use Requires: java-headless rebuild (#1067528)
* Wed Dec 11 2013 Michael Simacek <msimacek@redhat.com> - 1.9.0-14
- Workaround for NPE in setting NamingPolicy
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.0-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Mon Mar 25 2013 Tomas Radej <tradej@redhat.com> - 1.9.0-12
- Patched LocalizedMatcher due to hamcrest update, (bug upstream)
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.0-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Thu Sep 6 2012 Severin Gehwolf <sgehwolf@redhat.com> 1.9.0-10
- More Import-Package fixes. Note that fix-cglib-refs.patch is
not suitable for upstream: issue id=373
* Tue Sep 4 2012 Severin Gehwolf <sgehwolf@redhat.com> 1.9.0-9
- Fix missing Import-Package in manifest.
* Mon Aug 27 2012 Severin Gehwolf <sgehwolf@redhat.com> 1.9.0-8
- Add aqute bnd instructions for OSGi metadata
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.0-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Mon Apr 30 2012 Roman Kennke <rkennke@redhat.com> 1.9.0-6
- Place JavaDoc in directly under %%{_javadocdir}/%%{name} instead
of %%{_javadocdir}/%%{name}/javadoc
* Wed Apr 25 2012 Roman Kennke <rkennke@redhat.com> 1.9.0-5
- Removed post/postun hook for update_maven_depmap
* Tue Apr 24 2012 Roman Kennke <rkennke@redhat.com> 1.9.0-4
- Fix groupId of cglib dependency
- Add additional depmap for mockito-all
- Update depmap on post and postun
- Fix version in pom
* Wed Feb 22 2012 Roman Kennke <rkennke@redhat.com> 1.9.0-3
- Added cglib dependency to pom
* Tue Feb 21 2012 Roman Kennke <rkennke@redhat.com> 1.9.0-2
- Include upstream Maven pom.xml in package
- Added missing Requires for cglib, junit4, hamcrest, objenesis
- Added source tarball generating script to sources
* Thu Feb 16 2012 Roman Kennke <rkennke@redhat.com> 1.9.0-1
- Initial package