Upgrade to 58 (#1817981)
This commit is contained in:
parent
d74880f832
commit
8605a15661
22
mksh-58-faq.patch
Normal file
22
mksh-58-faq.patch
Normal file
@ -0,0 +1,22 @@
|
||||
http://www.mirbsd.org/cvs.cgi/src/bin/mksh/Build.sh.diff?r1=1.752;r2=1.753
|
||||
|
||||
--- src/bin/mksh/Build.sh 2020/03/27 10:15:52 1.752
|
||||
+++ src/bin/mksh/Build.sh 2020/03/27 23:36:23 1.753
|
||||
@@ -244,7 +244,7 @@ vq() {
|
||||
rmf() {
|
||||
for _f in "$@"; do
|
||||
case $_f in
|
||||
- *.1|*.ico) ;;
|
||||
+ *.1|*.faq|*.ico) ;;
|
||||
*) rm -f "$_f" ;;
|
||||
esac
|
||||
done
|
||||
@@ -651,7 +651,7 @@ oswarn=
|
||||
ccpc=-Wc,
|
||||
ccpl=-Wl,
|
||||
tsts=
|
||||
-ccpr='|| for _f in ${tcfn}*; do case $_f in *.1|*.ico) ;; *) rm -f "$_f" ;; esac; done'
|
||||
+ccpr='|| for _f in ${tcfn}*; do case $_f in *.1|*.faq|*.ico) ;; *) rm -f "$_f" ;; esac; done'
|
||||
|
||||
# Evil hack
|
||||
if test x"$TARGET_OS" = x"Android"; then
|
32
mksh.spec
32
mksh.spec
@ -4,21 +4,27 @@
|
||||
|
||||
Summary: MirBSD enhanced version of the Korn Shell
|
||||
Name: mksh
|
||||
Version: 57
|
||||
Release: 3%{?dist}
|
||||
Version: 58
|
||||
Release: 1%{?dist}
|
||||
# BSD (setmode.c), ISC (strlcpy.c), MirOS (the rest)
|
||||
License: MirOS and ISC and BSD
|
||||
URL: https://www.mirbsd.org/mksh.htm
|
||||
Source0: https://www.mirbsd.org/MirOS/dist/mir/%{name}/%{name}-R%{version}.tgz
|
||||
Source1: dot-mkshrc
|
||||
Source2: rtchecks.expected
|
||||
Patch0: mksh-58-faq.patch
|
||||
%if 0%{?fedora} >= 17 || 0%{?rhel} >= 7
|
||||
Conflicts: filesystem < 3
|
||||
Provides: /bin/lksh, /bin/mksh
|
||||
Provides: /bin/lksh
|
||||
Provides: /bin/mksh
|
||||
%endif
|
||||
Requires(post): grep
|
||||
Requires(postun): sed
|
||||
BuildRequires: gcc, util-linux, ed
|
||||
BuildRequires: gcc
|
||||
BuildRequires: util-linux
|
||||
BuildRequires: ed
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: sed
|
||||
|
||||
%description
|
||||
mksh is the MirBSD enhanced version of the Public Domain Korn shell (pdksh),
|
||||
@ -29,6 +35,7 @@ bourne shell replacement, pdksh successor and an alternative to the C shell.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%patch0 -p3 -b .faq
|
||||
|
||||
# we'll need this later
|
||||
cat >rtchecks <<'EOF'
|
||||
@ -61,24 +68,14 @@ print -r -- $((x++)):$sari=$uari. #9
|
||||
EOF
|
||||
|
||||
%build
|
||||
# Work around RHBZ #922974 on Fedora 19 and later
|
||||
%if 0%{?fedora} >= 19 || 0%{?rhel} >= 7
|
||||
CFLAGS="$RPM_OPT_FLAGS -DMKSH_DISABLE_EXPERIMENTAL" LDFLAGS="$RPM_LD_FLAGS" sh Build.sh -r
|
||||
%else
|
||||
CFLAGS="$RPM_OPT_FLAGS -DMKSH_DISABLE_EXPERIMENTAL" LDFLAGS="$RPM_LD_FLAGS" sh Build.sh -r -c lto
|
||||
%endif
|
||||
cp test.sh test_mksh.sh
|
||||
HAVE_PERSISTENT_HISTORY=0; export HAVE_PERSISTENT_HISTORY
|
||||
# Work around RHBZ #922974 on Fedora 19 and later
|
||||
%if 0%{?fedora} >= 19 || 0%{?rhel} >= 7
|
||||
CFLAGS="$RPM_OPT_FLAGS -DMKSH_DISABLE_EXPERIMENTAL" LDFLAGS="$RPM_LD_FLAGS" sh Build.sh -L -r
|
||||
%else
|
||||
CFLAGS="$RPM_OPT_FLAGS -DMKSH_DISABLE_EXPERIMENTAL" LDFLAGS="$RPM_LD_FLAGS" sh Build.sh -L -r -c lto
|
||||
%endif
|
||||
cp -f test.sh test_lksh.sh
|
||||
./mksh FAQ2HTML.sh
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
install -D -m 755 %{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
|
||||
install -D -m 755 lksh $RPM_BUILD_ROOT%{_bindir}/lksh
|
||||
install -D -m 644 %{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
|
||||
@ -124,7 +121,7 @@ if [ ! -x %{_bindir}/%{name} ]; then
|
||||
fi
|
||||
|
||||
%files
|
||||
%doc dot.mkshrc
|
||||
%doc dot.mkshrc FAQ.htm
|
||||
%{_bindir}/%{name}
|
||||
%{_bindir}/lksh
|
||||
%config(noreplace) %{_sysconfdir}/mkshrc
|
||||
@ -133,6 +130,9 @@ fi
|
||||
%{_mandir}/man1/lksh.1*
|
||||
|
||||
%changelog
|
||||
* Fri Mar 27 2020 Robert Scheck <robert@fedoraproject.org> 58-1
|
||||
- Upgrade to 58 (#1817981)
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 57-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mksh-R57.tgz) = 7d7fa557c17da4f1f62f82877a136439efb6d4f9fde52b2df39214db09868982e756df6e4fe83498f9013cbcf3252dc383b00ddfafaa4c9f143ffded7cd255b3
|
||||
SHA512 (mksh-R58.tgz) = 711351f8bbe8e44fcf9e7963f8e749938ec3ccb362fafd5350d44593841c2acb6d54ffa115dbb6b83c30865728a4c5274c05feedb063e293361e2830d263d80f
|
||||
|
Loading…
Reference in New Issue
Block a user