applying modified lockdev patch made by Jiri Popelka (#747936)
This commit is contained in:
parent
a1a26e73bd
commit
fb7b057d57
@ -1,3 +1,14 @@
|
|||||||
|
diff -up minicom-2.5/configure.in.rh minicom-2.5/configure.in
|
||||||
|
--- minicom-2.5/configure.in.rh 2011-10-07 18:59:53.741694461 +0200
|
||||||
|
+++ minicom-2.5/configure.in 2011-10-07 18:59:53.742694449 +0200
|
||||||
|
@@ -152,6 +152,7 @@ if test "x$found_termcap_h" != "x1"; the
|
||||||
|
fi
|
||||||
|
|
||||||
|
AC_CHECK_LIB(socket, socket)
|
||||||
|
+AC_CHECK_LIB(lockdev, ttylock)
|
||||||
|
|
||||||
|
dnl Checks for header files.
|
||||||
|
AC_HEADER_DIRENT
|
||||||
diff --git a/src/main.c b/src/main.c
|
diff --git a/src/main.c b/src/main.c
|
||||||
index bc4db89..8e68e2c 100644
|
index bc4db89..8e68e2c 100644
|
||||||
--- a/src/main.c
|
--- a/src/main.c
|
||||||
@ -105,7 +116,7 @@ index 309d54a..83f3fca 100644
|
|||||||
|
|
||||||
#include <time.h>
|
#include <time.h>
|
||||||
+#include <limits.h>
|
+#include <limits.h>
|
||||||
+#include <baudboy.h>
|
+#include <ttylock.h>
|
||||||
|
|
||||||
#ifdef USE_SOCKET
|
#ifdef USE_SOCKET
|
||||||
#include <sys/socket.h>
|
#include <sys/socket.h>
|
||||||
|
16
minicom.spec
16
minicom.spec
@ -1,13 +1,12 @@
|
|||||||
Summary: A text-based modem control and terminal emulation program
|
Summary: A text-based modem control and terminal emulation program
|
||||||
Name: minicom
|
Name: minicom
|
||||||
Version: 2.5
|
Version: 2.5
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
URL: http://alioth.debian.org/projects/minicom/
|
URL: http://alioth.debian.org/projects/minicom/
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/Communications
|
Group: Applications/Communications
|
||||||
ExcludeArch: s390 s390x
|
ExcludeArch: s390 s390x
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRequires: lockdev-devel ncurses-devel autoconf automake gettext-devel
|
||||||
BuildRequires: lockdev-devel ncurses-devel
|
|
||||||
Requires: lockdev lrzsz
|
Requires: lockdev lrzsz
|
||||||
|
|
||||||
Source0: http://alioth.debian.org/frs/download.php/3487/minicom-2.5.tar.gz
|
Source0: http://alioth.debian.org/frs/download.php/3487/minicom-2.5.tar.gz
|
||||||
@ -34,21 +33,18 @@ cp -pr doc doc_
|
|||||||
rm -f doc_/Makefile*
|
rm -f doc_/Makefile*
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
#./autogen.sh
|
||||||
|
autoreconf --verbose --force --install
|
||||||
%configure
|
%configure
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
make DESTDIR=$RPM_BUILD_ROOT install
|
make DESTDIR=$RPM_BUILD_ROOT install
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
|
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
|
||||||
|
|
||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
%clean
|
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
|
||||||
%doc ChangeLog AUTHORS NEWS TODO doc_/*
|
%doc ChangeLog AUTHORS NEWS TODO doc_/*
|
||||||
# DO NOT MAKE minicom SUID/SGID anything.
|
# DO NOT MAKE minicom SUID/SGID anything.
|
||||||
%{_bindir}/minicom
|
%{_bindir}/minicom
|
||||||
@ -58,6 +54,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 24 2011 Jaromir Capik <jcapik@redhat.com> 2.5-7
|
||||||
|
- applying modified lockdev patch made by Jiri Popelka (#747936)
|
||||||
|
- minor spec file changes according to the latest guidelines
|
||||||
|
|
||||||
* Wed Apr 6 2011 Jan Görig <jgorig@redhat.com> 2.5-6
|
* Wed Apr 6 2011 Jan Görig <jgorig@redhat.com> 2.5-6
|
||||||
- reverted last change (#681898)
|
- reverted last change (#681898)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user