- fixed crashing on non-readable directory (#675400)
- fixed typos in minicom and runscript manpages (#675453,#675456)
This commit is contained in:
parent
425076a6bc
commit
ada5b9e1ae
99
minicom-2.5-man-minicom.patch
Normal file
99
minicom-2.5-man-minicom.patch
Normal file
@ -0,0 +1,99 @@
|
||||
diff -up ./man/minicom.1.orig ./man/minicom.1
|
||||
--- ./man/minicom.1.orig 2010-08-09 21:54:03.000000000 +0200
|
||||
+++ ./man/minicom.1 2011-02-09 11:24:42.972547002 +0100
|
||||
@@ -16,7 +16,7 @@ minicom \- friendly serial communication
|
||||
.SH DESCRIPTION
|
||||
.B minicom
|
||||
is a communication program which somewhat resembles the shareware
|
||||
-program TELIX but is free with source code and runs under most unices.
|
||||
+program TELIX but is free with source code and runs under most Unices.
|
||||
Features include dialing directory with auto-redial, support for
|
||||
UUCP-style lock files on serial devices, a separate script language
|
||||
interpreter, capture to file, multiple users with individual
|
||||
@@ -35,10 +35,10 @@ minicom. For most systems, reasonable de
|
||||
.TP 0.5i
|
||||
.B \-o
|
||||
Do not initialize. Minicom will skip the initialization code. This
|
||||
-option is handy if you quitted from minicom without resetting, and
|
||||
+option is handy if you quit from minicom without resetting, and
|
||||
then want to restart a session. It is potentially dangerous though: no
|
||||
check for lock files etc. is made, so a normal user could interfere
|
||||
-with things like uucp... Maybe this will be taken out later. For now
|
||||
+with things like UUCP... maybe this will be taken out later. For now
|
||||
it is assumed, that users who are given access to a modem are
|
||||
responsible enough for their actions.
|
||||
.TP 0.5i
|
||||
@@ -65,7 +65,7 @@ and that have the relevant information i
|
||||
translation of characters with the high bit set. With this flag on,
|
||||
minicom will try to translate the IBM line characters to ASCII. Many PC-unix
|
||||
clones will display character correctly without translation (Linux in a
|
||||
-special mode, Coherent and Sco).
|
||||
+special mode, Coherent and SCO).
|
||||
.TP 0.5i
|
||||
.B \-L
|
||||
Ditto but assume screen uses an ISO8859 character set.
|
||||
@@ -118,7 +118,7 @@ completed.
|
||||
.BR P seudo
|
||||
terminal
|
||||
to use. This overrides the terminal port defined in the configuration
|
||||
-files, but only if it is a pseudo tty. The filename supplied must be of
|
||||
+files, but only if it is a pseudo TTY. The filename supplied must be of
|
||||
the form (/dev/)tty[p-z/][0-f], (/dev/)pts[p-z/][0-f] or
|
||||
(/dev/)pty[p-z/][0-f]. For example, /dev/ttyp1, pts/0 or /dev/ptyp2.
|
||||
.TP 0.5i
|
||||
@@ -189,7 +189,7 @@ sensible is to use device names, such as
|
||||
user creates his own configuration file, it will show up in his home
|
||||
directory as ".minirc.dfl" or ".minirc.\fIconfiguration\fR\|".
|
||||
.SH USE
|
||||
-Minicom is window based. To popup a window with the function you
|
||||
+Minicom is window based. To pop-up a window with the function you
|
||||
want, press Control-A (from now on, we will use C-A to mean
|
||||
Control-A), and then the function key (a-z or A-Z). By pressing C-A
|
||||
first and then 'z', a help screen comes up with a short summary of all
|
||||
@@ -500,8 +500,8 @@ file and directory menu is used.
|
||||
.TP 0.5i
|
||||
.B A - Serial device
|
||||
/dev/tty1 or /dev/ttyS1 for most people.
|
||||
-/dev/cua<n> is still possible under linux, but not recommended any more
|
||||
-because these devices are obsolete and many newly installed systems
|
||||
+/dev/cua<n> is still possible under GNU/Linux, but no longer recommended
|
||||
+as these devices are obsolete and many systems
|
||||
with kernel 2.2.x or newer don't have them.
|
||||
Use /dev/ttyS<n> instead.
|
||||
You may also have /dev/modem as a symlink to the real device.
|
||||
@@ -510,7 +510,7 @@ If you have modems connected to two or m
|
||||
all of them here in a list separated by space, comma or semicolon. When
|
||||
Minicom starts, it checks the list until it finds an available modem and
|
||||
uses that one. (However, you can't specify different init strings to
|
||||
-them ..at least not yet.)
|
||||
+them... at least not yet.)
|
||||
.br
|
||||
To use a UNIX socket for communication the device name must be prefixed
|
||||
with "unix#" following by the full path and the filename of the socket.
|
||||
@@ -520,7 +520,7 @@ establishes, minicom goes 'online'. If t
|
||||
switches to 'offline' again.
|
||||
.TP 0.5i
|
||||
.B B - Lock file location
|
||||
-On most systems This should be /usr/spool/uucp. Linux systems use
|
||||
+On most systems This should be /usr/spool/uucp. GNU/Linux systems use
|
||||
/var/lock. If this directory does not exist,
|
||||
minicom will not attempt to use lockfiles.
|
||||
.TP 0.5i
|
||||
@@ -799,7 +799,7 @@ to get the escape key, you had to press
|
||||
.PP
|
||||
As of release 1.3 this has bettered a little: now a 1-second timeout
|
||||
is builtin, like in vi. For systems that have the select() system call
|
||||
-the timeout is 0.5 seconds. And... surprise: a special Linux-dependant
|
||||
+the timeout is 0.5 seconds. And... surprise: a special Linux-dependent
|
||||
.BR hack " :-) was added. Now, minicom can separate the escape key and"
|
||||
escape-sequences. To see how dirty this was done, look into wkeys.c.
|
||||
But it works like a charm!
|
||||
@@ -837,7 +837,7 @@ for new versions since 1.78, helped by s
|
||||
filipg@paranoia.com wrote the History buffer searching to 1.79.
|
||||
.br
|
||||
Arnaldo Carvalho de Melo (acme@conectiva.com.br) did the internationalization
|
||||
-and the Brasilian Portuguese translations.
|
||||
+and the Brazilian Portuguese translations.
|
||||
.br
|
||||
Jim Seymour (jseymour@jimsun.LinxNet.com) wrote the multiple modem support
|
||||
and the filename selection window used since 1.80.
|
23
minicom-2.5-man-runscript.patch
Normal file
23
minicom-2.5-man-runscript.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -up ./man/runscript.1.orig ./man/runscript.1
|
||||
--- ./man/runscript.1.orig 2009-12-12 16:47:47.000000000 +0100
|
||||
+++ ./man/runscript.1 2011-02-09 11:29:34.821547000 +0100
|
||||
@@ -12,8 +12,8 @@ runscript \- script interpreter for mini
|
||||
.SH DESCRIPTION
|
||||
.B runscript
|
||||
is a simple script interpreter that can be called from within the minicom
|
||||
-communications program to automate tasks like logging in to a unix system
|
||||
-or your favorite bbs.
|
||||
+communications program to automate tasks like logging in to a Unix system
|
||||
+or your favorite BBS.
|
||||
.SH INVOCATION
|
||||
The program expects a script name and optionally a filename and the
|
||||
user's home directory as arguments, and it expects that it's input and
|
||||
@@ -155,7 +155,7 @@ finishes without errors, the original sc
|
||||
Write text to the logfile.
|
||||
.SH NOTES
|
||||
If you want to make your script to exit minicom (for example when
|
||||
-you use minicom to dial up your ISP, and then start a ppp or slip
|
||||
+you use minicom to dial up your ISP, and then start a PPP or SLIP
|
||||
session from a script), try the command "! killall \-9 minicom" as
|
||||
the last script command. The \-9 option should prevent minicom from
|
||||
hanging up the line and resetting the modem before exiting.
|
18
minicom-2.5-non-readable-dir.patch
Normal file
18
minicom-2.5-non-readable-dir.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff --git a/src/file.c b/src/file.c
|
||||
index ba3a1ee..fa60950 100644
|
||||
--- a/src/file.c
|
||||
+++ b/src/file.c
|
||||
@@ -331,7 +331,12 @@ static int new_filedir(GETSDIR_ENTRY *o_dirdat, int flushit)
|
||||
return -1;
|
||||
}
|
||||
|
||||
- rval = chdir(work_dir);
|
||||
+ /* chdir success doesn't guarantee that directory is readable */
|
||||
+ if(access(work_dir, R_OK) == 0)
|
||||
+ rval = chdir(work_dir);
|
||||
+ else
|
||||
+ rval = -1;
|
||||
+
|
||||
if (rval == 0) {
|
||||
/* was able to change to new working directory */
|
||||
free(prev_dir);
|
12
minicom.spec
12
minicom.spec
@ -1,7 +1,7 @@
|
||||
Summary: A text-based modem control and terminal emulation program
|
||||
Name: minicom
|
||||
Version: 2.5
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
URL: http://alioth.debian.org/projects/minicom/
|
||||
License: GPLv2+
|
||||
Group: Applications/Communications
|
||||
@ -13,6 +13,9 @@ Requires: lockdev lrzsz
|
||||
Source0: http://alioth.debian.org/frs/download.php/3487/minicom-2.5.tar.gz
|
||||
|
||||
Patch1: minicom-2.5-rh.patch
|
||||
Patch2: minicom-2.5-non-readable-dir.patch
|
||||
Patch3: minicom-2.5-man-minicom.patch
|
||||
Patch4: minicom-2.5-man-runscript.patch
|
||||
|
||||
%description
|
||||
Minicom is a simple text-based modem control and terminal emulation
|
||||
@ -23,6 +26,9 @@ language, and other features.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .rh
|
||||
%patch2 -p1 -b .dir
|
||||
%patch3 -p1 -b .man
|
||||
%patch4 -p1 -b .man
|
||||
|
||||
cp -pr doc doc_
|
||||
rm -f doc_/Makefile*
|
||||
@ -52,6 +58,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Wed Feb 09 2011 Jan Görig <jgorig@redhat.com> 2.5-3
|
||||
- fixed crashing on non-readable directory (#675400)
|
||||
- fixed typos in minicom and runscript manpages (#675453,#675456)
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user