import minicom-2.7.1-17.el9

This commit is contained in:
CentOS Sources 2022-05-17 06:44:47 -04:00 committed by Stepan Oksanichenko
commit 55a0529e01
13 changed files with 942 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/minicom-2.7.1.tar.gz

1
.minicom.metadata Normal file
View File

@ -0,0 +1 @@
915432810e7be05c684a634a2c6d45fec3c92cf9 SOURCES/minicom-2.7.1.tar.gz

View File

@ -0,0 +1,28 @@
From 6b93b699cc57c433ddd0f8a055c73a4b05b575fa Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ond=C5=99ej=20Lyson=C4=9Bk?= <olysonek@redhat.com>
Date: Mon, 13 Aug 2018 14:39:42 +0200
Subject: [PATCH 1/7] Add a missing va_end() call
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Ondřej Lysoněk <olysonek@redhat.com>
---
src/common.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/common.c b/src/common.c
index 86d806c..48f68f9 100644
--- a/src/common.c
+++ b/src/common.c
@@ -74,6 +74,7 @@ void do_log(const char *line, ...)
(ptr->tm_year)+1900, (ptr->tm_mon)+1, ptr->tm_mday,
ptr->tm_hour, ptr->tm_min, ptr->tm_sec);
vfprintf(logfile, line, ap);
+ va_end(ap);
fprintf(logfile, "\n");
fclose(logfile);
#else
--
2.14.4

View File

@ -0,0 +1,32 @@
From b65152ebc03832972115e6d98e50cb6190d01793 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ond=C5=99ej=20Lyson=C4=9Bk?= <olysonek@redhat.com>
Date: Mon, 3 Feb 2020 13:18:13 +0100
Subject: [PATCH 1/3] Drop superfluous global variable definitions
The file minicom.c, by including the minicom.h header, already defines
the global variables 'dial_user' and 'dial_pass'. The object file
minicom.o is always linked to dial.o. Thus the definitions in dial.c
can be dropped.
This fixes linking with gcc 10 which uses -fno-common by default,
disallowing multiple global variable definitions.
---
src/dial.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/src/dial.c b/src/dial.c
index eada5ee..d9d481f 100644
--- a/src/dial.c
+++ b/src/dial.c
@@ -146,8 +146,6 @@ static int newtype;
/* Access to ".dialdir" denied? */
static int dendd = 0;
static char *tagged;
-char *dial_user;
-char *dial_pass;
/* Change the baud rate. Treat all characters in the given array as if
* they were key presses within the comm parameters dialog (C-A P) and
--
2.24.1

View File

@ -0,0 +1,34 @@
From 924bd2da3a00e030e29d82b74ef82900bd50b475 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ond=C5=99ej=20Lyson=C4=9Bk?= <olysonek@redhat.com>
Date: Mon, 3 Feb 2020 13:18:33 +0100
Subject: [PATCH 2/3] Drop superfluous global variable definitions
The only place where the EXTERN macro mechanism is used to define the
global variables 'vt_outmap' and 'vt_inmap' is minicom.c (by defining
an empty EXTERN macro and including the minicom.h header). The file
vt100.c already defines these variables. The vt100.o object file is
always linked to minicom.o. Thus it is safe not to define the
variables in minicom.c and only declare them in the minicom.h header.
This fixes linking with gcc 10 which uses -fno-common by default,
disallowing multiple global variable definitions.
---
src/minicom.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/minicom.h b/src/minicom.h
index 061c013..0f9693b 100644
--- a/src/minicom.h
+++ b/src/minicom.h
@@ -141,7 +141,7 @@ EXTERN int sbcolor; /* Status Bar Background Color */
EXTERN int st_attr; /* Status Bar attributes. */
/* jl 04.09.97 conversion tables */
-EXTERN unsigned char vt_outmap[256], vt_inmap[256];
+extern unsigned char vt_outmap[256], vt_inmap[256];
/* MARK updated 02/17/95 - history buffer */
EXTERN int num_hist_lines; /* History buffer size */
--
2.24.1

View File

@ -0,0 +1,113 @@
From 695564da74fe7c95802f5bf59e442e23a2d7cbbf Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ond=C5=99ej=20Lyson=C4=9Bk?= <olysonek@redhat.com>
Date: Mon, 13 Aug 2018 14:39:43 +0200
Subject: [PATCH 2/7] Make sure strings copied by strncpy are null-terminated
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Ondřej Lysoněk <olysonek@redhat.com>
---
src/config.c | 1 +
src/dial.c | 3 +++
src/minicom.c | 3 +++
src/script.c | 2 ++
src/updown.c | 4 ++++
5 files changed, 13 insertions(+)
diff --git a/src/config.c b/src/config.c
index 78b25aa..ea939c8 100644
--- a/src/config.c
+++ b/src/config.c
@@ -88,6 +88,7 @@ void read_parms(void)
for (f = PROTO_BASE; f < MAXPROTO; f++) {
if (P_PNAME(f)[0] && P_PIORED(f) != 'Y' && P_PIORED(f) != 'N') {
strncpy(buf, P_PNAME(f) - 2, sizeof(buf));
+ buf[sizeof(buf) - 1] = '\0';
strcpy(P_PNAME(f), buf);
P_PIORED(f) = 'Y';
P_PFULL(f) = 'N';
diff --git a/src/dial.c b/src/dial.c
index a90c1d2..a3337e5 100644
--- a/src/dial.c
+++ b/src/dial.c
@@ -829,8 +829,11 @@ static int v1_read(FILE *fp, struct dialent *d)
memcpy(d->username, v1.username, sizeof(v1) - offsetof(struct v1_dialent, username));
strncpy(d->name, v1.name, sizeof(d->name));
+ d->name[sizeof(d->name) - 1] = '\0';
strncpy(d->number, v1.number, sizeof(d->number));
+ d->number[sizeof(d->number) - 1] = '\0';
strncpy(d->script, v1.script, sizeof(d->script));
+ d->script[sizeof(d->script) - 1] = '\0';
d->lastdate[0]=0;
d->lasttime[0]=0;
d->count=0;
diff --git a/src/minicom.c b/src/minicom.c
index 4eb47d4..876805a 100644
--- a/src/minicom.c
+++ b/src/minicom.c
@@ -1208,6 +1208,7 @@ int main(int argc, char **argv)
break;
case 't': /* Terminal type */
strncpy(termtype, optarg, sizeof(termtype));
+ termtype[sizeof(termtype) - 1] = '\0';
#ifdef __GLIBC__
/* Bug in older libc's (< 4.5.26 I think) */
if ((s = getenv("TERMCAP")) != NULL && *s != '/')
@@ -1322,7 +1323,9 @@ int main(int argc, char **argv)
strncpy(homedir, pwd->pw_dir, sizeof(homedir));
else
strncpy(homedir, s, sizeof(homedir));
+ homedir[sizeof(homedir) - 1] = '\0';
strncpy(username, pwd->pw_name, sizeof(username));
+ username[sizeof(username) - 1] = '\0';
/* Get personal parameter file */
snprintf(pparfile, sizeof(pparfile), "%s/.minirc.%s", homedir, use_port);
diff --git a/src/script.c b/src/script.c
index ee1284f..f7c4e3f 100644
--- a/src/script.c
+++ b/src/script.c
@@ -1099,12 +1099,14 @@ int main(int argc, char **argv)
if (argc > 2) {
strncpy(logfname, argv[2], sizeof(logfname));
+ logfname[sizeof(logfname) - 1] = '\0';
if (argc > 3)
strncpy(homedir, argv[3], sizeof(homedir));
else if ((s = getenv("HOME")) != NULL)
strncpy(homedir, s, sizeof(homedir));
else
homedir[0] = 0;
+ homedir[sizeof(homedir) - 1] = '\0';
}
else
logfname[0] = 0;
diff --git a/src/updown.c b/src/updown.c
index 726328e..54442bb 100644
--- a/src/updown.c
+++ b/src/updown.c
@@ -386,6 +386,7 @@ void updown(int what, int nr)
do_log("%s", trimbuf);
} else if (!strncmp (buffirst, "Bytes", 5)) {
strncpy (xfrstr, buf, sizeof(xfrstr));
+ xfrstr[sizeof(xfrstr) - 1] = '\0';
}
buffirst[0] = 0;
trimbuf[0] = 0;
@@ -698,8 +699,11 @@ void runscript(int ask, const char *s, const char *l, const char *p)
}
} else {
strncpy(scr_user, l, sizeof(scr_user));
+ scr_user[sizeof(scr_user) - 1] = '\0';
strncpy(scr_name, s, sizeof(scr_name));
+ scr_name[sizeof(scr_name) - 1] = '\0';
strncpy(scr_passwd, p, sizeof(scr_passwd));
+ scr_passwd[sizeof(scr_passwd) - 1] = '\0';
}
sprintf(scr_lines, "%d", (int) lines); /* jl 13.09.97 */
--
2.14.4

View File

@ -0,0 +1,39 @@
From a4fc603b3641d2efe31479116eb7ba66932901c7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ond=C5=99ej=20Lyson=C4=9Bk?= <olysonek@redhat.com>
Date: Mon, 3 Feb 2020 13:21:41 +0100
Subject: [PATCH 3/3] Drop superfluous global variable definitions
The only place where the EXTERN macro mechanism is used to define the
global variables 'portfd_is_socket', 'portfd_is_connected' and
'portfd_sock_addr' is minicom.c (by defining an empty EXTERN macro and
including the minicom.h header). The source file sysdep1_s.c already
defines these variables. The sysdep1_s.o object file is always linked
to minicom.o. Thus it is safe to drop the definitions from minicom.c
and only declare the variables in the minicom.h header.
This fixes linking with gcc 10 which uses -fno-common by default,
disallowing multiple global variable definitions.
---
src/minicom.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/minicom.h b/src/minicom.h
index 0f9693b..1e7cb8c 100644
--- a/src/minicom.h
+++ b/src/minicom.h
@@ -113,9 +113,9 @@ EXTERN char *dial_user; /* Our username there */
EXTERN char *dial_pass; /* Our password */
#ifdef USE_SOCKET
-EXTERN int portfd_is_socket; /* File descriptor is a unix socket */
-EXTERN int portfd_is_connected; /* 1 if the socket is connected */
-EXTERN struct sockaddr_un portfd_sock_addr; /* the unix socket address */
+extern int portfd_is_socket; /* File descriptor is a unix socket */
+extern int portfd_is_connected; /* 1 if the socket is connected */
+extern struct sockaddr_un portfd_sock_addr; /* the unix socket address */
#define portfd_connected ((portfd_is_socket && !portfd_is_connected) \
? -1 : portfd)
#else
--
2.24.1

View File

@ -0,0 +1,59 @@
From abc0836d587862ba512acf4d4fafcf8cb121bf0a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ond=C5=99ej=20Lyson=C4=9Bk?= <olysonek@redhat.com>
Date: Mon, 13 Aug 2018 14:39:44 +0200
Subject: [PATCH 3/7] Fix file descriptor leaks
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Ondřej Lysoněk <olysonek@redhat.com>
---
src/dial.c | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/src/dial.c b/src/dial.c
index a3337e5..eada5ee 100644
--- a/src/dial.c
+++ b/src/dial.c
@@ -912,6 +912,7 @@ int readdialdir(void)
if (fread(&dial_ver, sizeof(dial_ver), 1, fp) != 1)
{
werror(_("Failed to read dialing directory\n"));
+ fclose(fp);
return -1;
}
if (dial_ver.magic != DIALMAGIC) {
@@ -947,12 +948,14 @@ int readdialdir(void)
dial_ver.size > sizeof(struct v4_dialent)) {
werror(_("Phonelist garbled (unknown version?)"));
dialents = mkstdent();
+ fclose(fp);
return -1;
}
break;
case 5:
if (dial_ver.size != sizeof(struct dialent)) {
werror(_("Phonelist corrupted"));
+ fclose(fp);
return -1;
}
break;
@@ -961,6 +964,7 @@ int readdialdir(void)
// have different size on 32 and 64bit systems
if (dial_ver.size != sizeof(struct dialent) - sizeof(void *)) {
werror(_("Phonelist corrupted"));
+ fclose(fp);
return -1;
}
break;
@@ -968,6 +972,7 @@ int readdialdir(void)
werror(_("Unknown dialing directory version"));
dendd = 1;
dialents = mkstdent();
+ fclose(fp);
return -1;
}
--
2.14.4

View File

@ -0,0 +1,28 @@
From 97359edba99f9bc6f3f87590da2139c51fb409d4 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ond=C5=99ej=20Lyson=C4=9Bk?= <olysonek@redhat.com>
Date: Mon, 13 Aug 2018 14:39:45 +0200
Subject: [PATCH 4/7] Fix a directory handle leak
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Ondřej Lysoněk <olysonek@redhat.com>
---
src/getsdir.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/getsdir.c b/src/getsdir.c
index 2195b27..bd6b763 100644
--- a/src/getsdir.c
+++ b/src/getsdir.c
@@ -228,6 +228,7 @@ int getsdir(const char *dirpath, const char *pattern, int sortflags,
if (!*datptr)
{
free(*datptr);
+ closedir(dirp);
return -1;
}
--
2.14.4

View File

@ -0,0 +1,38 @@
From fa8feee1fce1c6e728512d9e6c0bfffa89f0ce62 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ond=C5=99ej=20Lyson=C4=9Bk?= <olysonek@redhat.com>
Date: Mon, 13 Aug 2018 14:39:46 +0200
Subject: [PATCH 5/7] Fix a read past end of buffer
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Ondřej Lysoněk <olysonek@redhat.com>
---
src/ascii-xfr.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/ascii-xfr.c b/src/ascii-xfr.c
index ca27ebf..79af763 100644
--- a/src/ascii-xfr.c
+++ b/src/ascii-xfr.c
@@ -207,7 +207,7 @@ int arecv(char *file)
}
while ((n = read(STDIN_FILENO, line, sizeof(line))) > 0) {
- for (s = line; n-- >0; s++) {
+ for (s = line; s - line < n; s++) {
if (*s == eofchar)
break;
if (dotrans && *s == '\r')
@@ -217,7 +217,7 @@ int arecv(char *file)
}
stats(first);
first = 0;
- if (*s == eofchar)
+ if (s - line < n && *s == eofchar)
break;
}
fclose(fp);
--
2.14.4

View File

@ -0,0 +1,30 @@
From a4e1679b67db6ecd7ce2891ed0bf5586125a9a08 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ond=C5=99ej=20Lyson=C4=9Bk?= <olysonek@redhat.com>
Date: Mon, 13 Aug 2018 14:39:47 +0200
Subject: [PATCH 6/7] Fix a warning about an unused variable
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Ondřej Lysoněk <olysonek@redhat.com>
---
src/config.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/config.c b/src/config.c
index ea939c8..36b6e37 100644
--- a/src/config.c
+++ b/src/config.c
@@ -536,7 +536,9 @@ static void doserial(void)
{
WIN *w;
char *serial_device = _(" A - Serial Device :");
+#if !HAVE_LOCKDEV
char *lockfile_location = _(" B - Lockfile Location :");
+#endif
char *callin_program = _(" C - Callin Program :");
char *callout_program = _(" D - Callout Program :");
char *bps_par_bits = _(" E - Bps/Par/Bits :");
--
2.14.4

View File

@ -0,0 +1,46 @@
From 1c97e4df9e01c5f22a12fb6ecce25b4d80fd8f7c Mon Sep 17 00:00:00 2001
From: Adam Lackorzynski <adam@os.inf.tu-dresden.de>
Date: Mon, 13 Aug 2018 14:39:48 +0200
Subject: [PATCH 7/7] loadconv: Add missing fclose()
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Issue found and reported by David Binderman.
This is a backport of commit f66b5c78.
Signed-off-by: Ondřej Lysoněk <olysonek@redhat.com>
---
src/config.c | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/src/config.c b/src/config.c
index 36b6e37..0da4989 100644
--- a/src/config.c
+++ b/src/config.c
@@ -1865,6 +1865,7 @@ void doconv(void)
int loadconv(char *buf)
{
FILE *fp;
+ int err = 0;
if ((fp = fopen(pfix_home(buf), "rb")) == (FILE *)NULL) {
werror(_("Cannot open conversion table %s"), pfix_home(buf));
@@ -1874,10 +1875,11 @@ int loadconv(char *buf)
|| fread(vt_outmap, sizeof(vt_outmap), (size_t)1, fp) != 1)
{
werror(_("Cannot read conversion table %s"), pfix_home(buf));
- return 1;
+ err = 1;
}
+
fclose(fp);
- return 0;
+ return err;
}
int saveconv(char *buf)
--
2.14.4

493
SPECS/minicom.spec Normal file
View File

@ -0,0 +1,493 @@
Summary: A text-based modem control and terminal emulation program
Name: minicom
Version: 2.7.1
Release: 17%{?dist}
URL: https://salsa.debian.org/minicom-team/minicom
# Some files are built from Public Domain files in addition to GPLv2+ files
# (/usr/bin/minicom). Some LGPLv2+ files *may* be used in building of certain
# files (minicom, ascii-xfr, runscript). They are probably not actually used,
# but I wasn't able to exclude them from the build process completely yet.
# The rest is simply GPLv2+.
License: GPLv2+ and LGPLv2+ and Public Domain
#ExcludeArch: s390 s390x
Source0: https://alioth.debian.org/frs/download.php/file/4215/%{name}-%{version}.tar.gz
# Upstream patch:
Patch1: 0001-Add-a-missing-va_end-call.patch
# Upstream patch:
Patch2: 0002-Make-sure-strings-copied-by-strncpy-are-null-termina.patch
# Upstream patch:
Patch3: 0003-Fix-file-descriptor-leaks.patch
# Upstream patch:
Patch4: 0004-Fix-a-directory-handle-leak.patch
# Upstream patch:
Patch5: 0005-Fix-a-read-past-end-of-buffer.patch
# Upstream patch:
Patch6: 0006-Fix-a-warning-about-an-unused-variable.patch
# Upstream patch:
Patch7: 0007-loadconv-Add-missing-fclose.patch
# Upstream patch:
Patch8: 0001-Drop-superfluous-global-variable-definitions.patch
# Upstream patch:
Patch9: 0002-Drop-superfluous-global-variable-definitions.patch
# Upstream patch:
Patch10: 0003-Drop-superfluous-global-variable-definitions.patch
BuildRequires: make
BuildRequires: lockdev-devel ncurses-devel autoconf automake gettext-devel
BuildRequires: gcc
# For %%autosetup -S git:
BuildRequires: git
Requires: lockdev lrzsz
%description
Minicom is a simple text-based modem control and terminal emulation
program somewhat similar to MSDOS Telix. Minicom includes a dialing
directory, full ANSI and VT100 emulation, an (external) scripting
language, and other features.
%prep
%autosetup -S git
cp -pr doc doc_
rm -f doc_/Makefile*
%build
#./autogen.sh
autoreconf --verbose --force --install
# Remove unused files to make sure we've got the License tag right.
# It seems this needs to be done after autoreconf, otherwise it will fail.
rm -f lib/snprintf.c
%configure
%make_build
%install
%make_install
mkdir -p %{buildroot}%{_sysconfdir}
%find_lang %{name}
%files -f %{name}.lang
%doc ChangeLog AUTHORS NEWS TODO doc_/*
%license COPYING
# DO NOT MAKE minicom SUID/SGID anything.
%{_bindir}/minicom
%{_bindir}/runscript
%{_bindir}/xminicom
%{_bindir}/ascii-xfr
%{_mandir}/man1/*
%changelog
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 2.7.1-17
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 2.7.1-16
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Mon Feb 10 2020 Ondřej Lysoněk <olysonek@redhat.com> - 2.7.1-13
- Fix build with gcc 10
- Resolves: rhbz#1799652
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Mon Aug 13 2018 Ondřej Lysoněk <olysonek@redhat.com> - 2.7.1-9
- Fix issues found by Coverity Scan
- Resolves: rhbz#1602618
* Mon Jul 23 2018 Ondřej Lysoněk <olysonek@redhat.com> - 2.7.1-8
- Corrected the License tag
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Mon Feb 19 2018 Ondřej Lysoněk <olysonek@redhat.com> - 2.7.1-6
- Add gcc to BuildRequires
* Tue Feb 13 2018 Vasiliy N. Glazov <vascom2@gmail.com> - 2.7.1-5
- Cleanup spec
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Jul 15 2017 Filipe Rosset <rosset.filipe@gmail.com> - 2.7.1-1
- Rebuilt to new upstream version 2.7.1 fixes rhbz#1443071 and rhbz#1443129
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.7-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 2.7-4
- Rebuilt for Fedora 23 Change
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Mon Jan 06 2014 Jaromir Capik <jcapik@redhat.com> - 2.7-1
- Update to 2.7
- Fixing bogus dates in the changelog
* Wed Aug 07 2013 Jaromir Capik <jcapik@redhat.com> - 2.6.2-4
- Fixing the license tag
* Wed Jul 31 2013 Jaromir Capik <jcapik@redhat.com> - 2.6.2-3
- RH man page scan (#948521)
* Thu Feb 07 2013 Jaromir Capik <jcapik@redhat.com> - 2.6.2-2
- Disabling lockfile warnings when the device disappears (ttyUSB hot unplug)
* Thu Feb 07 2013 Jaromir Capik <jcapik@redhat.com> - 2.6.2-1
- Update to 2.6.2
* Wed Jan 23 2013 Jaromir Capik <jcapik@redhat.com> - 2.6.1-2
- Disable lock path config when built with lockdev (#754235)
* Tue Jan 22 2013 Jaromir Capik <jcapik@redhat.com> - 2.6.1-1
- Update to 2.6.1
* Thu Nov 22 2012 Jaromir Capik <jcapik@redhat.com> 2.5-11
- Fixing the license tag
* Wed Nov 21 2012 Jaromir Capik <jcapik@redhat.com> 2.5-10
- Removing de-ANSI-fication (obsolete - support removed from autotools)
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Mon Oct 24 2011 Jaromir Capik <jcapik@redhat.com> 2.5-7
- applying modified lockdev patch made by Jiri Popelka (#747936)
- minor spec file changes according to the latest guidelines
* Wed Apr 6 2011 Jan Görig <jgorig@redhat.com> 2.5-6
- reverted last change (#681898)
* Wed Mar 9 2011 Jan Görig <jgorig@redhat.com> 2.5-5
- dropped rh patch because /var/lock/lockdev is now world writeable
* Thu Feb 24 2011 Jan Görig <jgorig@redhat.com> 2.5-4
- fixed crashing on device reconnecting (#678812)
* Wed Feb 09 2011 Jan Görig <jgorig@redhat.com> 2.5-3
- fixed crashing on non-readable directory (#675400)
- fixed typos in minicom and runscript manpages (#675453,#675456)
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Mon Jan 31 2011 Jan Görig <jgorig@redhat.com> 2.5-1
- update to new upstream version
- remove patches merged by upstream
- update rh patch to support unix socket (#592355)
* Fri Jan 14 2011 Jan Görig <jgorig@redhat.com> 2.4-2
- fixed typos in ascii-xfr manpage (#669098)
- fixed empty lines handling in configuration file (#669406)
* Tue Mar 9 2010 Jan Görig <jgorig@redhat.com> 2.4-1
- update to 2.4
- /etc/minicom.users removed by upstream
- add minicom-2.4-config.patch
- remove minicom-2.3-getline.patch - fixed in upstream
- remove minicom-2.3-drop-privs.patch - permissions handling removed by upstream
- remove minicom-2.3-ncurses.patch - deprecated
- modify minicom-2.4-rh.patch - wrong doinit checking (#519637)
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Thu Jul 16 2009 Miroslav Lichvar <mlichvar@redhat.com> 2.3-5
- rename getline to avoid conflict with glibc (#511715)
- remove makefiles from docs
- drop wchar patch
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Fri Aug 29 2008 Miroslav Lichvar <mlichvar@redhat.com> 2.3-3
- rediff patches with fuzz
* Thu Mar 13 2008 Lubomir Kundrak <lkundrak@redhat.com> 2.3-2
- Add ChangeLog to %%doc
* Sun Feb 24 2008 Lubomir Kundrak <lkundrak@redhat.com> 2.3-1
- 2.3
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-6
- Autorebuild for GCC 4.3
* Sun Sep 23 2007 Lubomir Kundrak <lkundrak@redhat.com> 2.2-5
- Fix capture file handling (#302081)
* Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> 2.2-4
- update license tag
* Wed Jul 25 2007 Miroslav Lichvar <mlichvar@redhat.com> 2.2-3
- check for errors on tty device (#248701)
* Tue Jul 10 2007 Miroslav Lichvar <mlichvar@redhat.com> 2.2-2
- improve signal handling a bit (#246465)
* Fri Mar 09 2007 Miroslav Lichvar <mlichvar@redhat.com> 2.2-1
- update to 2.2
- handle filenames with spaces (#98655)
- add requires for lrzsz
- spec cleanup
* Tue Jul 18 2006 Martin Stransky <stransky@redhat.com> 2.1-3
- removed unnecessary debug output (#199707)
* Tue Jul 18 2006 Martin Stransky <stransky@redhat.com> 2.1-2
- added ncurses-devel to BuildPrereq
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.1-1.2.2
- rebuild
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.1-1.2.1
- bump again for double-long bug on ppc(64)
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.1-1.2
- rebuilt for new gcc4.1 snapshot and glibc changes
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt
* Thu Jul 14 2005 Martin Stransky <stransky@redhat.com> 2.1-1
- New upstream version
* Mon Mar 7 2005 Martin Stransky <stransky@redhat.com>
- gcc4 patch
* Wed Oct 20 2004 Adrian Havill <havill@redhat.com> 2.00.0-20
- correct an off-by-one error array-store error (#110770)
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri Sep 12 2003 Adrian Havill <havill@redhat.com> 2.00.0-17.1
- bump n-v-r for RHEL
* Fri Sep 12 2003 Adrian Havill <havill@redhat.com> 2.00.0-17
- fix error handling for the case when you attempt to "goto" a dir
that doesn't exist. (#103902)
- updated URL in spec file
* Thu Aug 21 2003 Adrian Havill <havill@redhat.com> 2.00.0-16.1
- bump n-v-r for RHEL
* Thu Aug 21 2003 Adrian Havill <havill@redhat.com> 2.00.0-16
- don't overwrite buffer when ins chars (#98733)
* Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 2.00.0-15.1
- bump n-v-r for RHEL
* Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 2.00.0-15
- initialize savetrans, check vttrans to prevent segfaults with
certain ESC sequences (#84129)
* Fri Aug 01 2003 Adrian Havill <havill@redhat.com> 2.00.0-14
- removed static buffers that limit multi-file zmodem functionality (#98654)
- removed assertions from above patch, massage out conflicts with rh patch
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
- rebuilt
* Sat Jan 18 2003 Mike A. Harris <mharris@redhat.com> 2.00.0-11
- Update spec file URL to new homepage (#71894)
* Mon Dec 2 2002 Tim Powers <timp@redhat.com> 2.00.0-10
- add PreReq coreutils so that we get the ordering right in the
install
* Wed Nov 13 2002 Mike A. Harris <mharris@redhat.com> 2.00.0-9
- Added find_lang macro andlang files to package, also avoiding
_unpackaged_files_terminate_build
- Added with_desktop_menu_entry macro to disable minicom.desktop by default
* Tue Oct 8 2002 Mike A. Harris <mharris@redhat.com> 2.00.0-8
- All-arch rebuild
- Make /etc/minicom.users config(noreplace)
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Sun May 26 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Tue May 21 2002 Mike A. Harris <mharris@redhat.com> 2.00.0-4
- Rebuilt in new build environment
* Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 2.00.0-3
- Rebuilt in new build environment
* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 2.00.0-2
- automated rebuild
* Wed Nov 21 2001 Mike A. Harris <mharris@redhat.com> 2.00.0-1
- Updated to version 2.00.0-0, which now uses GNU autoconf for everything,
to ease portability and internationalization issues. Hold on for the
ride, as there's bound to be some bumps on the way. ;o) On the up side,
the packaging is likely to be MUCH more maintainable in the future, which
is very nice to see.
- Disabled most patches as they are either included now, not needed, or
it has yet to be determined.
* Fri Oct 12 2001 Trond Eivind Glomsrød <teg@redhat.com> 1.83.1-17
- Delete bad entries in ko.po, fix charset in ja.po
* Tue Aug 28 2001 Jeff Johnson <jbj@redhat.com>
- map specific errno's into status for return from helper.
* Tue Aug 14 2001 Jeff Johnson <jbj@redhat.com>
- rebuild against unzigged lockdev-1.0.0-11 (#51577).
- add BuildPrereq: on lockdev-devel, not /usr/include/baudboy.h.
* Sun Aug 12 2001 Mike A. Harris <mharris@redhat.com> 1.83.1-14
- Added Requires: lockdev (#51576)
- s/Copyright/License/
* Sat Jul 28 2001 Jeff Johnson <jbj@redhat.com>
- use baudboy for serial port locking.
* Mon Jul 23 2001 Mike A. Harris <mharris@redhat.com> 1.83.1-12
- Added minicom-1.83.1-disable-message.patch to disable warning message and
delay when running minicom as root since root-only is the only supported
method of running minicom now due to security issues.
* Sat Jul 21 2001 Tim Powers <timp@redhat.com> 1.83.1-11
- no minicom applnk entry. Is cluttering up the menus
* Tue Jun 19 2001 Florian La Roche <Florian.LaRoche@redhat.de>
- add ExcludeArch: s390 s390x
- allow to build with newer gettext versions
* Thu May 3 2001 Mike A. Harris <mharris@redhat.com> 1.83.1-8
- Changed minicom to disable SGID/SUID operation completely as it was
never designed to be secure, and likely never will be. (#35613)
- Updated the format string patch I made to fix more format string abuses.
- Added Czeck cs_CZ locale translations.
* Thu Apr 12 2001 Mike A. Harris <mharris@redhat.com>
- Fixed format string vuln in usage of do_log() (bug #35613)
- Fixed misc other format string abuse with werror().
- Changed main tarball to bzip2 compression
- Corrected Buildroot to use _tmppath
* Tue Mar 27 2001 Crutcher Dunnavant <crutcher@redhat.com>
- patch to drop mask for config file
* Fri Feb 23 2001 Jakub Jelinek <jakub@redhat.com>
- fix build under glibc 2.2.2
* Thu Aug 24 2000 Bill Nottingham <notting@redhat.com>
- drop privs on opening of capture file
* Fri Aug 4 2000 Bill Nottingham <notting@redhat.com>
- add translation to desktop entry
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
- automatic rebuild
* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
- update to 1.83.1
* Wed Apr 5 2000 Bill Nottingham <notting@redhat.com>
- rebuild against current ncurses/readline
* Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
- rebuild for sparc baud rates > 38400.
* Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
- wmconfig -> desktop
* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
- fix description
* Fri Dec 17 1999 Bill Nottingham <notting@redhat.com>
- update to 1.83.0
* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
- update to 1.82.1
- s/sunsite/metalab
* Wed May 19 1999 Jeff Johnson <jbj@redhat.com>
- restore setgid uucp to permit minicom to lock in /var/lock (#2922).
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
- auto rebuild in the new build environment (release 5)
* Sun Jan 24 1999 Michael Maher <mike@redhat.com>
- fixed bug, changed groups.
* Thu Oct 01 1998 Cristian Gafton <gafton@redhat.com>
- updated to 1.82 to include i18n fixes
* Wed Sep 02 1998 Michael Maher <mike@redhat.com>
- Built package for 5.2.
* Sun May 10 1998 Cristian Gafton <gafton@redhat.com>
- security fixes (alan cox, but he forgot about the changelog)
* Thu May 07 1998 Prospector System <bugs@redhat.com>
- translations modified for de, fr, tr
* Thu May 07 1998 Cristian Gafton <gafton@redhat.com>
- BuildRoot; updated .make patch to cope with the buildroot
- fixed the spec file
* Wed May 06 1998 Michael Maher <mike@redhat.com>
- update of package (1.81)
* Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
- added wmconfig entries
* Tue Oct 21 1997 Otto Hammersmith <otto@redhat.com>
- fixed source url
* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
- built against glibc