Disable lock path config when built with lockdev (#754235)
This commit is contained in:
parent
c03b9781dd
commit
416173820c
27
minicom-2.6.1-disable-lock-path-config-with-lockdev.patch
Normal file
27
minicom-2.6.1-disable-lock-path-config-with-lockdev.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
diff -Naur minicom-2.6.1.orig/src/config.c minicom-2.6.1/src/config.c
|
||||||
|
--- minicom-2.6.1.orig/src/config.c 2011-12-27 23:23:10.000000000 +0100
|
||||||
|
+++ minicom-2.6.1/src/config.c 2013-01-23 12:22:04.231148834 +0100
|
||||||
|
@@ -545,7 +545,11 @@
|
||||||
|
|
||||||
|
w = mc_wopen(5, 4, 75, 12, BDOUBLE, stdattr, mfcolor, mbcolor, 0, 0, 1);
|
||||||
|
mc_wprintf(w, "%s %.41s\n", serial_device, P_PORT);
|
||||||
|
+#if !HAVE_LOCKDEV
|
||||||
|
mc_wprintf(w, "%s %.41s\n", lockfile_location, P_LOCK);
|
||||||
|
+#else
|
||||||
|
+ mc_wprintf(w, "\n");
|
||||||
|
+#endif
|
||||||
|
mc_wprintf(w, "%s %.41s\n", callin_program, P_CALLIN);
|
||||||
|
mc_wprintf(w, "%s %.41s\n", callout_program, P_CALLOUT);
|
||||||
|
mc_wprintf(w, "%s %s %s%s%s\n",
|
||||||
|
@@ -565,9 +569,11 @@
|
||||||
|
case 'A':
|
||||||
|
pgets(w, mbslen (serial_device) + 1, 0, P_PORT, 64, 64, 1);
|
||||||
|
break;
|
||||||
|
+#if !HAVE_LOCKDEV
|
||||||
|
case 'B':
|
||||||
|
pgets(w, mbslen (lockfile_location) + 1, 1, P_LOCK, 64, 64, 1);
|
||||||
|
break;
|
||||||
|
+#endif
|
||||||
|
case 'C':
|
||||||
|
pgets(w, mbslen (callin_program) + 1, 2, P_CALLIN, 64, 64, 1);
|
||||||
|
break;
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A text-based modem control and terminal emulation program
|
Summary: A text-based modem control and terminal emulation program
|
||||||
Name: minicom
|
Name: minicom
|
||||||
Version: 2.6.1
|
Version: 2.6.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
URL: http://alioth.debian.org/projects/minicom/
|
URL: http://alioth.debian.org/projects/minicom/
|
||||||
License: GPL+ and GPLv2+ and GPLv2 and Public Domain and Copyright only
|
License: GPL+ and GPLv2+ and GPLv2 and Public Domain and Copyright only
|
||||||
Group: Applications/Communications
|
Group: Applications/Communications
|
||||||
@ -12,6 +12,7 @@ Requires: lockdev lrzsz
|
|||||||
Source0: https://alioth.debian.org/frs/download.php/3700/minicom-2.6.1.tar.gz
|
Source0: https://alioth.debian.org/frs/download.php/3700/minicom-2.6.1.tar.gz
|
||||||
|
|
||||||
Patch5: minicom-2.5-de-ANSI-fication-removed.patch
|
Patch5: minicom-2.5-de-ANSI-fication-removed.patch
|
||||||
|
Patch6: minicom-2.6.1-disable-lock-path-config-with-lockdev.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Minicom is a simple text-based modem control and terminal emulation
|
Minicom is a simple text-based modem control and terminal emulation
|
||||||
@ -22,6 +23,7 @@ language, and other features.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch5 -p1 -b .deansi
|
%patch5 -p1 -b .deansi
|
||||||
|
%patch6 -p1 -b .lockcfg
|
||||||
|
|
||||||
cp -pr doc doc_
|
cp -pr doc doc_
|
||||||
rm -f doc_/Makefile*
|
rm -f doc_/Makefile*
|
||||||
@ -48,6 +50,9 @@ mkdir -p %{buildroot}%{_sysconfdir}
|
|||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 23 2013 Jaromir Capik <jcapik@redhat.com> - 2.6.1-2
|
||||||
|
- Disable lock path config when built with lockdev (#754235)
|
||||||
|
|
||||||
* Tue Jan 22 2013 Jaromir Capik <jcapik@redhat.com> - 2.6.1-1
|
* Tue Jan 22 2013 Jaromir Capik <jcapik@redhat.com> - 2.6.1-1
|
||||||
- Update to 2.6.1
|
- Update to 2.6.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user