Update to 1.3.1
This commit is contained in:
parent
b65b64a252
commit
6cc69ea780
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@ zlib-1.2.3.tar.gz
|
|||||||
/zlib-1.2.11.tar.xz
|
/zlib-1.2.11.tar.xz
|
||||||
/zlib-1.2.12.tar.xz
|
/zlib-1.2.12.tar.xz
|
||||||
/zlib-1.2.13.tar.xz
|
/zlib-1.2.13.tar.xz
|
||||||
|
/zlib-1.3.1.tar.xz
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -rupN --no-dereference zlib-1.2.13/CMakeLists.txt zlib-1.2.13-new/CMakeLists.txt
|
diff -rupN --no-dereference zlib-1.3.1/CMakeLists.txt zlib-1.3.1-new/CMakeLists.txt
|
||||||
--- zlib-1.2.13/CMakeLists.txt 2022-10-13 07:06:55.000000000 +0200
|
--- zlib-1.3.1/CMakeLists.txt 2024-01-22 19:32:37.000000000 +0100
|
||||||
+++ zlib-1.2.13-new/CMakeLists.txt 2022-12-13 09:35:24.752040574 +0100
|
+++ zlib-1.3.1-new/CMakeLists.txt 2024-01-31 17:58:11.511530357 +0100
|
||||||
@@ -163,12 +163,16 @@ if(NOT CYGWIN)
|
@@ -167,12 +167,16 @@ if(NOT CYGWIN)
|
||||||
set_target_properties(zlib PROPERTIES VERSION ${ZLIB_FULL_VERSION})
|
set_target_properties(zlib PROPERTIES VERSION ${ZLIB_FULL_VERSION})
|
||||||
endif()
|
endif()
|
||||||
|
|
||||||
@ -9,7 +9,7 @@ diff -rupN --no-dereference zlib-1.2.13/CMakeLists.txt zlib-1.2.13-new/CMakeList
|
|||||||
+if(UNIX OR MINGW)
|
+if(UNIX OR MINGW)
|
||||||
# On unix-like platforms the library is almost always called libz
|
# On unix-like platforms the library is almost always called libz
|
||||||
set_target_properties(zlib zlibstatic PROPERTIES OUTPUT_NAME z)
|
set_target_properties(zlib zlibstatic PROPERTIES OUTPUT_NAME z)
|
||||||
if(NOT APPLE)
|
if(NOT APPLE AND NOT(CMAKE_SYSTEM_NAME STREQUAL AIX))
|
||||||
set_target_properties(zlib PROPERTIES LINK_FLAGS "-Wl,--version-script,\"${CMAKE_CURRENT_SOURCE_DIR}/zlib.map\"")
|
set_target_properties(zlib PROPERTIES LINK_FLAGS "-Wl,--version-script,\"${CMAKE_CURRENT_SOURCE_DIR}/zlib.map\"")
|
||||||
endif()
|
endif()
|
||||||
+ if(MINGW)
|
+ if(MINGW)
|
||||||
|
@ -1,13 +1,13 @@
|
|||||||
%{?mingw_package_header}
|
%{?mingw_package_header}
|
||||||
|
|
||||||
Name: mingw-zlib
|
Name: mingw-zlib
|
||||||
Version: 1.2.13
|
Version: 1.3.1
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: MinGW Windows zlib compression library
|
Summary: MinGW Windows zlib compression library
|
||||||
|
|
||||||
License: Zlib
|
License: Zlib
|
||||||
URL: http://www.zlib.net/
|
URL: https://www.zlib.net/
|
||||||
Source0: http://www.zlib.net/zlib-%{version}.tar.xz
|
Source0: https://www.zlib.net/zlib-%{version}.tar.xz
|
||||||
# Use UNIX naming convention for libraries
|
# Use UNIX naming convention for libraries
|
||||||
Patch0: mingw-zlib-cmake.patch
|
Patch0: mingw-zlib-cmake.patch
|
||||||
|
|
||||||
@ -105,6 +105,9 @@ rm -rf %{buildroot}%{mingw64_mandir}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 31 2024 Sandro Mani <manisandro@gmail.com> - 1.3.1-1
|
||||||
|
- Update to 1.3.1
|
||||||
|
|
||||||
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.13-5
|
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.13-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (zlib-1.2.13.tar.xz) = 9e7ac71a1824855ae526506883e439456b74ac0b811d54e94f6908249ba8719bec4c8d7672903c5280658b26cb6b5e93ecaaafe5cdc2980c760fa196773f0725
|
SHA512 (zlib-1.3.1.tar.xz) = 1e8e70b362d64a233591906a1f50b59001db04ca14aaffad522198b04680be501736e7d536b4191e2f99767e7001ca486cd802362cca2be05d5d409b83ea732d
|
||||||
|
Loading…
Reference in New Issue
Block a user