Fix widl default includedir (RHBZ #1047727)

This commit is contained in:
Erik van Pienbroek 2014-01-04 21:49:39 +01:00
parent bb63a50f0a
commit b45525908f
2 changed files with 30 additions and 1 deletions

View File

@ -0,0 +1,22 @@
--- a/mingw-w64-tools/widl/Makefile.am 2012-11-14 03:19:32.000000000 -0600
+++ b/mingw-w64-tools/widl/Makefile.am 2014-01-01 19:23:41.000000000 -0600
@@ -56,7 +56,7 @@ widl_SOURCES = src/widl.h \
include/winnls.h \
include/winnt.rh
-widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(includedir)/../$(target)/include\"
+widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(prefix)/$(target)/sys-root/mingw/include\"
widl_CFLAGS = -O3 -g -Wall -Wformat -Wpacked -Wmissing-declarations -Wimplicit-function-declaration -Wmissing-prototypes -Wstrict-aliasing=2
DISTCHECK_CONFIGURE_FLAGS = --host=$(host) --target=$(target)
--- a/mingw-w64-tools/widl/Makefile.in 2012-11-14 03:19:32.000000000 -0600
+++ b/mingw-w64-tools/widl/Makefile.in 2014-01-01 19:24:08.137423600 -0600
@@ -282,7 +282,7 @@ widl_SOURCES = src/widl.h \
include/winnls.h \
include/winnt.rh
-widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(includedir)/../$(target)/include\"
+widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(prefix)/$(target)/sys-root/mingw/include\"
widl_CFLAGS = -O3 -g -Wall -Wformat -Wpacked -Wmissing-declarations -Wimplicit-function-declaration -Wmissing-prototypes -Wstrict-aliasing=2
DISTCHECK_CONFIGURE_FLAGS = --host=$(host) --target=$(target)
all: all-am

View File

@ -4,7 +4,7 @@
Name: mingw-w64-tools Name: mingw-w64-tools
Version: 2.0.999 Version: 2.0.999
Release: 0.9.%{branch}.r%{snapshot_rev}.%{snapshot_date}%{?dist} Release: 0.10.%{branch}.r%{snapshot_rev}.%{snapshot_date}%{?dist}
Summary: Supplementary tools which are part of the mingw-w64 toolchain Summary: Supplementary tools which are part of the mingw-w64 toolchain
# http://sourceforge.net/mailarchive/forum.php?thread_name=5157C0FC.1010309%40users.sourceforge.net&forum_name=mingw-w64-public # http://sourceforge.net/mailarchive/forum.php?thread_name=5157C0FC.1010309%40users.sourceforge.net&forum_name=mingw-w64-public
@ -26,6 +26,9 @@ Source0: http://downloads.sourceforge.net/project/mingw-w64/mingw-w64/min
# just to make widl to build on s390 # just to make widl to build on s390
Patch0: %{name}-2.0.999-s390.patch Patch0: %{name}-2.0.999-s390.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1047727
Patch1: %{name}-2.0.999-widl-includedir.patch
BuildRequires: mingw32-filesystem >= 95 BuildRequires: mingw32-filesystem >= 95
BuildRequires: mingw64-filesystem >= 95 BuildRequires: mingw64-filesystem >= 95
@ -46,6 +49,7 @@ unzip %{S:0}
%setup -q -n mingw-w64-v%{version} %setup -q -n mingw-w64-v%{version}
%endif %endif
%patch0 -p2 -b .s390 %patch0 -p2 -b .s390
%patch1 -p1 -b .widl-includedir
%build %build
@ -97,6 +101,9 @@ popd
%changelog %changelog
* Wed Jan 1 2014 Yaakov Selkowitz <yselkowitz@users.sourceforge.net> - 2.0.999-0.10.trunk.r6228.20130907
- Fix widl default includedir (RHBZ #1047727)
* Sat Sep 7 2013 Erik van Pienbroek <epienbro@fedoraproject.org> - 2.0.999-0.9.trunk.r6228.20130907 * Sat Sep 7 2013 Erik van Pienbroek <epienbro@fedoraproject.org> - 2.0.999-0.9.trunk.r6228.20130907
- Update to r6228 (20130907 snapshot) - Update to r6228 (20130907 snapshot)
- Updated instructions to regenerate snapshots - Updated instructions to regenerate snapshots