Update to 6.0.0
This commit is contained in:
parent
aff09d92be
commit
52ec381e16
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
||||
/mingw-w64-v5.0.2.tar.bz2
|
||||
/mingw-w64-v5.0.3.tar.bz2
|
||||
/mingw-w64-v5.0.4.tar.bz2
|
||||
/mingw-w64-v6.0.0.tar.bz2
|
||||
|
@ -1,16 +1,16 @@
|
||||
diff -up mingw-w64-v2.0.999/mingw/mingw-w64-tools/widl/include/basetsd.h.s390 mingw-w64-v2.0.999/mingw/mingw-w64-tools/widl/include/basetsd.h
|
||||
--- mingw-w64-v2.0.999/mingw/mingw-w64-tools/widl/include/basetsd.h.s390 2012-01-24 11:11:33.000000000 +0100
|
||||
+++ mingw-w64-v2.0.999/mingw/mingw-w64-tools/widl/include/basetsd.h 2012-03-28 14:18:17.000000000 +0200
|
||||
@@ -36,7 +36,7 @@
|
||||
diff -rupN mingw-w64-v6.0.0/mingw-w64-tools/widl/include/basetsd.h mingw-w64-v6.0.0-new/mingw-w64-tools/widl/include/basetsd.h
|
||||
--- mingw-w64-v6.0.0/mingw-w64-tools/widl/include/basetsd.h 2018-09-14 16:16:43.000000000 +0200
|
||||
+++ mingw-w64-v6.0.0-new/mingw-w64-tools/widl/include/basetsd.h 2019-05-07 17:55:56.077196349 +0200
|
||||
@@ -36,7 +36,7 @@ extern "C" {
|
||||
* 64-bit.
|
||||
*/
|
||||
|
||||
-#if (defined(__x86_64__) || defined(__powerpc64__) || defined(__sparc64__) || defined(__aarch64__)) && !defined(_WIN64)
|
||||
+#if (defined(__x86_64__) || defined(__powerpc64__) || defined(__sparc64__) || defined(__aarch64__) || defined(__s390x__)) && !defined(_WIN64)
|
||||
-#if (defined(__x86_64__) || defined(__powerpc64__) || defined(__aarch64__)) && !defined(_WIN64)
|
||||
+#if (defined(__x86_64__) || defined(__powerpc64__) || defined(__aarch64__) || defined(__s390x__)) && !defined(_WIN64)
|
||||
#define _WIN64
|
||||
#endif
|
||||
|
||||
@@ -305,6 +305,10 @@ typedef ULONG_PTR KAFFINITY, *PKAFFINITY
|
||||
@@ -309,6 +309,10 @@ typedef ULONG_PTR KAFFINITY, *PKAFFINITY
|
||||
# undef WORDS_BIGENDIAN
|
||||
# undef BITFIELDS_BIGENDIAN
|
||||
# undef ALLOW_UNALIGNED_ACCESS
|
||||
@ -21,10 +21,10 @@ diff -up mingw-w64-v2.0.999/mingw/mingw-w64-tools/widl/include/basetsd.h.s390 mi
|
||||
#elif !defined(RC_INVOKED) && !defined(__WIDL__) && !defined(__midl)
|
||||
# error Unknown CPU architecture!
|
||||
#endif
|
||||
diff -up mingw-w64-v2.0.999/mingw/mingw-w64-tools/widl/include/winnt.h.s390 mingw-w64-v2.0.999/mingw/mingw-w64-tools/widl/include/winnt.h
|
||||
--- mingw-w64-v2.0.999/mingw/mingw-w64-tools/widl/include/winnt.h.s390 2012-01-24 11:11:33.000000000 +0100
|
||||
+++ mingw-w64-v2.0.999/mingw/mingw-w64-tools/widl/include/winnt.h 2012-03-28 14:20:07.000000000 +0200
|
||||
@@ -1910,6 +1910,36 @@ typedef struct _CONTEXT
|
||||
diff -rupN mingw-w64-v6.0.0/mingw-w64-tools/widl/include/winnt.h mingw-w64-v6.0.0-new/mingw-w64-tools/widl/include/winnt.h
|
||||
--- mingw-w64-v6.0.0/mingw-w64-tools/widl/include/winnt.h 2018-09-14 16:16:43.000000000 +0200
|
||||
+++ mingw-w64-v6.0.0-new/mingw-w64-tools/widl/include/winnt.h 2019-05-07 17:55:56.078196338 +0200
|
||||
@@ -2108,6 +2108,36 @@ typedef struct _STACK_FRAME_HEADER
|
||||
|
||||
#endif /* __powerpc__ */
|
||||
|
||||
|
@ -1,22 +1,24 @@
|
||||
--- mingw-w64-v5.0.2/mingw-w64-tools/widl/Makefile.am.orig 2017-06-19 12:09:10.579443494 +0200
|
||||
+++ mingw-w64-v5.0.2/mingw-w64-tools/widl/Makefile.am 2017-06-19 12:09:44.896439319 +0200
|
||||
@@ -58,7 +58,7 @@
|
||||
diff -rupN mingw-w64-v6.0.0/mingw-w64-tools/widl/Makefile.am mingw-w64-v6.0.0-new/mingw-w64-tools/widl/Makefile.am
|
||||
--- mingw-w64-v6.0.0/mingw-w64-tools/widl/Makefile.am 2018-09-14 16:16:43.000000000 +0200
|
||||
+++ mingw-w64-v6.0.0-new/mingw-w64-tools/widl/Makefile.am 2019-05-07 17:55:56.298194052 +0200
|
||||
@@ -58,7 +58,7 @@ widl_SOURCES = src/widl.h \
|
||||
include/pathtools.h \
|
||||
include/winnt.rh
|
||||
|
||||
-widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(includedir)/../$(target)/include\" -DDEFAULT_BINDIR=\"$(bindir)\"
|
||||
+widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(prefix)/$(target)/sys-root/mingw/include\" -DDEFAULT_BINDIR=\"$(bindir)\"
|
||||
widl_CFLAGS = -Wall -Wformat -Wpacked -Wmissing-declarations -Wimplicit-function-declaration -Wmissing-prototypes -Wstrict-aliasing=2
|
||||
widl_CFLAGS = -O3 -g -Wall -Wformat -Wpacked -Wmissing-declarations -Wimplicit-function-declaration -Wmissing-prototypes -Wstrict-aliasing=2
|
||||
|
||||
DISTCHECK_CONFIGURE_FLAGS = --host=$(host) --target=$(target)
|
||||
--- mingw-w64-v5.0.2/mingw-w64-tools/widl/Makefile.in.orig 2017-06-19 12:09:18.051442585 +0200
|
||||
+++ mingw-w64-v5.0.2/mingw-w64-tools/widl/Makefile.in 2017-06-19 12:10:12.177436000 +0200
|
||||
@@ -285,7 +285,7 @@
|
||||
diff -rupN mingw-w64-v6.0.0/mingw-w64-tools/widl/Makefile.in mingw-w64-v6.0.0-new/mingw-w64-tools/widl/Makefile.in
|
||||
--- mingw-w64-v6.0.0/mingw-w64-tools/widl/Makefile.in 2018-09-14 16:16:43.000000000 +0200
|
||||
+++ mingw-w64-v6.0.0-new/mingw-w64-tools/widl/Makefile.in 2019-05-07 17:55:56.299194042 +0200
|
||||
@@ -368,7 +368,7 @@ widl_SOURCES = src/widl.h \
|
||||
include/pathtools.h \
|
||||
include/winnt.rh
|
||||
|
||||
-widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(includedir)/../$(target)/include\" -DDEFAULT_BINDIR=\"$(bindir)\"
|
||||
+widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(prefix)/$(target)/sys-root/mingw/include\" -DDEFAULT_BINDIR=\"$(bindir)\"
|
||||
widl_CFLAGS = -Wall -Wformat -Wpacked -Wmissing-declarations -Wimplicit-function-declaration -Wmissing-prototypes -Wstrict-aliasing=2
|
||||
widl_CFLAGS = -O3 -g -Wall -Wformat -Wpacked -Wmissing-declarations -Wimplicit-function-declaration -Wmissing-prototypes -Wstrict-aliasing=2
|
||||
DISTCHECK_CONFIGURE_FLAGS = --host=$(host) --target=$(target)
|
||||
all: all-am
|
||||
|
@ -4,8 +4,8 @@
|
||||
#%%global branch trunk
|
||||
|
||||
Name: mingw-w64-tools
|
||||
Version: 5.0.4
|
||||
Release: 3%{?dist}
|
||||
Version: 6.0.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Supplementary tools which are part of the mingw-w64 toolchain
|
||||
|
||||
# http://sourceforge.net/mailarchive/forum.php?thread_name=5157C0FC.1010309%40users.sourceforge.net&forum_name=mingw-w64-public
|
||||
@ -45,12 +45,10 @@ rm -rf mingw-w64-v%{version}
|
||||
mkdir mingw-w64-v%{version}
|
||||
cd mingw-w64-v%{version}
|
||||
unzip %{S:0}
|
||||
%setup -q -D -T -n mingw-w64-v%{version}/mingw-w64-mingw-w64-%{snapshot_rev}
|
||||
%autosetup -p1 -D -T -n mingw-w64-v%{version}/mingw-w64-mingw-w64-%{snapshot_rev}
|
||||
%else
|
||||
%setup -q -n mingw-w64-v%{version}
|
||||
%autosetup -p1 -n mingw-w64-v%{version}
|
||||
%endif
|
||||
%patch0 -p2 -b .s390
|
||||
%patch1 -p1 -b .widl-includedir
|
||||
|
||||
|
||||
%build
|
||||
@ -102,6 +100,9 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue May 07 2019 Sandro Mani <manisandro@gmail.com> - 6.0.0-1
|
||||
- Update to 6.0.0
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mingw-w64-v5.0.4.tar.bz2) = 5b279222e86475a982e2aeb9fc14853f4fac0ca0c5a2d56f303584d1b348726afd99b0292a5ed050d326e7cb1434e5ad5b5dfdfb37c73fd08f13e7f4f4bcc046
|
||||
SHA512 (mingw-w64-v6.0.0.tar.bz2) = e3d3663e0cb33a16f90b1a33e81b5a30d26f7e34270b14e865c10068f2a2d32da9ef8cbbb0c3fed9c71429ae11c82152ff3b87d81558929b2a4993dc99cfc11e
|
||||
|
Loading…
Reference in New Issue
Block a user