Update to 5.0.2
This commit is contained in:
parent
faff1d1501
commit
46b5e9db40
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
|||||||
/mingw-w64-code-6559-trunk.zip
|
/mingw-w64-code-6559-trunk.zip
|
||||||
/mingw-w64-mingw-w64-502c72047e68fecf07f628628b75296863ff5b35.zip
|
/mingw-w64-mingw-w64-502c72047e68fecf07f628628b75296863ff5b35.zip
|
||||||
/mingw-w64-mingw-w64-430863ffea2f6101fbfc0ee35ee098ab2f96b53c.zip
|
/mingw-w64-mingw-w64-430863ffea2f6101fbfc0ee35ee098ab2f96b53c.zip
|
||||||
|
/mingw-w64-v5.0.2.tar.bz2
|
||||||
|
@ -0,0 +1,35 @@
|
|||||||
|
From 8243669e8dba9220d7a30b5eb3617b2ecedae4d8 Mon Sep 17 00:00:00 2001
|
||||||
|
From: sezero <sezero@users.sourceforge.net>
|
||||||
|
Date: Thu, 15 Jun 2017 09:45:52 +0300
|
||||||
|
Subject: [PATCH 1/2] genpeimg.c (pass_args): add a /* fallthru */ comment in
|
||||||
|
the switch after show_usage() to avoid -Wimplicit-fallthrough (show_usage):
|
||||||
|
mark the function with noreturn attribute.
|
||||||
|
|
||||||
|
---
|
||||||
|
mingw-w64-tools/genpeimg/src/genpeimg.c | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/mingw-w64-tools/genpeimg/src/genpeimg.c b/mingw-w64-tools/genpeimg/src/genpeimg.c
|
||||||
|
index f8ac44e1..19bc5e2c 100644
|
||||||
|
--- a/mingw-w64-tools/genpeimg/src/genpeimg.c
|
||||||
|
+++ b/mingw-w64-tools/genpeimg/src/genpeimg.c
|
||||||
|
@@ -28,7 +28,7 @@ unsigned short mask_pe_opt_hdr_dll_chara = 0xffff;
|
||||||
|
int dump_information = 0;
|
||||||
|
static char *file_name = NULL;
|
||||||
|
|
||||||
|
-static void
|
||||||
|
+static void __attribute__((noreturn))
|
||||||
|
show_usage (void)
|
||||||
|
{
|
||||||
|
fprintf (stderr, "genpeimg [options] files...\n");
|
||||||
|
@@ -204,6 +204,7 @@ pass_args (int argc, char **argv)
|
||||||
|
case 'h':
|
||||||
|
if (h[2] == 0)
|
||||||
|
show_usage ();
|
||||||
|
+ /* fallthru */
|
||||||
|
default:
|
||||||
|
error_point:
|
||||||
|
fprintf (stderr, "Unknown option ,%s'\n", h);
|
||||||
|
--
|
||||||
|
2.13.0
|
||||||
|
|
@ -0,0 +1,49 @@
|
|||||||
|
From b5d311c8e573a17a7b9b38d303fa7db6dc45e98f Mon Sep 17 00:00:00 2001
|
||||||
|
From: sezero <sezero@users.sourceforge.net>
|
||||||
|
Date: Thu, 15 Jun 2017 09:50:00 +0300
|
||||||
|
Subject: [PATCH 2/2] gendef.c (getMemonic): add /* fallthru */ comments in the
|
||||||
|
switch to avoid -Wimplicit-fallthrough
|
||||||
|
|
||||||
|
---
|
||||||
|
mingw-w64-tools/gendef/src/gendef.c | 10 +++++-----
|
||||||
|
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/mingw-w64-tools/gendef/src/gendef.c b/mingw-w64-tools/gendef/src/gendef.c
|
||||||
|
index 9d3c7954..12fd1e73 100644
|
||||||
|
--- a/mingw-w64-tools/gendef/src/gendef.c
|
||||||
|
+++ b/mingw-w64-tools/gendef/src/gendef.c
|
||||||
|
@@ -836,7 +836,7 @@ disassembleRetIntern (uint32_t pc, uint32_t *retpop, sAddresses *seen, sAddresse
|
||||||
|
if (!sz || code == c_ill)
|
||||||
|
{
|
||||||
|
PRDEBUG(" %s = 0x08%x ILL (%u) at least one==%d\n",name,
|
||||||
|
- (unsigned int) pc, (unsigned int) sz,atleast_one[0]);
|
||||||
|
+ (unsigned int) pc, (unsigned int) sz,atleast_one[0]);
|
||||||
|
#if ENABLE_DEBUG == 1
|
||||||
|
{
|
||||||
|
unsigned char *ppc = (unsigned char *) map_va (pc);
|
||||||
|
@@ -1031,10 +1031,10 @@ redo_switch:
|
||||||
|
PRDEBUG(" 0x%x illegal ", (unsigned int) b);
|
||||||
|
#endif
|
||||||
|
*aCode=c_ill; return 0;
|
||||||
|
- case c_4: sz++;
|
||||||
|
- case c_3: sz++;
|
||||||
|
+ case c_4: sz++;/* fallthru */
|
||||||
|
+ case c_3: sz++;/* fallthru */
|
||||||
|
case c_lb:
|
||||||
|
- case c_2: sz++;
|
||||||
|
+ case c_2: sz++;/* fallthru */
|
||||||
|
case c_retn: case c_retf:
|
||||||
|
case c_iret: case c_int3:
|
||||||
|
case c_ad: case c_op:
|
||||||
|
@@ -1061,7 +1061,7 @@ redo_switch:
|
||||||
|
p = (unsigned char *) map_va (pc + sz);
|
||||||
|
if (!p) { *aCode=c_ill; return 0; }
|
||||||
|
#if ENABLE_DEBUG == 1
|
||||||
|
- enter_save_insn(lw,p[0]);
|
||||||
|
+ enter_save_insn(lw,p[0]);
|
||||||
|
#endif
|
||||||
|
b&=~0x7; b|=(p[0]&7);
|
||||||
|
sz+=1;
|
||||||
|
--
|
||||||
|
2.13.0
|
||||||
|
|
@ -1,22 +0,0 @@
|
|||||||
--- a/mingw-w64-tools/widl/Makefile.am 2012-11-14 03:19:32.000000000 -0600
|
|
||||||
+++ b/mingw-w64-tools/widl/Makefile.am 2014-01-01 19:23:41.000000000 -0600
|
|
||||||
@@ -56,7 +56,7 @@ widl_SOURCES = src/widl.h \
|
|
||||||
include/winnls.h \
|
|
||||||
include/winnt.rh
|
|
||||||
|
|
||||||
-widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(includedir)/../$(target)/include\"
|
|
||||||
+widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(prefix)/$(target)/sys-root/mingw/include\"
|
|
||||||
widl_CFLAGS = -O3 -g -Wall -Wformat -Wpacked -Wmissing-declarations -Wimplicit-function-declaration -Wmissing-prototypes -Wstrict-aliasing=2
|
|
||||||
|
|
||||||
DISTCHECK_CONFIGURE_FLAGS = --host=$(host) --target=$(target)
|
|
||||||
--- a/mingw-w64-tools/widl/Makefile.in 2012-11-14 03:19:32.000000000 -0600
|
|
||||||
+++ b/mingw-w64-tools/widl/Makefile.in 2014-01-01 19:24:08.137423600 -0600
|
|
||||||
@@ -282,7 +282,7 @@ widl_SOURCES = src/widl.h \
|
|
||||||
include/winnls.h \
|
|
||||||
include/winnt.rh
|
|
||||||
|
|
||||||
-widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(includedir)/../$(target)/include\"
|
|
||||||
+widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(prefix)/$(target)/sys-root/mingw/include\"
|
|
||||||
widl_CFLAGS = -O3 -g -Wall -Wformat -Wpacked -Wmissing-declarations -Wimplicit-function-declaration -Wmissing-prototypes -Wstrict-aliasing=2
|
|
||||||
DISTCHECK_CONFIGURE_FLAGS = --host=$(host) --target=$(target)
|
|
||||||
all: all-am
|
|
22
mingw-w64-tools-widl-includedir.patch
Normal file
22
mingw-w64-tools-widl-includedir.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- mingw-w64-v5.0.2/mingw-w64-tools/widl/Makefile.am.orig 2017-06-19 12:09:10.579443494 +0200
|
||||||
|
+++ mingw-w64-v5.0.2/mingw-w64-tools/widl/Makefile.am 2017-06-19 12:09:44.896439319 +0200
|
||||||
|
@@ -58,7 +58,7 @@
|
||||||
|
include/pathtools.h \
|
||||||
|
include/winnt.rh
|
||||||
|
|
||||||
|
-widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(includedir)/../$(target)/include\" -DDEFAULT_BINDIR=\"$(bindir)\"
|
||||||
|
+widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(prefix)/$(target)/sys-root/mingw/include\" -DDEFAULT_BINDIR=\"$(bindir)\"
|
||||||
|
widl_CFLAGS = -Wall -Wformat -Wpacked -Wmissing-declarations -Wimplicit-function-declaration -Wmissing-prototypes -Wstrict-aliasing=2
|
||||||
|
|
||||||
|
DISTCHECK_CONFIGURE_FLAGS = --host=$(host) --target=$(target)
|
||||||
|
--- mingw-w64-v5.0.2/mingw-w64-tools/widl/Makefile.in.orig 2017-06-19 12:09:18.051442585 +0200
|
||||||
|
+++ mingw-w64-v5.0.2/mingw-w64-tools/widl/Makefile.in 2017-06-19 12:10:12.177436000 +0200
|
||||||
|
@@ -285,7 +285,7 @@
|
||||||
|
include/pathtools.h \
|
||||||
|
include/winnt.rh
|
||||||
|
|
||||||
|
-widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(includedir)/../$(target)/include\" -DDEFAULT_BINDIR=\"$(bindir)\"
|
||||||
|
+widl_CPPFLAGS = -I$(top_srcdir)/include -DDEFAULT_INCLUDE_DIR=\"$(prefix)/$(target)/sys-root/mingw/include\" -DDEFAULT_BINDIR=\"$(bindir)\"
|
||||||
|
widl_CFLAGS = -Wall -Wformat -Wpacked -Wmissing-declarations -Wimplicit-function-declaration -Wmissing-prototypes -Wstrict-aliasing=2
|
||||||
|
DISTCHECK_CONFIGURE_FLAGS = --host=$(host) --target=$(target)
|
||||||
|
all: all-am
|
@ -1,11 +1,11 @@
|
|||||||
%global snapshot_date 20140530
|
#%%global snapshot_date 20140530
|
||||||
%global snapshot_rev 430863ffea2f6101fbfc0ee35ee098ab2f96b53c
|
#%%global snapshot_rev 430863ffea2f6101fbfc0ee35ee098ab2f96b53c
|
||||||
%global snapshot_rev_short %(echo %snapshot_rev | cut -c1-6)
|
#%%global snapshot_rev_short %(echo %snapshot_rev | cut -c1-6)
|
||||||
%global branch trunk
|
#%%global branch trunk
|
||||||
|
|
||||||
Name: mingw-w64-tools
|
Name: mingw-w64-tools
|
||||||
Version: 3.1.999
|
Version: 5.0.2
|
||||||
Release: 0.9.%{branch}.git%{snapshot_rev_short}.%{snapshot_date}%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Supplementary tools which are part of the mingw-w64 toolchain
|
Summary: Supplementary tools which are part of the mingw-w64 toolchain
|
||||||
|
|
||||||
# http://sourceforge.net/mailarchive/forum.php?thread_name=5157C0FC.1010309%40users.sourceforge.net&forum_name=mingw-w64-public
|
# http://sourceforge.net/mailarchive/forum.php?thread_name=5157C0FC.1010309%40users.sourceforge.net&forum_name=mingw-w64-public
|
||||||
@ -25,10 +25,14 @@ Source0: http://sourceforge.net/code-snapshots/git/m/mi/mingw-w64/mingw-w
|
|||||||
Source0: http://downloads.sourceforge.net/mingw-w64/mingw-w64-v%{version}.tar.bz2
|
Source0: http://downloads.sourceforge.net/mingw-w64/mingw-w64-v%{version}.tar.bz2
|
||||||
%endif
|
%endif
|
||||||
# just to make widl to build on s390
|
# just to make widl to build on s390
|
||||||
Patch0: %{name}-2.0.999-s390.patch
|
Patch0: mingw-w64-tools-2.0.999-s390.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1047727
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1047727
|
||||||
Patch1: %{name}-2.0.999-widl-includedir.patch
|
Patch1: mingw-w64-tools-widl-includedir.patch
|
||||||
|
|
||||||
|
# Backported from upstream
|
||||||
|
Patch2: 0001-genpeimg.c-pass_args-add-a-fallthru-comment-in-the-s.patch
|
||||||
|
Patch3: 0002-gendef.c-getMemonic-add-fallthru-comments-in-the-swi.patch
|
||||||
|
|
||||||
BuildRequires: mingw32-filesystem >= 95
|
BuildRequires: mingw32-filesystem >= 95
|
||||||
BuildRequires: mingw64-filesystem >= 95
|
BuildRequires: mingw64-filesystem >= 95
|
||||||
@ -51,6 +55,8 @@ unzip %{S:0}
|
|||||||
%endif
|
%endif
|
||||||
%patch0 -p2 -b .s390
|
%patch0 -p2 -b .s390
|
||||||
%patch1 -p1 -b .widl-includedir
|
%patch1 -p1 -b .widl-includedir
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -102,6 +108,9 @@ popd
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 19 2017 Kalev Lember <klember@redhat.com> - 5.0.2-1
|
||||||
|
- Update to 5.0.2
|
||||||
|
|
||||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.999-0.9.trunk.git430863.20140530
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.999-0.9.trunk.git430863.20140530
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user