Update to 3.7.14.1 and dropped unneeded patches/autotools

- Update to 3.7.14.1
- Dropped all patches which are not needed for the mingw target
- There's no need to re-run the autotools any more
This commit is contained in:
Erik van Pienbroek 2012-12-06 21:06:56 +01:00
parent 0163dcb8a8
commit bfaf1f713a
7 changed files with 9 additions and 126 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@ sqlite-3.6.22.tar.gz
/sqlite-src-3070500.zip
/sqlite-src-3070900.zip
/sqlite-src-3071300.zip
/sqlite-src-3071401.zip

View File

@ -2,8 +2,8 @@
%global name1 sqlite
%global realver 3071300
%global rpmver 3.7.13
%global realver 3071401
%global rpmver 3.7.14.1
# bcond default logic is nicely backwards...
%bcond_with tcl
@ -21,19 +21,6 @@ Source0: http://www.sqlite.org/%{name1}-src-%{realver}.zip
BuildArch: noarch
# Patches from Fedora native package.
# Support a system-wide lemon template
Patch1: sqlite-3.6.23-lemon-system-template.patch
# Shut up stupid tests depending on system settings of allowed open fd's
Patch2: sqlite-3.7.7.1-stupid-openfiles-test.patch
# Shut up pagecache overflow test whose expected result depends on compile
# options and whatnot. Dunno why this started failing in 3.7.10 but
# doesn't seem particularly critical...
Patch3: sqlite-3.7.10-pagecache-overflow-test.patch
# sqlite >= 3.7.10 is buggy if malloc_usable_size() is detected, disable it:
# https://bugzilla.redhat.com/show_bug.cgi?id=801981
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665363
Patch4: sqlite-3.7.11-no-malloc-usable-size.patch
# Patches for MinGW port.
Patch1000: mingw32-sqlite-3.7.9-no-undefined.patch
@ -51,9 +38,6 @@ BuildRequires: mingw64-pdcurses
BuildRequires: mingw64-readline
BuildRequires: mingw64-termcap
BuildRequires: autoconf
BuildRequires: libtool
BuildRequires: /usr/bin/tclsh
%if %{with tcl}
@ -147,17 +131,8 @@ This package contains static cross-compiled library
%prep
%setup -q -n %{name1}-src-%{realver}
%patch1 -p1 -b .lemon-system-template
%patch2 -p1 -b .stupid-openfiles-test
%patch3 -p1 -b .pagecache-overflow-test
%patch4 -p1 -b .no-malloc-usable-size
%patch1000 -p1
# Ships with an old/broken version of libtool which cannot create
# Windows libraries properly. So pull in the current version.
autoreconf
libtoolize --force
%build
# I think there's a bug in the configure script where, if
@ -243,6 +218,11 @@ find $RPM_BUILD_ROOT -name "*.la" -delete
%changelog
* Thu Dec 6 2012 Erik van Pienbroek <epienbro@fedoraproject.org> - 3.7.14.1-1
- Update to 3.7.14.1
- Dropped all patches which are not needed for the mingw target
- There's no need to re-run the autotools any more
* Tue Dec 4 2012 Thomas Sailer <t.sailer@alumni.ethz.ch> - 3.7.13-1
- update to 3.7.13

View File

@ -1 +1 @@
13bb3eaae94592ef3220ea23582763f5 sqlite-src-3071300.zip
c594594be4c5353ceb43caade87ca7d6 sqlite-src-3071401.zip

View File

@ -1,21 +0,0 @@
diff -up sqlite-3.6.23/tool/lemon.c.system-template sqlite-3.6.23/tool/lemon.c
--- sqlite-3.6.23/tool/lemon.c.system-template 2010-03-10 16:40:35.000000000 +0200
+++ sqlite-3.6.23/tool/lemon.c 2010-03-10 16:40:39.000000000 +0200
@@ -3106,6 +3106,8 @@ PRIVATE FILE *tplt_open(struct lemon *le
tpltname = buf;
}else if( access(templatename,004)==0 ){
tpltname = templatename;
+ }else if( access("/usr/share/lemon/lempar.c", R_OK)==0){
+ tpltname = "/usr/share/lemon/lempar.c";
}else{
tpltname = pathsearch(lemp->argv0,templatename,0);
}
@@ -3117,7 +3119,7 @@ PRIVATE FILE *tplt_open(struct lemon *le
}
in = fopen(tpltname,"rb");
if( in==0 ){
- fprintf(stderr,"Can't open the template file \"%s\".\n",templatename);
+ fprintf(stderr,"Can't open the template file \"%s\".\n",tpltname);
lemp->errorcnt++;
return 0;
}

View File

@ -1,17 +0,0 @@
diff -up sqlite-src-3071000/test/memsubsys1.test.testfail sqlite-src-3071000/test/memsubsys1.test
--- sqlite-src-3071000/test/memsubsys1.test.testfail 2012-03-07 18:05:32.916081341 +0200
+++ sqlite-src-3071000/test/memsubsys1.test 2012-03-07 18:06:43.354841101 +0200
@@ -122,9 +122,10 @@ build_test_db memsubsys1-3.1 {PRAGMA pag
do_test memsubsys1-3.1.3 {
set pg_used [lindex [sqlite3_status SQLITE_STATUS_PAGECACHE_USED 0] 2]
} 0
-do_test memsubsys1-3.1.4 {
- set overflow [lindex [sqlite3_status SQLITE_STATUS_PAGECACHE_OVERFLOW 0] 2]
-} $max_pagecache
+# The exact value returned here depends on compile options and whatnot, *shrug*
+#do_test memsubsys1-3.1.4 {
+# set overflow [lindex [sqlite3_status SQLITE_STATUS_PAGECACHE_OVERFLOW 0] 2]
+#} $max_pagecache
do_test memsubsys1-3.1.5 {
set s_used [lindex [sqlite3_status SQLITE_STATUS_SCRATCH_USED 0] 2]
} 0

View File

@ -1,24 +0,0 @@
diff -up sqlite-src-3071100/configure.ac.malloc_usable_size sqlite-src-3071100/configure.ac
--- sqlite-src-3071100/configure.ac.malloc_usable_size 2012-04-25 09:36:02.999684178 +0300
+++ sqlite-src-3071100/configure.ac 2012-04-25 09:36:21.415584431 +0300
@@ -127,7 +127,7 @@ AC_CHECK_HEADERS([sys/types.h stdlib.h s
#########
# Figure out whether or not we have these functions
#
-AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size])
+AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime])
#########
# By default, we use the amalgamation (this may be changed below...)
diff -up sqlite-src-3071100/configure.malloc_usable_size sqlite-src-3071100/configure
--- sqlite-src-3071100/configure.malloc_usable_size 2012-04-25 09:36:10.255643392 +0300
+++ sqlite-src-3071100/configure 2012-04-25 09:36:37.684496632 +0300
@@ -12148,7 +12148,7 @@ done
-for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size
+for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime
do
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
{ $as_echo "$as_me:$LINENO: checking for $ac_func" >&5

View File

@ -1,36 +0,0 @@
diff -up sqlite-src-3070701/test/oserror.test.openfiles sqlite-src-3070701/test/oserror.test
--- sqlite-src-3070701/test/oserror.test.openfiles 2011-07-13 09:56:46.025857411 +0300
+++ sqlite-src-3070701/test/oserror.test 2011-07-13 09:57:11.634759798 +0300
@@ -51,19 +51,19 @@ proc do_re_test {tn script expression} {
# a call to getcwd() may fail if there are no free file descriptors. So
# an error may be reported for either open() or getcwd() here.
#
-puts "Possible valgrind error about invalid file descriptor follows:"
-do_test 1.1.1 {
- set ::log [list]
- list [catch {
- for {set i 0} {$i < 2000} {incr i} { sqlite3 dbh_$i test.db -readonly 1 }
- } msg] $msg
-} {1 {unable to open database file}}
-do_test 1.1.2 {
- catch { for {set i 0} {$i < 2000} {incr i} { dbh_$i close } }
-} {1}
-do_re_test 1.1.3 {
- lindex $::log 0
-} {^os_unix.c:\d+: \(\d+\) (open|getcwd)\(.*test.db\) - }
+#puts "Possible valgrind error about invalid file descriptor follows:"
+#do_test 1.1.1 {
+# set ::log [list]
+# list [catch {
+# for {set i 0} {$i < 2000} {incr i} { sqlite3 dbh_$i test.db -readonly 1 }
+# } msg] $msg
+#} {1 {unable to open database file}}
+#do_test 1.1.2 {
+# catch { for {set i 0} {$i < 2000} {incr i} { dbh_$i close } }
+#} {1}
+#do_re_test 1.1.3 {
+# lindex $::log 0
+#} {^os_unix.c:\d+: \(\d+\) (open|getcwd)\(.*test.db\) - }
# Test a failure in open() due to the path being a directory.