update to 3.10.1.0
This commit is contained in:
parent
d43a5f23e1
commit
b7c1dc3e40
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@ sqlite-3.6.22.tar.gz
|
||||
/sqlite-src-3080100.zip
|
||||
/sqlite-src-3080200.zip
|
||||
/sqlite-src-3080403.zip
|
||||
/sqlite-src-3100100.zip
|
||||
|
@ -2,8 +2,8 @@
|
||||
|
||||
%global name1 sqlite
|
||||
|
||||
%global realver 3080403
|
||||
%global rpmver 3.8.4.3
|
||||
%global realver 3100100
|
||||
%global rpmver 3.10.1.0
|
||||
|
||||
# bcond default logic is nicely backwards...
|
||||
%bcond_with tcl
|
||||
@ -11,13 +11,13 @@
|
||||
|
||||
Name: mingw-%{name1}
|
||||
Version: %{rpmver}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: MinGW Windows port of sqlite embeddable SQL database engine
|
||||
|
||||
License: Public Domain
|
||||
Group: Applications/Databases
|
||||
URL: http://www.sqlite.org/
|
||||
Source0: http://www.sqlite.org/2014/%{name1}-src-%{realver}.zip
|
||||
Source0: http://www.sqlite.org/2016/%{name1}-src-%{realver}.zip
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -224,6 +224,9 @@ mv $RPM_BUILD_ROOT%{mingw64_libdir}/libsqlite3-0.dll $RPM_BUILD_ROOT%{mingw64_bi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jan 14 2016 Thomas Sailer <t.sailer@alumni.ethz.ch> - 3.10.1.0-1
|
||||
- update to 3.10.1.0
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.4.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
34cd453499e4b4564560accf24a9a70e sqlite-src-3080403.zip
|
||||
037618ad92945e7a394ffe7ddbb9a85c sqlite-src-3100100.zip
|
||||
|
@ -1,13 +1,13 @@
|
||||
--- configure.ac.orig 2013-05-12 17:08:29.934340680 +0200
|
||||
+++ configure.ac 2013-05-12 17:09:42.918555699 +0200
|
||||
@@ -233,25 +233,6 @@
|
||||
--- configure.ac.orig 2016-01-14 18:40:14.000000000 +0100
|
||||
+++ configure.ac 2016-01-14 13:36:30.906755007 +0100
|
||||
@@ -179,25 +179,6 @@
|
||||
AC_SUBST(BUILD_CC)
|
||||
|
||||
##########
|
||||
-# Do we want to support multithreaded use of sqlite
|
||||
-#
|
||||
-AC_ARG_ENABLE(threadsafe,
|
||||
-AC_HELP_STRING([--enable-threadsafe],[Support threadsafe operation]),,enable_threadsafe=yes)
|
||||
-AC_HELP_STRING([--disable-threadsafe],[Disable mutexing]),,enable_threadsafe=yes)
|
||||
-AC_MSG_CHECKING([whether to support threadsafe operation])
|
||||
-if test "$enable_threadsafe" = "no"; then
|
||||
- SQLITE_THREADSAFE=0
|
||||
@ -23,10 +23,10 @@
|
||||
-fi
|
||||
-
|
||||
-##########
|
||||
# Do we want to allow a connection created in one thread to be used
|
||||
# in another thread. This does not work on many Linux systems (ex: RedHat 9)
|
||||
# due to bugs in the threading implementations. This is thus off by default.
|
||||
@@ -365,6 +346,25 @@
|
||||
# Do we want to support release
|
||||
#
|
||||
AC_ARG_ENABLE(releasemode,
|
||||
@@ -284,6 +265,25 @@
|
||||
AC_SUBST(TARGET_EXEEXT)
|
||||
|
||||
##########
|
||||
|
Loading…
Reference in New Issue
Block a user