Update to 3.8.1
This commit is contained in:
parent
eee7ffbd55
commit
a10dc68039
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@ sqlite-3.6.22.tar.gz
|
||||
/sqlite-src-3071600.zip
|
||||
/sqlite-src-3071602.zip
|
||||
/sqlite-src-3071700.zip
|
||||
/sqlite-src-3080100.zip
|
||||
|
@ -2,8 +2,8 @@
|
||||
|
||||
%global name1 sqlite
|
||||
|
||||
%global realver 3071700
|
||||
%global rpmver 3.7.17
|
||||
%global realver 3080100
|
||||
%global rpmver 3.8.1
|
||||
|
||||
# bcond default logic is nicely backwards...
|
||||
%bcond_with tcl
|
||||
@ -11,7 +11,7 @@
|
||||
|
||||
Name: mingw-%{name1}
|
||||
Version: %{rpmver}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: MinGW Windows port of sqlite embeddable SQL database engine
|
||||
|
||||
License: Public Domain
|
||||
@ -21,9 +21,6 @@ Source0: http://www.sqlite.org/2013/%{name1}-src-%{realver}.zip
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
# Patches for MinGW port.
|
||||
Patch1000: mingw32-sqlite-3.7.9-no-undefined.patch
|
||||
|
||||
# Don't try to link against pthreads even if it is available
|
||||
Patch1001: sqlite-dont-search-for-pthreads-on-non-unix.patch
|
||||
|
||||
@ -140,8 +137,6 @@ This package contains static cross-compiled library
|
||||
%patch1001 -p0
|
||||
autoreconf -i --force
|
||||
|
||||
%patch1000 -p1
|
||||
|
||||
|
||||
%build
|
||||
# I think there's a bug in the configure script where, if
|
||||
@ -229,6 +224,9 @@ mv $RPM_BUILD_ROOT%{mingw64_libdir}/libsqlite3-0.dll $RPM_BUILD_ROOT%{mingw64_bi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Nov 20 2013 Erik van Pienbroek <epienbro@fedoraproject.org> - 3.8.1-1
|
||||
- Update to 3.8.1
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.7.17-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- sqlite-3.7.9/Makefile.in.orig 2009-03-30 18:37:16.000000000 +0200
|
||||
+++ sqlite-3.7.9/Makefile.in 2009-04-23 11:16:17.000000000 +0200
|
||||
@@ -486,14 +486,15 @@
|
||||
|
||||
libsqlite3.la: $(LIBOBJ)
|
||||
$(LTLINK) -o $@ $(LIBOBJ) $(TLIBS) \
|
||||
- ${ALLOWRELEASE} -rpath "$(libdir)" -version-info "8:6:8"
|
||||
+ ${ALLOWRELEASE} -rpath "$(libdir)" -version-info "8:6:8" \
|
||||
+ -no-undefined
|
||||
|
||||
libtclsqlite3.la: tclsqlite.lo libsqlite3.la
|
||||
$(LTLINK) -o $@ tclsqlite.lo \
|
||||
libsqlite3.la @TCL_STUB_LIB_SPEC@ $(TLIBS) \
|
||||
-rpath "$(TCLLIBDIR)" \
|
||||
-version-info "8:6:8" \
|
||||
- -avoid-version
|
||||
+ -avoid-version -no-undefined
|
||||
|
||||
sqlite3$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h
|
||||
$(LTLINK) $(READLINE_FLAGS) \
|
Loading…
Reference in New Issue
Block a user