update patches for 3.11.0.0

This commit is contained in:
Thomas Sailer 2016-02-18 11:45:32 +01:00
parent 48a52c3f65
commit 71daaa50ef
2 changed files with 6 additions and 22 deletions

View File

@ -1,5 +1,5 @@
--- configure.ac.pthread 2016-01-20 22:49:56.000000000 +0100
+++ configure.ac 2016-01-21 12:44:53.595296633 +0100
--- configure.ac.pthread 2016-02-18 11:40:40.177797402 +0100
+++ configure.ac 2016-02-18 11:41:34.232609836 +0100
@@ -193,7 +193,7 @@
fi
AC_SUBST(SQLITE_THREADSAFE)
@ -7,5 +7,5 @@
-if test "$SQLITE_THREADSAFE" = "1"; then
+if test "$SQLITE_THREADSAFE" = "1" -a "$SQLITE_OS_UNIX" = "1" ; then
AC_SEARCH_LIBS(pthread_create, pthread)
AC_SEARCH_LIBS(pthread_mutexattr_init, pthread)
fi

View File

@ -1,6 +1,6 @@
--- configure.ac.cc 2016-01-21 12:46:12.406557715 +0100
+++ configure.ac 2016-01-21 12:53:44.120566439 +0100
@@ -258,16 +258,7 @@
--- configure.ac.cc 2016-02-18 11:42:35.868255721 +0100
+++ configure.ac 2016-02-18 11:42:35.889255260 +0100
@@ -259,16 +259,7 @@
if test "$CYGWIN" != "yes"; then
AC_CYGWIN
fi
@ -18,19 +18,3 @@
if test "$TARGET_EXEEXT" = ".exe"; then
SQLITE_OS_UNIX=0
SQLITE_OS_WIN=1
--- Makefile.in.cc 2016-01-21 12:58:26.251338551 +0100
+++ Makefile.in 2016-01-21 12:58:46.044901935 +0100
@@ -1169,10 +1169,10 @@
lib_install: libsqlite3.la
$(INSTALL) -d $(DESTDIR)$(libdir)
$(LTINSTALL) libsqlite3.la $(DESTDIR)$(libdir)
-
-install: sqlite3$(BEXE) lib_install sqlite3.h sqlite3.pc ${HAVE_TCL:1=tcl_install}
+
+install: sqlite3$(TEXE) lib_install sqlite3.h sqlite3.pc ${HAVE_TCL:1=tcl_install}
$(INSTALL) -d $(DESTDIR)$(bindir)
- $(LTINSTALL) sqlite3$(BEXE) $(DESTDIR)$(bindir)
+ $(LTINSTALL) sqlite3$(TEXE) $(DESTDIR)$(bindir)
$(INSTALL) -d $(DESTDIR)$(includedir)
$(INSTALL) -m 0644 sqlite3.h $(DESTDIR)$(includedir)
$(INSTALL) -m 0644 $(TOP)/src/sqlite3ext.h $(DESTDIR)$(includedir)