30 lines
1.4 KiB
Diff
30 lines
1.4 KiB
Diff
diff -rupN --no-dereference readline-8.1/shlib/Makefile.in readline-8.1-new/shlib/Makefile.in
|
|
--- readline-8.1/shlib/Makefile.in 2020-10-29 20:47:57.000000000 +0100
|
|
+++ readline-8.1-new/shlib/Makefile.in 2021-01-09 10:49:54.218777248 +0100
|
|
@@ -178,7 +178,7 @@ $(SHARED_READLINE): $(SHARED_OBJ)
|
|
|
|
$(SHARED_HISTORY): $(SHARED_HISTOBJ) xmalloc.so xfree.so
|
|
$(RM) $@
|
|
- $(SHOBJ_LD) ${SHOBJ_LDFLAGS} ${SHLIB_XLDFLAGS} -o $@ $(SHARED_HISTOBJ) xmalloc.so xfree.so $(SHLIB_LIBS)
|
|
+ $(SHOBJ_LD) ${SHOBJ_LDFLAGS} ${SHLIB_XLDFLAGS} -o $@ $(SHARED_HISTOBJ) xmalloc.so xfree.so
|
|
|
|
# Since tilde.c is shared between readline and bash, make sure we compile
|
|
# it with the right flags when it's built as part of readline
|
|
diff -rupN --no-dereference readline-8.1/support/shobj-conf readline-8.1-new/support/shobj-conf
|
|
--- readline-8.1/support/shobj-conf 2019-12-13 15:51:17.000000000 +0100
|
|
+++ readline-8.1-new/support/shobj-conf 2021-01-09 10:49:54.219777248 +0100
|
|
@@ -126,10 +126,11 @@ sunos5*|solaris2*)
|
|
linux*-*|gnu*-*|k*bsd*-gnu-*|freebsd*|dragonfly*)
|
|
SHOBJ_CFLAGS=-fPIC
|
|
SHOBJ_LD='${CC}'
|
|
- SHOBJ_LDFLAGS='-shared -Wl,-soname,$@'
|
|
+ SHOBJ_LDFLAGS='$(CFLAGS) -shared -Wl,-soname,$@'
|
|
|
|
- SHLIB_XLDFLAGS='-Wl,-rpath,$(libdir) -Wl,-soname,`basename $@ $(SHLIB_MINOR)`'
|
|
+ SHLIB_XLDFLAGS='-Wl,-soname,`basename $@ $(SHLIB_MINOR)`'
|
|
SHLIB_LIBVERSION='$(SHLIB_LIBSUFF).$(SHLIB_MAJOR)$(SHLIB_MINOR)'
|
|
+ SHLIB_LIBS='-ltinfo'
|
|
;;
|
|
|
|
# Darwin/MacOS X
|