Update to 8.1
This commit is contained in:
parent
962820cf32
commit
8d8eed8166
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
readline-5.2.tar.gz
|
||||
/readline-6.2.tar.gz
|
||||
/readline-8.0.tar.gz
|
||||
/readline-8.1.tar.gz
|
||||
|
@ -1,8 +1,8 @@
|
||||
%{?mingw_package_header}
|
||||
|
||||
Name: mingw-readline
|
||||
Version: 8.0
|
||||
Release: 3%{?dist}
|
||||
Version: 8.1
|
||||
Release: 1%{?dist}
|
||||
Summary: MinGW port of readline for editing typed command lines
|
||||
|
||||
License: GPLv2+
|
||||
@ -10,7 +10,9 @@ URL: http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
|
||||
Source0: ftp://ftp.gnu.org/gnu/readline/readline-%{version}.tar.gz
|
||||
|
||||
# Remove RPATH, use CFLAGS
|
||||
Patch101: readline-8.0-shlib.patch
|
||||
Patch1: readline-8.0-shlib.patch
|
||||
# SIG_BLOCK is not available on MINGW, its use should have been guaded by HAVE_POSIX_SIGNALS
|
||||
Patch2: readline-8.1-posix-signals.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -142,6 +144,9 @@ rm -f %{buildroot}%{mingw64_datadir}/readline/*.c
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Jan 09 2021 Sandro Mani <manisandro@gmail.com> - 8.1-1
|
||||
- Update to 8.1
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 8.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
|
@ -1,29 +0,0 @@
|
||||
From 0597f0b34a0c93578b83f24ecca9e66d183728c5 Mon Sep 17 00:00:00 2001
|
||||
From: jchaloup <jchaloup@redhat.com>
|
||||
Date: Mon, 26 May 2014 13:02:02 +0200
|
||||
Subject: [PATCH] security fix for debug functions
|
||||
|
||||
---
|
||||
util.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/util.c b/util.c
|
||||
index 6c68ad8..bc50dc1 100644
|
||||
--- a/util.c
|
||||
+++ b/util.c
|
||||
@@ -468,6 +468,7 @@ _rl_savestring (s)
|
||||
return (strcpy ((char *)xmalloc (1 + (int)strlen (s)), (s)));
|
||||
}
|
||||
|
||||
+#if defined (DEBUG)
|
||||
#if defined (USE_VARARGS)
|
||||
static FILE *_rl_tracefp;
|
||||
|
||||
@@ -524,3 +525,4 @@ _rl_trclose ()
|
||||
}
|
||||
|
||||
#endif
|
||||
+#endif /* DEBUG */
|
||||
--
|
||||
1.9.0
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff --git a/shlib/Makefile.in b/shlib/Makefile.in
|
||||
index f2ec3e4..5c8994c 100644
|
||||
--- a/shlib/Makefile.in
|
||||
+++ b/shlib/Makefile.in
|
||||
diff -rupN --no-dereference readline-8.1/shlib/Makefile.in readline-8.1-new/shlib/Makefile.in
|
||||
--- readline-8.1/shlib/Makefile.in 2020-10-29 20:47:57.000000000 +0100
|
||||
+++ readline-8.1-new/shlib/Makefile.in 2021-01-09 10:49:54.218777248 +0100
|
||||
@@ -178,7 +178,7 @@ $(SHARED_READLINE): $(SHARED_OBJ)
|
||||
|
||||
$(SHARED_HISTORY): $(SHARED_HISTOBJ) xmalloc.so xfree.so
|
||||
@ -11,12 +10,11 @@ index f2ec3e4..5c8994c 100644
|
||||
|
||||
# Since tilde.c is shared between readline and bash, make sure we compile
|
||||
# it with the right flags when it's built as part of readline
|
||||
diff --git a/support/shobj-conf b/support/shobj-conf
|
||||
index 7920f1b..e7520cb 100644
|
||||
--- a/support/shobj-conf
|
||||
+++ b/support/shobj-conf
|
||||
diff -rupN --no-dereference readline-8.1/support/shobj-conf readline-8.1-new/support/shobj-conf
|
||||
--- readline-8.1/support/shobj-conf 2019-12-13 15:51:17.000000000 +0100
|
||||
+++ readline-8.1-new/support/shobj-conf 2021-01-09 10:49:54.219777248 +0100
|
||||
@@ -126,10 +126,11 @@ sunos5*|solaris2*)
|
||||
linux*-*|gnu*-*|k*bsd*-gnu-*|freebsd*-gentoo)
|
||||
linux*-*|gnu*-*|k*bsd*-gnu-*|freebsd*|dragonfly*)
|
||||
SHOBJ_CFLAGS=-fPIC
|
||||
SHOBJ_LD='${CC}'
|
||||
- SHOBJ_LDFLAGS='-shared -Wl,-soname,$@'
|
||||
@ -28,4 +26,4 @@ index 7920f1b..e7520cb 100644
|
||||
+ SHLIB_LIBS='-ltinfo'
|
||||
;;
|
||||
|
||||
freebsd2*)
|
||||
# Darwin/MacOS X
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (readline-8.0.tar.gz) = 41759d27bc3a258fefd7f4ff3277fa6ab9c21abb7b160e1a75aa8eba547bd90b288514e76264bd94fb0172da8a4faa54aab2c07b68a0356918ecf7f1969e866f
|
||||
SHA512 (readline-8.1.tar.gz) = 27790d0461da3093a7fee6e89a51dcab5dc61928ec42e9228ab36493b17220641d5e481ea3d8fee5ee0044c70bf960f55c7d3f1a704cf6b9c42e5c269b797e00
|
||||
|
Loading…
Reference in New Issue
Block a user