Fix build and memory allocation function
resolves: rhbz#2084608 - Fix mismatched allocation function resolves: rhbz#2084613 - qga-win: race condition in build Signed-off-by: Konstantin Kostiuk <kkostiuk@redhat.com>
This commit is contained in:
parent
3af6e50f0f
commit
5b0936a8c8
@ -14,6 +14,6 @@ index 91ff57278e..586de296f5 100644
|
||||
+++ b/VERSION
|
||||
@@ -1 +1 @@
|
||||
-7.0.0
|
||||
+104.0.1
|
||||
+104.0.2
|
||||
--
|
||||
2.17.2
|
||||
|
@ -0,0 +1,25 @@
|
||||
From 0b188ab30b32fc16adbcb2da768edfa0ec1fc805 Mon Sep 17 00:00:00 2001
|
||||
From: Konstantin Kostiuk <kkostiuk@redhat.com>
|
||||
Date: Thu, 12 May 2022 15:41:43 +0000
|
||||
Subject: [PATCH] qga-vss: Add auto generated headers to dependencies
|
||||
|
||||
Signed-off-by: Konstantin Kostiuk <kkostiuk@redhat.com>
|
||||
---
|
||||
qga/vss-win32/meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/qga/vss-win32/meson.build b/qga/vss-win32/meson.build
|
||||
index 26c5dd6e0e..9483ccd3b8 100644
|
||||
--- a/qga/vss-win32/meson.build
|
||||
+++ b/qga/vss-win32/meson.build
|
||||
@@ -7,7 +7,7 @@ link_args = cc.get_supported_link_arguments([
|
||||
|
||||
qga_vss = shared_module(
|
||||
'qga-vss',
|
||||
- ['requester.cpp', 'provider.cpp', 'install.cpp'],
|
||||
+ ['requester.cpp', 'provider.cpp', 'install.cpp', genh],
|
||||
name_prefix: '',
|
||||
cpp_args: ['-Wno-unknown-pragmas', '-Wno-delete-non-virtual-dtor', '-Wno-non-virtual-dtor'],
|
||||
link_args: link_args,
|
||||
--
|
||||
2.25.1
|
33
0001-qga-vss-Use-a-proper-function-for-free-memory.patch
Normal file
33
0001-qga-vss-Use-a-proper-function-for-free-memory.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From 4ee7074cdf48e77886637e12f148e267329978d3 Mon Sep 17 00:00:00 2001
|
||||
From: Konstantin Kostiuk <kkostiuk@redhat.com>
|
||||
Date: Thu, 12 May 2022 15:43:37 +0000
|
||||
Subject: [PATCH] qga-vss: Use a proper function for free memory
|
||||
|
||||
volume_name_wchar is allocated by 'void* operator new [](long long unsigned int)
|
||||
|
||||
Signed-off-by: Konstantin Kostiuk <kkostiuk@redhat.com>
|
||||
---
|
||||
qga/vss-win32/requester.cpp | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/qga/vss-win32/requester.cpp b/qga/vss-win32/requester.cpp
|
||||
index 4513324dd2..b371affeab 100644
|
||||
--- a/qga/vss-win32/requester.cpp
|
||||
+++ b/qga/vss-win32/requester.cpp
|
||||
@@ -354,12 +354,12 @@ void requester_freeze(int *num_vols, void *mountpoints, ErrorSet *errset)
|
||||
if (FAILED(hr)) {
|
||||
err_set(errset, hr, "failed to add %S to snapshot set",
|
||||
volume_name_wchar);
|
||||
- delete volume_name_wchar;
|
||||
+ delete[] volume_name_wchar;
|
||||
goto out;
|
||||
}
|
||||
num_mount_points++;
|
||||
|
||||
- delete volume_name_wchar;
|
||||
+ delete[] volume_name_wchar;
|
||||
}
|
||||
|
||||
if (num_mount_points == 0) {
|
||||
--
|
||||
2.25.1
|
@ -6,7 +6,7 @@
|
||||
%define ga_distro "RHEL"
|
||||
|
||||
Name: mingw-qemu-ga-win
|
||||
Version: 104.0.1
|
||||
Version: 104.0.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Qemus Guest agent for Windows
|
||||
|
||||
@ -22,7 +22,8 @@ Patch0001: 0001-Change-Version.patch
|
||||
Patch0002: 0001-qga-Log-version-on-start.patch
|
||||
Patch0003: 0001-configure-Add-cross-prefix-for-widl-tool.patch
|
||||
Patch0004: 0002-qga-vss-always-build-qga-vss.tlb-when-qga-vss.dll-is.patch
|
||||
|
||||
Patch0005: 0001-qga-vss-Add-auto-generated-headers-to-dependencies.patch
|
||||
Patch0006: 0001-qga-vss-Use-a-proper-function-for-free-memory.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -66,6 +67,8 @@ Qemu Guest Agent for Windows
|
||||
%patch0002 -p1
|
||||
%patch0003 -p1
|
||||
%patch0004 -p1
|
||||
%patch0005 -p1
|
||||
%patch0006 -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -120,6 +123,11 @@ cp build/qga/qemu-ga-x86_64.msi $RPM_BUILD_ROOT%{mingw64_bindir}
|
||||
%{mingw64_bindir}/qemu-ga*
|
||||
|
||||
%changelog
|
||||
* Tue May 17 2022 Konstantin Kostiuk <kkostiuk@redhat.com> 104.0.2
|
||||
- Set version to 104.0.2
|
||||
- BZ#2084608 - Fix mismatched allocation function
|
||||
- BZ#2084613 - qga-win: race condition in build
|
||||
|
||||
* Thu May 12 2022 Konstantin Kostiuk <kkostiuk@redhat.com> 104.0.1
|
||||
- Set version to 104.0.1
|
||||
- BZ#2084493 - qemu-ga can't be installed
|
||||
|
Loading…
Reference in New Issue
Block a user