Initial import.

This commit is contained in:
Richard W.M. Jones 2009-01-30 11:48:10 +00:00
parent ad64cf0dc8
commit 77bf6ea8be
6 changed files with 134 additions and 0 deletions

View File

@ -0,0 +1 @@
pixman-0.13.2.tar.gz

1
import.log Normal file
View File

@ -0,0 +1 @@
mingw32-pixman-0_13_2-2_fc11:HEAD:mingw32-pixman-0.13.2-2.fc11.src.rpm:1233315903

16
make-pixman-snapshot.sh Executable file
View File

@ -0,0 +1,16 @@
#!/bin/sh
DIRNAME=pixman-$( date +%Y%m%d )
rm -rf $DIRNAME
git clone git://git.freedesktop.org/git/pixman $DIRNAME
cd $DIRNAME
if [ -z "$1" ]; then
git log | head -1
else
git checkout $1
fi
rm -rf .git
cd ..
tar jcf $DIRNAME.tar.bz2 $DIRNAME
rm -rf $DIRNAME

88
mingw32-pixman.spec Normal file
View File

@ -0,0 +1,88 @@
%define __strip %{_mingw32_strip}
%define __objdump %{_mingw32_objdump}
%define _use_internal_dependency_generator 0
%define __find_requires %{_mingw32_findrequires}
%define __find_provides %{_mingw32_findprovides}
Name: mingw32-pixman
Version: 0.13.2
Release: 2%{?dist}
Summary: MinGW Windows Pixman library
License: MIT
URL: http://xorg.freedesktop.org/
Group: Development/Libraries
Source0: http://xorg.freedesktop.org/archive/individual/lib/pixman-%{version}.tar.gz
Source1: make-pixman-snapshot.sh
Patch0: pixman-0.13.2-license.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: mingw32-filesystem >= 23
BuildRequires: mingw32-gcc
BuildRequires: mingw32-binutils
BuildRequires: mingw32-dlfcn
Requires: pkgconfig
%description
MinGW Windows Pixman library.
%prep
%setup -q -n pixman-%{version}
%patch0 -p1
%build
# Uses GTK for its testsuite, so disable this otherwise
# we have a chicken & egg problem on mingw
%{_mingw32_configure} --disable-gtk --disable-static
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make DESTDIR=$RPM_BUILD_ROOT install
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root)
%doc LICENSE
%{_mingw32_bindir}/libpixman-1-0.dll
%{_mingw32_includedir}/pixman-1
%{_mingw32_libdir}/libpixman-1.dll.a
%{_mingw32_libdir}/libpixman-1.la
%{_mingw32_libdir}/pkgconfig/pixman-1.pc
%changelog
* Thu Jan 15 2009 Richard W.M. Jones <rjones@redhat.com> - 0.13.2-2
- Include LICENSE file (freedesktop bug 19582).
* Tue Jan 13 2009 Richard W.M. Jones <rjones@redhat.com> - 0.13.2-1
- Resynch with Fedora package (0.13.2).
- Disable static library for speed.
- Use _smp_mflags.
- Requires pkgconfig.
- Depends on dlfcn.
* Wed Sep 24 2008 Richard W.M. Jones <rjones@redhat.com> - 0.12.0-2
- Rename mingw -> mingw32.
* Mon Sep 22 2008 Daniel P. Berrange <berrange@redhat.com> - 0.12.0-1
- Update to 0.12.0 release
* Wed Sep 10 2008 Richard W.M. Jones <rjones@redhat.com> - 0.11.10-2
- Remove static library.
* Tue Sep 9 2008 Daniel P. Berrange <berrange@redhat.com> - 0.11.10-1
- Initial RPM release

View File

@ -0,0 +1,27 @@
diff -urN pixman-0.13.2.orig/LICENSE pixman-0.13.2/LICENSE
--- pixman-0.13.2.orig/LICENSE 1970-01-01 01:00:00.000000000 +0100
+++ pixman-0.13.2/LICENSE 2009-01-15 13:14:47.000000000 +0000
@@ -0,0 +1,23 @@
+ Copyright © 2000 Keith Packard, member of The XFree86 Project, Inc.
+ 2005 Lars Knoll & Zack Rusin, Trolltech
+ 2008 Aaron Plattner, NVIDIA Corporation
+
+ Permission to use, copy, modify, distribute, and sell this software and its
+ documentation for any purpose is hereby granted without fee, provided that
+ the above copyright notice appear in all copies and that both that
+ copyright notice and this permission notice appear in supporting
+ documentation, and that the name of Keith Packard not be used in
+ advertising or publicity pertaining to distribution of the software without
+ specific, written prior permission. Keith Packard makes no
+ representations about the suitability of this software for any purpose. It
+ is provided "as is" without express or implied warranty.
+
+ THE COPYRIGHT HOLDERS DISCLAIM ALL WARRANTIES WITH REGARD TO THIS
+ SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND
+ FITNESS, IN NO EVENT SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY
+ SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN
+ AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING
+ OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS
+ SOFTWARE.
+

View File

@ -0,0 +1 @@
837df4a02c61a60a880644393b57faed pixman-0.13.2.tar.gz