Merge git://pkgs.fedoraproject.org/mingw32-pcre
This commit is contained in:
commit
2d03518e72
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
||||
/pcre-8.10.tar.gz
|
103
mingw32-pcre.spec
Normal file
103
mingw32-pcre.spec
Normal file
@ -0,0 +1,103 @@
|
||||
%global __strip %{_mingw32_strip}
|
||||
%global __objdump %{_mingw32_objdump}
|
||||
|
||||
%global _use_internal_dependency_generator 0
|
||||
%global __find_requires %{_mingw32_findrequires}
|
||||
%global __find_provides %{_mingw32_findprovides}
|
||||
|
||||
%define __debug_install_post %{_mingw32_debug_install_post}
|
||||
|
||||
Name: mingw32-pcre
|
||||
Version: 8.10
|
||||
Release: 6%{?dist}
|
||||
Summary: MinGW Windows pcre library
|
||||
|
||||
Group: Development/Libraries
|
||||
License: BSD
|
||||
URL: http://www.pcre.org/
|
||||
Source0: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-%{version}.tar.gz
|
||||
Patch0: pcre-8.10-multilib.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildArch: noarch
|
||||
|
||||
Requires: pkgconfig
|
||||
|
||||
BuildRequires: redhat-rpm-config
|
||||
BuildRequires: mingw32-filesystem >= 56
|
||||
BuildRequires: mingw32-gcc
|
||||
BuildRequires: mingw32-gcc-c++
|
||||
BuildRequires: mingw32-binutils
|
||||
|
||||
# New libtool to get rid of rpath
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
|
||||
%{?_mingw32_debug_package}
|
||||
|
||||
%description
|
||||
Cross compiled Perl-compatible regular expression library for use with mingw32.
|
||||
|
||||
PCRE has its own native API, but a set of "wrapper" functions that are based on
|
||||
the POSIX API are also supplied in the library libpcreposix. Note that this
|
||||
just provides a POSIX calling interface to PCRE: the regular expressions
|
||||
themselves still follow Perl syntax and semantics. The header file
|
||||
for the POSIX-style functions is called pcreposix.h.
|
||||
|
||||
%prep
|
||||
%setup -q -n pcre-%{version}
|
||||
|
||||
# Get rid of rpath
|
||||
%patch0 -p1 -b .multilib
|
||||
libtoolize --copy --force && autoreconf
|
||||
# One contributor's name is non-UTF-8
|
||||
for F in ChangeLog; do
|
||||
iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
|
||||
touch --reference "$F" "${F}.utf8"
|
||||
mv "${F}.utf8" "$F"
|
||||
done
|
||||
|
||||
%build
|
||||
%{_mingw32_configure} --enable-utf8 --enable-unicode-properties --disable-static
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make DESTDIR=$RPM_BUILD_ROOT install
|
||||
|
||||
rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/doc/*
|
||||
rm -rf $RPM_BUILD_ROOT%{_mingw32_datadir}/man/*
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%{_mingw32_bindir}/pcre-config
|
||||
%{_mingw32_bindir}/pcregrep.exe
|
||||
%{_mingw32_bindir}/pcretest.exe
|
||||
%{_mingw32_bindir}/libpcre*.dll
|
||||
%{_mingw32_libdir}/libpcre*.dll.a
|
||||
%{_mingw32_libdir}/libpcre*.la
|
||||
%{_mingw32_libdir}/pkgconfig/libpcre*.pc
|
||||
%{_mingw32_includedir}/*.h
|
||||
|
||||
%doc AUTHORS COPYING LICENCE NEWS README ChangeLog
|
||||
|
||||
%changelog
|
||||
* Mon Feb 27 2012 Erik van Pienbroek <epienbro@fedoraproject.org> - 8.10-6
|
||||
- Rebuild against the mingw-w64 toolchain
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.10-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri Apr 22 2011 Kalev Lember <kalev@smartlink.ee> - 8.10-4
|
||||
- Rebuilt for pseudo-reloc version mismatch (#698827)
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.10-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Sep 20 2010 Adam Stokes <astokes@redhat.com> - 8.10-2
|
||||
- Restore changes from the native package to pass package review process
|
||||
|
||||
* Wed Jul 21 2010 Ryan O'Hara <rohara@redhat.com> - 8.10-1
|
||||
- Initial spec file.
|
38
pcre-8.10-multilib.patch
Normal file
38
pcre-8.10-multilib.patch
Normal file
@ -0,0 +1,38 @@
|
||||
diff -Naur pcre-8.10.orig/pcre-config.in pcre-8.10/pcre-config.in
|
||||
--- pcre-8.10.orig/pcre-config.in 2010-03-02 12:08:45.000000000 +0100
|
||||
+++ pcre-8.10/pcre-config.in 2010-07-12 14:15:30.666700210 +0200
|
||||
@@ -15,16 +15,6 @@
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-libR=
|
||||
-case `uname -s` in
|
||||
- *SunOS*)
|
||||
- libR=" -R@libdir@"
|
||||
- ;;
|
||||
- *BSD*)
|
||||
- libR=" -Wl,-R@libdir@"
|
||||
- ;;
|
||||
-esac
|
||||
-
|
||||
while test $# -gt 0; do
|
||||
case "$1" in
|
||||
-*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
|
||||
@@ -58,14 +48,14 @@
|
||||
echo $includes @PCRE_STATIC_CFLAG@
|
||||
;;
|
||||
--libs-posix)
|
||||
- echo -L@libdir@$libR -lpcreposix -lpcre
|
||||
+ echo -lpcreposix -lpcre
|
||||
;;
|
||||
--libs)
|
||||
- echo -L@libdir@$libR -lpcre
|
||||
+ echo -lpcre
|
||||
;;
|
||||
--libs-cpp)
|
||||
if test @enable_cpp@ = yes ; then
|
||||
- echo -L@libdir@$libR -lpcrecpp -lpcre
|
||||
+ echo -lpcrecpp -lpcre
|
||||
else
|
||||
echo "${usage}" 1>&2
|
||||
fi
|
Loading…
Reference in New Issue
Block a user