mingw-openssl/mingw32-openssl-1.0.0-beta3-sfx.patch
Kalev Lember 1bc08028b9 - Added missing BuildRequires mingw32-dlfcn
- Reworked patches to rename *eay32.dll to lib*.dll
- Patch Configure script to use %%{_mingw32_cflags}
2009-08-29 20:22:06 +00:00

16 lines
711 B
Diff

diff -up openssl-1.0.0-beta3/engines/Makefile.mingw-libversion openssl-1.0.0-beta3/engines/Makefile
--- openssl-1.0.0-beta3/engines/Makefile.mingw-libversion 2009-08-29 22:33:22.000000000 +0300
+++ openssl-1.0.0-beta3/engines/Makefile 2009-08-29 22:34:15.000000000 +0300
@@ -110,7 +110,10 @@ install:
for l in $(LIBNAMES); do \
( echo installing $$l; \
pfx=lib; \
- if [ "$(PLATFORM)" != "Cygwin" ]; then \
+ if [ "$(PLATFORM)" = "mingw" ]; then \
+ sfx=.dll; \
+ cp $$pfx$$l$$sfx $(INSTALL_PREFIX)$(INSTALLTOP)/lib/engines/$$pfx$$l$$sfx.new; \
+ elif [ "$(PLATFORM)" != "Cygwin" ]; then \
case "$(CFLAGS)" in \
*DSO_BEOS*) sfx=".so";; \
*DSO_DLFCN*) sfx=".so";; \