16 lines
677 B
Diff
16 lines
677 B
Diff
diff -up openssl-1.0.0a/engines/Makefile.mingw-sfx openssl-1.0.0a/engines/Makefile
|
|
--- openssl-1.0.0a/engines/Makefile.mingw-sfx 2010-06-19 21:52:59.000000000 +0300
|
|
+++ openssl-1.0.0a/engines/Makefile 2010-06-19 21:53:34.000000000 +0300
|
|
@@ -111,7 +111,10 @@ install:
|
|
for l in $(LIBNAMES); do \
|
|
( echo installing $$l; \
|
|
pfx=lib; \
|
|
- if [ "$(PLATFORM)" != "Cygwin" ]; then \
|
|
+ if [ "$(PLATFORM)" = "mingw" ]; then \
|
|
+ sfx=.dll; \
|
|
+ cp $$pfx$$l$$sfx $(INSTALL_PREFIX)$(INSTALLTOP)/lib/engines/$$pfx$$l$$sfx.new; \
|
|
+ elif [ "$(PLATFORM)" != "Cygwin" ]; then \
|
|
case "$(CFLAGS)" in \
|
|
*DSO_BEOS*) sfx=".so";; \
|
|
*DSO_DLFCN*) sfx=".so";; \
|